Subject: Re: [sacm] Requested late modifications to the SWIMA specification

From: "Eric Voit (evoit)" <[email-masked]>
Date: Mon, 21 May 2018 18:07:43 +0000

Agree with Ira.   These seem like two reasonable changes.   While building out the expert guidelines, it might be useful to make some connection to of this new section from Section 10.4 (Registry for Software Data Models) which also makes reference to expert review.

Eric

From, Ira McDonald, Sat, 19 May 2018 12:10 

Hi Charles,

I agree with both proposed changes.

Thanks for your diligent work on this spec.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: mailto:[email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Fri, May 18, 2018 at 4:27 PM, Schmidt, Charles M. <mailto:[email-masked]&gt;
wrote:

> Hello,
>
> SWIMA is nearing finalization. However, there have been requests for some
> late changes to the document that would have a normative impact. Benjamin
> Kaduk (AD) indicated he is willing to consider allowing these changes
> without requiring a restart of the review process, but only if there are no
> objections from the working group. Both of these changes are such that
> making them will improve the standard, but neither are required for a
> functional standard and SWIMA can be finalized without either change if
> members of the workgroup object to those changes.
>
> Briefly, the requested changes are:
> 1) Add a section to the document's IANA considerations containing
> "Designated Expert Guidelines" for the Registry for Software Data Models
> that SWIMA defines. This section would follow the template of the
> Designated Expert Guidelines in section 7.1 of RFC 5792 (PA-TNC) and
> section 6.1 of RFC 5793 (PB-TNC). These guidelines contain normative text:
> values MUST be useful, not harmful to the Internet, and support
> interoperability; and referenced documents in the IANA tables MUST be made
> permanently available.
> 2) For both the Software Identifier Inventory and Software Inventory
> attributes, add an 8-byte "Reserved" field between the Source ID Number and
> Software Identifier Length fields in the message. This would make all four
> types of Response Attributes have a long segment of the same fields in the
> same order, which would simplify parser implementation. Currently Event
> attributes and Inventory attributes have a segment of fields that are the
> same EXCEPT that Event attributes have an 8-byte Action field between the
> Source ID Number and Software Identifier Length fields, which is absent in
> Inventory attributes.
>
> We will not make any change for which there are objections from the
> workgroup, and SWIMA's function will not be hindered by the absence of
> these changes. That said, I do feel that the changes would both benefit
> future IANA expert reviewers and implementers, respectively.
>
> I am aware of two implementations of SWIMA (by Andreas Steffan and
> Carl-Heinz Genzel), and both are supportive of the field change in item #2.
>
> Please let me know if you have any questions or concerns, and definitely
> speak up if you have an objection to either of these changes.
>
> Thanks,
> Charles
>
> _______________________________________________
> sacm mailing list
> mailto:[email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>

---

From: Adam Montville <[email-masked]>
Date: Tue, 22 May 2018 13:57:06 -0500

+1

> On May 21, 2018, at 1:07 PM, Eric Voit (evoit) <[email-masked]> wrote:
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: mailto:[email-masked] <mailto:[email-masked]>
> On Fri, May 18, 2018 at 4:27 PM, Schmidt, Charles M. <mailto:[email-masked] <mailto:[email-masked]>&gt;
> wrote:
> 
>> Hello,
>> 
>> mailto:[email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>
>> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>