Subject: [sacm] [sacmwg/draft-ietf-sacm-coswid] Express enumerations that are not defined in the current XSD but per nomartive text explictitly via cddl rules (#5)

From: Henk Birkholz <[email-masked]>
Date: Fri, 08 Jun 2018 08:38:10 -0700

There still might be a few cases left, where the value is text, but semantically it is a type-choice / enumeration. This should be double checked before meeting 102.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/5

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 08 Jun 2018 09:02:28 -0700

Used role (label 33) & rel (label 40) as proposal by example. The roles & rels type-choices still require an extension-point, I assume.

media (label 10) is currently a text value with a semantic that is a tad bit more complex than a type-choice: "EXPRESSION [[OPERATOR] [EXPRESSION] ... ]", where EXPRESSION can be a simple type-choice.... or ... "([PREFIX-]ENVIRONMENT.ATTRIBUTE:VALUE)" ... and so on and on....

I propose to deal with.... that in cddl, too. 

Also, the definition of rel seems to be wrong at the moment, as every SWID enumeration is actually NOT defined in https://www.iana.org/assignments/link-relations/link-relations.xhtml

This needs fixing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/5#issuecomment-395807739