Subject: [sacm] [IANA #1052969] Protocol Action: 'Software Inventory Message and Attributes (SWIMA) for PA-TNC' to Proposed Standard (draft-ietf-sacm-nea-swima-patnc-04.txt)

From: "Amanda Baber via RT" <[email-masked]>
Date: Fri, 01 Jun 2018 22:55:02 +0000

Dear Authors:

ATTENTION: A RESPONSE TO THIS MESSAGE IS NEEDED 

We've completed the registry actions for the following RFC-to-be:

draft-ietf-sacm-nea-swima-patnc-04

ACTION 1:

We've registered the following PA Subtype:

PEN: 0
Integer: 9
Name: SWIMA Attributes
Reference: [RFC-ietf-sacm-nea-swima-patnc-05]

Please see
https://www.iana.org/assignments/pb-tnc-parameters

ACTION 2:

We've registered the following PA-TNC Attribute Types:

PEN    Integer    Name    Reference

0	13	SWIMA Request	[RFC-ietf-sacm-nea-swima-patnc-05]
0	14	Software Identifier Inventory	[RFC-ietf-sacm-nea-swima-patnc-05]
0	15	Software Identifier Events	[RFC-ietf-sacm-nea-swima-patnc-05]
0	16	Software Inventory	[RFC-ietf-sacm-nea-swima-patnc-05]
0	17	Software Events	[RFC-ietf-sacm-nea-swima-patnc-05]
0	18	Subscription Status Request	[RFC-ietf-sacm-nea-swima-patnc-05]
0	19	Subscription Status Response	[RFC-ietf-sacm-nea-swima-patnc-05]
0	20	Source Metadata Request	[RFC-ietf-sacm-nea-swima-patnc-05]
0	21	Source Metadata Response	[RFC-ietf-sacm-nea-swima-patnc-05]

Please see
https://www.iana.org/assignments/pa-tnc-parameters

ACTION 3:

We've registered the following PA-TNC Error Codes:

PEN    Integer    Name    Reference

0	4	SWIMA_ERROR	[RFC-ietf-sacm-nea-swima-patnc-05]
0	5	SWIMA_SUBSCRIPTION_DENIED_ERROR	[RFC-ietf-sacm-nea-swima-patnc-05]
0	6	SWIMA_RESPONSE_TOO_LARGE_ERROR	[RFC-ietf-sacm-nea-swima-patnc-05]
0	7	SWIMA_SUBSCRIPTION_FULFILLMENT_ERROR	[RFC-ietf-sacm-nea-swima-patnc-05]
0	8	SWIMA_SUBSCRIPTION_ID_REUSE_ERROR	[RFC-ietf-sacm-nea-swima-patnc-05]

Please see
https://www.iana.org/assignments/pa-tnc-parameters

ACTION 4:

We've created the following registry under the heading "Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC) Parameters":

Software Data Model Types
Registration Procedure(s): Specification Required
Expert(s): David Waltermire, Jessica Fitzgerald-McKay
Reference: [RFC-ietf-sacm-nea-swima-patnc-05]

PEN 	Integer 	Name 	Reference 

0	0	ISO 2015 SWID Tags using XML	[RFC-ietf-sacm-nea-swima-patnc-05]
0	1	ISO 2009 SWID Tags using XML	[RFC-ietf-sacm-nea-swima-patnc-05]
0	2-191	Unassigned	
0	192-255	Reserved for local enterprise use	[RFC-ietf-sacm-nea-swima-patnc-05]

Please see
https://www.iana.org/assignments/pa-tnc-parameters

Please let us know whether this document's registry actions have been completed correctly. Once we receive your confirmation, we'll notify the RFC Editor that the actions are complete. If a team of authors is responsible for the document, and the actions have been performed correctly, please send a single confirmation message.

We'll update any references to this document in the registries when the RFC Editor notifies us that they've assigned an RFC number.

Best regards,

Amanda Baber
Lead IANA Services Specialist

---

From: "Schmidt, Charles M." <[email-masked]>
Date: Sat, 2 Jun 2018 16:55:44 +0000

Hello,

I have reviewed all these assignments and confirmed they are correct (modulo updating the references when the RFC number is assigned, as you noted). Thank you for your support on this.

Charles

> -----Original Message-----
> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: Friday, June 01, 2018 5:55 PM
> Cc: Schmidt, Charles M. <[email-masked]>; Haynes Jr., Dan
> <[email-masked]>; Coffin, Chris <[email-masked]>; Waltermire, David
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: [IANA #1052969] Protocol Action: 'Software Inventory Message and
> Attributes (SWIMA) for PA-TNC' to Proposed Standard (draft-ietf-sacm-nea-
> swima-patnc-04.txt)
> 
> Dear Authors:
> 
> We've created the following registry under the heading "Posture Attribute
> (PA) Protocol Compatible with Trusted Network Connect (TNC) Parameters":
> 
> Please let us know whether this document's registry actions have been
> completed correctly. Once we receive your confirmation, we'll notify the RFC
> Editor that the actions are complete. If a team of authors is responsible for
> the document, and the actions have been performed correctly, please send
> a single confirmation message.
> 
> We'll update any references to this document in the registries when the RFC
> Editor notifies us that they've assigned an RFC number.
> 
> Best regards,
> 
> Amanda Baber