Subject: Re: DRAFT minutes, SACRED WG, Minneapolis IETF

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Mon, 26 Mar 2001 15:32:21 -0500 (EST)

Yonge said:
	
	If none of the protocols is patent free, why we do not make the 
following
	choice:
	The requirement and standard do not specify any algorithm, leave it as a
	black-box... And the standard should be general enough so that most of 
the
	algorithms could be implemented (each algorithm should have a unique
	identifier).
	
PDM has not been patented. This doesn't mean of course that it is
absolutely certain someone doesn't have a patent that might cover some
aspects of it,
but PDM itself is not patented. So we don't need a statement from
our organizations that it will be licensed on reasonable terms, or
free terms provided that people who use it grant license to any
of their technology, ... It's simply not patented.

It would be nice to at least come up with a single MUST implement, as
well as a bunch of other choices, should the MUST alg wind up cryptographically
broken or with someone showing they have a patent on arithmetic which
covers it.

Radia

---

From: Tom Wu <[email-masked]>
Date: Mon, 26 Mar 2001 13:04:19 -0800

> broken or with someone showing they have a patent on arithmetic which

If one of the strong password methods like PDM or SRP becomes a MUST
implement, though, how does that help implementors that want to deploy a
different topology, like a Ford-Kaliski multi-server configuration? 
Their servers cannot support a "regular" strong password protocol, so
does that make their implementation non-sacred-compliant by design?

> Radia

Tom
-- 
Tom Wu
Principal Software Engineer
Arcot Systems
(408) 969-6124
"The Borg?  Sounds Swedish..."

---

From: Yongge Wang <[email-masked]>
Date: Mon, 26 Mar 2001 16:52:10 -0500 (EST)

> of their technology, ... It's simply not patented.

PDM is a nice protocol. Of course, as mentioned in the
previous summary of Milliapolos meeting, the client side
is a little slow. In particular, ECC is used in wireless
devices such as Palm for several well-known reasons.
If wireless devices will be one of the main users of SACRED,
I think PDM might need a nice refinement for ECC version.
At present, there is no natural efficient ECC version of PDM. 
We cannot imagine that each time Palm will generate a 
Elliptic Curve and count the points on it. 

One solution might be as follows though it is still a little
slow: the Elliptic Curve should be a public one. But each time,
the password should be used to generate the generator of the
Elliptic Curve group (this will look like the SPEKE,
hope this is not covered by the SPEKE patent).

Some factors might also be taken into consideration in 
desiging SACRED protocol. In order to support different
protocols, the same password might be delivered by the 
server to the client using several different algorithms.
Then the special care might need to be taken for
security reasons.
(e.g., my Palm and Desktop should download the same password,
though my Palm use ECC and Destop use DH.)

Yongge

> broken or with someone showing they have a patent on arithmetic which

-----------------------------------
Yongge Wang -- Crypto Mathematician
http://cs.uwm.edu/~wang/
-----------------------------------

---

From: John W Noerenberg II <[email-masked]>
Date: Tue, 27 Mar 2001 08:55:20 -0800

>broken or with someone showing they have a patent on arithmetic which

It's not a matter of, "it would be nice" (although I think you're 
just being generous, Radia <grin>).  Without mandatory algorithms, 
there is no guarantee of interoperability.

-- 

john noerenberg
[email-masked]
   --------------------------------------------------------------------------
   Peace of mind isn't at all superficial, really.  It's the whole thing.
   That which produces it is good maintenance; that which disturbs it
   is poor maintenance.
   -- Zen and the Art of Motorcycle Maintenance, Robert M. Pirsig, 1974
   --------------------------------------------------------------------------