Subject: The future of SACRED

From: Magnus Nystrom <[email-masked]>
Date: Mon, 26 Nov 2001 19:51:14 +0100 (W. Europe Standard Time)

Dear WG,

A second version of SACRED's protocol I-D was posted about four weeks
ago. To date, we have received only one comment on this draft. The
first version received very limited feedback too, which brought us to
ask, at the IETF in London, whether we have a broad enough
constituency to continue the work towards a standards-track document.

Given the continued low level of interaction on the mailing list, we
would therefore once again like to ask those of you who are interested
in developing a standards track protocol to step forward and
express your interest and willingness to contribute to the quality
of the solution. We feel that we would need this support from a
reasonable number of independent members of the group in order to
continue the work towards a standards-track RFC. If we don't get this
confirmation, our plan is to move the SACRED protocol document to
experimental track RFC sometime early next year (after a WG last
call).

Please send an email to the list before the IETF meeting in SLC (and
better yet include your comments on the current draft), so that we
know at the meeting whether the main topic to discuss is WG status or
the comments on the protocol draft.

Best regards,
-- Magnus and Stephen

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 28 Nov 2001 18:51:08 +0000

I know we said "before SLC" in that mail, but 48 hours 
later and no reaction at all tells me something:-)

Assuming no change from this, we'll be working to the 
following schedule:

- Discuss current drafts in SLC
- Re-issue in early/mid Jan (basically asap given the
  holidays)
- Issue 2 week WG last call
- Send to IESG after resolution of the (likely few:-)
  last call comments (possibly early Feb)
- WG goes dormant, then shuts-down when RFC(s)
  issue(s)

I'm ok with that schedule for the protocol draft. 
Any problems for the framework authors?

Stephen.

-- 
____________________________________________________________
Stephen Farrell         				   
Baltimore Technologies,   tel: (direct line) +353 1 881 6716
39 Parkgate Street,                     fax: +353 1 881 7000
Dublin 8.                mailto:[email-masked]
Ireland                             http://www.baltimore.com

---

From: Menno Pieters <[email-masked]>
Date: Wed, 28 Nov 2001 22:09:54 +0100

>later and no reaction at all tells me something:-)

Stephen/Magnus,

You're right the list has been a bit too silent. However, I still 
think it is an interesting initiative.

I won't be in SLC, but perhaps I can give some comments on the draft, 
before the meeting. At least I've taken the first step, downloaded 
and printed the draft, so I can read it in my own time and perhaps 
comment on it... :-)

So, please DO continue you're efforts!

Thanks and regards,

Menno Pieters

<CUT>
-- 
---------------------------------------------------
Menno Pieters
M&I/STELVIO bv - Adviseurs voor Internettechnologie
Postbus 2171             |              Zonnehof 41
3800 CD Amersfoort       |      3811 ND  Amersfoort
The Netherlands
telefoon/phone: +31-33-4.349.340
telefax:        +31-33-4.349.341
XOIP:           +31-20-8.720.349
e-mail          [email-masked]
website         http://www.stelvio.nl/
---------------------------------------------------

---

From: Dale Gustafson <[email-masked]>
Date: Thu, 29 Nov 2001 11:41:05 -0600

Hi Magnus and Stephen,

I apologize for not getting back to you sooner on this -- I've been out of town
much of the last month so have not been able to follow up on this.

I'd like to see the protocol document progress to standards track status.  I
believe there's real value in a standardized, general purpose secure credential
exchange capability that can be implemented in a wide range of internet devices.

I was only able to take a brief look at the latest revision and jot down a few
comments.  I'll revisit those and send to the list if there's anything of
substance in them.  I recall that this latest revision appeared to backtrack on
several important technical issues (capabilities that some of us had articulated
earlier reappeared albeit somewhat unexpectedly  :-).

Net-net, I believe the latest revision of the protocol document is a substantial
improvement over the previous and would like to see it driven to completion.
FWIW, I also think it might help if the rationale behind recent changes that
appear to be driven by parallel work in W3's XKMS area were more fully explained
to the group.  Without a little more background information, it may be difficult
for many/most to provide meaningful comments.

Best Regards,

Dale Gustafson
Future Foundation Inc.
+1 651 452-9033 office
+1 218 343-9724 mobile

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 30 Nov 2001 11:58:14 +0000

Hi Dale,

> for many/most to provide meaningful comments.

Basically, if we're using xml to define sacred data structures then it
seems sensible to try to be compatible with other xml-based security
work. The most relevant such thing is xkms, but xmldsig and xml encryption 
and saml are also related efforts. In fact, our choice of beep as 
transport isn't in-line with xkms or saml, since they're using soap/http, 
(but that was the concensus here), so its really only the sacred schema 
that could be used with xkms or saml.

If we weren't using xml for our payloads, there'd be no reason to think 
about xkms at all. If that (not using xml) were the concensus, that'd be 
fine by me.

Hope that helps,
Stephen.

PS: I should probably point out that I'm also slated to co-chair the
in-formation w3c xkms working group (which is neither a conflict of 
interest, nor a secret:-)

---

From: Dale Gustafson <[email-masked]>
Date: Fri, 30 Nov 2001 10:10:02 -0600

Stephen,

Your suggested schedule should be ok for a final draft of the framework document
as well.

We should probably plan on next revision of framework issued 1-2 weeks after
next revision of protocol doc.

Regards,

Dale Gustafson
Future Foundation Inc.
+1 651 452-9033 office
+1 218 343-9724 mobile

Stephen Farrell wrote:

> - Re-issue in early/mid Jan (basically asap given the holidays)
> - Send to IESG after resolution of the (likely few:-)  last call comments
> (possibly early Feb)
> - WG goes dormant, then shuts-down when RFC(s) issue(s)
>

> Stephen.

<snip>