Subject: I-D ACTION:draft-ietf-sacred-framework-03.txt

From: [email-masked]
Date: Mon, 04 Mar 2002 07:09:13 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Securely Available Credentials Working Group of the IETF.

	Title		: Securely Available Credentials - Credential Framework
	Author(s)	: D. Gustafson, M. Just, M. Nystrom
	Filename	: draft-ietf-sacred-framework-03.txt
	Pages		: 20
	Date		: 01-Mar-02
	
As the number, and more particularly the number of different
types, of devices connecting to the Internet increases, credential
mobility becomes an issue for IETF standardization. This draft
responds to the credential server framework requirements listed in
[SACRED]. It presents a strawman framework and outlines protocols
for securely available credentials.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sacred-framework-03.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-sacred-framework-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-sacred-framework-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Dale Gustafson <[email-masked]>
Date: Mon, 04 Mar 2002 10:38:57 -0600

Hi All,

Here is a summary of the changes made to create the latest draft of the SACRED Protocol
Framework document (draft-ietf-sacred-framework-03.txt).

Several sections of the document were reorganized (moved around) in order to make the document
easier to read, so I've referenced the changes both ways.

The primary changes made in this latest draft are:

-02 section  -03 section     editing changes made
-----------  -----------     ---------------------------------------------------------
 2.           2.             Changed requirements references to RFC-3157
                             Protocol framework applies to client/server only
                             "Account Password" and "Credential Password" terms used

 2.2          2.2            Session-level encryption key "derived" during mutual auth.

 3.1          4.2.1          Strong-password protocols "may" be used. xTLS is an alternative

 3.2          4.2.2          Reworded to describe "sTLS" and "cTLS" options
                             Added "4.3.3 Other Authentication Methods"

 4.           ---            Removed Authentication Options - this level of detail
                             is best covered by protocol document(s)

 ---          4.3            Added "Transport Protocol Suites" - included a "minimal"
                             summary of the list discussion on these topics.

 5.           3.             Protocol Framework - added summary description of protocol
                             elements used throughout (secured credential, credential name,
                             credential ID/fingerprint).  Note that ID is used throughout
                             this section based on our interpretation of the list discussion.
                             This should be clarified and harmonized with the protocol doc.

 5.1          3.1, 3.1.1     Added "Conditional Replace" description

 5.2          3.2, 3.2.1     Added GET-ALL credentials (GET-NULL) description
                             Clarified "Conditional Download" description

 6.           4.1            Secure Credential Formats - restructured and removed details
                             for PKCS#15 and PKCS#12 that can be found in the referenced
                             documents

 7.           7.             Updated to reference RFC-3157 (SACRED Requirements) and
                             added several references.

This revision attempted to capture the substance of recent list discussion and to improve
alignment with the approved Requirements document and the protocol document.  The need for
additional efforts, if any, can be discussed immediately on-list and/or in Minneapolis on
3/18.

Best Regards,

Dale Gustafson