Subject: Minor schema issues.

From: "Gareth Richards" <[email-masked]>
Date: Thu, 7 Mar 2002 13:47:22 -0000

I noticed that the schema is written to the October 2000 draft standard
rather than to the 2001 recomendation.  As far as I can see, only two
changes would be required:

In the header
  replace
	 xmlns="http://www.w3.org/2000/10/XMLSchema"
  with
	 xmlns="http://www.w3.org/2001/XMLSchema"

In  <element name="SRPAuthParams">
  replace
      <element name="HashAlg" type="uriReference"/>
  with
      <element name="HashAlg" type="anyURI"/>

Secondly, I think that the use of <any namespace="##other"/> in
SRPAuthParams and AuthInfoType is causing an ambiguity since we are using
unqualified local elements.  We can either make local elements qualified
(as done in the XKMS and XML-DSIG schema) or make SRPAuthParams non-local.
However, since these two elements are the only local ones in the schema it
may be more consistent to make them global.  For example:

  <element name="SRPAuthParams">
    <complexType>
      <sequence>
        <element name="N" type="ds:CryptoBinary"/>
        <element name="g" type="ds:CryptoBinary"/>
        <element name="HashAlg" type="anyURI"/>
      </sequence>
    </complexType>
  </element>

  <complexType name="AuthParamsType">
    <choice>
      <element ref="sacred:SRPAuthParams"/>
      <sequence maxOccurs="unbounded">
        <any namespace="##other"/>
      </sequence>
    </choice>
  </complexType>
  <element name="AuthParams" type="sacred:AuthParamsType"/>

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 07 Mar 2002 13:51:04 +0000

Thanks Gareth,

Will apply these next time 'round.

Stephen.

-- 
____________________________________________________________
Stephen Farrell         				   
Baltimore Technologies,   tel: (direct line) +353 1 881 6716
39 Parkgate Street,                     fax: +353 1 881 7000
Dublin 8.                mailto:[email-masked]
Ireland                             http://www.baltimore.com