Subject: [salud] draft-ietf-salud-alert-info-urns: duration value concatenation

From: Brett Tate <[email-masked]>
Date: Tue, 3 Jul 2012 06:04:29 -0700

Concerning draft-ietf-salud-alert-info-urns's durations, can they be combined to indicate a ring pattern?  If so, how?

For instance, would "urn:alert:duration:short:short:long" create a short:short:long ring pattern?

Thanks,
Brett

This email is intended solely for the person or entity to which it is addressed and may contain confidential and/or privileged information.  If you are not the intended recipient and have received this email in error, please notify BroadSoft, Inc. immediately by replying to this message, or by sending an email to [email-masked], and destroy all copies of this message, along with any attachment, prior to reading, distributing or copying it.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 03 Jul 2012 10:16:32 -0400

> For instance, would "urn:alert:duration:short:short:long" create a short:short:long ring pattern?

Are you serious, or joking?

In a word: NO.

	Thanks,
	Paul

---

From: Brett Tate <[email-masked]>
Date: Tue, 3 Jul 2012 07:42:51 -0700

Hi Paul,

Yes; I was serious. :) 

Since the draft has "short" and "long", I was basically just checking to see if the draft addressed the short-short-long type stuff that Adam mentioned in 2010.

http://www.ietf.org/mail-archive/web/dispatch/current/msg01740.html

Thanks,
Brett

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Paul Kyzivat
> Sent: Tuesday, July 03, 2012 10:17 AM
> To: [email-masked]
> Subject: Re: [salud] draft-ietf-salud-alert-info-urns: duration value
> concatenation
> 
> > Concerning draft-ietf-salud-alert-info-urns's durations, can they be
> combined to indicate a ring pattern?  If so, how?
> >
> _______________________________________________
> salud mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/salud

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Tue, 3 Jul 2012 11:13:27 -0400

On Tue, 2012-07-03 at 07:42 -0700, Brett Tate wrote:
> Since the draft has "short" and "long", I was basically just checking
> to see if the draft addressed the short-short-long type stuff that
> Adam mentioned in 2010.
> 

Given how the URNs are constructed, there is no way that
<urn:alert:duration:short:short:long> would mean short-short-long;
instead it would be some specialization of "short".

However, we could define <urn:alert:duration:short-short-long> to mean
short-short-long, or you could create a private URN
<urn:alert:duration:com.broadsoft:short-short-long>.

More importantly, do we need to define standard URNs for the various
TIA/EIA-41-D and 3GPP2 A.S0014 tones?

Dale

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 03 Jul 2012 14:24:30 -0400

On 7/3/12 11:13 AM, Worley, Dale R (Dale) wrote:
> However, we could define<urn:alert:duration:short-short-long>  to mean

We have tried to make thse urns be semantic indicators rather than 
describing the renderings. (Though short/long somewhat violates that.)

So I would prefer to define the semantic for which short-short-long is a 
common rendering, and let the UA decide whether to use that rendering or 
something else.

	Thanks,
	Paul