Subject: SASL C API bar BOF?

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Aug 2001 01:17:33 -0600

Hi,
Some people expressed their interest in C API for SASL. Anybody wants to
gather during IETF meeting to discuss this?

--
Alexey Melnikov
__________________________________________
R & D, ACI Worldwide (formerly MessagingDirect Ltd.)
phone 780.424.4922 x357

I speak for myself only, not for my employer.
__________________________________________

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Aug 2001 01:59:13 -0600

Leif Johansson wrote:

> On Wed, Aug 08, 2001 at 01:17:33AM -0600, Alexey Melnikov wrote:
> >
> > Hi,

> sure

Any preferences regarding time?

Alexey Melnikov

---

From: Lawrence Greenfield <[email-masked]>
Date: Wed, 8 Aug 2001 08:01:21 -0400

Date: Wed, 08 Aug 2001 01:17:33 -0600
   From: Alexey Melnikov <[email-masked]>
   Organization: ACI WorldWide / MessagingDirect

I'll come if others are interested.

Larry

---

From: Gregory Neil Shapiro <[email-masked]>
Date: Wed, 8 Aug 2001 05:58:13 -0700

> gather during IETF meeting to discuss this?

leg+> I'll come if others are interested.

Same here.. But I'll be mostly quiet (except for supporting the idea of
having one).  Currently, Larry is my supplier but it would nice for my
application to support other SASL libraries and having this API would help
with that portability (much like LDAP, IPv6, etc).

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Aug 2001 07:11:02 -0600

Actually that what I was thinking myself.

So, we meet on Thursday at 11:30 near IETF message board.

Tony Hansen wrote:

> May I suggest a lunch BOF on Thursday? (We're running out of time
> slots.)
>
>         Tony Hansen
>         [email-masked]
>
> Alexey Melnikov wrote:
> >

---

From: Tony Hansen <[email-masked]>
Date: Wed, 08 Aug 2001 09:07:17 -0400

Tony Hansen
	[email-masked]

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Aug 2001 07:52:45 -0600

Leif Johansson wrote:

> On Wed, Aug 08, 2001 at 07:11:02AM -0600, Alexey Melnikov wrote:
> >
> Could someone forward the latest version of the Chris Newman c-api draft
> as a basis for discussion.

I suggest we use CMU SASL API as a base for discussion.

Alexey Melnikov

---

From: Leif Johansson <[email-masked]>
Date: Wed, 8 Aug 2001 15:43:46 +0200

MVH leifj

---

From: Lawrence Greenfield <[email-masked]>
Date: Wed, 8 Aug 2001 11:51:38 -0400

The latest and greatest in Chris Newman/CMU/etc. API is:

http://bugzilla.andrew.cmu.edu/cvsweb/src/sasl/include/sasl.h?rev=1.43.2.21&content-type=text/x-cvsweb-markup

I'm going to check with Rob to make sure that he doesn't have any
pending changes, and then I'll post it in text.

saslplug.h in the same repository is the plugin api.

Larry

   Date: Wed, 08 Aug 2001 07:52:45 -0600
   From: Alexey Melnikov <[email-masked]>
   Organization: ACI WorldWide / MessagingDirect
   CC: Tony Hansen <[email-masked]>, SASL WG <[email-masked]>

---

From: Tony Hansen <[email-masked]>
Date: Thu, 09 Aug 2001 06:21:35 -0400

I'm attaching a man page for a C++ server api that I had developed a few
years ago. We might be able to get some ideas from there. Sorry for the
late posting -- the machine this was on was down most of yesterday.

	Tony

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Aug 2001 01:59:13 -0600

Alexey Melnikov

---

From: Lawrence Greenfield <[email-masked]>
Date: Wed, 8 Aug 2001 08:01:21 -0400

Larry

---

From: Gregory Neil Shapiro <[email-masked]>
Date: Wed, 8 Aug 2001 05:58:13 -0700

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Aug 2001 07:11:02 -0600

---

From: Tony Hansen <[email-masked]>
Date: Wed, 08 Aug 2001 09:07:17 -0400

Tony Hansen
	[email-masked]

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 08 Aug 2001 07:52:45 -0600

Alexey Melnikov

---

From: Leif Johansson <[email-masked]>
Date: Wed, 8 Aug 2001 15:43:46 +0200

MVH leifj

---

From: Lawrence Greenfield <[email-masked]>
Date: Wed, 8 Aug 2001 11:51:38 -0400

Larry

---

From: Tony Hansen <[email-masked]>
Date: Thu, 09 Aug 2001 06:21:35 -0400

Tony