Subject: md5 definitely broken?

From: Tony Hansen <[email-masked]>
Date: Wed, 18 Aug 2004 14:43:33 -0400

I saw a note in the openpgp mailing list about md5 definitely being 
cracked. Anyone know more?

	Tony Hansen
	[email-masked]

---

From: "Paul Leach" <[email-masked]>
Date: Wed, 18 Aug 2004 15:10:07 -0700

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Simon Josefsson
> Sent: Wednesday, August 18, 2004 12:02 PM
> To: [email-masked]
> Subject: Re: md5 definitely broken?
> 
> 
> Tony Hansen <[email-masked]> writes:
> 
> "Collisions for Hash Functions MD4, MD5, HAVAL-128 and RIPEMD"
> http://eprint.iacr.org/2004/199/
> 
> Whether "collisions" imply "cracked", in the real world, 
> probably depend on the details, and the application.  It is 
> not clear (to me, at least) how you would attack HMAC-MD5 
> based on the above result.

I've see mail from Hugo Krawczyk that says it does not place HMACs in
jeopardy.

Also, AFAIK, it has not been claimed that, given some arbitrary text, an
attacker can find other text that hashes to the same value. However, at
the current time, the existence of these collisions strongly implies
that that is possible, and one must assume that in the not to distant
future it will be done. Hence, it would be the conservative thing to do
to add SHA-1 based hashes to Digest (RFC 2831), as well as AES cipher
suite.