Subject: RE: DIGEST-MD5 interop issue

From: "Paul Leach" <[email-masked]>
Date: Fri, 13 Aug 2004 11:02:24 -0700

> -----Original Message-----
> From: Alexey Melnikov [mailto:[email-masked]] 
> Sent: Friday, August 13, 2004 10:36 AM
> To: Paul Leach
> Cc: Kurt D. Zeilenga; SASL WG
> Subject: Re: DIGEST-MD5 interop issue
> 
> Paul Leach wrote:
> 
> >
> >[Paul Leach] Use of names and realms of this form was not 
> the intention 
> >when the protocol was spec'd. The idea was that realms would be DNS 
> >names.
> >
> Although the former might be true, the latter is not, as RFC 
> 2831 has the following example of a realm:
> [email-masked].
> 
I sure don't recall that example.... I can only speak for my intentions
as I remember them.

The MSFT UI usually has two modes: one where there are two edit boxes
for entering name and realm (respectively); and one with one edit box
where special characters are understood as separating them.

An update could suggest some scheme such as this. Or it  could merely
state a requirement on UIs that arbitrary user names and realm names
have to be able to be entered, and that if they want to use special
characters to separate them, then they have to be able to escape the
special characters (and that they need to specify their escape rules).

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 14 Aug 2004 18:53:39 +0100

Paul Leach wrote:

>>Paul Leach wrote:
>>    
>>
>>>[Paul Leach] Use of names and realms of this form was not the intention 
>>>      
>>>
I like that.

Speaking of UI: the UI should also be able to display all realms 
advertised by the server (otherwise what is the point of advertising 
them anyway?), e.g. a listbox with advertised realms, but so that the 
client can type in a different realm.

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 14 Aug 2004 18:53:39 +0100

I like that.