Subject: SASL authentication failure: cannot connect to Courier authdaemond: Connection refused

From: Jesús García Crespo (aka Sevein) <[email-masked]>
Date: Thu, 14 Oct 2004 01:37:10 +0200

Hi! I am a Linux user who is trying to configure his own server in Internet to give services like www, smtp, imap and that stuff. I have been trying to do SMTP AUTH thanks to sasl library. Until now, I configured saslauthd with rimap to auth users against courier-imap (and authdaemond agains MySQL).

But I thought that it could be better to configure sasl to connect directly to authdaemond socket. I tried it. But I got this error (always):

[postfix/smtpd] warning: SASL authentication failure: cannot connect to Courier authdaemond: Connection refused

My configuration files:

/etc/sasl/smtpd.conf
^^^^^^^^^^^^^^^^^^^^
pwcheck_method: authdaemond
authdaemon_path: /var/lib/courier-imap/authdaemon/socket
mech_list: plain login
log_level: 7

ls -li /var/lib/courier-imap/authdaemon/socket 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
114898 srwxrwxrwx  1 root root 0 Oct 14 00:39 /var/lib/courier-imap/authdaemon/socket

Moreover, I did this because I though about the Postfix chroot:
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
mkdir -p /var/spool/postfix/var/lib/courier-imap/authdaemon/

ln /var/lib/courier-imap/authdaemon/socket /var/spool/postfix/var/lib/courier-imap/authdaemon/socket

I always restart Postfix when I make changes.

Gentoo Linux
courier-imap-3.0.7
cyrus-sasl-2.1.19-r1 (with authdaemond support)
postfix-2.1.3

Do you know what could I do? I am tired of the same!

-- 
Jesús García Crespo (aka Sevein)
http://www.sevein.com
[email-masked]

GnuGP key ID: E2DB17E8 (pgp.escomposlinux.org)

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 13 Oct 2004 17:03:33 -0700

Please note that this list is for discussing the standardization
of SASL and, in particular, undertaking the work of the IETF
SASL WG <http://www.ietf.org/html.charters/sasl-charter.html>.
Your post is off-topic here.

Issues specific to any particular SASL implementation should be
directed to forums specific to that implementation.  From your
message, I gather you are using the Cyrus SASL implementation.
Hence, I suggest you direct your comments to:
  <[email-masked]>
Information regarding how to subscribe to this list is available
at:
  http://asg.web.cmu.edu/sasl/#mailinglists

Thanks, Kurt - IETF SASL WG co-chair

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 13 Oct 2004 17:03:33 -0700