Subject: Re: Gen-ART review of draft-ietf-sasl-anon-04.txt

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 14 Dec 2004 20:50:16 -0800

At 08:33 PM 12/13/2004, Spencer Dawkins wrote:
>This specification is reasonable for publication as a proposed standard. All of my comments could be addressed in AUTH-48.
>
>My nit collection looks like this:
>
>- how deeply embedded is the word "trace" in the SASL community? The document defines it more than once, consistently, but every time I saw the word I kept finding myself wondering what "trace" had to do with this protocol specification. If it's too late to change it, that's fine - I'm just asking.

In the I-D, the word 'trace' has two basic uses.
        1) trace information
        2) the "trace" profile

The latter is intended to be named after the former.  The
former is descriptive of the kind of information being
carried.  I recall some discussion of alternatives; this
was the best we came up with.

>- Does this document replace RFC 2245, or obsolete it (the RFC-Editor word),
> or something else?

    Obsoletes: RFC 2245

    This document replaces RFC 2245.  Changes since RFC 2245 are
    detailed in Appendix A.

>- I thought "No additional characters are prohibited" was awkward -

As Stringprep says:
   It is important to note that a profile of this document MAY prohibit
   additional characters.
I felt it appropriate to note that no additional characters are
prohibited.  The sentence likely could be deleted without
causing implementor confusion.

>is the document saying "All other characters are permitted"?

No.

>- I thought "Information about who accesses an anonymous archive on a sensitive subject (e.g., sexual abuse) has strong privacy needs" was awkward 
>- at the very least, "who" has strong privacy needs, but the sentence seems to say the information has strong privacy needs. Possibly "Anyone who accesses an anonymous archive on a sensitive subject (e.g. sexual abuse) likely has strong privacy needs"?

Works for me.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 14 Dec 2004 20:50:16 -0800

Obsoletes: RFC 2245

As Stringprep says:

No.

Works for me.