Subject: Fwd: I-D ACTION:draft-zeilenga-sasl-rfc2222bis-00.txt

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 17 May 2005 17:30:07 -0700

Please consider the following draft as a replacement for
draft-ietf-sasl-rfc2222bis-xx.txt.

It became apparent to me some time ago that resolution of
the general readability issues (organization, terminology,
etc.) could only be resolved by significantly rewriting the
WG I-D, this I-D is one possible rewrite of the WG I-D.  And
that once rewritten, it would be easier to resolve any
lingering technical issues.  This I-D is a major rewrite
which attempts to resolve the general readability issues
as well as lingering technical issues.
 
As it is a major rewrite, it is best considered in whole.
Hence, with Tom's approval, we have individually submitted
this I-D and now request WG consideration.

As it is a major rewrite, it is difficult to enumerate
all of the differences between this I-D and the WG's I-D.
(The differences between this I-D and RFC 2222 are
summarized in the I-D.) I do note that security consideration
section undergone significant changes.  A lot of issues in
RFC2222 and/or WG I-D have been dealt with as security
considerations.  That is, this I-D is generally more
descriptive of security issues and possible approaches for
adding them than prescriptive to what approach protocols,
mechanisms, and/or implementations should use to address
security issues.  It is also noted that non-normative
"relationship to transport security" appendix has been
dropped.  This topic in at least one general Internet
security RFC.

I defer all chair action in regards the WG's RFC2222bis
deliverable, including this I-D, to Tom.

Kurt, as an individual contributor

>To: [email-masked]
>From: [email-masked]
>Date: Tue, 17 May 2005 15:45:30 -0400
>Subject: I-D ACTION:draft-zeilenga-sasl-rfc2222bis-00.txt
>Reply-To: [email-masked]
>
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>        Title           : Simple Authentication and Security Layer (SASL)
>        Author(s)       : A. Melnikov, K. Zeilenga
>        Filename        : draft-zeilenga-sasl-rfc2222bis-00.txt
>        Pages           : 29
>        Date            : 2005-5-17
>        
>The Simple Authentication and Security Layer (SASL) is a framework for
>  providing authentication and data security services in
>  connection-oriented protocols via replaceable mechanisms.  It provides
>  a structured interface between protocols and mechanisms.  The
>  resulting framework allows new protocols to reuse existing mechanisms
>  and allows old protocols to make use of new mechanisms.  The framework
>  also provides a protocol for securing subsequent protocol exchanges
>  within a data security layer.
>
>  This document describes how a SASL mechanism is structured, describes
>  how protocols include support for SASL, and defines the protocol for
>  carrying a data security layer over a connection.  Additionally, this
>  document defines one SASL mechanism, the EXTERNAL mechanism.
>
>  This document obsoletes RFC 2222.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-zeilenga-sasl-rfc2222bis-00.txt
>
>To remove yourself from the I-D Announcement list, send a message to 
>[email-masked] with the word unsubscribe in the body of the message.  
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
>to change your subscription settings.
>
>
>Internet-Drafts are also available by anonymous FTP. Login with the username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>        "get draft-zeilenga-sasl-rfc2222bis-00.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html 
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>        [email-masked].
>In the body type:
>        "FILE /internet-drafts/draft-zeilenga-sasl-rfc2222bis-00.txt".
>        
>NOTE:   The mail server at ietf.org can return the document in
>        MIME-encoded form by using the "mpack" utility.  To use this
>        feature, insert the command "ENCODING mime" before the "FILE"
>        command.  To decode the response(s), you will need "munpack" or
>        a MIME-compliant mail reader.  Different MIME-compliant mail readers
>        exhibit different behavior, especially when dealing with
>        "multipart" MIME messages (i.e. documents which have been split
>        up into multiple messages), so check your local documentation on
>        how to manipulate these messages.
>                
>                
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>
>Content-Type: text/plain
>Content-ID: <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-zeilenga-sasl-rfc2222bis-00.txt
>
>
><ftp://ftp.ietf.org/internet-drafts/draft-zeilenga-sasl-rfc2222bis-00.txt>
>_______________________________________________
>I-D-Announce mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/i-d-announce

---

From: Ken Murchison <[email-masked]>
Date: Mon, 23 May 2005 13:00:23 -0400

> draft-ietf-sasl-rfc2222bis-xx.txt.

I don't have any major problems with the format or content of this 
rewrite.  I didn't spot any technical errors after a quick first read, 
but there are a number of spelling/grammatical nits which I can 
enumerate if we decide to move forward with this doc.

-- 
Kenneth Murchison     Oceana Matrix Ltd.
Software Engineer     21 Princeton Place
716-662-8973 x26      Orchard Park, NY 14127
--PGP Public Key--    http://www.oceana.com/~ken/ksm.pgp

---

From: Ken Murchison <[email-masked]>
Date: Mon, 23 May 2005 13:00:23 -0400