Subject: Re: Some questions regarding LDAP schema registration

From: [email-masked] (Christopher W Apple)
Date: Mon, 12 Oct 1998 17:16:34 -0400 (EDT)

>  Could somebody please answer some of my questions
>  regarding LDAP schema registration process ?
>
>  1. Is there now a process to register an LDAP schema ?
>      I remember some work was started sometime last year.

There is no working system right now. My understanding was
that the Internet Directory Consortium was to pick up the
development and operations responsibility for it. Maybe someone
from that org will see this message and respond with status.

The documents are dependent on other documents which have not
made it through the pipe yet. I do not think that an IETF
Last Call will be issued for the schema listing service documents
until the other documents make it through.

>  2. How can I find out which LDAP schemas people have
>      defined so far ?

Post a message to the LDAP-related mailing lists asking about
particular types of schema. Right now, I believe this is the
only way of finding out what work has been done (other than
that in the LDAP specs).

>
>  3. Is there a process to avoid conflicts in attribute names
>      and object class names in the LDAP schemas defined
>      by various people ?  If not, then how do 2 LDAP directory
>      applications which define a same attribute name (or object class)
>      with different semantics work with a single LDAP directory ?

These questions are consistent with the spirit of what the
the schema listing proposal review process (defined in the
schema listing service documents) was supposed to insure against.
There are also supposed to be searching facilities associated with
the listing service that would enable schema writers to discover
if an attribute or object class name has beed used before.

There are pointers to all schema listing service documents at

	http://www.ietf.org/html.charters/schema-charter.html

>  thanks
>  sanjay

------------------------------------------------------------------------
Chris Apple                     Business Site: AnyWho Directory Service
Internet Directory Group                       http://www.anywho.com
AT&T Labs
[email-masked]
+1 908 582 2409                 Tired of slow directories?  Try AnyWho.
------------------------------------------------------------------------

---

From: Chris Harding <[email-masked]>
Date: Tue, 13 Oct 1998 07:18:19 +0100

The Schema Registry is something that the Internet Directory Consortium
wants to do. But the funding model for a registry of this kind is
difficult. It costs, not a lot, but something, to set up and run. The
costs are unlikely to be recovered through operating the registry -
if there is a big (or any?) charge to use it, people probably won't.
So the best way is through a consortium of some kind, funded by companies
that want to see it established because it will help their business.
The position right now is that we don't have the level of commitment 
that would enable us to set it up and run a registry. 

So, if you want to see one, talk to your management and pursuade them
to sign up! To do this, contact Clive Betteridge -
[email-masked] -
or myself.

>	http://www.ietf.org/html.charters/schema-charter.html

Regards,

Chris
+++++

-------------------------------------------------------------------------
           Chris Harding
  T H E    Development Manager
 O P E N   Apex Plaza, Forbury Road, Reading RG1 1AX, UK
G R O U P  Mailto:[email-masked]   Ph: +44 118 950 8311 x2262
           WWW: http://www.opengroup.org    Fx: +44 118 950 0110  

OSF/1, Motif, UNIX and the "X" device are registered trademarks in
the US and other countries, and IT DialTone and The Open Group are
trademarks of The Open Group.
-------------------------------------------------------------------------

---

From: Chris Newman <[email-masked]>
Date: Tue, 13 Oct 1998 15:05:11 -0700 (PDT)

> that would enable us to set it up and run a registry. 

I'd further add that lacking a registry, the only way to make a schema for
general-purpose use (as opposed to vendor-specific use) is to write a
standards track RFC for the schema.  I actually think this model has
worked well for SNMP MIBs which certainly resemble schemas in a number of
ways. 

		- Chris

---

From: [email-masked] (Sanjay Jain)
Date: Tue, 13 Oct 1998 16:54:34 -0700

> worked well for SNMP MIBs which certainly resemble schemas in a number of

 But this model does not prevent somebody to redefine an attribute or object class with
name which has already
 been used. Or does it ?

 sanjay