Subject: [scim] PRECIS questions

From: Sarah Mundy <[email-masked]>
Date: Mon, 31 Aug 2020 08:22:03 -0700

Hi all,

A couple of questions about PRECIS string comparison for SCIM 2.0:

1. The SCIM 2.0 spec references RFCs 7564 and 7613, which are obsolete
drafts of PRECIS. Are folks instead using the final versions, RFCs 8264 and
8265?

2. Can anyone point me to a stable, open-source library of PRECIS tools,
preferably in Java? What are other server implementers using? I haven't
been able to find anything but maybe I am not using the right keywords in
my searches.

Thanks,
Sarah

---

From: Phil Hunt <[email-masked]>
Date: Wed, 9 Sep 2020 10:59:46 -0700

Sarah,

In general when another spec is referenced, the published reference remains in existing drafts. Instead, the RFC editor marks the reference (e.g. RFC7613) as “updated" by or “obsoleted" by to let implementers know while preserving referential and historical integrity. 

IMO SCIM implementers should be looking at RFC8265 as it is more broad based than SASLprep and in my opinion more applicable to the SCIM and OAuth community.

I hadn’t gotten around to this myself, and I too would be interested in open source PRECIS library references.

Phillip Hunt
[email-masked]

> On Aug 31, 2020, at 8:22 AM, Sarah Mundy <[email-masked]> wrote:
> 
> Hi all,
> 
> 1. The SCIM 2.0 spec references RFCs 7564 and 7613, which are obsolete drafts of PRECIS. Are folks instead using the final versions, RFCs 8264 and 8265?
> 
> 2. Can anyone point me to a stable, open-source library of PRECIS tools, preferably in Java? What are other server implementers using? I haven't been able to find anything but maybe I am not using the right keywords in my searches.
> 
> Thanks,
> Sarah
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim