Subject: [Sdn] Agenda items for Vancouver?

From: David Meyer <[email-masked]>
Date: Mon, 18 Jun 2012 08:23:07 -0700

Folks,

Lars has informed me that we're going to get a slot at Vancouver for
an BoF around a possible SDN Research group. What I'd like to get is a
set of agenda items that could form the basis of SDN RG. Please send
me your ideas for agenda items and I'll put an draft agenda together
for your review.

Thnx,

--dmm

---

From: "David Lake (dlake)" <[email-masked]>
Date: Mon, 18 Jun 2012 21:46:29 +0200

Dave

I'd like to discuss how "SDN" is perceived/defined from an application
viewpoint - in other words, as a content provider, how I access the
elements between myself and the consumer to deliver the service through
the "programmability" protocol/API/framework/whatever.

David

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
David Meyer
Sent: Monday, June 18, 2012 8:23 AM
To: SDN IRTF list
Cc: Nick Feamster
Subject: [Sdn] Agenda items for Vancouver?

Folks,

Lars has informed me that we're going to get a slot at Vancouver for an
BoF around a possible SDN Research group. What I'd like to get is a set
of agenda items that could form the basis of SDN RG. Please send me your
ideas for agenda items and I'll put an draft agenda together for your
review.

Thnx,

--dmm
_______________________________________________
sdn mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sdn

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 18 Jun 2012 20:00:50 +0000

David, 

Is SDN already a WG under the IRTF? See the charter : http://www.1-4-5.net/~dmm/sdnrg.html

Why it is still a BoF instead of regular WG meeting for Vancouver? I am a little confused. 

Linda

> Sent: Monday, June 18, 2012 10:23 AM
> To: SDN IRTF list
> Cc: Nick Feamster

---

From: David Meyer <[email-masked]>
Date: Mon, 18 Jun 2012 13:37:20 -0700

Linda,

> Why it is still a BoF instead of regular WG meeting for Vancouver? I am a little confused.

No, there is no SDN RG yet. Lars wants us to meet in Vancouver to firm
up our plans/ideas and gauge interest before he makes a decision. Lars
can tell us more.

--dmm

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 19 Jun 2012 04:12:02 +0000

Hi,

My approach towards people who would like to start an RG is "act like you are one already." 

In other words, I'll approve rooms at the IETF for a year and make sure the meetings are on the agenda, and the RG instigators should use that time to build their community, meet and discuss research that is in scope. (And not spend a year discussing charter text. Charters are much less critical in the IRTF.)

Then, after a year, we sit down in the IRSG and discuss whether the proto-group had enough energy and was having useful enough discussions to formally charter it.

Lars
-- 
Sent from a mobile device; please excuse typos.

---

From: [email-masked]
Date: Tue, 19 Jun 2012 09:49:52 +0530 (IST)

Hi Dave,
  We had the following discussion earlier, would appreciate if you could
consider these for the agenda, if you want me to refine this with your
guidance, would much appreciate if you could offer the direction along
which to think.
 In general from IETF, i believe we can take the lead in brining
technologies beyond Ethernet MPLS, Carrier Ethernet, Wireless, Optical,
into the SDN fold.
  OSPF for example uses a standard graph optimizatino algorithms. Traffic
control in SDN, involving optimization problems and feedback control
would be another potential area we can look at.

  Thanks much.
Sitaraman
  >>>> On Tue, May 8, 2012 at 7:24 AM,  <[email-masked]> wrote:
>>>>> Hi Dave,
>>>>>  I meant to think the the Discovery of actual traffic flow across many
>>>>> devices would become more complex than one that is uniformly driven by
>>>>> a
>>>>> control plane constant figuration such as in plain MPLS-TP.
>>>>
>>>> Gotcha. Detection of flows has been a problem for schemes like Hedera
>>>> (see
>>>> http://static.usenix.org/event/nsdi10/tech/slides/al-fares.pdf);
>>>> basically how much does it cost to detect the flow and do you have
>>>> time to do anything about it?
>>>>
>>>>>  Dave, i am encouraged by Lars' call and it is likely that i will be
>>>>> at
>>>>> the receiving end of the knowledge to get me started off... if you
>>>>> could
>>>>> offer your further interaction time and guidance, i would put my
>>>>> energies
>>>>> in as and when time permits to do my bit to take this important
>>>>> paradigm
>>>>> shift in networking forward.
>>>>> Would much appreciate any furthe pointers you would advise.
>>>>
>>>> Sure, let's take this off line but I'll provide some pointers for you
>>>> to get going...
>>>>
>>>> --dmm
>>>>
>>>>> Thanks
>>>>> Sitaraman
>>>>>
>>>>>> On Tue, May 8, 2012 at 7:05 AM,  <[email-masked]> wrote:
>>>>>>> Hi,
>>>>>>>  Some of the questions i have is
>>>>>>>  Discovery:
>>>>>>>      A control plane driven configuration-determined flow can be to
>>>>>>> a
>>>>>>> large-extend discovered.  While offering flexibility in the control
>>>>>>> of traffic, is likely that the complexity could be transferred to
>>>>>>> monitoring beginning with discovery of network state.
>>>>>>
>>>>>> Not sure what you mean here. I agree a lot of initial config could be
>>>>>> discovered.
>>>>>>
>>>>>>>
>>>>>>> Cross Technology Handoffs:
>>>>>>>   Complexity of network operations could be,  to a large part,
>>>>>>> originated
>>>>>>> by multiplicity in the technologies. Cross technology handoffs are
>>>>>>> more
>>>>>>> often than not points of "interest" . This gives rise two questions,
>>>>>>>        a)  How is SDN to be defined for technologies other than
>>>>>>> Ethernet
>>>>>>> (MPLS,
>>>>>>> Carrier-Ethernet, GPON)?
>>>>>>
>>>>>> Yep, this is a great question.
>>>>>>
>>>>>>>               b) What are the SDN implications or how can SDN
>>>>>>> concept
>>>>>>> be
>>>>>>> leveraged in cross technology handoffs?
>>>>>>>
>>>>>>> OAM:
>>>>>>>        Ethernet OAM is vastly benefitted by fate-sharing MEP, MIP
>>>>>>> based
>>>>>>> OAM such
>>>>>>> as defined in 802.1ag and for MPLS in the G.8131.1/.2.   Fate
>>>>>>> sharing
>>>>>>> seems to logically mesh with the software defined control of
>>>>>>> forwarding
>>>>>>> plane.  Could we offer increased accuracy via finer control and
>>>>>>> granularity in OAM first per technology  transparent to the client
>>>>>>> server
>>>>>>> layer.  Specific OAM for adaptation layers.
>>>>>>
>>>>>> I've been talking quite a bit about the loss of fate-sharing (and its
>>>>>> implications) to the SDN crowd. As you point out, in cases where
>>>>>> we've
>>>>>> split control and data planes, we've generally "glued" the
>>>>>> fate-sharing back together with data plane OAM. Another great
>>>>>> question...
>>>>>>>
>>>>>>> Graph Theoretical  Operations of SDN Network.
>>>>>>>        Could combinatorial optimization methods be used to control
>>>>>>> traffic?
>>>>>>> For congestion control. Would such methods become more amenable with
>>>>>>> SDN in play?
>>>>>>>
>>>>>>> Interrelationship with OSS SDO.
>>>>>>>        What would be the intterelationship with OSS interfaces,  how
>>>>>>> would
>>>>>>> across-the-board OSS scenarios be different would it require
>>>>>>>        a)different information models?
>>>>>>>        b)different interfaces acting upon them?
>>>>>>>        c)different fault analysis across-the-board of the network?
>>>>>>
>>>>>> Yep, there are lots of players in this game, IETF, IEEE, ITU-T, MEF,
>>>>>> DTMF, ONF, ...
>>>>>>
>>>>>> --dmm

> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
>

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: "Myung-Ki Shin" <[email-masked]>
Date: Tue, 19 Jun 2012 13:34:19 +0900

Hi, 

As described in a proposed charter, I think SDN description languages
(including formal specification)
and APIs issues could be also considered as one of agenda items to form the
basis of SDNRG.

Thanks, 
Myung-Ki SHIN, ETRI

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David
Meyer
Sent: Tuesday, June 19, 2012 12:23 AM
To: SDN IRTF list
Cc: Nick Feamster
Subject: [Sdn] Agenda items for Vancouver?

Folks,

Lars has informed me that we're going to get a slot at Vancouver for an BoF
around a possible SDN Research group. What I'd like to get is a set of
agenda items that could form the basis of SDN RG. Please send me your ideas
for agenda items and I'll put an draft agenda together for your review.

Thnx,

--dmm

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 19 Jun 2012 07:09:13 +0200

You are correct; however, Lars wants us to treat things as if there is a wg.  One of the main points of the meeting in Vancouver is to sort out the charter and determine real interest levels as well as topic focus.

Tom

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 19 Jun 2012 06:02:27 +0000

s/WG/RG/ (I often make this mistake too :-)

And while discussing the charter is important to some degree, I think you should use most of the time to bring in the folks who are actively doing research this space and discuss their relevant research.

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 19 Jun 2012 09:17:40 +0200

> s/WG/RG/ (I often make this mistake too :-)

RG! :)

> And while discussing the charter is important to some degree, I think you should use most of the time to bring in the folks who are actively doing research this space and discuss their relevant res…

Precisely.

tom

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 19 Jun 2012 19:34:48 +0000

Hi,

> the "programmability" protocol/API/framework/whatever.
In that sense, you may have a look at a document we have just published
on SDN-ALTO interaction: http://datatracker.ietf.org/doc/draft-xie-alto-sdn-use-cases/

I wonder whether this could be of interest to the group and be discussed in
Vancouver.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at.
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 27 Jun 2012 19:10:22 -0400

just another reminder to please submit your proposals for topics for the meeting. we are formulating the agenda now and want to make sure we get as much fruitful discussion at the meeting as possible.

Tom

---

From: "Diego R. Lopez" <[email-masked]>
Date: Thu, 28 Jun 2012 23:33:31 +0000

Hi,

> just another reminder to please submit your proposals for topics for the meeting. we are formulating the agenda now and want to make sure we get as much fruitful discussion at the meeting as possib…

Just to make it formal, I'd like to ask for the opportunity of discussing on the
ideas around the ALTO-SDN interactions, and the protocol for inter-domain controller
communication.

Since I have already replied a message from Thomas on solutions and research, let
me remark that in the first case I'd like to use it to illustrate the possibilities
of using a semantically sound representation of the network (ALTO is a starting point
for it) in combination with SDN, in the second it would be about the need for
collaboration between different domains and how this can be achieved by means of
a mechanism to allow controller interaction.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

---

From: "Myung-Ki Shin" <[email-masked]>
Date: Fri, 29 Jun 2012 09:03:48 +0900

Hi all, 

We have submitted the revised I-D, titled 
Formal Specification for Software-Defined Networks (SDN)
http://tools.ietf.org/id/draft-shin-sdn-formal-specification-01.txt

We think that one of important properties of SDN is to provide formally
verifiable 
networking framework which cover formal specification, verification, etc.
In SDN, incomplete or malicious programmable entities could cause break-down
of underlying networks shared by heterogeneous devices and stake-holders.

I would like to ask for the opportunity of discussing on the ideas around 
SDN description languages, tools, and API issues at upcoming SDNRG BoF.

Thanks, 
Myung-Ki, 

-----Original Message-----
From: Myung-Ki Shin [mailto:[email-masked]] 
Sent: Tuesday, June 19, 2012 1:34 PM
To: 'David Meyer'; SDN IRTF list
Cc: Nick Feamster
Subject: RE: [Sdn] Agenda items for Vancouver?

Hi, 

As described in a proposed charter, I think SDN description languages
(including formal specification) and APIs issues could be also considered as
one of agenda items to form the basis of SDNRG.

Thanks,
Myung-Ki SHIN, ETRI

-----Original Message-----

Folks,

Thnx,

--dmm