Subject: [Sdn] IETF 93 - Tutorial for SDN OpenFlow and ForCES

From: "King, Daniel" <[email-masked]>
Date: Sat, 20 Jun 2015 19:58:21 +0000

Hi All,

There will be a "Tutorial for SDN OpenFlow and ForCES" at IETF 93 on Sunday, July 19, 2015. The tutorial info page is at  ietf.org/meeting/93/tutorials/sdn.html<http://ietf.org/meeting/93/tutorials/sdn.html>.

Presented by: Yaakov Stein and Evangelos Haleplidis
Day: Sunday, July 19, 2015
Time: 15:00-17:00
Room: TBD
Description:

1. The ideas behind the recent awaking of SDN
2. How an SDN is different from a conventional (routed) network
3. The components and interfaces of an SDN (SDN (whitebox) switch, SDN controller, SBI, NBI)
4. NFV
5. The southbound interfaces (OpenFlow, ForCES, ...)
     5.1 Zoom in on OpenFlow
     5.2 Zoom in on ForCES
<<

Check the Tutorial link for room assignment closer to the session.

BR, Dan.

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 24 Jun 2015 16:46:53 -0700

Where does I2RS fit in within this framework?  Is it not considered SDN?

Anoop

On Sat, Jun 20, 2015 at 12:58 PM, King, Daniel <[email-masked]>
wrote:

> Hi All,
>
> There will be a "Tutorial for SDN OpenFlow and ForCES" at IETF 93 on
> Sunday, July 19, 2015. The tutorial info page is at
> ietf.org/meeting/93/tutorials/sdn.html<
> http://ietf.org/meeting/93/tutorials/sdn.html>.
>
> >>
> _______________________________________________
> sdn mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/sdn
>
>

---

From: "King, Daniel" <[email-masked]>
Date: Fri, 26 Jun 2015 08:59:53 +0000

Hi Anoop,

Depends, which SDN framework do we want to discuss. ☺

Personally, I do see I2RS as method of programmatic control  (read and write) of routing state and intent. This certainly sounds like SDN capability to me. To be fair to the organizers, 2hrs is a limited window for an SDN tutorial and therefore it is not unreasonable to constrain the discussion to only two southbound protocols.

BR, Dan.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: 25 June 2015 00:47
To: King, Daniel
Cc: [email-masked]
Subject: Re: [Sdn] IETF 93 - Tutorial for SDN OpenFlow and ForCES

Anoop

On Sat, Jun 20, 2015 at 12:58 PM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

There will be a "Tutorial for SDN OpenFlow and ForCES" at IETF 93 on Sunday, July 19, 2015. The tutorial info page is at  ietf.org/meeting/93/tutorials/sdn.html<http://ietf.org/meeting/93/tutorials/sdn.html><http://ietf.org/meeting/93/tutorials/sdn.html>.

BR, Dan.

_______________________________________________
sdn mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/sdn

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Fri, 26 Jun 2015 22:58:05 +0300

Greetings Daniel and Annop,

That’s exactly the reason for the focus of the tutorial. We simply don’t have enough time, it’s a lot of material to cover. This topic could certainly cover a multi-day tutorial.

Anoop, in regards to I2RS, you can also check out RFC7426 (https://tools.ietf.org/html/rfc7426) for an example of how I2RS fits in the SDN framework.

Regards,

Evangelos.

From: sdn [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: Friday, June 26, 2015 12:00 PM
To: Anoop Ghanwani
Cc: [email-masked]
Subject: Re: [Sdn] IETF 93 - Tutorial for SDN OpenFlow and ForCES

Hi Anoop, 

Depends, which SDN framework do we want to discuss. J

BR, Dan. 

Anoop

On Sat, Jun 20, 2015 at 12:58 PM, King, Daniel <[email-masked]> wrote:

Hi All,

BR, Dan.