Subject: [Sdn] role based intent

From: Zhoutianran <[email-masked]>
Date: Wed, 3 Jun 2015 06:29:45 +0000

Hi Dave, Stuart, Bob and all,

I found many problems raised in the mailing list are coursed by the layered intent thinking. Maybe we are tainted by the ISO model:-)

For the layered intent, intent is a spectrum, very abstract at the top layer, more network specific and less abstract when the layer goes down. The problem is that the boundary of intent and non intent is vague. Or there is no boundary between this two, since one's what may be another one's how. And consequently, it looks like everything is intent and no clear intent definition.

The role based intent will provide only one intent layer. That is always the top layer abstraction for each role, as shown in the following figure. The functions can be layered as the implementation of the intent layer.

With the role based intent, although the end user's intent is much abstracted then the network administrator's intent, they are not related each other. I.e., the end user will not use the administrator's intent. And the admin will not provide additional services/interfaces to the end user.

The essential of layering is that the lower layer will provide interface to the higher layer. In order to fit up layer requirements, the lower layer will provide adequate interfaces/capabilities. That also means too much information for a dedicated up layer user/app.

For role based intent, we can firstly indentify various roles (no need to be complete, but those with attention), and then figure out the intent of each role. In this way, intent can be clear defined. That will also keep the intent of each role to a small set on what they really cares about, without expending to support other one's intent.

Best Regards,

Terence

---

From: Dave Hood <[email-masked]>
Date: Wed, 3 Jun 2015 13:03:16 +0000

Layering is the right issue, but the point is a little different. We, who look at the global scenario from the perspective of the gods, see that there is a recursion of clients/servers or customers/providers or ....

But from the perspective of any one of those interfaces, the other layers are completely invisible. So a given app can invoke intent against a given SDN controller, but the controller doesn't know whether the app is just a middleman, and the app doesn't know whether the controller can satisfy its requirements directly or whether it is also just a middleman.

You can have one intent layer, as long as you recognize that you are only seeing one slice of the world. If you insist on only one northernmost intent layer in toto, you will have to go back to the "make money" intent of the investors.

And if we recognize that each interface stands on its own, then any service invocation across that interface qualifies as an expression and satisfaction of intent by that particular invoker-provider pair.

Dave

From: Zhoutianran [mailto:[email-masked]]
Sent: Tuesday, June 02, 2015 11:30 PM
To: Dave Hood; STUART VENTERS; Natale, Bob
Cc: [email-masked]; [email-masked]
Subject: role based intent

Best Regards,

Terence

---

From: Xiayinben <[email-masked]>
Date: Wed, 3 Jun 2015 15:53:02 +0000

Hi Dave,

I think the meaning of ‘one intent layer’ is that each role has one intent layer but not all roles have one intent layer.
And we don’t need care about the layer relationship between different role’s intent. So  in general, there is only one intent layer.
Do you think this is acceptable?

Yinben

发件人: Ibnemo [mailto:[email-masked]] 代表 Dave Hood
发送时间: 2015年6月3日 21:03
收件人: Zhoutianran; STUART VENTERS; Natale, Bob
抄送: [email-masked]; [email-masked]
主题: Re: [Ibnemo] role based intent

Layering is the right issue, but the point is a little different. We, who look at the global scenario from the perspective of the gods, see that there is a recursion of clients/servers or customers/providers or ….

But from the perspective of any one of those interfaces, the other layers are completely invisible. So a given app can invoke intent against a given SDN controller, but the controller doesn’t know whether the app is just a middleman, and the app doesn’t know whether the controller can satisfy its requirements directly or whether it is also just a middleman.

You can have one intent layer, as long as you recognize that you are only seeing one slice of the world. If you insist on only one northernmost intent layer in toto, you will have to go back to the “make money” intent of the investors.

Dave

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

For role based intent, we can firstly indentify various roles (no need to be complete, but those with attention), and then figure out the intent of each role. In this way, intent can be clear defined. That will also keep the intent of each role to a small set on what they really cares about, without expending to support other one’s intent.

Best Regards,

Terence

---

From: Dave Hood <[email-masked]>
Date: Wed, 3 Jun 2015 15:59:24 +0000

I do think this is acceptable, but it takes us back to the point that any NBI conveys intent, for its user and its provider in its context, which renders the concept not particularly useful. It would be really helpful to see a concrete example of something that we can all agree is *not* intent.

Dave

From: Xiayinben [mailto:[email-masked]]
Sent: Wednesday, June 03, 2015 8:53 AM
To: Dave Hood; Zhoutianran; STUART VENTERS; Natale, Bob
Cc: [email-masked]; [email-masked]
Subject: 答复: role based intent

Hi Dave,

Yinben

发件人: Ibnemo [mailto:[email-masked]] 代表 Dave Hood
发送时间: 2015年6月3日 21:03
收件人: Zhoutianran; STUART VENTERS; Natale, Bob
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Ibnemo] role based intent

Dave

Best Regards,

Terence

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 3 Jun 2015 22:12:42 -0400

Tiaran/Terence: 

Very interesting concept.  It is the grouping of roles that make the intent
layer.  We look to this grouping the top of very specific acyclic graphs of
lower layer functions.  This emergence of the intent out of the essence of
being is a new thought.  Your theoretical examples are very interesting -
but can you give me an example. 

In another two field (organizational dynamics and general systems theory),
you are talking about groupings of functions emerging as systems.   Does
this  formal language John Strassner was suggesting something like this
idea? 

This is really insightful concept.  Can you give me  an example? 

Sue 

From: Ibnemo [mailto:[email-masked]] On Behalf Of Zhoutianran
Sent: Wednesday, June 03, 2015 2:30 AM
To: Dave Hood; STUART VENTERS; Natale, Bob
Cc: [email-masked]; [email-masked]
Subject: [Ibnemo] role based intent

I found many problems raised in the mailing list are coursed by the layered
intent thinking. Maybe we are tainted by the ISO model:-)

For the layered intent, intent is a spectrum, very abstract at the top
layer, more network specific and less abstract when the layer goes down. The
problem is that the boundary of intent and non intent is vague. Or there is
no boundary between this two, since one's what may be another one's how. And
consequently, it looks like everything is intent and no clear intent
definition.

The role based intent will provide only one intent layer. That is always the
top layer abstraction for each role, as shown in the following figure. The
functions can be layered as the implementation of the intent layer.

With the role based intent, although the end user's intent is much
abstracted then the network administrator's intent, they are not related
each other. I.e., the end user will not use the administrator's intent. And
the admin will not provide additional services/interfaces to the end user.

The essential of layering is that the lower layer will provide interface to
the higher layer. In order to fit up layer requirements, the lower layer
will provide adequate interfaces/capabilities. That also means too much
information for a dedicated up layer user/app.

For role based intent, we can firstly indentify various roles (no need to be
complete, but those with attention), and then figure out the intent of each
role. In this way, intent can be clear defined. That will also keep the
intent of each role to a small set on what they really cares about, without
expending to support other one's intent.

Best Regards,

Terence

---

From: Xiayinben <[email-masked]>
Date: Thu, 4 Jun 2015 03:41:44 +0000

OK. If you agree that an intent is related with specific user’s role, so *not* intent is also related with user. What the user doesn’t care is not his intent.
For example, BD of SP’s intent is providing higher SLA guarantee to user’s flow than background flow. But that moving background flow to other path or blocking background flow are not BD’s concern, so this is not BD’s intent.

About NBI design, I think any system has its specific target users, SDN controller is no exception.
So when we clarify the target user of SDN controller, we will be able to clearly define what is intent interface of SDN controller.
Hope this is useful. :)

Yinben

发件人: Dave Hood [mailto:[email-masked]]
发送时间: 2015年6月3日 23:59
收件人: Xiayinben; Zhoutianran; STUART VENTERS; Natale, Bob
抄送: [email-masked]; [email-masked]
主题: RE: role based intent

Dave

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi Dave,

Yinben

Dave

Best Regards,

Terence