Subject: [seamoby] HMIPv6 & regional registrations

From: [email-masked]
Date: Tue, 30 Jan 2001 11:32:36 +0200

James,

> There are other consequences. HMIPv6 exposes the Local 
> Care-of Address for the same reason. Thus, MIPv6 derives 
> no hierarchy hiding benefits from HMIP. Also, I suspect that 
> the need for authentication will make network assisted 
> handoff during dormant mode difficult, because the access routers 
> need to do the  binding update to the home agent while the mobile 
> is in dormant mode.

Is this the case for both the hierarchical MIPv6 & MIPv6 with
regional registrations?  If so, this could then be part of the
problem we wish to solve would be some sort of localized
mobility which doesn't encounter the same problems.

br,
John

---

From: James Kempf <[email-masked]>
Date: Tue, 30 Jan 2001 01:56:07 -0800

John,

>mobility which doesn't encounter the same problems.

I'm not sure about MIPv6 with regional registrations, but it certainly is 
true of
regular mode HMIPv6.

                 jak

---

From: Claude Castelluccia <[email-masked]>
Date: Tue, 30 Jan 2001 12:51:39 +0100

James,

Could you explain me why this is true for HMIPv6?
I am very interested ;-)....

Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: James Kempf <[email-masked]>
Date: Tue, 30 Jan 2001 08:02:33 -0800

Claude,

>I am very interested ;-)....

After looking over the draft, I see that you are right. The LCoA
only goes to the CN if they are on the same link.

However, the draft does say that the mobile can send the LCoA
to the last MAP. This is certainly a way for hierarchical information
to leak out. This won't work if, for example, the LCoA is a site-local
address. Shouldn't the last MAP be treated like any other corresponding
node?

                 jak

---

From: Claude Castelluccia <[email-masked]>
Date: Tue, 30 Jan 2001 18:00:03 +0100

> only goes to the CN if they are on the same link.

actually both solutions are possible: a MN can either use its LCoA or RCoA

as source address....

> address. Shouldn't the last MAP be treated like any other corresponding

you are right but I think we should allow both solutions and let the MN
decide which solution to use....

The MN should probably use its LCoA to register with its previous MAP if
the new and previous MAP belong to the same site and administrative domain

(the routing will then be optimal).

The MN should (or must) probably use its new RCoA to register with its
previous MAP if the new MAP is in an other site or administration
domain....

does it make sense?

regards,

Claude.

--

---

From: James Kempf <[email-masked]>
Date: Tue, 30 Jan 2001 12:26:07 -0800

Claude,

At 06:00 PM 1/30/01 +0100, Claude Castelluccia wrote:
>previous MAP if the new MAP is in an other site or administration domain....
>
>does it make sense?

Yes, but I think the draft needs to make this clearer.

                 jak