Subject: RE: [seamoby] More beating my head against the wall....

From: "Gary Kenward" <[email-masked]>
Date: Fri, 19 Jan 2001 00:19:08 -0500

You are preaching to the choir, as you fully well know.
My point was, is there quantitative justification for the statement you
made that MIP is too slow?

Gary

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, January 18, 2001 3:38 PM
> To: Kenward, Gary [WDLN2:AN10:EXCH]
> Cc: [email-masked]
> Subject: RE: [seamoby] More beating my head against the wall....
> 
> 
> 
> 
> 
> 
> 
> 
> Sent by:  "Gary Kenward" <[email-masked]>
> 
> *snip*
> 
> 
> I would tend to agree with you Phil, but do we have tangible 
> evidence that
> the MIP routing is too slow, and the routing at the edge is 
> required? I
> *believe*
> it is a problem, but I suspect the claim would be contentious without
> numbers.
> 
> pdn>If it were not slow (my measurements done about 2 years 
> back indicated
> pdn>that it was), why would the MIP group be so actively pursuing fast
> pdn>handoff?  My REAL belief is that fast hand off work belongs in
> pdn>SeaMoby.  That is if you are willing to seperate the world into
> pdn>Core routing (mobile IP) and edge tunnelling (SeaMoby).  
> This type of
> pdn>division of labor makes MUCH more sense to me technically, but the
> pdn>politics of such a reorganization make its possibility of 
> existence
> pdn>tenuous.  Just think how the MIP group would be free to 
> worry about
> pdn>optimizing the router chains for mobility rather than edge device
> pdn>junk.  SeaMoby would only have to worry about eventually sending a
> pdn>new MIP registration while a temporary tunnel keeps the connection
> pdn>seamless.  Perhaps I really am wacked, but this is the way I see
> pdn>it.
> 
> 
> 
>

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Fri, 19 Jan 2001 10:05:43 -0800

RE: [seamoby] More beating my head against the wall....

---
Andrew
http://comet.columbia.edu/~campbell

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On
Behalf Of Gary Kenward
  Sent: Thursday, January 18, 2001 9:19 PM
  To: [email-masked]'
  Cc: [email-masked]
  Subject: RE: [seamoby] More beating my head against the wall....

  [Andrew T. Campbell]

  Nop!

  Gary

---

From: "Dave Martin" <[email-masked]>
Date: Sun, 21 Jan 2001 10:12:02 -0500

RE: [seamoby] More beating my head against the wall....In our current Mobile IP network (MIPv4), it takes several seconds (~3) to change FAs (COA).  L2 plays almost no part in this delay (our L2 *can* support realtime data traffic).  If necessary I can provide more detail on the delay budget, but I hope that we can agree that MIP as it is today would not support real time services (e.g. voice).

So I would content that MIP (current version) is too slow to support mobility between FAs.

I would also contend that MIP will probably always be too slow unless something is done to optimize the "edge" to bridge the gap while the "core" is updated with new routing information.  My definition of "edge" is the closest router to the mobile (AR), and my definition of core is the rest of the supporting network (HA, AAA, FA etc).

As a another voice in the choir ... I also believe that the fast-handoff work belongs in seamoby.

----- Original Message ----- 
  From: Gary Kenward 
  To: [email-masked]' 
  Cc: [email-masked] 
  Sent: Friday, January 19, 2001 12:19 AM
  Subject: RE: [seamoby] More beating my head against the wall....

  Gary

---

From: Pat Calhoun <[email-masked]>
Date: Sun, 21 Jan 2001 10:04:21 -0800 (PST)

> As a another voice in the choir ... I also believe that the fast-handoff
> belongs in seamoby.

Well, Mobile IP work items belong in Mobile IP. They have already fast handoff
in their charter, and I don't see why or how we could convince the IESG to
make them part with it for mere convenience.

Are you, then, stating that Micro-Mobility, or edge mobility, is a solved
problem in Mobile IP?

PatC

---

From: "Dave Martin" <[email-masked]>
Date: Sun, 21 Jan 2001 16:06:57 -0500

<snipping irrelevant thoughts about where fast-handoff belongs ... the fact
is that it is in the Mobile IP group and I should just accept that fact and
move on>

> Are you, then, stating that Micro-Mobility, or edge mobility, is a solved

Micro/edge mobility is already solved in most large wireless networks, it's
just that there is no global standard, and that the mobility is typically
done at layer 2.  There is value in having a unified standard to rally
around, and to formally define how layer 2 and layer 3 mobility protocols
should work together.

Your question does actually raise an interesting point. A HA's purpose is to
shield the rest of the network from changes in routing topology as a node
moves from subnet to subnet.  Isn't the intra-domain/micro-mobility problem
basically the same problem at a finer layer--namely to shield the HA from
changes in routing topology?

---

From: Phil Neumiller <[email-masked]>
Date: Tue, 23 Jan 2001 21:02:48 -0600

Hi Dave,

> around, and to formally define how layer 2 and layer 3 mobility protocols

This is a great observation.  When we started the OBAST work, open base
station transport, we observed LOTS (upto 90%), commonality between all
the worlds cellular systems (in what they actually do).  We thought that
a single bearer and signalling transport format (augmented by SCTP) could
be defined and absolutely hide any radio specific technology thus facilitating 
macro-diversity and handoff between heterogenous radio technologies.

This original OBAST concept has been lost in the formulation of the
SeaMoby charter. :-(  Its too bad, since it is something that fits nicely
in the IETF transport work area.  Maybe we can revive this as part of 
SeaMoby.

> changes in routing topology?

I like this thinking too.  Its sort of like applying a recursive algorithm.
But... then again, isn't this sort of how HMIP works?

Take it easy,

Phil