Subject: RE: [seamoby] MicroMobility Algorithm Outline Revision 0.0001

From: Kulwinder Atwal <[email-masked]>
Date: Wed, 3 Jan 2001 12:09:54 -0500

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Wednesday, January 03, 2001 11:10 AM
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [seamoby] MicroMobility Algorithm Outline Revision 0.0001
> 
> 
> Kulwinder,
> 
> My understanding from the presentation given several IETFs 
> back is that IP over 
> Bluetooth will use PPP. Please correct me if I am wrong on 
> this point.

This PPP/RFCOMM profile is completely optional, and should be viewed as 
an interm measure.  I would like to work with the IETF to find a better way
to put IP over Bluetooth. The Bluetooth SIG will "Rubber Stamp" it if it
comes from the IETF.  

> PPP is a 
> long way above the details of the L1 protocol that you have 
> presented below, if 
> I recall from the presentation correctly, and so would not be 
> able to make 
> direct use of this refined slot scheme. 

We can create a new profile called the "Roaming" profile.

> Given that, I don't quite see
> the problem with doing SAR. It would have to be fitted into L2/L2.5
> somewhere.

You can do SAR. 

But, you CANNOT fit a whole IPv6 packet in one slot when you have seven
slaves.  Each slave gets one packet per one slot per 10 mSec.  It will take
several slots per slave to do one IPv6 packet.  Therefore, it will take
longer that 10 mSec.  For real-time the limit is 10 mSec.  Therefore, within
10 mSec the max packet payload is 28 bytes.

So if you want to do real-time seamless mobility using IPv6 ( meaning you
want to use an IPv6 packet to switch a slave) it cannot be done because you
will go well over the 10 mSec time limit.

To summerize, SAR yes. 
Real-time Seamless Mobility (switch slaves using IPv6 in 10 mSec)
mathematically not possible.

Also, read my email to follow regarding what you saw in the June IETF BOF
for Bluetooth.

- Kulwinder. 

> 
> Or am I missing something?
> 
> 		jak
> 
> >From: Kulwinder Atwal <[email-masked]>
> >To: "'James Kempf'" <[email-masked]>, 
> [email-masked], 
> [email-masked], [email-masked]
> >Subject: RE: [seamoby] MicroMobility Algorithm Outline 
> Revision 0.0001
> >Date: Wed, 3 Jan 2001 10:52:29 -0500 
> >MIME-Version: 1.0
> >
> >I was waiting for this question.
> >Here we go.
> >
> >If we say that real-time is 10 mSec, then in 10mSec 
> Bluetooth has a total of
> >8 Master/Slave slot pairs.
> >
> >A Master/Slave slot pair is composed of one Master TX slot 
> and one Slave TX
> >slot. A slot is 625 microseconds.  A slot Master/Slave slot 
> pair is two of
> >these, or 1.25 milliseconds.
> >
> >There is a max of seven active slaves on a Bluetooth net. 
> >( 1.25 mSec x 7 = 8.75 mSec)
> >
> >Therefore, if we want all slaves to have the same number of 
> slots, then we
> >have one Master/Slave slot pair left over.  It is this pair 
> that we can use
> >to do seamless mobility in real-time (10 mSec).
> >
> >So, the phrase to focus on is "Real-time seamless mobility".
> >
> >Of course, we can do IP SAR to all seven MNs, but it will 
> not happen in
> >real-time.
> >
> >- Kulwinder. 
> >
> >> -----Original Message-----
> >> From: James Kempf [mailto:[email-masked]]
> >> Sent: Wednesday, January 03, 2001 8:41 AM
> >> To: [email-masked]; [email-masked];
> >> [email-masked]; [email-masked]
> >> Subject: RE: [seamoby] MicroMobility Algorithm Outline 
> Revision 0.0001
> >> 
> >> 
> >> 
> >> >> Thus, intra-network handover can be made to maintain some BE 
> >> >> support while
> >> >> the MN realizes that an inter-network handover is now 
> >> required per the
> >> >> subscriber's configuration. I think the intra-network 
> >> handover is what
> >> >> everyone is discussing as micromobility?
> >> >
> >> >I don't think using IP is a good idea for intra-network hand-off.
> >> >Just the IPv6 header is 40 bytes.  The largest single slot 
> >> packet that I can
> >> >send over Bluetooth has 28 bytes of payload.  This means 
> >> that Bluetooth
> >> >cannot use IPv6 to do real-time seamless mobility.
> >> >
> >> 
> >> I don't understand this statement. The Bluetooth device 
> simply needs
> >> to do segmentation and reassambly. CDMA radio frames are 
> also limited
> >> in size, and nobody is suggesting that IPv6 can't be used for
> >> mobility on CMDA.
> >> 
> >> 		jak
> >> 
>

---

From: Peter Lei <[email-masked]>
Date: Wed, 03 Jan 2001 12:06:48 -0600

Kulwinder,

[snip]
> mathematically not possible.

I don't follow this... Even with IPv4, without header compression you're
only going to get 8 bytes of payload, not including the TCP/UDP/SCTP header,
on this link...

Also, I'll point out that the SAR is already there-- see the first couple
of bits in the data header of the baseband payload in conjunction with
L2CAP...

--peter