Subject: [seamoby] Micromobility Problem Statement ISSUE 1

From: [email-masked]
Date: Wed, 3 Jan 2001 10:45:07 -0600

Nothing stays homogeneous very long.  The beauty of an IP based solution
is that it can evolve seperately from air interfaces.  The WHOLE point here is
take things that are "commonly done" by a majority of air interfaces to enact
micro
mobility, and place this over IP.  This way a new radio interface can be easily
 plopped in to an old system without breaking the signalling.  This is the most
important design principle for micro-mobility I can think of.

PROBLEM STATEMENT ISSUE 1
Existing air interfaces have a tendency to do the same things in different ways.
Our collective experience with many air interfaces over time has lead us to
believe that micro-mobility can be implemented as an IP based protocol.
This will allow air interface technology to evolve seperately from the handoff
algorithms that are deployed.

Sent by:  Kulwinder Atwal <[email-masked]>

To:   "'Mika Ylianttila'" <[email-masked]>, [email-masked]
cc:    (Phil Neumiller/MW/US/3Com)
Subject:  RE: [seamoby] MicroMobility Algorithm Outline Revision 0.0001

No, it just seems like a waste of effort.  Someone has to show me the real
value of doing this on a homogenous net.  Since we are talking about
real-time preformance, it would take time to compress/decompress.  If I can
do it without compression and get the same value I will.

- Kal.

> -----Original Message-----
> From: Mika Ylianttila [mailto:[email-masked]]
> Sent: Wednesday, January 03, 2001 6:13 AM
> To: [email-masked]
> Subject: RE: [seamoby] MicroMobility Algorithm Outline Revision 0.0001
>
>
> On Wed, 3 Jan 2001, Kulwinder Atwal wrote:
>
> >I don't think using IP is a good idea for intra-network hand-off.
> >Just the IPv6 header is 40 bytes.  The largest single slot
> packet that I can
> >send over Bluetooth has 28 bytes of payload.  This means
> that Bluetooth
> >cannot use IPv6 to do real-time seamless mobility.
>
>   Did you forget the possibility for header compression?  ;)
>
> --
> Mika Ylianttila
> M.Sc., Project Manager
> Centre for Wireless Communications
> PL 4500, Tutkijantie 2 E, FIN-90014
> University of Oulu, Finland
>
>

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Wed, 3 Jan 2001 14:27:22 -0800

Phil:

Your message is intriguing but throws up lots of challenges.

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of [email-masked]
> Sent: Wednesday, January 03, 2001 8:45 AM
> To: [email-masked]
> Subject: [seamoby] Micromobility Problem Statement ISSUE 1
> 
> 
> 
> 

This is an interesting and important point. Historically
wireless control has been a level 1 issue and one can be
radical (and academic) and say: why not build the key
controllers over IP with an eye to evolving simple radio
interfaces. 

One can look, for example, at the WCDMA UTRAN
and Core Network functions and implement them over IP. Clearly,
handoff control, and paging is feasible but some fast time
scale controllers such as fast power control make be more
challenging but the message (in a 3GPP/3GPP2 sense) is
why not build the UE, UTRAN and CN all over IP? 
I'm being a tad simplistic here to make the point.

I could make the same argument for cdma2000/TD-CDMA, etc.  

But regardless of whether people agree with 
"IP everywhere" for 3G networks I would argue that 
we need IP paging and handoff control at layer 3
regardless of what is happening at L1 today.

I would hedge my bets and predict that many of the 
L1 wireless and mobile control
functions will be implemented over IP as wireless connectivity
becomes the norm for Internet. In that case one could imagine that
future radios will be simple and interface to a set of 
programmable controllers over IP. These controllers 
could be implemented in a fully
distributed fashion and could be reused for a variety of
competing radio technology and environments. (With CIP we implemented 
IP handoff and paging in a fully distributed manner -
as a modest test case). 

> This will allow air interface technology to evolve separately 
> from the handoff