Subject: RE: [seamoby] problem statement and rechartering (was: Re: The ri ght protocol was RE: [seamoby-mm] ietf-seamoby-mm-pr oblem-00-a1.txt)

From: "Gary Kenward" <[email-masked]>
Date: Tue, 30 Jan 2001 14:47:54 -0500

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Sent: Tuesday, January 30, 2001 3:42 AM
> To: Dana L. Blair; Patrice Calhoun; Kulwinder Atwal
> Cc: 'Pat Calhoun'; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]'
> Subject: Re: [seamoby] problem statement and rechartering 
> (was: Re: The
> right protocol was RE: [seamoby-mm] ietf-seamoby-mm-pr 
> oblem-00-a1.txt)
> 
> 
> Dana,
> 
>> There are lots of innovations one could make in this area, 
> but I'm afraid that
> mobile IP has a certain amount of deployment momentum at the 
> moment. It
> would be really a shame, when mobile IP is right at the cusp 
> of becoming real
> after 10 years of hard work, to have energy diverted by a new 
> protocol. 

I'm with you to this point, James. But, if we were to follow this logic
through, we'd still be trying to get ISDN to work, or maybe even, 
*shudder* X.25.  I'm willing to bet that the total person years and
$$$ invested in both of these solutions far outweighs what has been
expended on MIP.

The telecom industry, and ITU, are  known for there inertia. Are you
implying
that the IETF must avoid developing better solutions simply because
people spent 10 years on a solution that wasn't needed?

Gary

>                          jak

---

From: James Kempf <[email-masked]>
Date: Tue, 30 Jan 2001 12:48:59 -0800

At 02:47 PM 1/30/01 -0500, Gary Kenward wrote:

>The telecom industry, and ITU, are  known for there inertia. Are you implying

If I thought that, I wouldn't have recommended micromobility be taken to 
the IRTF.
And if I thought mobile IP wasn't needed, I wouldn't be working
on fast handoff (and care so much that the right solution be adopted).

Mobile IP has made some straightforward
extrapolations from the wired case, but it is not clear that they
are optimal. The Seamoby micromobilty design team
has decided to restrict discussion of the need for a new micromobility
protocol to intrasubnet mobility. Now, it is not at all clear that this
is even a problem at L3 given support provided in L2 for mobility
between access points. I don't want to prejudge the outcome of
their process, but I have the impression that this decision was
as much influenced by the fact that mobile IP is the mobility
protocol of choice for the intersubnet case and the people who
have been pushing for doing a new micromobility protocol are
looking for some space where they can do some new work.
I don't think that's the right way to get the best mobility solution.

I think Phil N., Andrew C., and the others that have new ideas in
this area need some space where they can explore exactly
what is the right way to do mobility at the edge and in the
core, without regard to precedent. The IETF is not the
right place for this work, since the intent of IETF standards
is to facilitate interoperability and deployment. The IRTF
is.

The fact of the matter is that mobile IP has deployment momentum
even if it isn't the best (in some abstract sense) protocol given
what we know now. It clearly was when it was designed, and
the deployment momentum suggests we finish it and make
it available for the 3G's and others. After all, would the Internet
have ever happened if IPv4 had been abandoned  immediately when
Deering and others began to realize the problems it has?

                 jak