Subject: Re: [seamoby] Some thoughts on paging problem

From: James Kempf <[email-masked]>
Date: Thu, 4 Jan 2001 09:36:34 -0800 (PST)

Michael,

What I've described is basically the way CDMA works.

		jak
		
>From: Michael Thomas <[email-masked]>
>MIME-Version: 1.0
>Content-Transfer-Encoding: 7bit
>Date: Thu, 4 Jan 2001 09:27:37 -0800 (PST)
>To: <[email-masked]>
>Cc: "Michael Thomas" <[email-masked]>, <[email-masked]>, 
<[email-masked]>, <[email-masked]>, <[email-masked]>
>Subject: Re: [seamoby] Some thoughts on paging problem
>X-Face: &,heK/V66p?[2!i|tVn,9lN0TUvEv7:9FzXREj/AuzN4m<D]vnFJ>u!4x[/Z4t{V}~L]+Sk 
@RFNnJEg~WZ/(8<`5a),-7ukALWa^&?&D2R0CSG3kO5~#6JxLF\d,g">$%B!0w{W)qIhmwhye104zd 
bUcI'1!
>
>James Kempf writes:
> > It's different because the mobile comes up, sends a short registration
> > message to the RAN on a control channel (not a traffic channel), then
> > goes back to sleep again. The FA figures out because the RAN via
> > L2 tells it that a mobile has just moved into its paging area.
> > Minimizing traffic channel usage for this kind of signalling is
> > a requirement for some operators.
>
>   I've gotten the impression that you cannot count on the
>   mobile always re-registering mainly because to require
>   it to do so is not efficient batterywise (and probably
>   other reasons). I thought this was the ships-in-the-night
>   problem.
>
>   Reality check: I've been running on the assumption that
>   the paging problem to be solved is where the
>   last FA loses track of the exact location of
>   the MN, and may in fact not be attached to the
>   same interface and may not even be listening to 
>   the same technology's control channel. Are we
>   in sync here?
>
>		Mike

---

From: James Kempf <[email-masked]>
Date: Thu, 4 Jan 2001 12:57:37 -0800 (PST)

Ram,

>
>The conclusion that myself and Jim arrived at a few days ago was that
>IP paging could be circumvented IF a single FA always covered one
>whole paging area (the movement outside which an L2 update must be sent
>-
>this L2 update could then be used instead of a Mobile IP registration
>to update the network). However, I am not sure one FA will always
>map onto one paging area...in fact, this assumption really precludes
>implementing a network that has one FA per base station because
>paging areas typically consist of a set of base stations.
>
>To summarize, IP paging is needed if mobiles could move
>from the coverage of one FA to another FA without sending any updates
>(L2 or L3) - in this case, some messages need to be examined among
>the FAs to find the FA that currently serves the mobile.
>
>Hope this clarifies.

This is essentially correct. The one to one mapping of a paging
area to a subnet is required to use pro-active for paging.

Examining the other two cases we have:

1) Multiple FAs per paging area.

2) Multiple paging areas per FA.

Note that the first one would not work with proactive because if
the mobile is in dormant mode when it moves from one FA to another
there will be no L2 signal because it did not cross a paging
area boundary. When it does cross a paging boundary, it doesn't
cross a subnet boundary so there is no way for the FA to find
out where to send an incoming packet.

However, the second one would work. The reason is because when
the mobile moves from one paging area to another, L2 could take care of
updating the link address to CoA binding within the subnet, as
discussed in response to Gopal's scenario. Proactive isn't involved in
this case because the mobile is not moving subnets, but it
is still possible to cause the local subnet forwarding info
to be updated so the mobile is tracked at L3.

Comments?

		jak