Subject: Re: [seamoby-paging] RE: [seamoby] Some thoughts on paging proble m

From: Colin Elliott <[email-masked]>
Date: Tue, 9 Jan 2001 13:37:40 -0500

At 09:16 PM 20/12/00 -0500, Kulwinder Atwal wrote:

>> -----Original Message-----
>> From: Gopal Dommety [mailto:[email-masked]]
>> Sent: Wednesday, December 20, 2000 6:39 PM
>> To: James Kempf; [email-masked]; [email-masked]
>> Cc: [email-masked]; [email-masked];
>> [email-masked]
>> Subject: Re: [seamoby] Some thoughts on paging problem
>> 
>> 
>> 
>> Proactive draft  works well in the case that the old FA 
>> knows where the mobile is moving to (i.e, the new FA).  
>> But this is not always the case.
>
>The only way to determine this is for the mobile to be forced to
periodicaly
>transmit a small
>ID packet, or have the connection be terminated by the network.
>
>The network FAs would use the RSSI to determine where the mobile was
headed.
>RSSI (Receive Signal Strength Indicator) is used to measure the RF power
>level of mobiles.
>  The FAs compare the results.  The mobile is moving toward the FA with the
>stronger 
>value.  The FA gets to service the mobile.

Two observations from what you are stating:

1. RSSI happens at L1 and L2 and FA and mobile IP stuff happens at L3
2. there are scenarios where AP (terminating the wireless L2) and FA could 
be over a routed cloud.

>This is already done in Cellular and Bluetooth.  No need to re-invent the
>wheel. 

You seem to be make some assumptions on the tight-coupledness of L2 and L3.
this is not 
necessarly bad, but there is merit in leaving them loosely coupled or no
coupling at all.

-gopal

>> 
>> -Gopal
>> 
>> At 12:40 PM 20/12/00 -0800, James Kempf wrote:
>> >Ram,
>> >
>> >The mechanism proposed in the draft does double duty. During 
>> an active
>> >call, it allows handoff of an RTP stream with minimal latency. If the
>> >mobile is dormant, it allows the network to track the mobile so that
>> >the mobile's CoA reflects its current location. Consequently, a 
>> >specialized paging mechanism is not needed.
>> >
>> >There might perhaps be some changes needed for IPv6 due to the need
>> >for authenticated binding updates, but I think a mechanism that
>> >allows the network to track the mobile, either through MIPv6 
>> CoA update
>> >or through standard routing table update, would be better than
>> >a specialized paging mechanism. 
>> >
>> >                jak
>> >
>> >>Date: Wed, 20 Dec 2000 20:33:17 +0000
>> >>From: Ramachandran Ramjee <[email-masked]>
>> >>X-Accept-Language: en
>> >>MIME-Version: 1.0
>> >>To: James Kempf <[email-masked]>
>> >>CC: [email-masked], [email-masked], 
>> [email-masked]
>> >>Subject: Re: [seamoby] Some thoughts on paging problem
>> >>Content-Transfer-Encoding: 7bit
>> >>
>> >>Hi James,
>> >>
>> >>James wrote..
>> >>> One could, I suppose, make an argument for
>> >>> having a specialized L3 mechanism participate in finding 
>> a dormant mobile, 
>> >but
>> >>> there ways to achieve this without a specialized mechanism, for
>> >>> example, pro-active handoff 
>> (draft-calhoun-mobileip-proactive-fa-03.txt).
>> >>
>> >>I think IP paging is exactly that - a specialized L3 mechanism 
>> >>for finding a dormant mobile. 
>> >>
>> >>If pro-active handoff solves this and is general enough, then that's
>> >>great.
>> >>
>> >>Cheers,
>> >>Ram
>> 
>
>-------------------------- eGroups Sponsor -------------------------~-~>
>eLerts
>It's Easy. It's Fun. Best of All, it's Free!
>http://click.egroups.com/1/9699/1/_/_/_/977365002/
>---------------------------------------------------------------------_->
>
>To unsubscribe from this group, send an email to:
>[email-masked]

---

From: Kulwinder Atwal <[email-masked]>
Date: Sat, 13 Jan 2001 00:13:00 -0500

> 2. there are scenarios where AP (terminating the wireless L2) 

Let me describe my view of the wireless IP access network.
 
AP (Access Point): stationary wireless device with wired link to AR.
AR (Access Router): stationary wired/wireless router connected to at least
one AP. 
MN (Mobile Node): a mobile device with a wireless link.  The mobile device
may act as a mobile router if the *particular network* permits.

Re-phrasing:  The APs compare Radio Signal Strength results through the ARs
with a real-time RTT (Round-Trip-Time).

Real-time switching cannot happen over an unbounded routed cloud.  We must
consider Round-Trip-Time between ARs.  Round-Trip-Time must be less than the
Real-time response time for the switch to have occurred in Real-Time.  If we
consider a video stream as a test case, then we will typically want less
than at least 10 mSec for a Round-Trip-Time.

I was considered the more common case, as a starting point.

> necessarly bad, but there is merit in leaving them loosely 

Can you please describe some merits?

- Kulwinder.

---

From: "Gary Kenward" <[email-masked]>
Date: Tue, 16 Jan 2001 15:19:05 -0500

Kulwinder:

  Sorry for getting to this so late.

I agree on your observations concerning bounding the domain. I believe
the issue is not so much bounding the routing domain (although this is a
good thing to do, it is not the focus of SeaMoby), rather we must bound
the domain for handoffs. This is as applicable to context transfer as it
is for micromobility. The extreme case for context transfer is to replicate
context in every AP in the access network, which does not seem to be
a practical approach.

The statement you make concerning RSSI and combining is, I believe, 
out of scope. For two reasons: one, as already has been discussed, RSSI
may not be available, or may not be the best handover indicator for 
all wireless links; second, RSSI and RSSI comparison is an L2 function,
as it is specific to the L1 technology. To elaborate briefly on the latter,
the metric used to estimate RSSI, and it's treatment (e.g. quantization,
thresholds, value mapping) will depend upon the modulation technique,
the propagation environment, etc.

Again, we must abstract out the mechanisms for selecting new APs and
triggering the handoff.

Gary

> From: Kulwinder Atwal [mailto:[email-masked]]
> Sent: Saturday, January 13, 2001 12:13 AM
> To: Colin Elliott; [email-masked]; James Kempf;
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked];
> Subject: RE: [seamoby-paging] RE: [seamoby] Some thoughts on paging
> proble m
> 
> 
>

---

From: Kulwinder Atwal <[email-masked]>
Date: Tue, 16 Jan 2001 16:34:12 -0500

I agree, it was an old email of mine that someone reponded to.
In writing a quick response, I forgot to clarify that it is an L2 issue.
 
- Kulwinder.

-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Tuesday, January 16, 2001 3:19 PM
To: 'Kulwinder Atwal'; Colin Elliott; [email-masked]; James
Kempf; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: RE: [seamoby-paging] RE: [seamoby] Some thoughts on paging proble m

Gary