Subject: RE: [seamoby] Some thoughts and issues

From: "Gary Kenward" <[email-masked]>
Date: Fri, 5 Jan 2001 11:10:40 -0500

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 9:27 PM
> To: Phil Neumiller
> Cc: Pat Calhoun; Nakhjiri Madjid-MNAKHJI1; Kenward, Gary
> [WDLN2:AN10:EXCH]; [email-masked]'; James Kempf;
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [seamoby] Some thoughts and issues
> 
> 
> > 
> > Micro-mobility in the "classical" sense does not equal SeaMoby
> > micro-mobility
> > in my mind.  We are discussing inter-domain context 
> transfer, as such we

It was my understanding that we were concerned with context transfer in
general,
intra- and inter- domain. I am deluded as usual?

Gary
Or, am I taking this out of context?

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 5 Jan 2001 14:42:51 -0500

Or, MIP at the edge of the core and CIP at the edge of the access?
"Core" being one of the many heavily overloaded words.

Gary

> Sent: Thursday, January 04, 2001 10:44 PM
> To: Phil Neumiller
> OOps.... I SHOULD have said Mobile IP in the core, and 
> Cellular IP at the edge.
>  sigh.
> 
> PatC
> > Pat Calhoun wrote:
> > 
> > > Perhaps, and this is, I believe, alot of what Cellular IP 
> (Mobile IP at the
> > > edges, Cellular IP in the core) was all about. I even 
> sent an e-mail today
> > > describing something similar.
> > > 
> > > PatC
> > 
> > Huh?  I seem to have this reversed, i.e. MIP at the core and
> > micro-mobility
> > at the edge, I don't seem to understand your comment.
> 
> 
>

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 5 Jan 2001 14:41:13 -0500

We still seem to be having a hard time defining what micro-mobility is in
the SeaMoby sense. Dare I ask what "micromobility in the classic sense"
means?

Gary

> From: Phil Neumiller [mailto:[email-masked]]
> Sent: Thursday, January 04, 2001 9:25 PM
> To: Pat Calhoun
> Cc: Nakhjiri Madjid-MNAKHJI1; Kenward, Gary [WDLN2:AN10:EXCH];
> [email-masked]'; James Kempf; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Bizzare comments below...
> 
> Pat Calhoun wrote:
> > 
> > > Sorry for the really late reply. I am catching up with 
> the email. I agree
> > > with Gary here. Having a trigger for context transfer and 
> the actual context
> > > transfer are two different things. I thought one of the 
> issues that we are
> > > trying to solve in Seamoby was micromobility or handover 
> while CoA does not
> > > change, a problem that MIP does not deal with, so why are 
> mentioning mobile
> > > IP handoff solutions. Furthormore, as far as I know 
> (maybe this info needs
> > > to updated) fast handoff drafts do not address or provide 
> a solution for the
> > > context transfer problem.
> > >
> > I believe that Raj's point was more along the lines that it 
> is possible to
> > re-use Mobile IP messages to "transport" opaque context 
> information during a
> > handoff. Now, I believe that we really do care about Mobile 
> IP, because it
> > DOES provide fast handoff without requiring a CoA change. Now, the
> > micro-mobility folks (whose list was just setup and will be 
> announced
> > shortly), need to specify what problem exists that Mobile 
> IP does not. This is
> > something that the IESG folks are really interested in 
> hearing, so we owe it
> > to them.
> > =
> Pat,
> 
> in my mind.  We are discussing inter-domain context transfer, 
> as such we
> may
> in fact be wanting to extend existing MIP messages, etc.  Here goes a
> REALLY
> wacko idea... Since you yourself said that the fast handover 
> solutions 
> live on the edge wouldn't the more prudent division of labor 
> be between
> core (current MIP stuff) and edge (future seamoby stuff) 
> mobility???  If
> this
> COULD be agreed upon, then FAST handover (that piggy backs context
> transfer) 
> moves to the edge mobility WG (formerly known as SeaMoby).  
> OK, maybe I
> am
> suggesting something totally wacked here...
> 
> Thanks,
> 
> Phil
>

---

From: James Kempf <[email-masked]>
Date: Fri, 5 Jan 2001 15:13:30 -0800 (PST)

>
>Dana Blair wrote:
>> Therefore,  I believe that micromobility in the SEAMOBY sense should
>> address movement of an IP device while it uses the same IP address.  So the 
point
>> of the attachment (link) of an IP device may change as it moves, but the IP 
address assigned
>> to the device will not if the device is micro-mobile.
>
>I like this definition a lot. 
>
>1) It clearly distinguishes micro-mobility from Mobile IP (where
>the IP address of the mobile changes)
>

I think you need to say the CoA, not just the IP address. Because
the IP address doesn't change in mobile IP if you are talking
about the home address.

This definition covers a number of areas that I've been thinking of.

>2) It also illustrates the fact the micro-mobility can be handled
>in L2 as is done in cellular and wireless LAN networks and 
>in L3 if seamoby/IETF proposes a solution.
>
>Now, IF we all agree to this definition, then the BIG question is
>why do we need L3 micro-mobility and that is a separate thread
>in itself.
>

		jak

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 5 Jan 2001 18:52:02 -0500

Thanks Dana.
I think your definition works in the context of MIP/SeaMoby. Like Pat, I 
suspect something is missing, but I don't know what. At least we have
something
to think around.

Other then James' explanation of the MWIF definition, I am unclear as to
what "classic micromobility" is. With all respect to MWIF, I'm not sure
they are the definitive source of "classic" definitions. 

More realistically, I shouldn't really worry about it. The point is that the
definition is context sensitive. E.g. the MWIF description holds only if
their
is a RAN that is distinct from a "core" network. I personally believe that
there
is no real requirement for a "RAN" as defined by 2G and 3G networks (I'm 
not a big fan of hierarchical network topolgies).

But then, this is off topic. 

Gary

> From: Dana L. Blair [mailto:[email-masked]]
> Sent: Friday, January 05, 2001 4:36 PM
> To: James Kempf; [email-masked]; [email-masked];
> Kenward, Gary [WDLN2:AN10:EXCH]
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> Subject: RE: [seamoby] Some thoughts and issues
> 
> 
> At 01:25 PM 1/5/01 -0800, James Kempf wrote:
> >Gary,
> >
> This thread is very long so this may have already been mentioned.
> Defining "micromobility in the SEAMOBY sense" means defining 
> micromobility
> in the internet sense since SEAMOBY is an IETF working group. 
>  Micromobility
> addresses directing data to/from a moving endpoint.  For the internet,
> the endpoint has an IP address.
> 
> address movement of an IP device while it uses the same IP 
> address.  So the point
> of the attachment (link) of an IP device may change as it 
> moves, but the IP address assigned
> I have copied the micromobility alias since this discussion 
> directly relates the problem
> statement for micromobility.
> 
> thanks,
> Dana
> 
> >
> >This probably isn't going to help much, but we've defined 
> micromobility
> >in MWIF as mobility within a radio access network, and macromobility
> >as between radio access networks.
> >
> >		jak
> >
> 
>

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 5 Jan 2001 18:42:19 -0500

Hmmm. It helps if this is what Phil was referring to. 

Thanks,
Gary

> From: James Kempf [mailto:[email-masked]]
> Sent: Friday, January 05, 2001 4:26 PM
> To: [email-masked]; [email-masked]; Kenward, Gary
> [WDLN2:AN10:EXCH]
> [email-masked]; [email-masked]

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 5 Jan 2001 19:04:54 -0500

I think this discussion highlights what is appealing about Dana's
description of micromobility. If we try and define micromobility
in terms of what it does for a RAN we run into the problem of
defining a RAN, which leads to debates over the mobility support
in different RAN technologies, which iterates back over issues
concerning the definition of the RAN boundaries.

Perhaps we can defined micromobility in terms of mobility between
APs (and thus between an abstract Access Network which could
represent a single wireless link, a wireless PAN, a wireless LAN, or a 
complete wireless network), without change in the MN IP address.

I think that at some point an informational ID may be required to
describe micromobility for each wireless networking technology, and
I suspect that each description will differ. The challenge will be to
minimize the differences and ensure that they are options, not
customizations.

Gary

> From: Michael A. Ramalho [mailto:[email-masked]]
> Sent: Friday, January 05, 2001 4:58 PM
> I think you are right. That definition might be OK for MWIF 
> ... but ...
> what would you call a "radio access network" outside of that context?
> 
> For example ... lets say I have an enterprise router with two 
> types of radio
> system access links on it ... and my mobile decides to 
> request a handoff
> between one wireless access link technology to the other ... but stays
> connected to the same router.
> 
> Would that handoff ... probably within one subnet ... but 
> between two different
> types of radio access links ... be considered macromobility?
> 
> That would be odd, indeed!
> 
> I think IP-oriented people think of (micro)mobility w.r.t. 
> subnets (or trust
> boundaries or administrative domains) without regard for the 
> actual technology
> used on the access link. Conversely, cellular folks usually think of
> (macro)mobility
> between types of "radio access networks".
> 
> So what is our "[micro|macro]mobility" based on ... mobility 
> between "networks"
> or between IP "domains/subsets/domains/clouds"?
> 
> If we are talking IP mobility ... I'd suggest the latter ... 
> but if I were
> a cellular IP guy ... I'd probably argue the former.
> 
> This is why we need that problem definition .....
> 
> 
> Michael A. Ramalho, Ph.D.
> Office email: [email-masked]
> Personal email: [email-masked]
> Office: +1.732.449.5762
> Cell: +1.732.809.0188
> Pager: +1.800.365.4578
>