Subject: RE: [seamoby] micro, schmicro

From: Kulwinder Atwal <[email-masked]>
Date: Tue, 16 Jan 2001 22:24:42 -0500

> 
> I think you are misunderstanding Phil's point
> which I took to mean that the placement of the
> foreign agent is not necessarily the same as the
> placement of the AR. While I wonder whether that's
> an especially wise idea from the standpoint of
> needing to have a security relationship with both
> the AR (aka NAS) and the FA (for BU's, say), I
> think I probably disagree with your premise too.
> I don't think that we can or should make any
> assumption that the AR's will always know a priori
> about one another. I think it's useful in many
> cases to allow such topology knowledge to be used
> for network based moves, but this is not
> sufficient: it's a local optimization. The more
> general case where the old AR doesn't know squat
> about the new AR is also a perfectly valid case
> that needs to be accounted for.
> 
> 	   Mike

Yes, I think we can do better.

At least we must say that the OAR and the NAR must communicate 
messages affecting the handover either through a single agreed upon 
path.  

Or, use transactions in Seamoby such that a positive confirmation is
required 
 from both for every mode change.

I think Phil highlights some of the problems in current protocols that need
to be resolved by a transaction-based Seamoby protocol.

NB: I think calling it a Foriegn Agent is a little Xenophobic.  If I am at
work every day I am not in a "Foriegn" place.  I think as someone has
suggested "Mobility Agent" may be more technically accurate.

- Kulwinder.

---

From: Phil Neumiller <[email-masked]>
Date: Wed, 17 Jan 2001 07:31:38 -0600

Michael Thomas wrote:
> placement of the AR.

Yes this is my point.

> While I wonder whether that's
I wasn't sure if anyone would understand my arcane
drawing but I believe the jist of my argument has
been better stated by Michael above.  

Kulwinder,

Whether we like it our not, I think one of SeaMoby's
requirements will be to indeed cooperate with MIPv4
and MIPv6 since they "pretty much" exist.  So I am not 
afraid of using terms like FA when talking about SeaMoby
requirements since these things are part of reality
currently and thus make up fixed parts of our problem
space.

Thanks,

Phil