Subject: RE: [seamoby] MicroMobility Algorithm Outline Revision 0.0001

From: Kulwinder Atwal <[email-masked]>
Date: Wed, 3 Jan 2001 04:50:41 -0500

> -----Original Message-----
> From: Michael Ruckstuhl [mailto:[email-masked]]
> Sent: Tuesday, January 02, 2001 3:06 PM
> To: 'Kulwinder Atwal'; [email-masked]
> Subject: RE: [seamoby] MicroMobility Algorithm Outline Revision 0.0001
> 
> 
> One of the things I got out of Erik Anderlind's comments 
> (12/20) was the
> idea of separating handover on the local service network from 
> selection of
> 'the (current) best' service network. The MN has its own 
> ideas of best -
> billing cost, battery cost, bandwidth cost, etc. However, if 
> micromobility
> can satisfy our needs on the current service network, we 
> don't have to jump
> through hoops to know all the RSSI gradient information. For 
> the times (and
> there will be some) when the current service network cannot 
> maintain our QoS
> needs following the handover, notification of this 
> degradation of service
> must be propagated to the correct layer on the MN, which would then
> re-evaluate local service networks, and choose the 'best'.
> 
> I would like to see a segregation of inter- and intra- service network
> handovers. 

I agree completely.

> 
> I think that the intra- handovers should be covered by whatever cost
> agreements exist between the service provider and the 
> subscriber, presenting
> an 'homogenous' network, requiring no real awareness of Full Radio Map
> (other networks) by the MN. I think that inter- handovers are more
> complicated because the subscriber wants the 'best deal' and 
> may have cost
> vs. QoS vs. bandwidth tradeoffs affecting network selection. 

I have tried to solve the problem both ways, just give this idea a chance.
Just in case I missed something.  I wanted to show the wired guys that an
honest effort had been made.
 
> Thus, intra-network handover can be made to maintain some BE 
> support while
> the MN realizes that an inter-network handover is now required per the
> subscriber's configuration. I think the intra-network handover is what
> everyone is discussing as micromobility?

I don't think using IP is a good idea for intra-network hand-off.
Just the IPv6 header is 40 bytes.  The largest single slot packet that I can
send over Bluetooth has 28 bytes of payload.  This means that Bluetooth
cannot use IPv6 to do real-time seamless mobility.

I agree with everything that you have said.  The only place for IP is in
switch packet flows between two different types of networks.

 - Kulwinder.

---

From: Mika Ylianttila <[email-masked]>
Date: Wed, 3 Jan 2001 13:13:23 +0200 (EET)

>cannot use IPv6 to do real-time seamless mobility.

  Did you forget the possibility for header compression?  ;)

--
Mika Ylianttila
M.Sc., Project Manager
Centre for Wireless Communications
PL 4500, Tutkijantie 2 E, FIN-90014
University of Oulu, Finland