Subject: Re: [seamoby] Some thoughts on paging problem

From: Claude Castelluccia <[email-masked]>
Date: Thu, 04 Jan 2001 14:20:25 +0100

Hello James,

James Kempf wrote:

> > > You don't have to query multiple FAs. When
> > > a mobile transfers from one FA to another in dormant mode (determined
> > > because the L2 paging area boundry is crossed while the mobile is
> > > in dormant mode and the FA is monitoring the L2 trigger) the new FA
> > > assigns a new CoA for the mobile and
> > > informs the GFA.

yes, but the FA have to send a BU to the GFA each time the MN moves...
In IP Paging we also try to limit the number of BUs sent over the network
when a MN is dormant...

>
> >
> >   I don't understand this. How can a FA know that a mobile
> >   has moved passed the L2 paging area if the mobile is not
> >   speaking to the FA (ie, it's dormant). If the answer is
> >   that the mobile tells the FA, then I don't see why this
> >   situation is any different than wake-mode. If it doesn't,
> >   I'm at a loss as to how FA figures that out.
> >
>
> It's different because the mobile comes up, sends a short registration
> message to the RAN on a control channel (not a traffic channel), then
> goes back to sleep again. The FA figures out because the RAN via
> L2 tells it that a mobile has just moved into its paging area.
> Minimizing traffic channel usage for this kind of signalling is
> a requirement for some operators.

You actually make the assumption that some L2 paging is provided...
I don't think that we should make such assumption (or build systems that
make this assumption) in Seamboby...
If L2 paging is used, it should of course be used as an optimization...

regards,

Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: Michael Thomas <[email-masked]>
Date: Thu, 4 Jan 2001 09:27:37 -0800 (PST)

> a requirement for some operators.

   I've gotten the impression that you cannot count on the
   mobile always re-registering mainly because to require
   it to do so is not efficient batterywise (and probably
   other reasons). I thought this was the ships-in-the-night
   problem.

   Reality check: I've been running on the assumption that
   the paging problem to be solved is where the
   last FA loses track of the exact location of
   the MN, and may in fact not be attached to the
   same interface and may not even be listening to 
   the same technology's control channel. Are we
   in sync here?

		Mike

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 4 Jan 2001 09:29:32 -0800 (PST)

>    the same technology's control channel. Are we

I believe that we are in sync. I believe that Jim's point is that some recent
activities in the Mobile IP WG does allow for the mobile to be tracked without
requiring that it registers with the network. This is the proactive work. So
the main question is whether this proposal is sufficient, or whether there are
situations where additional paging work is required.

PatC

---

From: Michael Thomas <[email-masked]>
Date: Thu, 4 Jan 2001 10:01:41 -0800 (PST)

> situations where additional paging work is required.

   Proactive implies that the access point knows or has a 
   good guess as to where the mobile will move. My personal
   take is that that is probably not sufficient, especially
   if you want to deal with the vagueries of mixed technology.
   It seems exceedingly ugly, but doesn't the more general
   case require some sort of search?

		Mike

---

From: Ramachandran Ramjee <[email-masked]>
Date: Thu, 04 Jan 2001 20:29:02 +0000

Hi Pat,

The conclusion that myself and Jim arrived at a few days ago was that
IP paging could be circumvented IF a single FA always covered one
whole paging area (the movement outside which an L2 update must be sent
-
this L2 update could then be used instead of a Mobile IP registration
to update the network). However, I am not sure one FA will always
map onto one paging area...in fact, this assumption really precludes
implementing a network that has one FA per base station because
paging areas typically consist of a set of base stations.

To summarize, IP paging is needed if mobiles could move
from the coverage of one FA to another FA without sending any updates
(L2 or L3) - in this case, some messages need to be examined among
the FAs to find the FA that currently serves the mobile.

Hope this clarifies.

Cheers,
Ram

> To unsubscribe from this group, send an email to:
> [email-masked]