Subject: RE: [seamoby] A CNP perspective on context transfer.

From: "Hamid Syed" <[email-masked]>
Date: Thu, 18 Jan 2001 14:02:16 -0500

Hi Phil,

I guess the main problem is "when" to carry out the actual context transfer
and what may happen between the time the context was transfered and the time
when the actual handover of bearer resources occur
For example, in the proactive approach, the actual transfer of context
happens whenever the candidate and the source realizes that the mobile may
get connectivity thru the candidate. Of course, the candidate can submit a
bid but this bid would be based on its current capabilities, which may
change with the time. Again as an example, one of the factors while deciding
a bid is resource availability. The candidate can submit a bid with the
current available resources at time t1, but the mobile may decide to get
connected to it at time t2. Now between this delta time, the situation of
the available resources at the candidate may change. This is one example
where one of the deciding factor is time-dependent. The whole purpose of
context transfer and bidding would fail in this scenario. Not to mention
that the situation may become even worst for per packet context information.

just some thoughts

-Hamid Syed

> -----Original Message-----
> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	Tuesday, January 16, 2001 3:07 PM
> To:	Syed, Hamid [WDLN2:AN22:EXCH]
> Cc:	[email-masked]; [email-masked];
> [email-masked]
> Subject:	[seamoby] A CNP perspective on context transfer.
> 
> 
> 
> 
> The contract bidding analogy is very applicable to context transfer.
> Consider
> the following.
> 
> A CONTRACT between an AP/AR pair may be established by a process of mutual
> selection based on a two way transfer of context.  Handover candidates
> (contractors)
> evaluate hand over requests made by handover sources.  The candidates then
> submit bids on those parts of contracts for which they are suited.  The
> bids
> contain
> the parts of the contract that can be handled by both parties.  The
> handover
> source
> can then take the best bid from its perspective and assign the handover in
> a
> locally
> optimal manner.  This scales to the globe.
> 
> I believe the transport mechanism we put in place for context transfer
> should
> support this pattern.  The semantics of payload are interpreted by the
> local
> mobility manager (micro-mobility) not the transport mechanism itself.
> 
> Thanks,
> 
> Phil
> 
>

---

From: Phil Neumiller <[email-masked]>
Date: Thu, 18 Jan 2001 20:28:06 -0600

Hello Hamid,

> Hamid Syed wrote:
> 
> Hi Phil,
> 
> I guess the main problem is "when" to carry out the actual context transfer and what may happen between the time the context was
> transfered and the time when the actual handover of bearer resources occur
> 

pdn>This is precisely why I ADVOCATE bundling context transfer in the form of a 
pdn>"contract" with each hand over request sent to handover candidates (contractors).

> For example, in the proactive approach, the actual transfer of context happens whenever the candidate and the source realizes
> that the mobile may get connectivity thru the candidate. Of course, the candidate can submit a bid but this bid would be based on
> its current capabilities, which may change with the time. Again as an example, one of the factors while deciding a bid is
> resource availability. The candidate can submit a bid with the current available resources at time t1, but the mobile may decide
> to get connected to it at time t2. Now between this delta time, the situation of the available resources at the candidate may
> change. This is one example where one of the deciding factor is time-dependent. The whole purpose of context transfer and bidding
> would fail in this scenario. Not to mention that the situation may become even worst for per packet context information.

pdn>Yes, and the VERY closest you can tie state transfer to when it is needed
pdn>(the moment before the handoff decision made) is by bundling the context
pdn>with the handover request and the reflected and pruned context in the bids
pdn>that come back.  The bids will come back from each handover candidate, and
pdn>the manager of the anchor (the microflows bound to the MN that is moving),
pdn>will decide which candidate should get awarded the contract.  I just don't
pdn>see a more efficient way to do this.  Of course I AM WORKING in the SOLUTION
pdn>SPACE here (currently a sin in SeaMoby), but I have the code running, and
pdn>I have been playing with such a system for several years now. :-)

 [email-masked]
>      The contract bidding analogy is very applicable to context transfer.  Consider
>      the following.
> 
>      selection based on a two way transfer of context.  Handover candidates (contractors)
>      submit bids on those parts of contracts for which they are suited.  The bids contain
>      the parts of the contract that can be handled by both parties.  The handover source
>      can then take the best bid from its perspective and assign the handover in a locally
>      I believe the transport mechanism we put in place for context transfer should
>      support this pattern.  The semantics of payload are interpreted by the local