Subject: RE: [seamoby] Some thoughts and issues

From: [email-masked]
Date: Wed, 10 Jan 2001 11:46:12 +0200

Hi all,

> I think IP-oriented people think of (micro)mobility w.r.t. 
> subnets (or trust 
> boundaries or administrative domains) without regard for the 
> actual technology 
> used on the access link. Conversely, cellular folks usually think of 
> (macro)mobility 
> between types of "radio access networks". 
> 
> So what is our "[micro|macro]mobility" based on ... mobility 
> between "networks" 
> or between IP "domains/subsets/domains/clouds"? 
> 
> If we are talking IP mobility ... I'd suggest the latter ... 
> but if I were 
> a cellular IP guy ... I'd probably argue the former. 

I think that we should define micromobility as mobility
within a subnet and/or domain.  Macromobility then would
be mobility between subnets and/or domains.

This may even work for cellular folks.  I think that many in the 
near future, many companies will be rolling out base stations
which support multiple radio technologies, so that clear
boundaries within cellular networks will blur as well.

best regards,
John

---

From: Michael Thomas <[email-masked]>
Date: Fri, 12 Jan 2001 16:33:21 -0800 (PST)

> be mobility between subnets and/or domains.

Not to pick on John, but...

I'm probably the only one, but I find this desire
to find a home for the phrases "micro mobility"
and "macro mobility" to be almost, well...
procrustean. I've yet to see why the use of these
two terms yield any light, nor do they seem to
yield a useful taxonomy. Instead, they seem to be
like dummies that we are hide-bound to find some
appropriate clothes for them to don.

It seems clear that there is a set of variables of
how movement happens (MBB, BBM), whether the MN or
AR or initiates the move, whether or not it
crosses a trust boundary, whether or not it needs
to move subnets, etc, etc. What doesn't seem clear
to me _at all_ is that these, in fact, collapse
into exactly two scenarios. Even if they did
collapse into two, it's even less clear that
"micro" and "macro" are within 90 degrees of what
the scenarios should be named.

It seems to me that instead of getting wrapped
around the axle about how many angels dance on the
head of micro and macro, it would be better to
agree on what all of the variables are, how they
interact, and what these of scenarios we have
to consider are.

	    Mike

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 12 Jan 2001 16:38:31 -0800 (PST)

Michael,

You do have a point, but my experience is that it is really hard to all agree
on a problem, if we cannot even agree on a set of terminology. That said, if
you'd like to provide these "variables" for all to see, we can then call these
two scenarios foo and bar, and then move on.

For those of you that are not in the context list, we had a call earlier this
week, agreed on an architecture, and the basis for a problem statement. A good
portion of the call was to make sure that we were all in agreement, and this
included agreeing on terminology.

my 2 cents,

PatC