Subject: [seamoby] More beating my head against the wall....

From: [email-masked]
Date: Thu, 18 Jan 2001 08:31:23 -0600

---------------------- Forwarded by Phil Neumiller/MW/US/3Com on 01/18/2001
08:24 AM ---------------------------

Phil Neumiller/MW/US/3Com
01/17/2001 03:36 PM

Sent by:  Phil Neumiller  -  Network Systems Architect, RCG

To:   [email-masked]
cc:
Subject:  More beating my head against the wall....

BZZZZZZZTTTTTT.  WRONG ANSWER.

When Phil thinks of "edge mobility" (the mobility previously known as
micromobility), he does not give a rat's gluteous maximus about a
change in COA.  He sincerely believes that a new routable IP address
(not necessarily KNOWN TO BE THE COA YET) can be known to the
source AP well before MIP knows jack.  Methinks my arguments (which
have made my face rather blue) have escaped all.

NO NO NO NO.  In Phil's utopian world, edge mobility may indeed mean
an EVENTUAL change in COA forced by a prefix/subnet change that is
handled by edge mobility!  EDGE MOBILITY compensates for the delay
incured upstream in the big I by mobile IP when the COA MUST CHANGE.
So yes EDGE MOBILITY DOES ROUTING!!!!    Yes this is the main
problem statement of EDGE mobility.  NO, I don't think the classical
definition of micromobility buys me squat for seamlessness.

Yikes, I must have said this about 89 times now.  Maybe I need to
take a break or something since I can not seam to communicate this
no matter how hard I try.

Am I totally wacked here or what???

Thanks,

Phil

---

From: "Gary Kenward" <[email-masked]>
Date: Thu, 18 Jan 2001 12:12:39 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, January 18, 2001 9:31 AM
> To: [email-masked]
> Subject: [seamoby] More beating my head against the wall....

*snip*

> Am I totally wacked here or what???

Ask us no questions and we will tell you no lies?
(j/k).

I would tend to agree with you Phil, but do we have tangible evidence that 
the MIP routing is too slow, and the routing at the edge is required? I
*believe*
it is a problem, but I suspect the claim would be contentious without
numbers.
Anyone want to publish an experimental ID? Or, have I missed something
again,
is there already publish results on MIP routing performance?

Just asking,
Gary

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 19 Jan 2001 00:05:06 -0500

I am aware of the triangular routing problem with MIPv4.
I believe that Phil was referring to CoA used in MIPv6.
 
Still no numbers.
 
Gary

-----Original Message-----
From: c4mcr [mailto:[email-masked]]
Sent: Thursday, January 18, 2001 11:46 PM
To: Kenward, Gary [WDLN2:AN10:EXCH]; seamoby
Subject: Re: [seamoby] More beating my head against the wall....

Hi
 
MIPv4 is known to have triangular routing problem. 
(Yes, there are many papers you can refer to)
Solution: Host based routing.
 
"Only one solution exist that does not need host based routing and
yet resolve most triangular routing problem --> IIP"
 
Moving to MIPv6? 
Reinvented Host based routing 
(Get away with it, since not many people is it)
Does Yahoo and many millions of server support it?
They eventually will, but when? Do you have patient to wait? :)

"Only one solution exist that allows you to migrate from IPv4 to IPv6
without the pain --> IIP"
 
Cheers
Chern Nam Yap

----Original Message-----
From: Gary Kenward < [email-masked]
<mailto:[email-masked]> >
To: [email-masked] <mailto:[email-masked]>  <
[email-masked] <mailto:[email-masked]> >
Date: Friday, January 19, 2001 5:03 AM
Subject: RE: [seamoby] More beating my head against the wall....

> From: [email-masked] <mailto:[email-masked]>  [
mailto:[email-masked] <mailto:[email-masked]> ] 

*snip* 

Just asking, 
Gary

---

From: "Andrew T. Campbell" <[email-masked]>
Date: Fri, 19 Jan 2001 13:19:27 -0800

RE: [seamoby] More beating my head against the wall....

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On
Behalf Of Gary Kenward
    Sent: Thursday, January 18, 2001 9:19 PM
    To: [email-masked]'
    Cc: [email-masked]
    Subject: RE: [seamoby] More beating my head against the wall....

    You are preaching to the choir, as you fully well know.
    My point was, is there quantitative justification for the statement you
    made  that MIP is too slow?
    [Andrew T. Campbell]

    I should of added (to my Nop) that CIP is fast but you can tune MIP to
operate "fast" but

    there are penalties to doing that; hence the need for edge mobility.

---

From: "Gary Kenward" <[email-masked]>
Date: Sun, 21 Jan 2001 15:39:35 -0600

Thanks Dave, for the reasoned contribution. I agree with your definitions of
edge versus core, although you refer mostly to what I would call core
services rather then a core network (moot point for now I think).
 
As for micromobility (not fast handoff, as Pat has pointed out), it seems to
me that "bridging the gap" is one view of the objective, when MIP is
present. In reality, "bridging the gap" without MIP should provide a
seamless mobility solution for within the access network at the IP layer.
 
Gary

-----Original Message-----
From: Dave Martin [mailto:[email-masked]]
Sent: Sunday, January 21, 2001 10:12 AM
To: Kenward, Gary [WDLN2:AN10:EXCH]; Phil_Neumiller
Cc: seamoby
Subject: Re: [seamoby] More beating my head against the wall....

In our current Mobile IP network (MIPv4), it takes several seconds (~3) to
change FAs (COA).  L2 plays almost no part in this delay (our L2 *can*
support realtime data traffic).  If necessary I can provide more detail on
the delay budget, but I hope that we can agree that MIP as it is today would
not support real time services (e.g. voice).
 
So I would content that MIP (current version) is too slow to support
mobility between FAs.
 
I would also contend that MIP will probably always be too slow unless
something is done to optimize the "edge" to bridge the gap while the "core"
is updated with new routing information.  My definition of "edge" is the
closest router to the mobile (AR), and my definition of core is the rest of
the supporting network (HA, AAA, FA etc).
 
As a another voice in the choir ... I also believe that the fast-handoff
work belongs in seamoby.
 
----- Original Message ----- 

From: Gary Kenward <mailto:[email-masked]>  
To: [email-masked]' <mailto:[email-masked]'>  
Cc: [email-masked] <mailto:[email-masked]>  
Sent: Friday, January 19, 2001 12:19 AM
Subject: RE: [seamoby] More beating my head against the wall....

Gary 

> Sent: Thursday, January 18, 2001 3:38 PM 
> To: Kenward, Gary [WDLN2:AN10:EXCH] 
> Cc: [email-masked] <mailto:[email-masked]>  
> Sent by:  "Gary Kenward" <[email-masked]> 
> 
> *snip* 
> 
> 
> pdn>If it were not slow (my measurements done about 2 years 
> back indicated 
> pdn>that it was), why would the MIP group be so actively pursuing fast 
> pdn>handoff?  My REAL belief is that fast hand off work belongs in 
> pdn>SeaMoby.  That is if you are willing to seperate the world into 
> pdn>Core routing (mobile IP) and edge tunnelling (SeaMoby).  
> This type of 
> pdn>division of labor makes MUCH more sense to me technically, but the 
> pdn>politics of such a reorganization make its possibility of 
> existence 
> pdn>tenuous.  Just think how the MIP group would be free to 
> worry about 
> pdn>optimizing the router chains for mobility rather than edge device 
> pdn>junk.  SeaMoby would only have to worry about eventually sending a 
> pdn>new MIP registration while a temporary tunnel keeps the connection 
> pdn>seamless.  Perhaps I really am wacked, but this is the way I see 
> pdn>it. 
> 
> 
> 
>

---

From: "Gary Kenward" <[email-masked]>
Date: Sun, 21 Jan 2001 16:34:03 -0500

> Sent: Sunday, January 21, 2001 4:07 PM
> To: Pat Calhoun
> Cc: Kenward, Gary [WDLN2:AN10:EXCH]; Phil_Neumiller; seamoby
*more snipping*
> 
> Micro/edge mobility is already solved in most large wireless 
> networks, it's
> just that there is no global standard, and that the mobility 
> is typically
> done at layer 2.  There is value in having a unified standard to rally
> around, and to formally define how layer 2 and layer 3 
> mobility protocols
> should work together.

And most of these solutions are not friendly to packet switched traffic
(I am tempted to say all...)..

Gary

---

From: [email-masked]
Date: Mon, 22 Jan 2001 11:37:52 +0200

Hi Dana,

> Once we have a problem statement for our (micro)mobility design
> team that is accepted by the IESG, we can create a set of criteria
> to judge various mobility solutions.  

Which I am trying to compile, as an alpha-document.  Hopefully,
I will have something out on the MM list today.  As per my
usual mantra, I am trying to keep it simple, and hopefully
stay above the debate ...

John