Subject: RE: [seamoby] some issues on the ct draft

From: "Gary Kenward" <[email-masked]>
Date: Thu, 22 Feb 2001 22:56:46 -0500

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Thursday, February 22, 2001 5:05 PM
> To: Kulwinder Atwal
> Cc: 'Shahrier, Sharif M.'; 'James Kempf'; [email-masked];
> [email-masked]; Kenward, Gary [WDLN2:AN10:EXCH];
> [email-masked]; Kiernan, Brian G.
> Subject: RE: [seamoby] some issues on the ct draft
> 
> 
> I've been following this thread with some interest. 
> Kulwinder, I believe that
> you misunderstood Sharif's comment. I do not believe that he 
> was proposing
> transfering context at layer 2, but simply stating that a PDP 
> context is a
> candidate for CT.
> 
> If this is correct, I agree that one could transfer a PDP 
> context, but there
> are many other candidates, and the draft in question wasn't 
> intended to be
> complete.
> 
> I agree that bringing up the PDP should be done in the 
> requirements phase.

Why? PDP context is a solution. The requirements draft should
focus on requirements. Unless someone sees a need to interwork
with PDP context, then interworking might be a requirement.

When we look at solutions we should review all proposed solutions,
and if Sharif, or someone else wishes to introduce a PDP context
based solution, then great. However, I fail to see how PDP context
is any part of the requirements.

What am I missing here?

Gary
> 
> PatC
> 
> > We already have a 3G bias by mentioning 3G in the intro of 
> the Charter.  
> > 
> > A L2 context transfer may not work the same way as an L3 
> context transfer.
> > What we should provide are the requirements of each 
> technology in terms of
> > context transfer, and determine the best L3 approached from there.
> > 
> > Either you want L2 transfer, in which case you already have 
> it in PDP
> > context.
> > Or, you want L3 transfer so that it will work across all 
> technologies.
> > 
> > Maybe, in the requirements phase everyone could provide 
> references to the
> > requirements of particular technologies.
> > 
> > 
> > - Kulwinder.
> > 
> > > -----Original Message-----
> > > From: Shahrier, Sharif M. 
> [mailto:[email-masked]]
> > > Sent: Thursday, February 22, 2001 1:12 PM
> > > To: 'James Kempf'; [email-masked]; Shahrier, Sharif M.
> > > Cc: [email-masked]; [email-masked];
> > > [email-masked]; Kiernan, Brian G.
> > > Subject: RE: [seamoby] some issues on the ct draft
> > > 
> > > 
> > > James,
> > > 
> > > I did not impy that IETF should incorporate any part of the 
> > > GPRS methodology
> > > into the IP context transfer protocol. I simply stated that 
> > > somewhere (in
> > > the introduction) a mention should be made of the PDP 
> context transfer
> > > scheme. I believe that it should be mentioned and perhaps 
> > > some articles
> > > referenced because it is predominantly deployed today. As 
> > > currently defined,
> > > GPRS lies below IP layer.
> > > 
> > > Sharif Shahrier
> > > 
> > > -----Original Message-----
> > > From: James Kempf [mailto:[email-masked]]
> > > Sent: Thursday, February 22, 2001 12:45 PM
> > > To: [email-masked]; [email-masked]
> > > Cc: [email-masked]; [email-masked];
> > > [email-masked]; [email-masked];
> > > [email-masked]
> > > Subject: Re: [seamoby] some issues on the ct draft
> > > 
> > > 
> > > Sharif,
> > > 
> > > >2. I would like to bring up the PDP-context as deployed in 
> > > GPRS networks.
> > > >Since, this network is commercially used today and forms 
> > > over 80 percent of
> > > >the world's mobile packet network, I don't think we should 
> > > ignore it. Thus,
> > > >I will send you some text on the activation and transfer of 
> > > PDP-context as
> > > >an example of what's deployed today.
> > > >
> > > 
> > > I do not believe IETF should get into specifying standards 
> > > for technologies
> > > that other SDOs control. Therefore, I do not think there should be
> > > any mention of GPRS in a context transfer protocol for IETF.
> > > 
> > > That said, I agree that some accommodation needs to be made for
> > > transfering unspecified context. I did some work last year
> > > on transferring radio channel context for an IP replacement to
> > > the IS-41 hard handover messages, and it required such support.
> > > The work never went anywhere but it illustrated to me the need for
> > > such support. 
> > > 
> > > 		jak
> > > 
> 
> 
>

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 26 Feb 2001 17:37:23 -0800 (PST)

> with PDP context, then interworking might be a requirement.

well, perhaps I am missing something. I was NOT proposing PDP was a solution,
but merely that whatever PDP is, it may be one of the blobs that we tranfer
from a to b.

> is any part of the requirements.

ok, perhaps I was not clear, but read my above clearification. I am not
endorsing, nor proposing, use of PDP. I was under the impression that PDP was
something that we could transfer.

> What am I missing here?

Apparently I was missing context

PatC