Subject: RE: [seamoby] Arch discussions in IETF

From: [email-masked]
Date: Wed, 28 Feb 2001 15:47:01 -0600

Phil,

I do not see anyone saying that Mobile IP is the only solution for all
scenarios that require mobility. I am sure there are many scenarios
that Mobile IP may or may not be the most optimal solution. If Mobile
IP is unable to work as well as anything else you may have in mind 
for specific scenarios, then why deploy Mobile IP in such scenarios?
Can you be more specific on the kind of environments and requirements
that these environments have that would make it impossible for Mobile
IP to work in.

-Basavaraj

Pls. note that the Mobile IP mailing list has a new address.

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2001 1:46 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [seamoby] Arch discussions in IETF
> 
> 
> 
> 
> 
> We have said countless times that IETF does not define 
> architecture.  However
> MIP did.
> Many of the problems people have with MIP are with its basic 
> architecture, not
> the protocol.
> Why can't their be an architectural debate on MIP in the IETF 
> (not protocol).
> There are
> boxes defined.  There is a CN, a MN, an HA, a set of routers. 
>  Lets talk about
> how these
> need to play in today's modern residential and business 
> deployments.  Why do we
> always
> have to cater to cellular?  Why do the cellular guys get most 
> the say?   The
> Internet has
> new stuff like FTC, VoIP, SLP,  RSVP, diffserv, and new radio access
> technologies that
> can enable different types of mobility architectures.   Is an 
> HA still a good
> idea in
> every scenario?  Why?  Can we talk about this?  If not why 
> not?  Inquiring minds
> want to
> know.
> 
> Here is an example.  Why do I always need to use MIP?  Let's 
> say I have a
> community of
> VPN's defined to interlink residences that interoperate with 
> mobility (a bunch
> of families
> allows their mobiles to operate in each other's premises), 
> i.e. mobile hosts are
> allowed
> to seamless travel within theses spaces but only in theses 
> spaces (could be set
> up
> in hotel rooms, conferences, etc).  The COA changes but there 
> is no HA.
> 
> I have lots of scenarios like this.
> 
> Thanks,
> 
> Phil
> 
> 
> 
> I believe that the problem statement does have some things 
> that Mobile IP will
> have a REALLY hard time handling. However, as I have stated 
> numerous times,
> statements like "MIP is too slow" just doesn't cut it. Let's 
> get to the meat
> of the requirements, and then we can identify whether MIP can 
> do the job.
> 
> PatC
> 
>

---

From: [email-masked]
Date: Wed, 28 Feb 2001 15:47:01 -0600

Phil,

-Basavaraj

---

From: [email-masked]
Date: Wed, 28 Feb 2001 16:11:37 -0600

Hi Raj,

>for specific scenarios, then why deploy Mobile IP in such scenarios?

Then where might these other solutions be standardized in the IETF?
Would this fall under the classification of micro-mobility even though
the "so-called" COA or routing prefix does indeed change?  I guess what
I am getting at is there may be cases of infra-structure-less mobility
where the COA changes but there is no HA.  Would this be micro or
macro mobility?

>that these environments have that would make it impossible for Mobile

Sure.  Specifically, I am very interested in portable devices that will
find there way into homes.  Wireless appliances, MP3 players, digital
radios, digital security devices, gaming units, VoIP devices, etc.  I
am also interested in these types of devices that may be used in small
to medium business that may not have large infrastructures in place.

Thank you,

Phil Neumiller

---

From: [email-masked]
Date: Wed, 28 Feb 2001 16:11:37 -0600

Hi Raj,

Thank you,

Phil Neumiller

---

From: [email-masked]
Date: Wed, 28 Feb 2001 16:11:37 -0600

Hi Raj,

Thank you,

Phil Neumiller

---

From: [email-masked]
Date: Wed, 28 Feb 2001 16:11:37 -0600

Hi Raj,

Thank you,

Phil Neumiller

---

From: [email-masked]
Date: Wed, 28 Feb 2001 16:11:37 -0600

Hi Raj,

Thank you,

Phil Neumiller

---

From: [email-masked]
Date: Wed, 28 Feb 2001 15:47:01 -0600

Phil,

-Basavaraj

---

From: [email-masked]
Date: Wed, 28 Feb 2001 16:11:37 -0600

Hi Raj,

Thank you,

Phil Neumiller

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 23:39:05 +0100

> where the COA changes but there is no HA.  
> 
	=> There was a draft presented in San Diego about Homeless 
	MIPv6. Just an example and I'm not trying to force MIP.

	Regards,

	Hesham

---

From: [email-masked]
Date: Wed, 28 Feb 2001 16:11:37 -0600

Hi Raj,

Thank you,

Phil Neumiller

---

From: [email-masked]
Date: Wed, 28 Feb 2001 19:42:06 -0600

Phil,

>Then where might these other solutions be standardized in the IETF?

Seamoby??? Some other WG (MANET, Mobile IP, New WG)? Or is it the
IRTF that 

Do these kind of scenarios and problems get covered in the mobility
management problems statement I-D? If you believe this kind of
mobility currently does not have a WG in the IETF that deals with it,
then maybe that's what Seamoby should do. 

>where the COA changes but there is no HA.  Would this be micro or

The terms micro and macro mobility are overloaded and perceptions are
different w.r.t where micro mobility ends and macro mobility
begins. The non-existence of an HA has no implications on whether you
are dealing with micro or macro mobility. I mean do you consider macro
mobility as only those cases wherein the MN sends a binding update to
the HA?

>to medium business that may not have large infrastructures in place.

Is there any limitation in terms of having Mobile IP support for such
devices? And why would you not be able to have Mobile IP in whatever
infrastructure exists (either in the home network or the small
business)? Are you concerned with the fact that if you have Mobile IP,
then you need an HA at the least (in the case of IPv6)? 

Regards,
-Basavaraj

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 23:39:05 +0100

Regards,

 Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 23:39:05 +0100

Regards,

 Hesham

---

From: [email-masked]
Date: Wed, 28 Feb 2001 19:42:06 -0600

Phil,

Regards,
-Basavaraj

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 23:39:05 +0100

Regards,

 Hesham