Subject: RE: [seamoby] Single sentence problem statements

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Thu, 8 Feb 2001 12:58:36 +0100

Hello Mike

>  > >  > 	As for IKE and whether it's too heavy, spectrum 
> inefficient ..etc
>  > >  > 	please have a look at 
> draft-soliman-mobileip-routeopt--mipv6-00.txt 
>  > >  > 	which proposes an alternative.
>  > > 
>  > > This is _simpler_ than IKE? Yikes. Also: it looks
>  > > like you've managed to recreate the cross realm
>  > > Kerberos wheel with about 15 years less deployment
>  > > experience.
>  > > 
>  > 	=> So Sending one message from the MN to establish an 
>  > 	SA is more complex than doing an IKE exchange in your opinion ?
>  > 	Apart from suffering the "Yikes", is there a technical argument
>  > 	against the draft ?
>  > 	Really, we'd like to get some technical feedback.
> 
>     Well, first of all the notion that CN has any
>     relationship with a AAA of any sort is highly
>     suspect, IMO. Whose AAA is my apache web
>     server supposed to be contacting?

Clearly it doesn't apply to all cases and this was not the purpose of
the draft. On the other hand I expect the AAA infrastructure to be
widespread, it already includes some KDC functionality and therefore
looks pretty good for the purpose of things like SA establishment
for Mobile IP route opt. between mobile devices. My thinking is that
Route opt will be most useful for real-time applications between mobiles
so your apache web server example was not the aim.

> 
>     Second, if you want centralized key distribution in 
>     the manner you are describing, Kerberos is a far
>     better fit and has been around forever. Kerberos in
>     general has a lot of very appealing properties for
>     fast mobility and scaling.
> 

The mechanism in the draft is different from Kerberos. We try
to eliminate the direct communication between nodes and only go
through the AAA infrastructure. Also, you seem to be assuming that
Kerberos KDCs will be available everywhere while AAA won't be?

Rgds
/Karim

---

From: Michael Thomas <[email-masked]>
Date: Thu, 8 Feb 2001 12:53:51 -0800 (PST)

First, let me apologize since this is pretty
off-topic -- I wanted to take this to mobile-ip,
but Nortel's listserv seems to have completely
melted down.

 > widespread, it already includes some KDC functionality and therefore
                                       ^
                                       |
                                       tenuous to put it in the most
                                       charitable terms

 > so your apache web server example was not the aim.

   I don't see why there's any advantage if it means that you
   have to have a completely different mechanism to deal
   with servers and interrealm. The moblie node is 
   then stuck with yet another way to key SA's.

   The entire scheme strikes me as a gigantic hack
   and yet another misuse of AAA which seems to be
   giant accretion disk of bad ideas.

 > to eliminate the direct communication between nodes

   That sounds like a bug not a feature to me.   
   How, for example, do you plan to allow each
   host to contribute to the keying material
   entropy? Cipher suite negotiation? Cross
   realm keying and policy? Oh, and best of all
   how does MN/CN trust the AAA? Current AAA
   assumes unidirectional (client->AAA) trust.

 > and only go

   AAA certainly will not be used where access
   control is not needed. Kerberos and distributed
   PKI's at least have the advantage that they 
   address security problems common across narrow
   slices of the problem space.

	     Mike

---

From: Patrice Calhoun <[email-masked]>
Date: Thu, 8 Feb 2001 13:03:38 -0800 (PST)

>    Oh, and best of all
Correction. RADIUS has a unidirectional trust relationship. Diameter does not,
and it's bi-directional relationship is a MUST for Mobile IP.

PatC

---

From: Michael Thomas <[email-masked]>
Date: Thu, 8 Feb 2001 13:18:52 -0800 (PST)

> and it's bi-directional relationship is a MUST for Mobile IP.

   Well, I did say current. The last I heard in
   the AAA WG, MN and AAA  don't directly communicate.
   How does MN verify the identity of the AAA
   cryptographically? Is it done case by case?
   At least Kerberos has IAKERB which gives a
   standard way to deal with relay-like
   functionality with mutual authentication.

	      Mike

---

From: "David Oran" <[email-masked]>
Date: Mon, 12 Feb 2001 11:20:12 -0500

Is that relationship with the MN or the AR? If with the AR I'm not sure Mike's point is addressed.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Patrice Calhoun
> Sent: Thursday, February 08, 2001 4:04 PM
> To: Michael Thomas
> Cc: Karim El-Malki (ERA); [email-masked]
> Subject: RE: [seamoby] Single sentence problem statements
> 
> 
> >    Oh, and best of all
> Correction. RADIUS has a unidirectional trust relationship. 
> Diameter does not, and it's bi-directional relationship is a 
> MUST for Mobile IP.
> 
> PatC
> 
>

---

From: Patrice Calhoun <[email-masked]>
Date: Mon, 12 Feb 2001 08:23:03 -0800 (PST)

> Mike's point is addressed.

An MN has a bi-directional relationship with the AAAH. This is needed in order
to compute the MN-HA auth extention in the Registration Reply. The AAAH sends
an ephemeral key to the HA, which is used to compute the MN-HA auth ext.

There is no concept of an AR in MIPv4. The AAA/Mipv6 interactions haven't been
worked out yet.

PatC