Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

From: [email-masked]
Date: Fri, 23 Feb 2001 14:33:04 +0200

Hi Hesham,

> > Just to be pendantic, do you mean to state that if there isn't
> > an existing solution for something, there cannot be a problem?
> > 
> 	=> Of course not, I meant the opposite. A problem can 
> 	only be a problem if there is NO existing solution. 
> 	That's why when you define a problem you should say that for 
> 	your particular requirements there is no solution.

I'll split the hairs this time and state that there MAY be solutions 
for MM, but it is not well defined or understood.  For example,
Cellular IP COULD be our solution.  However, to get the right
answer, one should ask the right question.  This is what I 
believe we are attempting to do.

> > > => Is it low or zero ?
> > 
> > The target is zero.  
> > 
> 	=> Please say that in the text.

Please refer to the abstract:

Abstract

Seamless mobility requires preserving the capability, security, and quality
of service offered to a mobile node during handovers. To achieve
seamlessness, low (ideally no) latency and low (ideally zero) packet loss
handover protocols are needed. 

> > > Ch 3.1
> > > 
> > > "4)   Configurability:    Plug & Play of routers/base stations not
> > >                               addressed - need to configure 
> > > HA/FA/GFA's
> > >                               etc."
> > > => V6 ??
> > 
> > V6 doesn't address the capabilites of the routers & base stations. 
> > 
> 	=> You're talking about P&P and then referring to v4 entities
> 	as being a problem. I'm saying that you don't 
> 	have FAs on each link in v6. 

Yes, but SeaMoby may need to address MIPv4 as well.  But, I will adjust
the language and mention MAPs (HMIPv6) as well.
 
> > V6 does have autoconfiguration, but there's more to it.
> > 
> 	=> John, is it not clear to you that the text only addresses
> 	v4 ? Are we meant to guess what configuration problems v6 have ?

I will fix this & mention that plug & play isn't only about
autoconfiguration.

> > > "Mobile Network      controversial.
> > >           Support:"
> > > 
> > > => Why is it controversial ?
> > 
> > Controversial because there are those that feel MIP does not
> > attequately support the needs of Mobile Networks.  This needs
> > to be analyzed.
> > 
> 	=> "feel" ? Ok I guess we can skip this one. 

I'll root around for some supporting info on this.  I can't remember
who wanted this point ...

> > > In Ch 4.1.1
> > > 
> > > You mention this scenario and then you go into the details 
> > > of L2 interactions. I don't see this as being relevant for 
> > > IP protocols. You clearly defined an Access Point as an L2
> > > device and I agree with that, but this means that such device
> > > doesn't have IP in it. So I'm not sure why this section
> > > is needed and why refer to IEEE stuff.
> > 
> > If an access router is connected to 2 different access points,
> > which have overlapping coverage by 2 different L2s, there may
> > need to be some way to handle this.  MM may be needed to 
> > select between APs of different L2 types.  
> > 
> 	=> So the MN can select one of the 2 AP's right ?
> 	Is the suggestion that we need IP protocols for this choice 
> 	to be made ? 
> 	Perhaps that MM could be a function/API in the MN.
> 	It's just not obvious to me that we need L3 protocols 
> 	(between to nodes) for this, since the APs don't 
> 	have an L3 stack.

There would be IP from the APs to the to the Access Routers.
Of course, we could let the mobile handle this, but also
we may wish to let the network do this as well.  There have
been proposals to have some contract bidding algorithms for
network assisted handovers.  In such a case, the capabilities
of the access points may be a factor in the determining the
handover candidates.  This may or may not be a requirement.  
This is something we should discuss in the requirements part.

cheers,
John

---

From: "Dana L. Blair" <[email-masked]>
Date: Tue, 27 Feb 2001 08:31:49 -0500

>the language and mention MAPs (HMIPv6) as well.

SEAMOBY needs to consider both IPv4 and IPv6 solutions.

>who wanted this point ...

That was me.  I'll state it a little more clearly.  Charlie and I debated this
point on the list, so the debate may come back up here.

Mobile IPv4 (rfc2002 or route optimization draft) does not address how to support route opimization for
Host on a Mobile Network.

Mobile IPv6 draft does not even mention Mobile Networks much less how to support
route optimization for Hosts on a Mobile Network.

>> 	(between to nodes) for this, since the APs don't 

Let's not get too hung up on the scenarios.  The requirements process would
weed good and bad ideas of the scenarios.

I don't think we should assume that the AP and AR can be combined
into a single system.  Route advertisements is an example of
an AP/AR advertising its network capabilities so there is already
a precedent for layer 3 protocol.  The MN may get information
from Layer 3 and Layer 2 to make the "best" handover decision.

thanks,
Dana