Subject: RE: [seamoby] centralized vs. distributed context storage

From: "Gary Kenward" <[email-masked]>
Date: Thu, 22 Feb 2001 22:47:46 -0500

Fault tolerance is an important part of the problem statement, and
some text should be added. However, you are describing a solution.

In fact, I don't believe anyone has actually supported a "centralized"
repository - it was simply included as an example for completeness.

Gary

> -----Original Message-----
> From: Shahrier, Sharif M. [mailto:[email-masked]]
> Sent: Thursday, February 22, 2001 3:09 PM
> To: 'Henrik Levkowetz'; Shahrier, Sharif M.
> Cc: Pat Calhoun; Kenward, Gary [WDLN2:AN10:EXCH];
> [email-masked]'
> Subject: [seamoby] centralized vs. distributed context storage
> 
> 
> I had a favorable response to the fault-tolerant issues of 
> context storage
> in a centralized  vs. distributed repository. Thus, in this 
> light I would
> like to add a sub-section following 4.1.4 on "distributed 
> repository". Under
> this scheme, there would be several repositories, keeping 
> copies of the
> contexts, e.g. a 3MR system. Hence, if one of them fails, it is still
> possible to retreive the context from a working repository. Another
> advantage of a 3MR (NMR, in general) is that it reduces 
> contention compared
> to a centralized repository. Of course, a disavantage of the 
> distributed
> case is that more hardware is required for the replications.
> 
> Sharif Shahrier
>

---

From: "Shahrier, Sharif M." <[email-masked]>
Date: Fri, 23 Feb 2001 09:22:04 -0500

Gary,
 
What I want to do is to add a sub-section following "centralized repository"
called "distributed repository" ---
for completeness sake. We should describe the stucture of such a repository
and discuss some advantags over the entralized scheme, namely
fault-tolerance. However, the disadvantage is that it may require more
hadware.
 
That's all the additions I want to make on the ct draft for now. I will be
sending text on this to Henrick by Monday.
 
Thanks.
 
Sharif

-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Thursday, February 22, 2001 10:48 PM
To: 'Shahrier, Sharif M.'; 'Henrik Levkowetz'
Cc: Pat Calhoun; [email-masked]'
Subject: RE: [seamoby] centralized vs. distributed context storage

Gary 

> From: Shahrier, Sharif M. [ mailto:[email-masked]
<mailto:[email-masked]> ]

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Fri, 23 Feb 2001 11:13:41 -0600

I admit fault tolerant context storage is an important issue, however, storage issues were removed, since the draft is concerned with context TRANSFER, not storage. The central versus distributed repository was mentioned since it affects the transfer mechanism. For fault tolerance in that respect, we added RELIABILITY IN CONTEXT TRANSFER instead.

Madjid 

-----Original Message-----
From: Shahrier, Sharif M. [mailto:[email-masked]]
Sent: Thursday, February 22, 2001 2:09 PM
To: 'Henrik Levkowetz'; Shahrier, Sharif M.
Cc: Pat Calhoun; Gary Kenward; [email-masked]'
Subject: [seamoby] centralized vs. distributed context storage

I had a favorable response to the fault-tolerant issues of context storage
in a centralized  vs. distributed repository. Thus, in this light I would
like to add a sub-section following 4.1.4 on "distributed repository". Under
this scheme, there would be several repositories, keeping copies of the
contexts, e.g. a 3MR system. Hence, if one of them fails, it is still
possible to retreive the context from a working repository. Another
advantage of a 3MR (NMR, in general) is that it reduces contention compared
to a centralized repository. Of course, a disavantage of the distributed
case is that more hardware is required for the replications.

Sharif Shahrier

---

From: "Shahrier, Sharif M." <[email-masked]>
Date: Mon, 26 Feb 2001 14:53:36 -0500

OK. But we must discuss this in the requirements phase.

-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Monday, February 26, 2001 10:53 AM
To: 'Pat Calhoun'; Shahrier, Sharif M.
Cc: 'Henrik Levkowetz'; [email-masked]; Kiernan, Brian G.
Subject: RE: [seamoby] centralized vs. distributed context storage

On this basis alone, I do not agree with the proposed change. 
There was plenty of opportunity to propose this addition 
prior to the last release, and the suggested change really doesn't 
significantly change the problem statement (while it is definitely 
relevant to the requirements). 

I think as a wg, we all want to move forward to working on 
solutions. 

Gary 

> From: Pat Calhoun [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Friday, February 23, 2001 9:41 AM 
> To: Shahrier, Sharif M. 
> Cc: 'Henrik Levkowetz'; [email-masked]; Kiernan, Brian G. 
> If the WG agrees that your proposed new section is worth 
> being included, then 
> the editor must include it. However, do keep in mind that 
> this would push our 
> problem statement being delivered to the IESG until April 9th, at the 
> earliest, since the next revision of the problem statement 
> I-D cannot be 
> submitted until after the IETF (and it takes a few days to 
> get published + 2 
> weeks last call). 
> 
> My 2 cents, 
> 
> PatC 
> > Henrik, 
> > 
> > I don't disagree with you. All I wish to do is add a small 
> sub-section 
> > called "distributed repository" following the text on "centralized 
> > repository". I will be sending you text to look at. Other 
> than that, I'll 
> > have no futher comments on the ct draft. 
> > 
> > Thank you. 
> > 
> > Sharif 
> > 
> > From: Henrik Levkowetz [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> > Sent: Thursday, February 22, 2001 5:56 PM 
> > Cc: [email-masked] 
> > Subject: Re: [seamoby] centralized vs. distributed context storage 
> > 
> > 
> > Sharif, 
> > 
> >     I'd like to look forward to the next step, which I hope 
> willd be a 
> > requirements document, rather than fiddle too much with the problem 
> > statement.  From the comments so far, it seems that we have managed 
> > to present the case for context transfer in an acceptable 
> form, which 
> > will enable us to go forward -- which is the whole idea. 
> >     Would it be acceptable to you to leave the draft as-is for now, 
> > and then maybe, if it finds favour with the gods, put your thoughts 
> > and requirements into the requirements document? 
> > 
> >     Regards, 
> >         Henrik 
> > 
> > Sharif wrote: 
> repository". 
> > Under