Subject: RE: [seamoby] Is Mobile IP too slow or is Routing Table Update Too slow? (was....)

From: "Dana L. Blair" <[email-masked]>
Date: Tue, 27 Feb 2001 10:49:58 -0500

At 03:07 PM 2/27/01 +0100, Hesham Soliman  (ERA) wrote:
>> >>  
>> >> ..i.e.: The only thing that regional/hierarchical schemes give you is 
>less 
>> >signaling traffic over the network in the cases were your Home Agent 
>happens 
>> >to be far away..
>> >> 
>> >	=> The amount of signalling is not dependant on how far away the HA is. 
>> >	What HMIP gives you is reduced signalling, better routing and ability to 
>> >	better handle frequent movements. The "better routing" part is due to 
>> >	the fact that packets do not need to be routed via the old AR first. Of 
>course
>> >	the old AR may in many cases not be directly connected to the new AR
>> >	(ie. not sharing a link with the new AR). 
>> 
>> What HMIP gives you is multiple stateful single points 
>> 
>	=> Multiple ?? I'm only aware of one. Could you 
>	please explain ?

There is the Home Agent and other anchor points.

>
>> single points of failure that inhibit
>> routing optimization instead of a one single point of failure that 
>inhibits routing
>> optimization (the Home Agent).
>> 
>	=> So you're only objection is clearly the redunduncy issue. 
>	We've already planned to prposing a solution for that anyway. 

Not really.  I see the HMIP solution as equivalent to introducing NAT's into
the network.  It breaks end to end addressability.

>
>> By route optimization I don't mean Mobile IP routing
>> optimization.  
>> 
>> I mean the more basic principle of letting routers choose the best path
>> from source to destination which includes routing arould failure points.
>> 
>	=> Yes that's fine, but MIP solves a problem that has to scale for 
>	the whole Internet. Now there is an argument that once ou have 
>	that solution and can also support local mobility with minor 
>	extensions, is it really worth inventing something new ? 
>	Maybe, but there is no proof yet. All I'm hearing from you 
>	is feelings. I admit the redundancy issue is important but 
>	I think it's fixable.

I think there are feelings on both sides of this issue since there is no
globally scaled Mobile IP network deployed yet.    I take the historical side of the internet
which says keep the internals of the network dumb (just layer 3 router protocols)
and push intelligence to the endpoint (clients, servers, peers).  This goal
of the IP network is one reason why IP has triumphed over other networking
protocols, OSI, SNA, Novell, SS7, ATM.   However, we won't really know for
certain until implementation, but I think history is on the side of addressing
endpoints and not middle men.

BTW, please don't take my comments to mean that I don't think Mobile IP has any value.
It does and should be worked on.  However,  I do believe there is a need for a mobility
solution that fits the historical end-to-end internet addressing model.  That is what we
tried to define in the micromobility effort within SEAMOBY.

thanks,
Dana

>	Hesham

---

From: Claude Castelluccia <[email-masked]>
Date: Wed, 28 Feb 2001 09:57:17 +0100

> the network.  It breaks end to end addressability.

Well what can I tell you: you probably did not read the right HMIP draft (or did you read it at
all?) ...

Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/