Subject: The trouble with MIP (was:RE: [seamoby] I-D ACTION:draft-ietf-sea moby-mm-problem-00.txt)

From: George Tsirtsis <[email-masked]>
Date: Fri, 23 Feb 2001 04:49:39 -0500

I am trying to follow this discussion but traffic levels are getting
worst...and that does not help...Anyway...

Here is a different (abstract) take on what the problem with MIP is...

If you think that scaling MIP requires Hierarchical/Regional FAs, GFAs, MAPs
and other such "in the middle of the network boxes" (the MIP Home Agent is
already one of these) then that is were MIP's limitation is. Introduction of
such boxes in the Internet data path will take from it the fundamental
feature of distributed networking that Internet has been trying to maintain
for long time now i.e.: the idea that loosing a router (or even a number of
routers does not bring down the network). It also takes away the idea that
intelligence exists at the edge which basically means that the middle of the
network should all be the same (i.e.: Routers with varying decries of bit
shifting capability) and thus cheap...and other such fine points...

Now, micromobility protocols that require a tree like network to operate
improve only up to a point....i.e.: they represent the limit of what
hierarchical MIP approaches can do...(put a hierarchical/regional FA on
every branching point of the tree network and you get a micromobility
protocol), the fact that they may use different signaling mechanisms does
not change the principle of operation.

George

-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Friday, February 23, 2001 4:06 AM
To: 'Hesham Soliman (ERA)'; 'Michael Thomas'
Cc: [email-masked]
Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

> -----Original Message----- 
> From: Hesham Soliman (ERA) [mailto:[email-masked]] 
> Sent: Thursday, February 22, 2001 5:47 PM 
> To: 'Michael Thomas'; Hesham Soliman (ERA) 
> Cc: [email-masked] 
> Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt 
> 
> 
> > Hesham Soliman  (ERA) writes: 
> >  > "The assumption is that a local protocol can address these goals 
> >  >    better by limiting its applicability to a smaller 
> domain (such as an 
> >  >    intranet - e.g. warehouse, and not the entire 
> internet as in the 
> >  >    case of Mobile IP) and reverting to Mobile IP for the 
> general case 
> >  >    of internet mobility support." 
> >  > 
> >  > => This already assumes that the mm protocol is not 
> >  > based on MIP. I think it's premature to say so. Also I 
> >  > don't see why limiting the applicability of a protocol 
> >  > to a local domain makes it "better". 
> >  > BTW what is "better" ? 
> > 
> >    Um, that's exactly what HMIP does, yet I don't 
> >    see you complaining about it. 
> > 
>       => HMIP IS MIP with very minor extensions. 
>       I had two simple questions, why is it assumed 
>       that MIP is only good for inter-domain mobility 
>       and what is"better". "better" needs to be explained. 
*sigh* The problem is that "better" largely means faster 
(and in some discussions, less complex). The problem being 
that no one will agree on what "faster" means. There are no 
solid numbers. 
The IETF usually relies upon operational experience and empirical 
measurements of operational networks to determine if a solution 
is performing as it should. 
However, there is much at stake here. After 10+ years of development, 
there is little, if any, operational experience with MIP (none with HMIP 
or FH). And there are many who are do not believe that MIP will provide 
the performance they need for wireless networks they wish to deploy 
in the near future - they don't have time to wait for reports on operational

experience. 
This discussion has been spinning around for at least 8 months now. 
No one is going to get any closer to defining "better". And the lack 
of a crisp definition is not going to silence those that believe there 
is a better way. 
Just my 2 cents (Canadian) worth. 
Gary

---

From: "cnyap" <[email-masked]>
Date: Sun, 25 Feb 2001 14:15:56 -0000

Hi

Yes, what you have said is true.
May be you want to try IIP instead. :)
http://search.ietf.org/internet-drafts/draft-cnyap-iip-02.txt

Chern Nam Yap
MIEEE, MSc(Res), BSc(Hons)
Research Associate
Center for Mobile Communication Research
Department of Electronic and Electrical Engineering
University of Sheffield
F132 Mappin Building
Mappin Street
Sheffield S1 3JD
United Kingdom
Tel:+44 (0) 114-222-5182
Mobile:+ 44(0) 7712804892
Web: www.mobile1.net
E-mail: [email-masked]

----- Original Message -----
From: "George Tsirtsis" <[email-masked]>
To: "'Gary Kenward'" <[email-masked]>; "'Hesham Soliman (ERA)'"
<[email-masked]>; "'Michael Thomas'" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Vincent Park"
<[email-masked]>
Sent: Friday, February 23, 2001 9:49 AM
Subject: The trouble with MIP (was:RE: [seamoby] I-D
ACTION:draft-ietf-seamoby-mm-problem-00.txt)

---

From: "cnyap" <[email-masked]>
Date: Sun, 25 Feb 2001 14:15:56 -0000

Hi

Chern Nam Yap