Subject: RE: [seamoby] comments on draft-ietf-seamoby-mm-problem-00.txt

From: "Dana L. Blair" <[email-masked]>
Date: Tue, 27 Feb 2001 08:20:59 -0500

At 04:48 PM 2/21/01 -0600, Roberts Philip-qa3445 wrote:
>
>
>> ----------
>> From: 	[email-masked]
>> Sent: 	Wednesday, February 21, 2001 4:20 PM
>> To: 	Roberts Philip-qa3445
>> Cc: 	[email-masked]
>> Subject: 	Re: [seamoby] comments on draft-ietf-seamoby-mm-problem-00.txt
>> 
>> 
>> 
>> Hi Phil,
>> 
>Hi Phil,
>
>
>
>
>
>
>> While this seems to be a very concrete item for the working group it's
>> difficult to see the problem statement in the rest of the document for which
>> this work would apply.  It appears to be a solution without a problem.
>> Specifically one might want to state a problem and then why a combination of
>> mobile ip fast handovers and regional registrations wouldn't suffice to
>> solve it.

I think our problem statement captures the real problem.  How to support mobility
while maintaining the same routable IP address ?  All non-mobile devices work
today by keeping the same IP address while connected to the internet.  Servers
have a permanent IP address because that need to always be reachable.  Clients
may get a temporary IP address during a dialup connection, but the address remains
constant during the dialup connection.

I think it is interesting that the religion about Mobile IP has discarded/ignored a basic assumption about
how the internet works.  In solving the problem,  Mobile IP has introduced a stateful intermediary (Home Agent)
in the middle of the IP network which breaks the end-to-end model which has allowed the internet
to scale to the level it has.  By end-to-end I mean intelligence (layer 4 and above) at the endpoints
and routing (layer 3) in the middle.   Mobile IPv6 has extended the abuse introduced by Mobile IPv4
by requiring an IPSEC endpoing in the middle of the network.  Maybe Mobile IPv4 was the only
solution 4 or 5 years ago when Mobile IP was initially being discussed, but we want to look at the
original problem. 

We might not to work on stating the problem in a better way.  I'll try to make an attempt.

Problem Statment:
The internet works with clients, servers, and peers using the same IP address
while connected to the internet.   The internet works by addressing devices at the edge of the
network not in the middle of the network.  Mobile clients, servers, and peers should operate
the same way.  How can the internet support mobile clients, servers, and peers while
keeping the same routable IP address ?

Please don't confuse routable IP address with Mobile IP Home Address.   The Mobile IP Home Address
is only routable to the endpoint (client, server, or peer) if the MN is on the home nework and not
using a virtual home network.

>> 
>> pdn>Early on, I had a single sentence problem statement that b*tched about
>> pdn>how slow mobile IP would be if/when used in a tangle of pico cells
>> pdn>and how completely unnecessary it is in these scenarios.  It got yanked.
>> pdn>I still believe we need a single statement that does complain about
>> pdn>how MIP is intended for macro not micro-mobility.
>> 
>I'm not sure about the history of intent, or the meaning of macro or 
>micro-mobility, but perhaps a useful item to suggest would be a performance 
>analysis?

Performance analysis can support or defeat just about any solution depending
on the network characteristics.  At a higher level, it is best to keep routing topology
changes near the point of change instead of transporting them all the way back
to some middle man in the network like a Home Agent. 
The best way to do
this is define a solution which does not require a middle man (stateful gateway).
Unfortunately, Mobile IP assumes the middle man then tries to work around it.

thanks,
Dana

>> There are a few other interesting items in the document.  I was intrigued by
>> the idea of discovery of new access link and new access router, and
>> characteristics of those.  Fast handover is a fairly large problem with lots
>> of aspects.  Mobile IP solves one part of it.  There are other pieces that
>> need to be solved on the router side of it in routed networks.
>> 
>> pdn>I am not sure what you mean here Phil.  Given that MIP is in the router
>> pdn>work area of the IETF wouldn't this be more work for MIP?
>> 
>All I meant was that discovery of new access routers and their 
>characteristics was an interesting problem to be investigated.
>
>
>> One last comment.  I was hoping to find a definition of micromobility in the
>> definitions section.  Is it possible to add that?
>> 
>> pdn>Whoops.  Probably should define macro-mobility too!
>> 
>> Phil (not that one, the other one)
>> 
>> Phil (not the original email author, that one)
>> 
>Phil (figuring out which one is left as an exercise for the reader)
>
>
>
>
>

---

From: Erik Anderlind <[email-masked]>
Date: Tue, 27 Feb 2001 11:27:59 -0500

Hi Dana,
I completely agree with your synopsis of the mobility problem.
Single points that traffic must pass through are not desireable.
Performance is important, but so is communication service availability.
...Erik