Subject: RE: [seamoby] Is Mobile IP too slow or is Routing Table Update To o slow? (was....)

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 27 Feb 2001 15:07:10 +0100

> >>  
> >> ..i.e.: The only thing that regional/hierarchical schemes give you is less 
> >signaling traffic over the network in the cases were your Home Agent happens 
> >to be far away..
> >> 
> >	=> The amount of signalling is not dependant on how far away the HA is. 
> >	What HMIP gives you is reduced signalling, better routing and ability to 
> >	better handle frequent movements. The "better routing" part is due to 
> >	the fact that packets do not need to be routed via the old AR first. Of course
> >	the old AR may in many cases not be directly connected to the new AR
> >	(ie. not sharing a link with the new AR). 
> 
> What HMIP gives you is multiple stateful single points 
> 
	=> Multiple ?? I'm only aware of one. Could you 
	please explain ?

> single points of failure that inhibit
> routing optimization instead of a one single point of failure that inhibits routing
> optimization (the Home Agent).
> 
	=> So you're only objection is clearly the redunduncy issue. 
	We've already planned to prposing a solution for that anyway. 

> By route optimization I don't mean Mobile IP routing
> optimization.  
> 
> I mean the more basic principle of letting routers choose the best path
> from source to destination which includes routing arould failure points.
> 
	=> Yes that's fine, but MIP solves a problem that has to scale for 
	the whole Internet. Now there is an argument that once ou have 
	that solution and can also support local mobility with minor 
	extensions, is it really worth inventing something new ? 
	Maybe, but there is no proof yet. All I'm hearing from you 
	is feelings. I admit the redundancy issue is important but 
	I think it's fixable.

	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Tue, 27 Feb 2001 08:00:41 -0800 (PST)

> 	We've already planned to prposing a solution for that anyway. 

   And least cost routing. And administrative
   overhead. And general complexity of having an
   overlay network.
 
 > 	the whole Internet. 

   MIP does, HMIP does not.

 >      Now there is an argument that once ou have 

   There's nothing new to invent for a routing protocol
   to change the reachability of a host (or subnet) to
   another router, as far as I know.

 > 	is feelings. I admit the redundancy issue is important but 

   With routing based solutions, there's about, oh say,
   going on 30 years of experience of how to deal with
   failover and redundancy. It was extremely painful,
   and continues to be extremely painful. Pardon me
   if I view your "fixable" with healthy dose of
   skepticism.
   
		Mike