Subject: RE: [seamoby] Re: New name -> Seamless to become Hidden Handover? ?

From: "Gary Kenward" <[email-masked]>
Date: Fri, 2 Feb 2001 10:53:14 -0500

comments inserted....

> -----Original Message-----
> From: Jukka Manner [mailto:[email-masked]]
> Sent: Friday, February 02, 2001 2:23 AM
> To: Phil_Neumiller
> Cc: seamoby
> Subject: Re: [seamoby] Re: New name -> Seamless to become Hidden
> Handover??
> 
> 
> 
> 	Hi,
> 
> On Thu, 1 Feb 2001 [email-masked] wrote:
> >
> >         A HiHo handover deals mainly with QoS, so to an 
> application and its
> >
> > pdn>Wherever did you get this fixation on QoS?  IMHO, a 
> HiHo  is the epitome
> > pdn>of handovers combining all desirable qualities including QoS.
> >

I probably should have said "service" or "quality of service",
without the capitals. From a users perspective, there is a service
(http + IPSec for secure www browsing for example), and there
is the quality with which that service is provided. 

So, in order to end this micro-debate, let's substitute "context"
for "QoS", and define (as we have been) context (e.g. QoS, security,
etc.).

> 
> 	Notice the word "mainly"... Anyway, if QoS weren't such 
> a big deal, we
> wouldn't have nearly such a big problem as the CT team 
> is/will be having.

If QoS weren't such a big deal, we would have only BE and
any old handover mechanism that took less then 1/2 sec and
dropped fewer the 1% of the packets would do....

(these are the rough thresholds where TCP starts to act up)

> 
> > flows a HiHo should not be seen. But if a HiHo is also a 
> Vertical handover and

HiHo, HiHo, it's off to work we go...

I feel like I'm in a Disney movie. We don't need a new term.
seamless works fine enough.

> > the IP layer's network interface changes, i.e.. a HO from a 
> 3G network to a WLAN,
> > the HO is noticed, at least the user will see this.
> >
> > pdn>If its a vertical HO, and the COA must change, it is no 

No. As I pointed out to Jukka, a COA will change only if the
veridical handoff is inter-network. There are real scenarios where
the vertical handoff is intra-network.

> longer a HiHo or
> > pdn>a concern of SeaMoby MM (however SeaMoby CT is still 
> interested).  This is
> > pdn>my understanding of the SeaMoby boundaries, i.e. 
> Micro-mobility is invoked
> > pdn>when COA does not change, and CT controlled by either 
> Macro or Micro mobility
> > pdn>will always be invoked in some manner.
> >
> 
> 	True, that Seamoby MM might not be interested, but CT 
> team is definitely
> interested: Context transfer deals with change of ARs, 
> independent of whether
> the link layer technology changes or not (or might be part of 
> a CT, but does not
> limit it).
> 
> 	But isn't an inter-technology HO, that still maintains 
> the context of
> the MH a HiHo? If we do a HO from some 3G tech to WLAN and 
> keep the QoS,
> wouldn't that still be a HiHo? Or do we need a new term to 
> define that HO:
> 
> "Context-aware" HO: context+seamless+including inter-tech ?

The purpose of these definitions is to map out the problem space
clearly enough for ourselves and the IETF to understand what it is 
we want to work on.

The definitions will never be linear, complete, and closed. And we will
be here forever if we attempt to make them so. What we do need to
be careful about, is ensuring that the definitions are not redundant,
nor contradictory, nor co-dependent.

Put another way, we need to describe the complex problem space by
identifying and defining a sparse set of independent definitions.

Gary

> > Take it easy,
> > pdn
> 	You too, :)
> 	Jukka

---

From: Phil Neumiller <[email-masked]>
Date: Fri, 02 Feb 2001 20:12:00 -0600

> Gary Kenward wrote:

This is interesting Gary.  As an aside, what would happen if
we tunnelled TCP and UDP over SCTP to avoid these strange 
things?  (I KNOW ITS SOLUTION SPACE!!!!)

> seamless works fine enough.

<pdn>
Yeah, I guess its time to kill the Disney references (even though
I could could have claimed the "Grumpy" dwarf name).  Seamless
is overloaded, but we might as well build a black hole for it
here in SeaMoby.  Perhaps we can get the MIP guys to stop using
the term sooooo very much??? :-)  They seem to use it like a
marketing term for their fast handoff work which in the SeaMoby
sense is nowhere near Seamless, go figure.
</pdn>

> No. 
pdn>Yes... I should have not added the comma, I meant vertical + COA change
pdn>not vertical => COA change.

>As I pointed out to Jukka, a COA will change only if the
> veridical handoff is inter-network.
pdn>Of course.  and there are bound to be lots of both types in the
pdn>near future

>>>but CT

pdn>Yes I did indicate this.

> > the MH a HiHo?
pdn>Yeah but HiHo is dead, lets call it CMobyHO or seamoby HO or
pdn>something.  PLEASE SOMEBODY GIVE US AN ACRONYM for SEAMOBY
pdn>MICROMOBILITY HANDOVER.  HiHo is too flaky.  THO is not PC.
pdn>CMobHO?  CMbyHo?  IDHO (intra-domain handover)???????????

> > If we do a HO from some 3G tech to WLAN and
> > keep the QoS,

No.  Lets just have uno name for the seamoby HO.  We let MIP 
folks do their own thing as far as naming goes when CT is involved.
 
> identifying and defining a sparse set of independent definitions.

So, the definitions provide a "basis" for our space.  The problem
statements our set of theorems.  Gary, do you have a mathematics
background per chance?  Often your verbage strikes me as that of
a mathematician....

TNX,

-pdn (N9FCW)

---

From: Patrice Calhoun <[email-masked]>
Date: Mon, 5 Feb 2001 05:31:31 -0800 (PST)

> things?  (I KNOW ITS SOLUTION SPACE!!!!)

Tunneling a reliable transport over a reliable transport is evil. Let's not go
there...

> sense is nowhere near Seamless, go figure.

Having participated heavily in the MIP work, I have *never* heard anyone use
the term seamless. The only term that I know of that was used is fast.

PatC