Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

From: "Dana L. Blair" <[email-masked]>
Date: Tue, 27 Feb 2001 09:50:44 -0500

At 02:52 PM 2/27/01 +0100, Hesham Soliman  (ERA) wrote:
>> >Did you read my answer to Mike ?
>> >if not, you can read HMIPv6 extended 
>> >mode to see how Mobile networks are supported in a 
>> >route optimised way. 
>> 
>> I don't consider any heirarchical scheme to be consistent
>> with route optimization.  Route optimization means the
>> IP routing layer (IS-IS, BGP, OSPF, ...) of the internet chooses the best 
>path
>> between client and server or one peer and another.  
>> 
>	=> That's your interpretation of the problem. MIP IS 
>	a routing protocol. Route optimisation in this context

We can agree to disagree on this point but the issues of addressing
something in the middle of the network instead of the actual endpoint
remain the same.

>	means choosing the shortest path between two nodes
>	on the Internet. 

Can you define node ?

>	I hope you don't mean that having a router in the 
>	middle that encapsulates a packet and forwards it
>	to the right address is breaking the Internet 
>	model. That _is_routing.

But that is not what a Home Agent does.  No user application like
email or web browsing on the internet addresses a router.  The cNode
and MN in Mobile IP actually address the Home Agent which has no
user application executing on it.

Furthermore, the Home Agent does not simply change the destination address or
look for a next hop address.   It
tunnels the packet.  The inner portion of an IP tunnel is the application
layer of the outer header.  So the Home Agent is in effect an application
layer switch in the middle of the network which is not too different than a NAT.

>
>> An
>> anchor point anywhere in the network is neither client nor
>> server nor peer and therefore 
>> 
>	=> It's a router ! They are usually in the middle
>	and they're not clients or servers.

See my point above.  The Home Agent is not a router.  Non-mobile
clients, servers, and peers do not address routers.  IOW, the IP
destination address of a packet originiating from a fixed client, server, or
peer on the internet is not the address of a router.  The same
behavior should be supported for mobile devices.

>
>> (a) interferes with routing optimization introducing
>> unnecessary latency, 
>> 
>	=> It's a router !

It's interesting that we disagree on the definition of a router.
In any case, my points are still valid.

>
>> and (b) reduces reliability by introducing a stateful
>> single point of failure.
>> 
>	=> I agree, but there are ways of making it redundant
>	like any other router.

The only way is stateful transfer which requires some state other
than IP routing to be transfered.  It's expensive an wasteful.
What about networks that want to be multihomed ?

>
>> >When Dana said it was not in the basic MIPv6 draft he 
>> >was right, but it doesn't mean that it's not done.
>> >
>> >As fo MIPv4 I agree that you can't do it in a route
>> >optimised way, but can you receive route optimised
>> >packets at all when following RFC2002 ?
>> 
>> There is a route optimizaton draft for Mobile IPv4.
>> 
>	=> I know. I was referring to RFC2002.
>
>	Regards,
>	Hesham

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 27 Feb 2001 10:19:36 -0800

Hello Dana,

> user application executing on it.

No user application addresses the home agent, either, unless you want
to call the mobile-ip daemon a user application.  Then you'd have to
call all routing protocols user applications, as well.

> layer switch in the middle of the network which is not too different than a NAT.

We can hammer definitions all day long until everything looks like a NAT.
But the facts remain that routers can tunnel.  Calling IP an application
running on top of IP is stretching the point far past useful discussion,
all the way into gasification.

> behavior should be supported for mobile devices.

The home agent can well be considered a router.  It can run
Mobile IP directly alongside other routing protocols, or it can
run the single Mobile IP routing protocol.  I wonder how you
might be able to devise a definition of "router" that does what
you want it to do.  The one you tried in this paragraph doesn't
seem to get anywhere close, unless you do the previous stretch.

> In any case, my points are still valid.

The point about how a home agent isn't a router depends on
your definition of a router, and thus the validity of that
particular point does too.  So far, I didn't see the other point(s)
of your message, unless you were referring to robustness but
I thought that was in other messages.

Regards,
Charlie P.

---

From: "Dana L. Blair" <[email-masked]>
Date: Tue, 27 Feb 2001 13:57:26 -0500

>call all routing protocols user applications, as well.

1. When the cNode builds a packet destined for the Mobile Node what IP address
does it put in the IP destination field ?

2. Which device in the internet is advertising a route the IP destination address
in question 1 ?

3. Is the device in question 2 running a software process for the application contained
in the packet ?

thanks,
Dana

---

From: Charlie Perkins <[email-masked]>
Date: Tue, 27 Feb 2001 11:23:11 -0800

Hello again,

Quiz time!  Yippee!  I want to win a prize.

> does it put in the IP destination field ?

The mobile node's home address.

> 2. Which device in the internet is advertising a route the IP destination address

It could be the home agent, or it could be another router on the
network to which the home agent is connected.  Of course, the typical
case is that the routers advertise a prefix, not the specific home address
of the mobile node.

> 3. Is the device in question 2 running a software process for the application contained

Typically not.

Do I get a prize?

Regards,
Charlie P.