Subject: RE: [seamoby] Is Mobile IP too slow or is Routing Table Update To o slow? (was....)

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 27 Feb 2001 20:06:10 +0100

> gnaling traffic over the network in the cases were your Home Agent 
> >happens 
> >> >to be far away..
> >> >> 
> >> >	=> The amount of signalling is not dependant on how far away the HA is. 
> >> >	What HMIP gives you is reduced signalling, better routing and ability to 
> >> >	better handle frequent movements. The "better routing" part is due to 
> >> >	the fact that packets do not need to be routed via the old AR first. Of 
> >course
> >> >	the old AR may in many cases not be directly connected to the new AR
> >> >	(ie. not sharing a link with the new AR). 
> >> 
> >> What HMIP gives you is multiple stateful single points 
> >> 
> >	=> Multiple ?? I'm only aware of one. Could you 
> >	please explain ?
> 
> There is the Home Agent and other anchor points.
> 
	=> No HA after route optimisation kicks in.
	Clearly this is more relevant to MIPv6 than v4.

> >
> >> single points of failure that inhibit
> >> routing optimization instead of a one single point of failure that 
> >inhibits routing
> >> optimization (the Home Agent).
> >> 
> >	=> So you're only objection is clearly the redunduncy issue. 
> >	We've already planned to prposing a solution for that anyway. 
> 
> Not really.  I see the HMIP solution as equivalent to introducing NAT's into
> the network.  It breaks end to end addressability.
> 
	=> I really don't see how it could possibly be a NAT
	but I already explaioned that in a previous mail.

> >
> >> By route optimization I don't mean Mobile IP routing
> >> optimization.  
> >> 
> >> I mean the more basic principle of letting routers choose the best path
> >> from source to destination which includes routing arould failure points.
> >> 
> >	=> Yes that's fine, but MIP solves a problem that has to scale for 
> >	the whole Internet. Now there is an argument that once ou have 
> >	that solution and can also support local mobility with minor 
> >	extensions, is it really worth inventing something new ? 
> >	Maybe, but there is no proof yet. All I'm hearing from you 
> >	is feelings. I admit the redundancy issue is important but 
> >	I think it's fixable.
> 
> I think there are feelings on both sides of this issue since there is no
> globally scaled Mobile IP network deployed yet.    I take the historical side of the internet
> which says keep the internals of the network dumb (just layer 3 router protocols)
> and push intelligence to the endpoint (clients, servers, peers).  This goal
> of the IP network is one reason why IP has triumphed over other networking
> protocols, OSI, SNA, Novell, SS7, ATM.   However, we won't really know for
> certain until implementation, but I think history is on the side of addressing
> endpoints and not middle men.
> 
> BTW, please don't take my comments to mean that I don't think Mobile IP has any value.
> It does and should be worked on.  However,  I do believe there is a need for a mobility
> solution that fits the historical end-to-end internet addressing model.  That is what we
> tried to define in the micromobility effort within SEAMOBY.
> 
	=> I do see your criticism of MIP as if you're saying it's useless,
	and that's ok. We shouldn't discourage other ideas. You do
	have a good point with the single points of failure also, but 
	not with your NAT analogy. 
	But the question is if whatever protocol SEAMOBY comes 
	up with has to interact with MIP, aren't you still stuck
	with the single points of failure (HA) ?
	Unless of course you come up with a replacement for MIP ?
	If that's the aim, then it is definitely not in your draft or the charter. 

	Regards,
	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Tue, 27 Feb 2001 11:24:16 -0800 (PST)

> 	but I already explaioned that in a previous mail.

   I don't think I agree with Dana's analogy with
   NAT's, but there is something at stake here. 

   Right now with the fixed Internet, my host need
   only know of exactly one router -- the default
   router. Many argued that even that was too
   onerous of a piece of knowledge, and things
   like DHCP (nee bootp) were invented which
   addressed that.

   Addition of a HA adds yet another layer of
   must-know requirements, and HMIP, FMIP, and
   all the rest that a MN must keep track of keeps
   adding to the complexity of the client at the
   cost of understanding the network topology. 
   This is especially true with HMIP which 
   requires lots of knowledge of the network.

   All in all, this seems to be headed us back
   to the bad old days of UUCP bang-paths. There
   is considerable reason, IMO, to be extremely
   skeptical of things which happily -- as if it
   something new or important -- bring us full circle
   to that which we managed to escape from because
   of IP.   

		Mike