Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 27 Feb 2001 14:52:14 +0100

> >Did you read my answer to Mike ?
> >if not, you can read HMIPv6 extended 
> >mode to see how Mobile networks are supported in a 
> >route optimised way. 
> 
> I don't consider any heirarchical scheme to be consistent
> with route optimization.  Route optimization means the
> IP routing layer (IS-IS, BGP, OSPF, ...) of the internet chooses the best path
> between client and server or one peer and another.  
> 
	=> That's your interpretation of the problem. MIP IS 
	a routing protocol. Route optimisation in this context
	means choosing the shortest path between two nodes
	on the Internet. 
	I hope you don't mean that having a router in the 
	middle that encapsulates a packet and forwards it
	to the right address is breaking the Internet 
	model. That _is_routing.

> An
> anchor point anywhere in the network is neither client nor
> server nor peer and therefore 
> 
	=> It's a router ! They are usually in the middle
	and they're not clients or servers.

> (a) interferes with routing optimization introducing
> unnecessary latency, 
> 
	=> It's a router !

> and (b) reduces reliability by introducing a stateful
> single point of failure.
> 
	=> I agree, but there are ways of making it redundant
	like any other router.

> >When Dana said it was not in the basic MIPv6 draft he 
> >was right, but it doesn't mean that it's not done.
> >
> >As fo MIPv4 I agree that you can't do it in a route
> >optimised way, but can you receive route optimised
> >packets at all when following RFC2002 ?
> 
> There is a route optimizaton draft for Mobile IPv4.
> 
	=> I know. I was referring to RFC2002.

	Regards,
	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Tue, 27 Feb 2001 07:46:04 -0800 (PST)

> 	to the right address is breaking the Internet 

   It may be routing, but it's not necessarily least
   cost routing with all of the failover/convergence 
   properties of real routing protocols. HMIP fails on both of
   those accounts.

 > 	and they're not clients or servers.

   But is, in general case, not in the least cost
   path.

 > > (a) interferes with routing optimization introducing

   But is, in general case, not in the least cost
   path.
 
 > 	=> I agree, but there are ways of making it redundant

   Yes, it's called using routing protocols. 

   How do you propose getting rid of backhoes?

	      Mike