Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

From: Michael Thomas <[email-masked]>
Date: Fri, 23 Feb 2001 09:51:22 -0800 (PST)

James Kempf writes:
 > In point of fact, macrodiversity resolution must be done at some point
 > back in the wired network. One can argue how useful or necessary including
 > macrodiversity is for a radio protocol, but CDMA currently
 > has it and there are good reasons (e.g. combatting Rayleigh fading) for
 > having it in. So having some kind of wired networks over which radio
 > frames are running to the macrodiversity resolution point
 > is a necessity for CDMA protocols.
 > 
 > Given that and the desire of many 3G operators and vendors
 > to use IP in their RANs, I don't see any reason why it should not
 > be considered.

   Well, my question is what is "it"? Support is a pretty
   loaded term, and I'm drawing a blank of what would be
   new, IETFwise, about a set of l2-over-IP flows going
   multiple places. Am I misremembering something? That
   seems to be just a standard tunneling application which
   doesn't doesn't have much of anything to do with CT or
   MM.

>  If one does consider it, it makes an even stronger case
 > for using a routing update based protocol instead of a tunnelling protocol,
 > because the time constraints on doing soft handoff are pretty strict, 
 > and the need to avoid mobile node involvement argues for maintaining the IP 
 > address. 

   I wish I could be happy about that, but it still doesn't
   make much sense to me. Let's make certain we're communicating:
   The thingy responsible for macro-diversity (SDU, I think)
   needs to transport multiple copies of the radio frames, not
   the IP datagrams that arrived at the GGSN, to
   the base stations that are visible to MN. These 
   frames are encapsulated as IP datagrams whose
   destination are the base stations involved with 
   the mobile node at the time. The base stations
   merely takes the radio frame and transmits it.
   The mobile receives it, adds all of the frames
   up as a L1/L2 operation up, and then
   reassembles the IP datagram and delivers it.
   Something similar happens in the reverse
   direction.

   Now, I certainly wouldn't disagree that there
   are any number of challenges, not the least of
   which is the implications for ISSLL, but I fail
   to see what that has to do with whether MIP
   or route based mobility is appropriate. MIP
   never even comes into the picture at this level
   because the _base stations and SDU's_ which
   are the destinations of the radio frames aren't
   mobile themselves. The tunneled data is just
   plain old IP datagrams.

 > This kind of mobility is currently handled by dedicated radio
 > network layer protocols, but, given the right kind of micromobilty
 > protocol, I think it could be handled by IP transport mechanisms in the
 > future.

   Sure, I'm all for IPifying everything, but
   I really don't see what this has to do with
   IP mobility qua IP mobility.

	Mike

---

From: James Kempf <[email-masked]>
Date: Fri, 23 Feb 2001 08:45:39 -0800 (PST)

Hi Mike,

> > Don't forget the cellular case where the network between the
> > AP and the Access Router may not even have full mobile packets
> > on it. It may have radio frames. I think this needs to be supported 
> > as well.
>
>   Supported in what way? Certainly not by SEAMOBY, I hope.
>   If we have to "support" every bad network design, we
>   might as well give up now.
>

"Bad" is naturally a subjective judgement, but I will refrain, as
has been discussed on this list recently with reference to "good", from 
pursuing that topic.

Given that and the desire of many 3G operators and vendors
to use IP in their RANs, I don't see any reason why it should not
be considered. If one does consider it, it makes an even stronger case
for using a routing update based protocol instead of a tunnelling protocol,
because the time constraints on doing soft handoff are pretty strict, 
and the need to avoid mobile node involvement argues for maintaining the IP 
address. This kind of mobility is currently handled by dedicated radio
network layer protocols, but, given the right kind of micromobilty
protocol, I think it could be handled by IP transport mechanisms in the
future.

In short, including these kind of networks strengthens your argument
about the need for routing based approaches to micromobility.

		jak

---

From: "Dana L. Blair" <[email-masked]>
Date: Tue, 27 Feb 2001 07:32:20 -0500

>is a necessity for CDMA protocols.

That is true but don't assume that the resolution point is in the middle of the
network.   It could be co-located with the cell tower and an Internet connection.

>about the need for routing based approaches to micromobility.

This is an interesting point.  Maybe we should include macro-diversity in
the next revision of the micro-mobility problem statement draft.

thanks,
Dana