Subject: Re: [seamoby] Re: New name -> Seamless to become Hidden Handover? ?

From: Patrice Calhoun <[email-masked]>
Date: Mon, 5 Feb 2001 08:37:39 -0800 (PST)

> SCTP Retransmitting a TCP transmission doesn't sound like a great idea to me.
> This comment was a result of your TCP over SCTP proposal above. > 
> pdn>Yes this sounds like a really bad idea on the surface.  It seems to
> violate the
> pdn>end-to-end principle, etc.  
It really has nothing to do with end-to-end (or anymore than existing
tunneling mechanisms).

> However, if we are assuming edge devices that
> pdn>have really lousy connections that come and go (like wireless for
> instance) pdn>this starts to make more sense.  If we assume routers you are
> right on!

Let me put it this way. If congestion is occuring, why do you want to further
congest the network by retransmitting TCP retransmissions???

Here is an example (Rn is the retransmission number):

   TCP:R0(Packet)------>
                  SCTP:R0(TCP:R0(Packet))------>
                  SCTP:R1(TCP:R0(Packet))------>
   TCP:R1(Packet)------>
                  SCTP:R0(TCP:R1(Packet))------>
                  SCTP:R2(TCP:R0(Packet))------>
                  SCTP:R1(TCP:R1(Packet))------>
   Ad Nauseum

See what I mean, now?

PatC

---

From: David Frascone <[email-masked]>
Date: Mon, 5 Feb 2001 11:11:46 -0600

On Mon, Feb 05, 2001 at 10:38:03AM -0600, [email-masked] wrote:
> 
> Please respond to Patrice Calhoun <[email-masked]>
> 
> Let me try again.
> 
> This comment was a result of your TCP over SCTP proposal above.
> 
> pdn>Yes this sounds like a really bad idea on the surface.  It seems to violate
> the
> pdn>end-to-end principle, etc.  However, if we are assuming edge devices that
> pdn>have really lousy connections that come and go (like wireless for instance)
> pdn>this starts to make more sense.  If we assume routers you are right on!
> 

I get dizzy thinking of SCTP retransmitting TCP retransmissions.  

Say that ten times fast :)

-Dave

---

From: [email-masked]
Date: Mon, 5 Feb 2001 10:38:03 -0600

Let me try again.

-Phil