Subject: [seamoby] Is Mobile IP too slow or is Routing Table Update Too slow? (was....)

From: James Kempf <[email-masked]>
Date: Wed, 21 Feb 2001 14:30:16 -0800 (PST)

Phil,

Just one comment...

>While this seems to be a very concrete item for the working group it's
>difficult to see the problem statement in the rest of the document for which
>this work would apply.  It appears to be a solution without a problem.
>Specifically one might want to state a problem and then why a combination of
>mobile ip fast handovers and regional registrations wouldn't suffice to
>solve it.
>
>pdn>Early on, I had a single sentence problem statement that b*tched about
>pdn>how slow mobile IP would be if/when used in a tangle of pico cells
>pdn>and how completely unnecessary it is in these scenarios.  It got yanked.
>pdn>I still believe we need a single statement that does complain about
>pdn>how MIP is intended for macro not micro-mobility.
>

I've heard this mentioned a number of times and I have not seen the
numbers to prove it. I've also heard the opposite, namely that
a routing update solution would be too slow because the convergence
of routing tables is a slow process. 

The point is, nobody really knows. It seems to me that one of the
charter items for Seamoby might be to find out if there is a problem.
Some hard, cold data can do alot to convince.

		jak

---

From: [email-masked]
Date: Wed, 21 Feb 2001 16:54:59 -0600

If I don't have to communicate with upstream routers, I simply don't.
I don't have to wait for them.  They don't have to wait for me.  Unless we
are able to ignore latency (which I don't like to do), micro-mobility will
blow the doors off mobile IP in a bee's nest of edge devices on the
edge where IP addrs don't change.  I know this is a hand waving
argument but its intuitively obvious isn't it James?

-pdn

---

From: "Dana L. Blair" <[email-masked]>
Date: Tue, 27 Feb 2001 08:35:05 -0500

At 01:27 PM 2/27/01 +0100, Hesham Soliman  (ERA) wrote:
>>  
>> ..i.e.: The only thing that regional/hierarchical schemes give you is less 
>signaling traffic over the network in the cases were your Home Agent happens 
>to be far away..
>> 
>	=> The amount of signalling is not dependant on how far away the HA is. 
>	What HMIP gives you is reduced signalling, better routing and ability to 
>	better handle frequent movements. The "better routing" part is due to 
>	the fact that packets do not need to be routed via the old AR first. Of course
>	the old AR may in many cases not be directly connected to the new AR
>	(ie. not sharing a link with the new AR). 

What HMIP gives you is multiple stateful single points single points of failure that inhibit
routing optimization instead of a one single point of failure that inhibits routing
optimization (the Home Agent).

By route optimization I don't mean Mobile IP routing
optimization.  I mean the more basic principle of letting routers choose the best path
from source to destination which includes routing arould failure points.

thanks,
Dana

>>  
>	Hesham 
>
>> 	-----Original Message----- 
>> 	From: Claude Castelluccia [mailto:[email-masked]]
>> 	Sent: Tuesday, February 27, 2001 8:51 AM
>> 	To: Andrew T. Campbell
>> 	Cc: 'Charlie Perkins'; 'Gary Kenward'; [email-masked]
>> 	Subject: Re: [seamoby] Is Mobile IP too slow or is Routing Table Update 
>To o slow? (was....)
>> 	
>> 	
>> 	  
>> 	Hello, 
>> 
>> 	"Andrew T. Campbell" wrote: 
>> 
>> 		Hello Charlie: 
>> 
>> 		I'm in agreement that MIP can run fast - but you wouldn't 
>> 		want to do that in a large scale way, right?
>> 
>> 	For the large scale scenario, you probably  have to use HMIP that is only 
>a simple extension to MIPv6. HMIPv6 use the same components, same 
>registration protocols, ... than 
>> 	MIPv6 and I see (or at least I'd like to see it)  it as part of MIPv6... 
>> 
>> 	I am convinced that with appropriate parameters (rt adverts. frequency. 
>MAP location,....) you can handle 
>> 	voice handover with Mobile IPv6 in a small network...but you probably 
>need the hierarchical extension for a large scale scenario.... 
>> 
>> 	regards, 
>> 	Claude. 
>> 	  
>> 
>> 
>> 		I think you are hinting at that in your response. 
>> 
>> 		BTW, do you have a reference for the Mobile IP handling 
>> 		voice? 
>> 
>> 		Thanks, 
>> 		--- 
>> 		Andrew 
>> 		<http://comet.columbia.edu/~campbell> 
>> 
>> 		> -----Original Message----- 
>> 		> From: [email-masked] [ 
><mailto:[email-masked]>]On 
>> 		> Behalf Of Charlie Perkins 
>> 		> Sent: Monday, February 26, 2001 5:44 PM 
>> 		> To: Gary Kenward 
>> 		> Cc: [email-masked] 
>> 		> Subject: Re: [seamoby] Is Mobile IP too slow or is Routing 
>> 		> Table Update 
>> 		> To o slow? (was....) 
>> 		> 
>> 		> 
>> 		> 
>> 		> Hello Gary, 
>> 		> 
>> 		> Mobile IP can be arbitrarily fast or slow.  If you'd like to make 
>> 		> it slow, crank down the advertisement rate to once per hour. 
>> 		> If you'd like it fast, register in response to layer-2 triggers over 
>> 		> a fast core network.  There isn't any one answer.  However, 
>> 		> it has been shown that, given appropriate and obvious parameters, 
>> 		> Mobile IP can handle voice handovers. 
>> 		> 
>> 		> Regards, 
>> 		> Charlie P. 
>> 		> 
>> 		> 
>> 		> Gary Kenward wrote: 
>> 		> 
>> 		> > 
>> 		> > 
>> 		> > I asked the question early on as to how slow was MIP (on 
>> 		> > the CT email list). The only concrete answer I received was 
>> 		> > 2-3 seconds for a handover. A single data point, to be sure, 
>> 		> > but it doesn't sound too fast to me. 
>> 		> > 
>> 		> > The email exchange is available on the CT archive. 
>> 		> > 
>> 		> > Gary 
>> 		> > 
>> 		> > > -----Original Message----- 
>> 		> > > From: James Kempf [ <mailto:[email-masked]>] 
>> 		> > > Sent: Wednesday, February 21, 2001 5:30 PM 
>> 		> > > To: [email-masked] 
>> 		> > > Cc: [email-masked] 
>> 		> > > Subject: [seamoby] Is Mobile IP too slow or is Routing Table 
>> 		> > > Update Too 
>> 		> > > slow? (was....) 
>> 		> > > 
>> 		> > > 
>> 		> > > Phil, 
>> 		> > > 
>> 		> > > Just one comment... 
>> 		> > > 
>> 		> > > >Specifically one might want to state a problem and then why > 
>> 		> > > a combination of 
>> 	-- 
>> 	----------------------------------------
>> 	Claude CASTELLUCCIA, INRIA Rhone-Alpes  
>> 	ph:  +33 4.76.61.52.15 (fax: 52.52)
>> 	<http://www.inrialpes.fr/planete/>
>> 	  
>>