Subject: RE: [seamoby] centralized vs. distributed context storage

From: "Gary Kenward" <[email-masked]>
Date: Mon, 26 Feb 2001 10:52:30 -0500

On this basis alone, I do not agree with the proposed change. 
There was plenty of opportunity to propose this addition 
prior to the last release, and the suggested change really doesn't
significantly change the problem statement (while it is definitely
relevant to the requirements).

I think as a wg, we all want to move forward to working on
solutions.

Gary

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Friday, February 23, 2001 9:41 AM
> To: Shahrier, Sharif M.
> Cc: 'Henrik Levkowetz'; [email-masked]; Kiernan, Brian G.
> Subject: RE: [seamoby] centralized vs. distributed context storage
> 
> 
> If the WG agrees that your proposed new section is worth 
> being included, then
> the editor must include it. However, do keep in mind that 
> this would push our
> problem statement being delivered to the IESG until April 9th, at the
> earliest, since the next revision of the problem statement 
> I-D cannot be
> submitted until after the IETF (and it takes a few days to 
> get published + 2
> weeks last call).
> 
> My 2 cents,
> 
> PatC
> > Henrik,
> > 
> > I don't disagree with you. All I wish to do is add a small 
> sub-section
> > called "distributed repository" following the text on "centralized
> > repository". I will be sending you text to look at. Other 
> than that, I'll
> > have no futher comments on the ct draft.
> > 
> > Thank you.
> > 
> > Sharif
> > 
> > -----Original Message-----
> > From: Henrik Levkowetz [mailto:[email-masked]]
> > Sent: Thursday, February 22, 2001 5:56 PM
> > Cc: [email-masked]
> > Subject: Re: [seamoby] centralized vs. distributed context storage
> > 
> > 
> > Sharif,
> > 
> >     I'd like to look forward to the next step, which I hope 
> willd be a
> > requirements document, rather than fiddle too much with the problem
> > statement.  From the comments so far, it seems that we have managed
> > to present the case for context transfer in an acceptable 
> form, which
> > will enable us to go forward -- which is the whole idea.
> >     Would it be acceptable to you to leave the draft as-is for now,
> > and then maybe, if it finds favour with the gods, put your thoughts
> > and requirements into the requirements document?
> > 
> >     Regards,
> >         Henrik
> > 
> > Sharif wrote:
> > > I had a favorable response to the fault-tolerant issues 
> of context storage
> > > in a centralized  vs. distributed repository. Thus, in 
> this light I would
> > > like to add a sub-section following 4.1.4 on "distributed 
> repository".
> > Under
> > > this scheme, there would be several repositories, keeping 
> copies of the
> > > contexts, e.g. a 3MR system. Hence, if one of them fails, 
> it is still
> > > possible to retreive the context from a working 
> repository. Another
> > > advantage of a 3MR (NMR, in general) is that it reduces contention
> > compared
> > > to a centralized repository. Of course, a disavantage of 
> the distributed
> > > case is that more hardware is required for the replications.
> > > 
> > > Sharif Shahrier
> > > 
> 
> 
>

---

From: Michael Thomas <[email-masked]>
Date: Mon, 26 Feb 2001 08:49:11 -0800 (PST)

I agree with Gary. Assuming that the problem
statement is just for a binary yes/no decision on
whether to move forward toward requirements,
backing up to place more and more reasons in the
problem statement is akin to beating the stain
in the street where once had lain a dead horse.

       Mike

Gary Kenward writes:
 > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
 > <HTML>
 > <HEAD>
 > <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
 > <META NAME="Generator" CONTENT="MS Exchange Server version 5.5.2654.19">
 > <TITLE>RE: [seamoby] centralized vs. distributed context storage</TITLE>
 > </HEAD>
 > <BODY>
 > 
 > <P><FONT SIZE=2>On this basis alone, I do not agree with the proposed change. </FONT>
 > <BR><FONT SIZE=2>There was plenty of opportunity to propose this addition </FONT>
 > <BR><FONT SIZE=2>prior to the last release, and the suggested change really doesn't</FONT>
 > <BR><FONT SIZE=2>significantly change the problem statement (while it is definitely</FONT>
 > <BR><FONT SIZE=2>relevant to the requirements).</FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>I think as a wg, we all want to move forward to working on</FONT>
 > <BR><FONT SIZE=2>solutions.</FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>Gary</FONT>
 > </P>
 > 
 > <P><FONT SIZE=2>&gt; -----Original Message-----</FONT>
 > <BR><FONT SIZE=2>&gt; From: Pat Calhoun [<A HREF="mailto:[email-masked]">mailto:[email-masked]</A>]</FONT>
 > <BR><FONT SIZE=2>&gt; Sent: Friday, February 23, 2001 9:41 AM</FONT>
 > <BR><FONT SIZE=2>&gt; To: Shahrier, Sharif M.</FONT>
 > <BR><FONT SIZE=2>&gt; Cc: 'Henrik Levkowetz'; [email-masked]; Kiernan, Brian G.</FONT>
 > <BR><FONT SIZE=2>&gt; Subject: RE: [seamoby] centralized vs. distributed context storage</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; If the WG agrees that your proposed new section is worth </FONT>
 > <BR><FONT SIZE=2>&gt; being included, then</FONT>
 > <BR><FONT SIZE=2>&gt; the editor must include it. However, do keep in mind that </FONT>
 > <BR><FONT SIZE=2>&gt; this would push our</FONT>
 > <BR><FONT SIZE=2>&gt; problem statement being delivered to the IESG until April 9th, at the</FONT>
 > <BR><FONT SIZE=2>&gt; earliest, since the next revision of the problem statement </FONT>
 > <BR><FONT SIZE=2>&gt; I-D cannot be</FONT>
 > <BR><FONT SIZE=2>&gt; submitted until after the IETF (and it takes a few days to </FONT>
 > <BR><FONT SIZE=2>&gt; get published + 2</FONT>
 > <BR><FONT SIZE=2>&gt; weeks last call).</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; My 2 cents,</FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; PatC</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Henrik,</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; I don't disagree with you. All I wish to do is add a small </FONT>
 > <BR><FONT SIZE=2>&gt; sub-section</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; called &quot;distributed repository&quot; following the text on &quot;centralized</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; repository&quot;. I will be sending you text to look at. Other </FONT>
 > <BR><FONT SIZE=2>&gt; than that, I'll</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; have no futher comments on the ct draft.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Thank you.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Sharif</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; -----Original Message-----</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; From: Henrik Levkowetz [<A HREF="mailto:[email-masked]">mailto:[email-masked]</A>]</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Sent: Thursday, February 22, 2001 5:56 PM</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Cc: [email-masked]</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Subject: Re: [seamoby] centralized vs. distributed context storage</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Sharif,</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp; I'd like to look forward to the next step, which I hope </FONT>
 > <BR><FONT SIZE=2>&gt; willd be a</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; requirements document, rather than fiddle too much with the problem</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; statement.&nbsp; From the comments so far, it seems that we have managed</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; to present the case for context transfer in an acceptable </FONT>
 > <BR><FONT SIZE=2>&gt; form, which</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; will enable us to go forward -- which is the whole idea.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp; Would it be acceptable to you to leave the draft as-is for now,</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; and then maybe, if it finds favour with the gods, put your thoughts</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; and requirements into the requirements document?</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp; Regards,</FONT>
 > <BR><FONT SIZE=2>&gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Henrik</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Sharif wrote:</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; I had a favorable response to the fault-tolerant issues </FONT>
 > <BR><FONT SIZE=2>&gt; of context storage</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; in a centralized&nbsp; vs. distributed repository. Thus, in </FONT>
 > <BR><FONT SIZE=2>&gt; this light I would</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; like to add a sub-section following 4.1.4 on &quot;distributed </FONT>
 > <BR><FONT SIZE=2>&gt; repository&quot;.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; Under</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; this scheme, there would be several repositories, keeping </FONT>
 > <BR><FONT SIZE=2>&gt; copies of the</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; contexts, e.g. a 3MR system. Hence, if one of them fails, </FONT>
 > <BR><FONT SIZE=2>&gt; it is still</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; possible to retreive the context from a working </FONT>
 > <BR><FONT SIZE=2>&gt; repository. Another</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; advantage of a 3MR (NMR, in general) is that it reduces contention</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; compared</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; to a centralized repository. Of course, a disavantage of </FONT>
 > <BR><FONT SIZE=2>&gt; the distributed</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; case is that more hardware is required for the replications.</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; Sharif Shahrier</FONT>
 > <BR><FONT SIZE=2>&gt; &gt; &gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > <BR><FONT SIZE=2>&gt; </FONT>
 > </P>
 > 
 > </BODY>
 > </HTML>