Subject: RE: [seamoby] Is Mobile IP too slow or is Routing Table UpdateTo o slow? (was....)

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 17:26:45 +0100

Hello Gopal,

I believe  Claude's statement was in reference to HMIPv6.
we don't want a multi-level hierarchy (like v4), just one level is enough.
That doesn't mean one MAP per domain, you can have several, 
but the MN only needs to choose one.

Regards,
Hesham

> -----Original Message-----
> From:	Gopal Dommety [SMTP:[email-masked]]
> Sent:	Tuesday, 27 February 2001 7:11
> To:	Claude Castelluccia
> Cc:	Andrew T. Campbell; 'Charlie Perkins'; 'Gary Kenward'; [email-masked]
> Subject:	Re: [seamoby] Is Mobile IP too slow or is Routing Table UpdateTo o slow? (was....)
> 
> 
> 
> At 12:56 PM 27/02/01 +0100, Claude Castelluccia wrote:
> >Gopal Dommety wrote: 
> >>  
> >>There are several components to handoff delay (see an  old anchor handoff draft). One of the delays is the backhaul delay 
> >>(most of the time this is not the problem unless you are doing VPN etc). If this is a problem it is better to perform anchor kind of a handoff.
> >I don't understand your point...HMIP provides "anchor-based" handoffs... 
> > It is based on MAP (Mobile ANCHOR Points) but these MAPs do not have to be deployed (although they 
> >can) on every links (as most of others fast handoff solutions require) .... 
> >>  
> >>Hierarchical instantiations do help but mainly to reduce the signaling (or limit the signaling to the local domain). 
> >> 
> >not only ....it reduces handoff delay, provides location privacy and a lot more ;-)  
> 
> Depending on the hierarchys and the movement it could increase the latency (the packet processing time is typicall order of magnitude than the
> packet forwarding time). Long time  ago I happen to have done some research on the
> number of hierarchies on the impact of handoff latencies and signalling. For internet kind of traffic (the actual paraments are the packet
> processing  times and the forwarding delays of routers) the number of hierarchies tended to be 2 (HA and FA) for handoff latencies.
> 
> -Gopal
> 
> 
> 
> >Claude. 
> >-- 
> >
> >----------------------------------------
> >Claude CASTELLUCCIA, INRIA Rhone-Alpes  
> >ph:  +33 4.76.61.52.15 (fax: 52.52)
> ><http://www.inrialpes.fr/planete/>http://www.inrialpes.fr/planete/

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 22:21:09 +0100

>  > Can you elaborate why you believe a design that accommodates multiple levels of
>  > hierarchy is a bad idea? The draft doesn't go into much detail on this point.
> 
>    Also: it doesn't seem to make sense given its claimed
>    ability to support mobile routers: why wouldn't a 
>    mobile router in turn want to hook up to a MAP and
>    so on and so forth.
> 
	=> As I said to James we do see that as the only case 
	where it is needed and I've clarified that in the new
	revision coming out tomorrow or so.
	So you're right, this scenario is recommended
	_only_ for the mobile router case.

	Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 22:18:21 +0100

Hi James

> hierarchy is a bad idea? The draft doesn't go into much detail on this point.
	=> Well since the MIP list is broken we can take the discusion
	on the sister list :)
	First of all we do support the multi-level case in the draft, however 
	we only recommend it for the mobile router case, where the MR
	is a MAP and it connects to another MAP in the network. 
	This is clearly mentioned in the draft I'm submitting 
	tomorrow. So apologies if it's not obvious in the current draft. 

	As for the normal case (mobile nodes and not networks) we 
	can't see the benefit of having a mult-level hierarchy where 
	packets are routed from one level to another down the 
	hierarchy till they reach the MN. We see that as an 
	equivalent to a "circuit" in the IP network and I don't 
	think that's a benefit. Definitely less robust. 
	Obviously all these routers in the hierarchy are single
	points of failure. If one crashes not only the services 
	will be distrupted, but the MN will not know about it 
	(if the hierarchy is hidden). 

	We do see great benefits in having multiple MAPs
	for redundany and  load sharing, but not for a tree 
	of hierarchies.

	So let me turn the question around and as you if 
	you think there is any benefit in having a multi-level
	hierarchy ?

---

From: [email-masked]
Date: Wed, 28 Feb 2001 15:49:44 -0600

>  => Well since the MIP list is broken we can take the discusion

The new MIP list is located at : [email-masked]

-Basavaraj

---

From: [email-masked]
Date: Wed, 28 Feb 2001 15:49:44 -0600

-Basavaraj

---

From: [email-masked]
Date: Wed, 28 Feb 2001 15:49:44 -0600

-Basavaraj