Subject: RE: [seamoby] Is Mobile IP too slow or is Routing Table Update To o slow? (was....)

From: Michael Thomas <[email-masked]>
Date: Tue, 27 Feb 2001 11:11:31 -0800 (PST)

Hesham Soliman  (ERA) writes:
 > >  > 	=> Have you heard of topologically correct addresses?
 > > 
 > >    No, I haven't. Please explain. 
 > > 
 > > => I'll let you find out. One hint "route aggregation".

   Uh, that does not make the current placement of a
   route "correct" or "incorrect" it means that within
   a reasonable bounds that you ought to aggregate
   routes so that it doesn't lead to *GLOBALLY*
   unaggregated routes. Since nobody's talking about
   propogating host routes on the Internet, I have no
   idea what your point is. Locally unaggregated routes,
   so long as they do not lead to excessive traffic
   in the routing plane, or excessive FIB entires are
   not a problem at all. That's why this is being
   spoken of in terms of micro mobility.

 > >    Do you even know what the longest prefix match
 > >    algorithm is? 
 > > 
 > > => uh Ummm, oh no you got me there !

   If you assume "topologically correct" routes, why
   do you need longest prefix match?

	       Mike

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 27 Feb 2001 19:54:00 +0100

>  > > >> 
>  > > >	=> However if we consider other localised mobility management 
>  > > >	techniques provided by MIP like regional reg for MIPv4 and HMIPv6 for 
>  > > >	MIPv6, propagation delays will not be so significant.
>  > > >
>  > > 
>  > > Not as significant but the tradeoff is unoptimal routing 
>  > > 
>  > 	=> Can you please explain where the "unoptimal" routing 
>  > 	comes from ?
> 
>     Uh, the fact that tunneling schemes do not guarantee
>     least cost routing?
> 
> 
>  > > Have your heard of a routing protocol ?
>  > > 
>  > 	Have you heard of IPv6 ? In this funny technology the 
>  > 	IPv6 node gets an address that belongs to the subnet
>  > 	it's on. Otherwise its address becomes topologically 
>  > 	incorrect. So when you hange routers, you change addresses.
> 
>    This is completely and utterly bogus. *Completely*.
> 
> Homework assignment: why does it
>    exist over a first prefix match algorithm?
> 
> => These are hard questions for a novice 
	like me.

	Hesham