Subject: RE: [seamoby] I-D ACTION:draft-ietf-seamoby-mm-problem-00.txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 22 Feb 2001 22:15:01 +0100

Hi Phil(N) and John, 

I promised a more specific list of comments and here 
it is:

General: I still don't see a motivation in the draft for 
the advantages of moving without changing IP addresses.

The problem needs to be explained in light of the existing
solutions, otherwise it can't be a problem.

Intro:

  "Current IP mobility solutions
   tend to focus primarily on best effort data transport to and from a
   mobile device where the routable IP address (for example, Mobile IP
   Care-of Address) of the Mobile Device changes during handoff."

=> I don't agree that the focus is only on best effort 
services. As you know there is work to support real time
services.

"The assumption is that a local protocol can address these goals
   better by limiting its applicability to a smaller domain (such as an
   intranet - e.g. warehouse, and not the entire internet as in the
   case of Mobile IP) and reverting to Mobile IP for the general case
   of internet mobility support."

=> This already assumes that the mm protocol is not 
based on MIP. I think it's premature to say so. Also I 
don't see why limiting the applicability of a protocol
to a local domain makes it "better". 
BTW what is "better" ?

Ch 1.1 

Where the mobility may be:

     Within a subnet.

=> Within a subnet ? Is this an IP protocol ?
It seems more like an API in the MN than an
IP protocol. Maybe someone can explain this 
better ?

"Within a limited number of hops"

=> I don't get this, what does it mean ? domain ?

Ch 1.2

"Moreover, a lightweight approach, customized to the exact
   requirements of local mobility while interoperable with a more
   general mobility  mechanism (e.g. Mobile-IP)"

=> Again assuming that the mm solution is not MIP-based

"While studying solutions for Seamless handoffs using the same
  routable IP address handoff"

=> Why does it have to be the same IP address ? Is this 
a definition of mm ? If so why ?

Ch 1.3

"Local Mobility    The movement of an IP device without requiring
                         a change to its routable IP address. Although
                         its point of attachment may change during the
                         move, the IP address used to reach the device
                         (both its home and IP subnet routable IP
                         address) do not change."

=> This makes it local mobility within a subnet doesn't it ?
Or is the assumption here that MNs will have topologially 
incorrect addresses ? At least for v6.

"This procedure has strict timing
                         requirement for the execution and low (zero)
                         packet loss."

=> Is it low or zero ?

Ch 2.1

"* Mobility without changing the routable IP address"

=> Why is this mandatory ? I haven't seen it explained anywhere.

Ch 3

"Regional Registration for IPv4, IPv6"

=> You mean HMIPv6 ?

Ch 3.1

"4)   Configurability:    Plug & Play of routers/base stations not
                              addressed - need to configure HA/FA/GFA's
                              etc."
=> V6 ??

"6)   QoS:                controversial; tunneling complicates QoS
                              support"

=> Does RSVP support mobility at all ? Maybe tunnelling 
makes it slightly more difficult, but we have a bigger 
problem if RSVP does not support mobility.

"     9)   Security/Message    controversial; speed of message (e.g.,
          Authentication:     context transfer) authentication during
                              cross-AD handoff may require expedited
                              techniques (e.g., key or ticket"

=> We've already discussed this. Could you detail where 
the security problems are.

"Mobile Network      controversial.
          Support:"

=> Why is it controversial ?

Ch 3.1.1

"3.1.1 Scalability Issues

   1)   There is a concern that A GFA/FA in every AR may not scale or
        even be desirable in extremely inexpensive AR devices.

=> V6 ? I'm not sure about "extremely expensive" Once
you have an FA you can port it to different nodes.

   2)  There is a concern that putting an FA essentially everywhere
       would add a lot of complication to what could be a relatively
       simple micro-mobility handoff.

=> V6 ?

   3)  There are some thoughts that micro-mobility could possibly be
       handled completely by MNs."

=> I'm not sure what this means either. Could you please elaborate.

In general, I don't think words like "concen" and "thoughts" are
very effective. If you thnik there is a problem you should explain
it clearly and show the motives.

In Ch 4.1.1

You mention this scenario and then you go into the details 
of L2 interactions. I don't see this as being relevant for 
IP protocols. You clearly defined an Access Point as an L2
device and I agree with that, but this means that such device
doesn't have IP in it. So I'm not sure why this section
is needed and why refer to IEEE stuff.

I hope this is more specific and clarifies my concern.

Regards,
Hesham

---

From: Michael Thomas <[email-masked]>
Date: Thu, 22 Feb 2001 13:53:39 -0800 (PST)

> to a local domain makes it "better". 

   Um, that's exactly what HMIP does, yet I don't
   see you complaining about it.

 > => I don't get this, what does it mean ? domain ?

   This seems clear enough to me: it means that it
   doesn't scale to the whole Internet.

 > => Again assuming that the mm solution is not MIP-based

   I think *you're* the one thinking it ought to
   be MIP based. I don't read any requirements for
   mechanisms in that statement; it just
   recognizes that MIP is already the solution 
   for macro mobility.
 
 > a definition of mm ? If so why ?

   There is a lot to be said about keeping the
   same IP address if it is at all possible. I,
   like Phil, have a hard time seeing why that's
   especially controversial since the entire
   Internet as currently built makes exactly that
   assumption. If you don't change IP addresses,
   you get to ignore a tremendous number of
   questions that MIP in its many forms beg.

 > incorrect addresses ? At least for v6.

   "Topologically incorrect" doesn't have any meaning
   in IP until you get up to the BGP level. Within an 
   autonomous system, you can place subnets -- including
   /32 or /128's anywhere you want. What you're talking
   about is purely a local optimization for route 
   aggregation.

 >                               addressed - need to configure HA/FA/GFA's
   
   If you end up with HMIP or FMIP, you end up
   with things that are sort of like FA's, and
   they all require configuration. Hardly an
   optimal situation for the great unwashed
   masses.
 
 > problem if RSVP does not support mobility.

   RSVP certainly supports non-mobility. Not
   changing IP addresses works as-is. The
   questions that MIP raises are quite profound
   and aren't going to be resolved very quickly.

 > => Why is it controversial ?

   Because it's not currently supported in MIP at
   all? Not changing IP addresses works as-is.

 > you have an FA you can port it to different nodes.

   You've glossed over "desirable" and "scale". We
   have to consider that these network will need
   to be deployed real human beings too. Just because
   a cellular folks can afford to spend scads of
   money on network engineering to save every 
   precious bit of air bandwidth, doesn't mean
   that everybody else will or should. Indeed, 
   the advent of cheap 802.11 provides tons of
   motivation to sacrifice bandwidth inefficiency
   for ease of deployment. 

   HMIP and CT and anything else that requires
   a whole lot of smarts about network engineering
   don't give me the warm fuzzies about ease of
   deployment. It would be very nice to have a
   "good enough" solution that optimizes around
   that sweet spot too.

	      Mike