Subject: RE: [seamoby] IRTF mm problem statement

From: Phil Roberts <[email-masked]>
Date: Tue, 1 May 2001 11:58:14 -0400

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Tuesday, May 01, 2001 11:23 AM
> To: Glenn Morrow
> Cc: Pat Calhoun; [email-masked]'
> Subject: Re: [seamoby] IRTF mm problem statement
> 
> 
> On Tue, May 01, 2001 at 10:15:50AM -0500, Glenn Morrow wrote:
> > Pat,
> > 
> > I was responding to the explicit verbage in the document 
> about NOT exploring
> > the use of BGP and OSPF. I was simply trying to indicate 
> that perhaps the
> > group should not limit itself in this manner. I felt that 
> in order to do get
> > the point across, I had to give at least a rough example of 
> how you might be
> > able to use these protocols to help solve part of the 
> problem and how an MM
> > protocol can work with these protocols in a synergistic manner. 
> > 
> > It seemed to me that the verbage in the document about 
> these protocols was
> > perhaps making an assumption it shouldn't have. i.e. that 
> BGP and OSPF would
> > have to be used to install per-node routes and that the 
> scaling problems of
> > MANET would be inherent.
> 
> Given that this draft is still on my to-do list, I should 
> have read it prior to
> sending my e-mail :( If what you say is true, I agree that 
> perhaps ruling out
> specific routing protocols MAY be a tad premature.
> 
> Phil, what are the reasoning?
> 
> Thanks,
> 
> PatC
> 

Hi,

    here are the two sentences that mention OSPF

- Could such mobility requirements and fast restoration requirements be met
in a way that is more efficient and simpler than approaches based on Mobile
IP and OSPF by using a routing protocol that implements host routes within a
limited scope within the network?

- A  comparison with OSPF and Mobile IP are involved in making such an
assessment both in terms of relative scalability, performance, and
complexity.

    I don't think mentioning them in this way does anything other than state
the problem or suggests that an alternative must be used.  But it would be
fairly easy to modify it to suggest enhancements to OSPF as an alternate,
sounds a little too solution oriented.  What if in the first I said, "using
a *new or enhanced existing* routing protocol ...?"  And I could just delete
the last sentence.  I do agree that limiting choices and suggesting
solutions are not appropriate in this doc.

Phil

---

From: Michael Thomas <[email-masked]>
Date: Tue, 1 May 2001 09:15:13 -0700 (PDT)

Phil, 

Perhaps it would be better to state it in terms of
intradomain routing protocols instead of naming
OSPF specifically. Then the MANET folks, as well
as other IGP's won't feel like they're being ruled
out. In fact, I think that wide-net comparison is
an important part of the work.

		Mike

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 1 May 2001 09:07:41 -0700

On Tue, May 01, 2001 at 11:58:14AM -0400, Phil Roberts wrote:
> sounds a little too solution oriented.  

I agree.

> What if in the first I said, "using

I think this would be less controversial, and more appropriate to this type
of document.

Thanks,

PatC