Subject: RE: [seamoby] suggestions for MM IRTF statement

From: Phil Roberts <[email-masked]>
Date: Wed, 2 May 2001 17:42:55 -0400

Mike,

     thanks for your comments.  They are all good and I've incorporated
almost all of them in the doc with a little wordsmithing in places to make
it flow well.  I have questions about this one:
> o I might start this with "The current Internet
>   has a high expectation that nodes are
>   stationary. While Mobile IP goes to some 
>   length to hide the mobility from the end 
>   system communicating to the mobile network,
>   it uses tunnels which are not necessarily
>   transparent to routers in the tunnel path. 
>   This in turn causes services which are 
>   provided by those routers, such as quality 
>   of service guarantees, to be impacted by
>   the mobility.

Up to this point I have the following question.  You say which *are not*
necessarily transparent to routers.  Do you mean to say that *are*
necessarily transparent to routers?
Presumably if there are foreign agents involved or mobile aware access
routers for v6 they can and will handle QoS characteristics for themselves
and between themselves and the mobile, but the next router or two up the
chain doesn't see the mobility and can't really deal with the fact that the
flow has moved.  Just trying to understand what you're after here.

> However, mobility in many 
>   respects can be viewed as just a change in topology for the
>   impacted subnets -- a property with which routers
>   are well acquainted. Thus, it would be 
>   desirable to have a means of providing
>   mobility which leveraged routers inherent
>   ability to deal with topology changes, even
>   if they do not scale to a global scope as
>   mobile IP does. Another other property we would
>   like to take as fully advantage of as possible
>   is local convergence. That is, if changes can
>   be isolated within a small region -- namely
>   close to the mobile node's points of
>   attachment, we can avoid potentially costly
>   signaling of all of the elements currently
>   sharing state with the host or hosts on the
>   mobile network."
> 
> 

Phil

---

From: Michael Thomas <[email-masked]>
Date: Wed, 2 May 2001 15:58:25 -0700 (PDT)

> necessarily transparent to routers?

   You're right, that's pretty awful; a maze
   of double negatives, all alike. 

   How about:

While Mobile IP provides transparency of the
mobility to correspondent nodes communicating with
hosts on the mobile network, Mobile IP does not
provide transparency for any state contained
within routers along the paths from correspondent
nodes and the mobile node's home agent. That is,
state in routers which is dependent on the
stability of the source or destination address in
the IP header will be negatively impacted by
Mobile IP's need to change care of addresses. For
example, when a mobile node changes its care of
addresss, the mobile node's current reservation
would require that the filter specs be updated
with the new care of address. By instead treating
the mobility as a topology change within the local
area, these unpleasant second order effects can be
avoided.  

 > flow has moved.  Just trying to understand what you're after here.

Basically, the problem is that filterspec might
need to change since the CoA is what you'd naively
put in the filterspec (it's what's in the IP
header, after all), which pretty much pooches your
handover unless we do something about it with
NSIS. A MM based solution neatly skates past that
little road block which is pretty nice.

	    Mike