Subject: RE: [seamoby] An API issue

From: Kulwinder Atwal <[email-masked]>
Date: Wed, 16 May 2001 17:06:51 -0400

> -----Original Message-----
> From: Randall R. Stewart [mailto:[email-masked]]
> Sent: Wednesday, May 16, 2001 3:22 PM
> To: [email-masked]
> Subject: [seamoby] An API issue
> 
> 
> Dear All:
> 
> I have a problem and was wondering if anyone else
> has encountered this...
> 
> This may be the wrong place to take this issue Pat, if it
> is, please redirect me..
> 
> Here is the jest of the problem. I have a wireless card
> driver (it can be any type you can imagine.. GSM, 802.11
> even blue-tooth...).
> 
> It gets a signal that an event has transpired
> i.e. Association fell apart or came up, i.e. I can now reach
> a AR or I can no longer reach an AR or maybe some other trigger
> type event of interest. This is the ole Layer-2
> trigger that everyone talks about....
> 
> Now HOW do I get it up to layer 3?
> 
> This seems like a real naive question I know... but when you
> start digging in to at least most unixy stacks, you have 
> a layer 2 driver servicing the card (or is it layer 1:>),
> its interfaces to upper layers are:
> 
> A) ioctl... user requests/response model
> B) packet arrival -> submit to ether_input()
> C) packet sending -> output routine is called.
> 

  D) Interrupts (linux disable_irq/enable_irq)

Hardware Interrupt -> Interrupt Handler -> Interrupt Service Routine ->
Proxy -> Thread

- Kulwinder.

---

From: "Randall R. Stewart" <[email-masked]>
Date: Thu, 17 May 2001 06:26:00 -0500

> Hardware Interrupt -> Interrupt Handler -> Interrupt Service Routine ->

Huh?

This is not the question... I already have the interupt
that tells me an event happened on the card. My question
is directed at how we transfer it in a standard way
to an event/layer-2 trigger. 

That way all cards could play nice and present a standard
layer-2 trigger mechanism...

R

-- 
Randall R. Stewart
[email-masked] or [email-masked]
815-342-5222 (cell) 815-477-2127 (work)