Subject: [seamoby] suggestions for MM IRTF statement

From: Michael Thomas <[email-masked]>
Date: Wed, 2 May 2001 13:33:16 -0700 (PDT)

PhilR,

As promised, here are my suggestions.

Abstract:

o replace "new routing protocol" with "a routing protocol"
  which leaves the door open to tweaks on old or in development
  protocols

o replace mobile host with mobile node so as to encompass
  hosts and routers.

o we need to emphasize that the property that we keep the
  same routable address within a limited scope. How about:

  "...to implement a routing protocol whose purpose is
   to allow a mobile node to retain connectivity
   via its current IP subnet while it moves within
   the scope of the micro mobility domain. In general this
   domain is expected to be contained within an
   autonomous system so that global aggregation
   of subnets is still preserved. An additional
   benefit of the protocols is that mobile nodes may more quickly
   react to failed links..."

Introduction:

o use "stationary" instead of "static"
o replace "host routing" with "a protocol which
  allows the mobile node to keep its current IP
  subnet when it attaches to a new access router."
o I'd say it's not the routing protocols, but the
  routers in the last sentence of paragraph 1.
o p2: I'd replace "the use of host routing ..." 
  with: "how a local subnet mobility routing
  protocol can be employed to enable mobility and
  fast network recovery."

Problem Statement:

o Replace first sentence with "Why is there a 
  perceived need for a non-tunnel based routing
  based solution for mobility?"
o I might start this with "The current Internet
  has a high expectation that nodes are
  stationary. While Mobile IP goes to some 
  length to hide the mobility from the end 
  system communicating to the mobile network,
  it uses tunnels which are not necessarily
  transparent to routers in the tunnel path. 
  This in turn causes services which are 
  provided by those routers, such as quality 
  of service guarantees, to be impacted by
  the mobility. However, mobility in many 
  respects can be viewed as just a change in topology for the
  impacted subnets -- a property with which routers
  are well acquainted. Thus, it would be 
  desirable to have a means of providing
  mobility which leveraged routers inherent
  ability to deal with topology changes, even
  if they do not scale to a global scope as
  mobile IP does. Another other property we would
  like to take as fully advantage of as possible
  is local convergence. That is, if changes can
  be isolated within a small region -- namely
  close to the mobile node's points of
  attachment, we can avoid potentially costly
  signaling of all of the elements currently
  sharing state with the host or hosts on the
  mobile network."

  -- last part probably needs to be combined better with
     what you have on the signaling overhead 

o I'd replace OSPF with intradomain routing
  protocols. May want to mention MANET in there
  too.

o Replace "implements host routes" with "local
  subnet mobility routing protocol..."

2.2:

o Replace last sentence: "Could a local subnet
  mobility routing protocol aid in this respect?"

2.3: 

o Replace "scale of host routing..." with 
  "scale of local subnet mobility routing"

o Qualify need, as in "the potential need"

o Replace "OSPF" with "intradomain routing
  protocols, MANET protocols, as well as Mobile IP"

	     Mike

---

From: "Phil Neumiller" <[email-masked]>
Date: Wed, 2 May 2001 16:27:21 -0500

I really like Mike's changes (for my two cents worth)!

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 2 May 2001 14:57:06 -0700

> I really like Mike's changes (for my two cents worth)!

I admit that it was very nice to have a list of concrete changes to make
to the I-D. This way, you don't have to interpret meanings.

Thanks Mike!

PatC