Subject: RE: Wireless Terminology Draft( was: Re: [seamoby] Seamoby Charte r Last Call)

From: "Gary Kenward" <[email-masked]>
Date: Fri, 18 May 2001 13:42:39 -0400

So that it is clear, the new version of the ct problem statement 
does not use the reference architecture of the original draft. The
only terms that may seem familiar are mobile node, and access network.
This was done to simplify the problem statement, and avoid some of the
persistent controversy, not because there was anything wrong with the 
original reference architecture or nomenclature (probably yet another
argument in favour of producing a nomenclature reference draft).

Gary

> -----Original Message-----
> From: Jukka Manner [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 12:46 PM
> To: Nakhjiri Madjid-MNAKHJI1
> Cc: Syed, Hamid [WDLN2:AN22:EXCH]; 'James Kempf'; seamoby
> Subject: RE: Wireless Terminology Draft( was: Re: [seamoby] Seamoby
> Charte r Last Call)
> 
> 
> 
> 
> 	Hi, quick answers inline (I'm off to have a weekend 
> break for once...:)
> 
> 	Have a nice weekend all of you,
> 
> 	Jukka
> 
> On Fri, 18 May 2001, Nakhjiri Madjid-MNAKHJI1 wrote:
> 
> > Jukka,
> >
> > Thanks for taking charge on this. Did you do a diff on your
> > definitions and CT problem statement draft? Since you were
> > intimately involved with CT PS draft, I assume you did that.
> 
> 	Actually, the terminology in the CT draft was taken 
> from the terminology
> draft. Some wording was changed, if I remember correctly, in 
> the CT draft, but
> the basic definitions were the same.
> 
> > I think we did a good job of defining CT related terminology,
> > but I don't know how it differred from MM or Paging terminology,
> > it would be nice to do a diff with those as well to have a WG
> > wide common terminology draft.
> 
> 	The MM team used "our" CT terms and added some new 
> ones; those could be
> added to a new terminology draft. The Paging team had only a 
> few terms of
> "their" own, but those could be added as well.
> 
> >
> > Thanks again,
> > Madjid
> >
> > -----Original Message-----
> > From: Jukka Manner [mailto:[email-masked]]
> > Sent: Tuesday, May 15, 2001 1:25 AM
> > To: Hamid Syed
> > Cc: 'James Kempf'; [email-masked]
> > Subject: RE: Wireless Terminology Draft( was: Re: [seamoby] Seamoby
> > Charter Last Call)
> >
> >
> >
> > 	Hamid,
> >
> > 	Thank you for suggesting it. The draft was originally meant to
> > support the work in Seamoby, but it would be an even better 
> idea to make it
> > a more thorough document for use in more or less all work 
> relating to mobile
> > and
> > wireless environments, including Seamoby, Mobile-IP, and 
> possibly MANET.
> >
> > 	I would be happy to continue the work on the 
> terminology taking as
> > basis
> > the mentioned draft.
> >
> > 	BR,
> >
> > 	Jukka
> >
> > On Mon, 14 May 2001, Hamid Syed wrote:
> >
> > > Hello james,
> > >
> > > A draft was submitted to seamoby early this year that 
> attempted to capture
> > > the wireless terminology. her eis the link:
> > > 
> http://search.ietf.org/internet-drafts/draft-manner-seamoby-te
> rms-01.txt
> > >
> > > br
> > >
> > > -Hamid
> > >
> > > > -----Original Message-----
> > > > From:	James Kempf [SMTP:[email-masked]]
> > > > Sent:	Monday, May 14, 2001 1:47 PM
> > > > To:	[email-masked]
> > > > Subject:	Wireless Terminology Draft( was: Re: 
> [seamoby] Seamoby
> > > > Charter Last  Call)
> > > >
> > > >
> > > > ------------- Begin Forwarded Message -------------
> > > >
> > > > Date: Mon, 14 May 2001 10:43:47 -0700 (PDT)
> > > > From: James Kempf <[email-masked]>
> > > > Subject: Re: [seamoby] Seamoby Charter Last Call
> > > > To: [email-masked], [email-masked]
> > > > Content-MD5: 6F7Vl9kYVVbqr66TeEQyRw==
> > > >
> > > > Hi Charlie,
> > > >
> > > >
> > > > >> Maybe we need a terminology draft, or at least, 
> define this term
> > > > >> somewhere so that it can be referred to. I'm suprised nobody
> > > > >> has done a generalized terminology draft for 
> wireless terms before in
> > > > the MIP
> > > > >> group.
> > > > >
> > > > >RFC 2002 does start off with a long list of terminology.
> > > > >
> > > > >It is questionable whether any specific wireless terms are
> > > > >needed for a protocol running over IP.  What is needed is
> > > > >a list of useful terms.  For instance, one might care about
> > > > >error rate or bandwidth even if the medium were not wireless.
> > > > >I don't think that chip rate, for instance, should be part
> > > > >of the [seamoby] terminology list.
> > > > >
> > > >
> > > > Actually, there are plenty of wireless terms that need 
> definition.
> > > > Access point, handoff (or handover IETF should select which one
> > > > it wants to use), context transfer, paging, etc. etc.
> > > >
> > > > >Do you think that there are terms which SHOULD have 
> been defined
> > > > >for RFC 2002?  If so, now would be a good time to mention them
> > > > >before RFC 2002bis goes to the RFC editor's desk.
> > > > >
> > > >
> > > > No, I think they have wider applicability. More and 
> more wireless
> > > > stuff is going on. There are now two working groups associated
> > > > with wireless, and others that have a big wireless 
> component. I think
> > > > having a
> > > > terminology draft that collects all terminology that 
> could be referred
> > to
> > > > by
> > > > drafts would be a benefit.
> > > >
> > > > 		jak
> > > >
> > > >
> > > >
> > > > ------------- End Forwarded Message -------------
> > > >
> > > >
> > >
> >
> 
>

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Fri, 18 May 2001 16:40:03 -0500

-----Original Message-----
From: Jukka Manner [mailto:[email-masked]]
Sent: Friday, May 18, 2001 11:46 AM
To: Nakhjiri Madjid-MNAKHJI1
Cc: Hamid Syed; 'James Kempf'; [email-masked]
Subject: RE: Wireless Terminology Draft( was: Re: [seamoby] Seamoby
Charter Last Call)

	Hi, quick answers inline (I'm off to have a weekend break for
once...:)

	Jukka

> intimately involved with CT PS draft, I assume you did that.

	Actually, the terminology in the CT draft was taken from the
terminology
draft. Some wording was changed, if I remember correctly, in the CT draft,
but
the basic definitions were the same.

MN>> Yes some wordings were changed, but didn't mean to take credit away
from you. Sorry :)

> wide common terminology draft.

	The MM team used "our" CT terms and added some new ones; those could
be
added to a new terminology draft. The Paging team had only a few terms of
"their" own, but those could be added as well.

MN>> Ok, it would be nice to have a common terminology draft (info RFC?) for

the WG that all the design teams can share, IMO.

 Thanks again,
 Madjid

> support the work in Seamoby, but it would be an even better idea to make
it
> a more thorough document for use in more or less all work relating to
mobile
> and
> wireless environments, including Seamoby, Mobile-IP, and possibly MANET.
>
> 	I would be happy to continue the work on the terminology taking as
> basis
> the mentioned draft.
>
> 	BR,
>
> 	Jukka
>
> > A draft was submitted to seamoby early this year that attempted to
capture
> > http://search.ietf.org/internet-drafts/draft-manner-seamoby-terms-01.txt
> >
> > br
> >
> > -Hamid
> >
> > > Subject:	Wireless Terminology Draft( was: Re: [seamoby] Seamoby
> > > Charter Last  Call)
> > >
> > >
> > > >> Maybe we need a terminology draft, or at least, define this term
> > > >> has done a generalized terminology draft for wireless terms before
in
> > > Actually, there are plenty of wireless terms that need definition.
> > > >Do you think that there are terms which SHOULD have been defined
> > > No, I think they have wider applicability. More and more wireless
> > > with wireless, and others that have a big wireless component. I think
> > > having a
> > > terminology draft that collects all terminology that could be referred
> to
> > > by

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Fri, 18 May 2001 16:43:37 -0500

-----Original Message-----
From: Charles E. Perkins [mailto:[email-masked]]
Sent: Friday, May 18, 2001 12:50 PM
To: Nakhjiri Madjid-MNAKHJI1
Cc: 'Jukka Manner'; Hamid Syed; 'James Kempf'; [email-masked];
Mobile Ad Hoc IETF working group
Subject: Re: Wireless Terminology Draft( was: Re: [seamoby] Seamoby
Charter Last Call)

Hello folks,

I made an attempt a few years ago to develop such a terminology
draft, within the context of the [manet] working group.  Here
is a URL for the draft if you are interested:
	http://people.nokia.net/~charliep/txt/manet/term.txt

If you would like to use some of the definitions in that draft,
and/or if you are looking for help in creating the new draft,
I'd be happy to work on it.

The draft was rejected within the [manet] working group for
a reason that I thought was very curious.  Essentially, the
objection was made that every working group Internet Draft should
contain its own terminology definitions, and that no common
terminology draft was desirable. 

MN>> Interesting. I find this peculiar, since the problem statement
was criticized for being too long and elaborate.
If every draft contains its own terminology, then you got 2-3 extra
overhead pages right there. What is wrong to have one reference within
the group?

Regards,
Madjid

 I disagreed with that reason
then, and I still disagree with it, but I haven't felt a very
strong need to take up the matter within the [manet] group
since I didn't need yet another battle on my hands.

I do think it would be a good idea to keep the terminology
draft separated out from a more wide-ranging wireless issues
draft, such as has generated a lot of recent interest on this
mailing list.

Regards,
Charlie P.

PS. to [manet] working group readers: I'd be happy to reintroduce
    the old draft, or a revision of it, for reconsideration.

Nakhjiri Madjid-MNAKHJI1 wrote:
> support the work in Seamoby, but it would be an even better idea to make it
> a more thorough document for use in more or less all work relating to mobile
> and
> > A draft was submitted to seamoby early this year that attempted to capture
> > > >> has done a generalized terminology draft for wireless terms before in
> > > the MIP
> > > >> group.
> > > >

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Fri, 18 May 2001 16:47:27 -0500

Gary,

I thought we were only talking about the terminology section, not the 
reference architecture, but anyways!
I am not objecting to this, however, this is ok, as long as we don't loose
track of all
terminology work (if it does not go into any document whatsoever!) and find 
 find a home for all terminology and reference architecture text that people
worked on.

Regards,
Madjid
 
-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Friday, May 18, 2001 12:43 PM
To: 'Jukka Manner'; Nakhjiri Madjid-MNAKHJI1; Hamid Syed; 'James Kempf'
Cc: seamoby
Subject: RE: Wireless Terminology Draft( was: Re: [seamoby] Seamoby Charte r
Last Call)

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 18 May 2001 17:51:34 -0400

In my experience, terminology cannot be defined unless you
can relate the entities being described, hence, you do need
to start discussing the reference architecture at some level.
E.g. the terminology in the problem statement was all derived
from the reference architecture.

I agree, it's worth retaining. How or where is a tougher question.

Gary

> From: Nakhjiri Madjid-MNAKHJI1 [mailto:[email-masked]]
> Sent: Friday, May 18, 2001 5:47 PM
> To: Kenward, Gary [WDLN2:AN10:EXCH]; 'Jukka Manner'; Nakhjiri
> Madjid-MNAKHJI1; Syed, Hamid [WDLN2:AN22:EXCH]; 'James Kempf'
> Cc: seamoby

---

From: Nakhjiri Madjid-MNAKHJI1 <[email-masked]>
Date: Fri, 18 May 2001 17:11:33 -0500

-----Original Message-----
From: Gary Kenward [mailto:[email-masked]]
Sent: Friday, May 18, 2001 4:52 PM
To: 'Nakhjiri Madjid-MNAKHJI1'
Cc: 'seamoby'
Subject: RE: Wireless Terminology Draft( was: Re: [seamoby] Seamoby Charte r
Last Call)

MN>> fair enough

MN>> How about a separate WG draft that all teams and the rest of
WG can use? Seems like, Jukka has already got most of it in place
and people are willing to chip in.

Regards,
Madjid

---

From: "Gary Kenward" <[email-masked]>
Date: Fri, 18 May 2001 21:33:55 -0400

I'm all for it. But I think the idea should be run by the ADs first,
just to be sure that the effort has some chance of making it to an
rfc (probably informational).

Gary

> Sent: Friday, May 18, 2001 6:12 PM
> To: Kenward, Gary [WDLN2:AN10:EXCH]; Nakhjiri Madjid-MNAKHJI1
> Cc: 'seamoby'