Subject: [Seamoby] CARD - FMIPv6 protocol interworking

From: Singh Ajoy-ASINGH1 <[email-masked]>
Date: Fri, 20 Dec 2002 10:35:43 -0600

Hello All,

The CARD design team would like to solicit WG consensus about CARD 
and FMIPv6 protocol inter-working.  The selection of anyone method 
from the proposed list would help us to focus in the right direction 
during the next phase of the protocol design. The high-level description
of the various approaches with their relative merits and de-merits is 
listed below:
 
Tight Coupling Approach 
Intermediate Approach
Loose Coupling Approach 

Tight Coupling Approach: In this case, we can define CARD signaling as 
an extension to the FMIPv6 messages. This makes the CARD protocol tightly
coupled with FMIv6 protocol. 

The following are the PROS and CONS of this approach:

PROS: Enables inter-working of CARD and FMIPv6. Probably this will make 
CARD and FMIPv6 implementation less complicated. 

CONS: This approach restricts the deployment of CARD to FMIpv6 only.  
This approach may also require modification to the present FMIPv6 protocol. 

Intermediate Approach: In this approach, we can define CARD signaling as 
generic ICMP options. These ICMP options can be piggybacked upon any ICMP 
message including FMIPv6 signaling messages. Additionally, we can also define 
new CARD ICMP messages, which can be used when no outgoing ICMP messages are 
pending. 

The following are the PROS and CONS of this approach:

PROS: This approach enables the deployment of CARD along with any protocol 
including FMIPv6.  This also provides opportunity for additional optimization 
when deployed with FMIPv6 by exploiting the possibility of piggybacking CARD 
signaling over the FMIPv6 messages. 
 
CONS: The CARD protocol will be slightly more complex compared to the other 
approaches.

Loose Coupling Approach: We can define CARD signaling as new set of messages 
and prohibit the possibility of piggybacking upon any FMIPv6 messages. 

The following are the PROS and CONS of this approach:

PROS:De-couples CARD from any other protocol including FMIPv6. Probably this
is simpler to implement. 
 
CONS: Adds extra over the air messages during critical path of handoff which 
may not be desirable for the most wireless link. 

Please send your choice if any.

Regards,
Ajoy
_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Eunsoo Shim" <[email-masked]>
Date: Fri, 20 Dec 2002 16:35:13 -0500

Hi,

I also support for the Intermediate Approach.
Thanks.

Eunsoo

>From: Rajeev Koodli <[email-masked]>
>To: Singh Ajoy-ASINGH1 <[email-masked]>
>CC: [email-masked]
>Subject: Re: [Seamoby] CARD - FMIPv6 protocol interworking
>Date: Fri, 20 Dec 2002 12:03:08 -0800
>
>
>Ajoy,
>
>for MN - AR signaling, it would be good to have ICMP options.
>So, I guess that means "Intermediate Approach" without
>necessarily endorsing all the associated PROS and CONS.
>
>Regards,
>
>-Rajeev
>
>
>Singh Ajoy-ASINGH1 wrote:
>
> > Hello All,
> >
>https://www1.ietf.org/mailman/listinfo/seamob

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail&xAPID=42&PS=47575&PI=7324&DI=7474&SU= 
http://www.hotmail.msn.com/cgi-bin/getmsg&HL=1216hotmailtaglines_addphotos_3mf

---

From: "Eunsoo Shim" <[email-masked]>
Date: Fri, 20 Dec 2002 16:35:13 -0500

Hi,

Eunsoo

---

From: [email-masked]
Date: Mon, 23 Dec 2002 14:42:12 -0500

Hello Ajoy,
I support the Intermediate Approach. 

Thanks,
Govind.

-----Original Message-----
From: ext Singh Ajoy-ASINGH1 [mailto:[email-masked]]
Sent: Friday, December 20, 2002 11:36 AM
To: [email-masked]
Subject: [Seamoby] CARD - FMIPv6 protocol interworking

Hello All,

Tight Coupling Approach 
Intermediate Approach
Loose Coupling Approach 

 

 

Regards,
Ajoy

---

From: [email-masked]
Date: Mon, 23 Dec 2002 14:42:12 -0500

Hello Ajoy,

Thanks,
Govind.

-----Original Message-----
From: ext Singh Ajoy-ASINGH1 [mailto:[email-masked]]
Sent: Friday, December 20, 2002 11:36 AM
To: [email-masked]
Subject: [Seamoby] CARD - FMIPv6 protocol interworking

Hello All,

Tight Coupling Approach 
Intermediate Approach
Loose Coupling Approach 

 

 

Regards,
Ajoy