Subject: Re: [Seamoby] [issue30] How to handle bad MN's authorization Token?

From: Rajeev Koodli <[email-masked]>
Date: Mon, 08 Dec 2003 11:13:50 -0800

John Loughney SEAMOBY-Issues wrote:

> New submission from John Loughney <[email-masked]>:
>
> In case nAR requests the transfer by a CTR message, the pAR must verify
> the MN's authorization token. If this token is unvalid, what do we do ?
>
> Possible solutions:
>
>  - nothing ? the pAR does not answer to nAR.
>  - pAR indicates the error to nAR:
>         * In the CTD message.
>         * In a error message which could carry error information.
>

pAR MUST respond to nAR with an appropriate error.
nAR SHOULD convey the result to the MN.

-Rajeev

>
> others ?
>
> ----------
> category: Editorial
> document: draft-ietf-seamoby-ctp-05.txt
> messages: 39
> nosy: jloughney
> priority: Should Fix
> status: No Discussion
> title: How to handle bad MN's authorization Token?
> _____________________________________________________________
> Seamoby CTP Issues <[email-masked]>
> <http://danforsberg.info:8080/draft-ietf-seamoby-ctp/issue30>
> _____________________________________________________________
>
> _______________________________________________
> Seamoby mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/seamoby

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: Julien Bournelle <[email-masked]>
Date: Tue, 9 Dec 2003 09:55:33 +0100

Hi,

> nAR SHOULD convey the result to the MN.

I agree with that but how to carry this error ? In the CTD message or do
we create a new message to carry error ?

thanks,

-- 
[email-masked]

---

From: Rajeev Koodli <[email-masked]>
Date: Fri, 12 Dec 2003 16:03:26 -0800

> we create a new message to carry error ?

This should be supplied in CTD. We don't need another
message particularly for carrying the error.

Regards,

-Rajeev