Subject: RE: [Seamoby] DoCoMo Implementation Issues with CTP

From: "Soliman Hesham" <[email-masked]>
Date: Thu, 19 Feb 2004 22:04:09 -0500

> > Well, CTAR includes MN's IP(v4,v6) addresses. So does
 > > PCTD. So, nAR can still match the contexts. Since the token
 > > does not include PAR's address, verification can still be
 > > done.
 > > 
 > I think I didnot make my point clear.
 > MN is claiming that it came from one pAR IP Address(IPV6),
 > but the nAR has a PCTD that says pAR IP is different(IPv4),
 > How can nAR verify the Token without matching the pAR IP ?

=> Just out of curiosity, why do you expect the protocol
to function in this scenario? If I understand you correctly
the MN is moving from a v6 AR to a v4 only one. Even if 
CT worked in this scenario, many other things will break.
Is there a requirement for CT to work here ?

Hesham

 > 
 > > >
 > > > > Is the confusion in whether `V' bits also refer to
 > > > > PAR and NAR addresses ? If so, we should clarify that they
 > > > > refer to MN's IP addresses only, and that the router address
 > > > > must be either IPv4 or IPv6 but not both.
 > > > >
 > > > This description in the draft may clarify things, but how to
 > > > identify the IP version AR in CT messages.
 > > > I guess another V flag for AR might simply things.
 > > >
 > > 
 > > Perhaps this is not necessary. (See above)
 > >
 > I mean,
 > In CTAR Message there is pAR IP,
 > how can nAR know that there is IPv4 or IPv6 address of pAR,
 > if the V flag is only for MN IP version.
 > 
 > 
 > regards,
 > Raghu 
 > 
 > _______________________________________________
 > Seamoby mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/seamoby
 > 

_______________________________________________
Seamoby mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/seamoby

---

From: "Raghu" <[email-masked]>
Date: Thu, 19 Feb 2004 19:15:36 -0800

----- Original Message ----- 
From: "Soliman Hesham" <[email-masked]>
To: "Raghu" <[email-masked]>; <[email-masked]>
Sent: Thursday, February 19, 2004 7:04 PM
Subject: RE: [Seamoby] DoCoMo Implementation Issues with CTP

> Is there a requirement for CT to work here ?
MN is moving from pAR(v6 & v4) to nAR(v6 & v4).
According to Rajeev's previous mail, only one IP should be used,
either v6 or v4, for AR. In this case I was asking how the
funtionality should be with the above question.

I am expecting nothing to break in CTP when MN
moves from v6 to v4 only AR. 
Can you please provide some examples that break.

regards,
Raghu

---

From: "James Kempf" <[email-masked]>
Date: Fri, 20 Feb 2004 09:43:19 -0800

> Is there a requirement for CT to work here ?

I believe there is no requirement for CTP between IP versions. It might be
possible, depending on the context type, but I don't think it should be
required in general.

Perhaps the draft should specifically forbid this?

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Fri, 20 Feb 2004 09:54:23 -0800

Hi Hesham,

> Is there a requirement for CT to work here ?

The issue is separation of MN's contexts (belonging to
both IPv4 and IPv6 addresses) and the IP addresses used
in the Src, Dst fields in CTP messages. The assumption is
that routers know what IP version to use for transporting
the CTP messages. But that version (i.e., v4) does not necessarily
indicate whether the AR is dual-stacked or not to support
the contexts themselves. If an AR receives contexts it does
not support for whatever reason, it discards them.

Hope this clarifies.

-Rajeev