Subject: SSH2 Encrypted Private Key

From: "Benjamin Bruheim" <[email-masked]>
Date: Thu, 21 Mar 2002 16:00:20 +0100

Hello,

I'm currently doing an implementation of ssh; I haven't got far, because I'm wondering, where can I find info on the format of SSH2 Encrypted Private Keys? The public key has its own proposal though. I may implement the RSA-keys (who look almost the same :) ), but I can't find any formal format-descriptions.

// Benjamin Bruheim

---

From: Markus Friedl <[email-masked]>
Date: Thu, 21 Mar 2002 16:06:03 +0100

> I'm currently doing an implementation of ssh; I haven't got far, because I'm wondering, where can I find info on the format of SSH2 Encrypted Private Keys? The public key has its own proposal thoug…

there is no common format for private keys.

(and you don't need it if you wnat to implement ssh2).

---

From: "Benjamin Bruheim" <[email-masked]>
Date: Thu, 21 Mar 2002 16:13:37 +0100

> (and you don't need it if you wnat to implement ssh2).

Well, this is a problem when creating a personal key, and you want to keep the key across several applications. As far as I can see, ssh.com's private ssh2-key is propriatary. OpenSSH's keys is just poorly documented (and I guess its only available in sourcecodes), or badly referenced.

And, I will regret it if I invent my own format. :P

// Benjamin

---

From: Markus Friedl <[email-masked]>
Date: Thu, 21 Mar 2002 16:16:39 +0100

OpenSSH uses a PEM format as provided by OpenSSL, e.g.

	$ openssl genrsa -out bla 1024