Subject: RE: SFTP File open modes

From: Richard Whalen <[email-masked]>
Date: Fri, 29 Mar 2002 09:38:07 -0500

> -----Original Message-----
> From: Derek Fawcus [mailto:[email-masked]]
> Sent: Thursday, March 28, 2002 12:33 PM
> To: [email-masked]
> Subject: Re: SFTP File open modes
> 
> 
> On Thu, Mar 28, 2002 at 05:21:34PM +0000, Derek Fawcus wrote:
> > 
> > Rather than turn SFTP into a version of FTP,  I'd suggest 
> that a way be
> > documented to run FTP over SSH.
> > 
> > i.e. a SSH session connection would serve as the FTP 
> control connection
> > (port 21?),  and additional SSH connections would be opened for each
> > FTP file transfer connection (port 20?).
> 
> Or even easier - just use the SSH tcp port forwarding 
> facility.  Plumb the
> client and server into this and you have it all with minimal changes.
> 
> DF
> 

A big problem with port forwarding is that you have to set up a forwarding
for each system that you want to talk to. Yes, they could probably be set up
dynamically, but then you have to educate the users how to do that.  Most
users do ok at exchanging files, but if you ask them to set up forwarding,
you are getting too technical for them.  Don't think of what's easy for you
to do - think of what would be easy for the least technical member of your
family to do.

----------------------
Richard Whalen
Process Software

---

From: Niels Provos <[email-masked]>
Date: Fri, 29 Mar 2002 09:41:53 -0500

> to do - think of what would be easy for the least technical member of your
I suggest that you try out the OpenSSH implementation of the SSH
protocols.  We support dynamic port forwarding.  A user just
configures their application to use a SOCKS proxy and the rest works
automatically.  It is very easy to set up for the users as many
applications know about SOCKS.

Regards,
  Niels Provos.

---

From: Markus Friedl <[email-masked]>
Date: Sat, 30 Mar 2002 17:44:03 +0100

On Fri, Mar 29, 2002 at 09:38:07AM -0500, Richard Whalen wrote:
> dynamically,

Yes.

> but then you have to educate the users how to do that.

No.

That's a client implementation issue.  With OpenSSH we
have an experimental SOCKS4 interface for dynamic portforwarding
(see -D in ssh(1)), so this is not a protocol issue.

With SSH protocol v2 you can request server-to-client
or client-to-server forwardings at any time, you don't
need to setup forwardings in advance.