Subject: Filexfer version 3 vs. Filexfer version 4

From: Dan Davidson <[email-masked]>
Date: Mon, 25 Nov 2002 11:30:54 +0200

Hi,

	The version 4 of the SSH File Transfer Protocol strictly forbids the
transmission
of extensions in the SSH_FXP_INIT packet.
However, it may happen that a version 3 Client initiating a connection
towards a version 4 Server
will send such extensions in the INIT message.

What behavior is expected from the Server in such a case ?

Thanks and best regards,
Dan

---

From: Richard Whalen <[email-masked]>
Date: Mon, 25 Nov 2002 09:14:26 -0500

> -----Original Message-----
> From: Dan Davidson [mailto:[email-masked]]
> Sent: Monday, November 25, 2002 4:31 AM
> To: [email-masked]
> Subject: Filexfer version 3 vs. Filexfer version 4
> 
> 
> Hi,
> 

I believe that this depends upon the server.  If the server "supports" V3 as
well as V4, then it should process the extension information.  If it only
supports V4, then it would be reasonable to ignore the entire message as it
is ill-formed and there is no error response to the SSH_FXP_INIT packet.

The extensions were removed from the SSH_FXP_INIT packet as their presence
can cause problems when a V3 client sends them to a V2 server.

----------------------
Richard Whalen
Process Software
508-879-6994x261