Subject: Re: Resolving the newmodes algorithm list.

From: [email-masked] (Peter Gutmann)
Date: Wed, 30 Jul 2003 10:36:20 +1200

Bill Sommerfeld <[email-masked]> writes:

>Also, what do people think of boosting aes128-ctr to MANDATORY ?

Given that AES-CTR's main feature is that it's building block for a variety of
confidentiality+integrity modes (rather than a mode in and of itself) and that
it's parallelisable (if you happen to be doing, say, Gbps link encryption in
hardware), what would be the benefit of this?

Peter.

---

From: Damien Miller <[email-masked]>
Date: Wed, 30 Jul 2003 13:05:17 +1000

> hardware), what would be the benefit of this?

There was a long discussions on problems with CBC modes on this list a 
while back. CTR mode was offered as not vulnerable to the same problems.

-d