Subject: Re: Transport I-D: KEXINIT reserved field needs description

From: [email-masked] (Peter Gutmann)
Date: Tue, 22 Jul 2003 22:06:59 +1200

Markus Friedl <[email-masked]> writes:
>On Mon, Jul 21, 2003 at 03:17:42PM -0700, Nicolas Williams wrote:
>>Can implementors describe how they handle non-zero values for the last
>>field of SSH_MSG_KEXINIT?
>
>OpenSSH will accept non-zero values for the reserved uint32 value, but will
>not allow more data after this field.

Same for cryptlib.

Peter.

---

From: Bill Sommerfeld <[email-masked]>
Date: Tue, 22 Jul 2003 06:11:08 -0400

> >not allow more data after this field.

What's the detailed behavior?  suddenly drop the connection?  drop the
connection after sending an error packet?

---

From: Jon Bright <[email-masked]>
Date: Tue, 22 Jul 2003 12:16:48 +0200

> connection after sending an error packet?

PenguiNet will allow any value in the reserved field and silently ignore 
any additional data in the packet.

--
Jon Bright
Lead Programmer, Silicon Circus Ltd.
http://www.siliconcircus.com

---

From: Markus Friedl <[email-masked]>
Date: Tue, 22 Jul 2003 12:27:35 +0200

> connection after sending an error packet?

yes, OpenSSH will send a SSH2_MSG_DISCONNECT/SSH2_DISCONNECT_PROTOCOL_ERROR
error message and close the connection.

---

From: Paul Swartz <[email-masked]>
Date: Tue, 22 Jul 2003 09:22:18 -0500

> any additional data in the packet.

Conch will also allow any value and ignore extra data.

-p
-- 
       Paul Swartz
(o_    http://www.twistedmatrix.com/users/z3p.twistd/  _o)
//\    [email-masked]                           /\\
V_/_   AIM: z3penguin                                 _\_V->