Subject: [sfc] questions of "load balancing considerations" in the draft-quinn-sfc-arch-05

From: Linda Dunbar <[email-masked]>
Date: Wed, 28 May 2014 19:34:31 +0000

Paul and Joel,

Does the Load Balancing Figure 5 (of draft-quinn-sfc-arch-05) assume that SF1 is responsible for balancing traffic among the 3 instances of SF2, and SF3 is responsible for balancing traffic among the 3 instances of SF4?

Isn't it a single point of failure?

Some service functions are Stateful, i.e. they may require packets from same flows to traverse the same service function instance. For the Load Balancing scheme described by Figure 5, do you assume that SF1 and SF3 will be responsible for making sure that same flows go through the same service function instance?

For the stateful service functions, if a flow is switched from SF-Instance-X to SF-Instance-Y, the SF-Instance-Y needs to synchronize the states from SF-Instance-X. Who is responsible for those states maintenance for the Load Balancing described in Figure 5?

Linda

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 28 May 2014 15:36:24 -0400

No, that is not the intent of the figure.
But we have been unable to draw a figure with the service functions and 
the load balancers that can actually fit on a page and be read.

Yours,
Joel

On 5/28/14, 3:34 PM, Linda Dunbar wrote:
> Paul and Joel,
>
> Does the Load Balancing Figure 5 (of draft-quinn-sfc-arch-05) assume
> that SF1 is responsible for balancing traffic among the 3 instances of
> SF2, and SF3 is responsible for balancing traffic among the 3 instances
> of SF4?
>
> Isn’t it a single point of failure?
>
> Some service functions are Stateful, i.e. they may require packets from
> same flows to traverse the same service function instance. For the Load
> Balancing scheme described by Figure 5, do you assume that SF1 and SF3
> will be responsible for making sure that same flows go through the same
> service function instance?
>
> For the stateful service functions, if a flow is switched from
> SF-Instance-X to SF-Instance-Y, the SF-Instance-Y needs to synchronize
> the states from SF-Instance-X. Who is responsible for those states
> maintenance for the Load Balancing described in Figure 5?
>
> Linda
>

---

From: Eric Gray <[email-masked]>
Date: Wed, 28 May 2014 20:48:39 +0000

Linda,

                As Joel pointed out in his separate response the figure is not intended to
indicate that there are points that are "responsible for balancing traffic."

                As I understand it, the purpose of the figure is to try to shed some light on
an idea that should be obvious but is very hard to illustrate.

                The idea is that - in order to support chaining of a set of functions, when
there are various forms of network elasticity (function redundancy or load-sharing,
or network path redundancy or load sharing for example), it must be possible to
pick a path that corresponds to the desired/intended function chain.

                This should  be obvious.

                In the example in the figure, the role of SF3 (for example) is to provide a
point of convergence after the redundant/load-distributing service group shown
as multiple instances of SF2.

                SF3 could also be part of a load-sharing, or redundant group of multiple
convergence points.  But - at some point - a certain amount of complexity in an
illustrative depiction significantly detracts from the intent of the illustration.

                It is even possible that this figure has already passed that point.

                Can you suggest an easier way to illustrate the point?

--
Eric

From: sfc [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Wednesday, May 28, 2014 3:35 PM
To: Paul Quinn (paulq); Joel M. Halpern
Cc: [email-masked]
Subject: [sfc] questions of "load balancing considerations" in the draft-quinn-sfc-arch-05

Paul and Joel,

Linda