Subject: Re: [sfc] IPR related to draft-ietf-sfc-problem-statement

From: Thomas Narten <[email-masked]>
Date: Fri, 02 May 2014 13:10:49 -0400

Let me try to split this thread into two different pieces.

At Thu, 24 Apr 2014 08:27:20 +0200, <[email-masked]> wrote:

> When checking the tracker, I found there is an IPR disclosure for the problem
> statement document:
> 
> https://datatracker.ietf.org/ipr/search/?option=document_search&id=
> draft-ietf-sfc-problem-statement
> 
> I’m surprised to see such disclosure for a document that is supposed to
> describe only problems (except section 3).

Personally, I'm surprised too. But doesn't matter.

Making an IPR disclosure is a legal decision, not an engineering
one. The IETF is quite clear about IPR -- better to be safe and
disclose, rather than not. And in my experience, IPR disclosures
always have an explicit or implicit use of the word "may" to indicate
that IPR "may" apply. Whether IPR does actually apply to specific
technology is a nuanced discussion and one involving lawyers and the
courts. Different people will have different opinions.

> I’m re-iterating my comment to remove section 3 from the PS draft as it seems
> this is the only part that is close to the solution part than the problem
> discussion.

It's hard to see how removing section 3 will have any impact on IPR
related to SFC. First, removing the section will not necessarily lead
to the disclosure statement being removed (see above).

Second, if there actually is in fact IPR that applies to SFC, that
will become clear when we develop solutions, and additional specific
disclosures will need to be made then. (Making a disclosure for one
document isn't enough -- disclosures need to be made for every
document to which IPR might apply.) Thus, tweaking the problem
statement in an attempt to avoid an IPR disclosure seems more like
wishful thinking than substance.  Any IPR that applies to the problem
statement will surely come up again in the context of specific a
solution. IMO, it would be more appropriate for the WG to discuss how
to handle potential IPR when discussing specific solutions -- when we
can have a discussion in the context of specific technical approaches
that are being considered.

A number of folk on this thread have added a "+1". It would be helpful
to get additional clarity as to whether the agreement is about the
surprise at the IPR statement and a desire to try and avoid having the
problem statement document have an IPR disclosure statement associated
with it, or whether there is a support to remove section 3 for other
reasons than the IPR disclosure (there have been earlier/separate
threads on this question).

Thomas

> 
> Cheers,
> 
> Med
> 
> 
> [2  <text/plain; us-ascii (7bit)>]
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

---

From: Ron Parker <[email-masked]>
Date: Fri, 2 May 2014 17:26:26 +0000

Thomas,

It would seem that the group has at least 3 paths wrt the IPR issue on the problem statement:

1)  Accept it as it is
2)  The IPR claimant voluntarily decides to withdraw the claim, either with or without corresponding content changes
3)  A new draft is proposed by another party without IPR claims attached

Can we get consensus on which path we would like to follow?

   Ron

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Thomas Narten
Sent: Friday, May 02, 2014 1:11 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [sfc] IPR related to draft-ietf-sfc-problem-statement

At Thu, 24 Apr 2014 08:27:20 +0200, <[email-masked]> wrote:

> When checking the tracker, I found there is an IPR disclosure for the 
> problem statement document:
> 
> I¢m surprised to see such disclosure for a document that is supposed 
> to describe only problems (except section 3).

Making an IPR disclosure is a legal decision, not an engineering one. The IETF is quite clear about IPR -- better to be safe and disclose, rather than not. And in my experience, IPR disclosures always have an explicit or implicit use of the word "may" to indicate that IPR "may" apply. Whether IPR does actually apply to specific technology is a nuanced discussion and one involving lawyers and the courts. Different people will have different opinions.

> I¢m re-iterating my comment to remove section 3 from the PS draft as 
> it seems this is the only part that is close to the solution part than 
> the problem discussion.

It's hard to see how removing section 3 will have any impact on IPR related to SFC. First, removing the section will not necessarily lead to the disclosure statement being removed (see above).

Second, if there actually is in fact IPR that applies to SFC, that will become clear when we develop solutions, and additional specific disclosures will need to be made then. (Making a disclosure for one document isn't enough -- disclosures need to be made for every document to which IPR might apply.) Thus, tweaking the problem statement in an attempt to avoid an IPR disclosure seems more like wishful thinking than substance.  Any IPR that applies to the problem statement will surely come up again in the context of specific a solution. IMO, it would be more appropriate for the WG to discuss how to handle potential IPR when discussing specific solutions -- when we can have a discussion in the context of specific technical approaches that are being considered.

A number of folk on this thread have added a "+1". It would be helpful to get additional clarity as to whether the agreement is about the surprise at the IPR statement and a desire to try and avoid having the problem statement document have an IPR disclosure statement associated with it, or whether there is a support to remove section 3 for other reasons than the IPR disclosure (there have been earlier/separate threads on this question).

Thomas

---

From: Thomas Narten <[email-masked]>
Date: Fri, 02 May 2014 16:47:21 -0400

Hi Ron.

> It would seem that the group has at least 3 paths wrt the IPR issue on

Right. And this is what happens in practice with most IPR disclosures
these days. I'll just note that there have been some 45 disclosures in
the IETF so far this year. For all of 2013, there were some 279.
 
IPR List: http://datatracker.ietf.org/ipr/

> 2) The IPR claimant voluntarily decides to withdraw the claim, either
>     with or without corresponding content changes

In theory, this could happen. In practice, it's happened rarely. And
the IPR holder would need a reason to do so. It is unclear to me what
such motivation would be in this  case (but of course the WG could
attempt to make such a case).

> 3) A new draft is proposed by another party without IPR claims

One of the realities of technology development is that much if not
most technologies are covered by IPR of some sort. In most cases, we
don't even know what that IPR is (e.g., there are plenty of IPR
holders who don't even participate in the IETF). Any attempt at trying
to change the problem statement in a way that avoids specific IPR that
we know of would not address the potential IPR we don't know of.

> Can we get consensus on which path we would like to follow?

We are about to start a WG LC on the problem statement. Folk should
followup there if they think a specific action should be taken wrt the
disclosure.

Thomas
> 
>    Ron
> 
> 
> -----Original Message----- From: sfc [mailto:[email-masked]] On
> Behalf Of Thomas Narten Sent: Friday, May 02, 2014 1:11 PM To:
> [email-masked] Cc: [email-masked] Subject: Re: [sfc] IPR
> related to draft-ietf-sfc-problem-statement
> 
> > When checking the tracker, I found there is an IPR disclosure for
> > the problem statement document:
> > 
> > it seems this is the only part that is close to the solution part
> > than the problem discussion.
>

---

From: Loa Andersson <[email-masked]>
Date: Sat, 03 May 2014 08:45:30 +0200

Folks,

> the IETF so far this year. For all of 2013, there were some 279.

I think the issue is not that most IPR disclosures does not lead to any
action at all.

For FRAND statements there is no problems to accept it as it is; however
this is not FRAND but RAND.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 3 May 2014 11:04:05 -0400

I agree with Loa - RAND on a problem statement implies that the entire
technology is possibly encumbered. It would be best if the draft could be
revised such that the IPR claim no longer applies, if that's even possible.
That said, it's difficult to recommend specific changes without knowing why
the IPR claim was made. Looking at the patent itself, "Creating distributed
proxy configurations" at http://www.google.com/patents/US7200679 and
looking at Figure 3 and Claim 1 in particular, the implication to me is
that it's the entire technology that's being claimed. If that's the case,
then our choices to look to be:

- Accept that the entire technology is encumbered with a RAND claim, and
continue on.

- Drop the entire effort.

- Ask the claimant to fill in section V.C. of the IPR claim, or otherwise
clarify exactly what they are claiming.

- Ask the claimant to change their claim from RAND licensing to free
licensing with reciprocity.

Cheers,
Andy

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 5 May 2014 03:18:18 +0000

SFCers, Thomas,

I think the line of reasoning proposed at the beginning of this thread is not only fallacious but also quite dangerous.

The first email on this thread from Med is basically saying/implying that an existing IPR disclosure for draft-ietf-sfc-problem-statement applies to a particular section of that document only (Section 3), and also that consequently that specific Section ought to be removed (regardless of licensing terms of that IPR disclosure). Both are, IMHO, non-sequitur.

I am not a lawyer and I do not play one on this list -- however, it *cannot* be inferred from the IPR disclosure that the IPR only applies to Section 3. Similarly, it cannot be concluded as a consequence that a Section of a document should be surgically removed. Both statements are misleading.

There are many reasons for which an IPR disclosure can apply to a Problem Statement document, to a Use Case document, to a Requirements document, and of course to an Architecture and Protocol documents. I think it is dangerous to correlate the IPR to a specific section, and even worst to a particular action concerning such section. You can see other examples searching at https://datatracker.ietf.org/ipr/search/

The IPR disclosure points to Patent No: 7200679, that subject matter *may* apply, and all of us should consider this and make an assessment on the WGLC. However, the oversimplification below is incorrect and harmful.

More importantly, there is really not full consensus (to my knowledge, ADs please clarify otherwise) regardless the transitive nature of IPR disclosures and their terms. The disclosure applies to draft-quinn-sfc-problem-statement-02, and there is no explicit disclosure for any version of draft-ietf-sfc-problem-statement. That ought to be clarified. See for example the discussion at http://www.ietf.org/mail-archive/web/ipr-wg/current/msg06187.html

My 2¢,

Carlos.

On Apr 30, 2014, at 3:18 PM, Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:

I also agree with everyone else on this thread.

Cheers,
Andy

On Wed, Apr 30, 2014 at 1:06 PM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
+1.

Linda

From: sfc [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ron Parker
Sent: Saturday, April 26, 2014 11:19 AM
To: Liushucheng (Will)
Cc: Jiangyuanlong; BOUCADAIR Mohamed IMT/OLN; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

+1

  Ron

On Apr 25, 2014, at 9:21 PM, "Liushucheng (Will)" <[email-masked]<mailto:[email-masked]>> wrote:
+1.

According to what we have agreed on the charter about the PS,
 “This document will provide a summary of the
problem space to be addressed by the SFC working group including
example high-level use cases. Additionally, the working group will
normalize nomenclature and definitions for service function chaining.”
The part related to explicit architecture should be merged into the architecture document.

Regards,
Will (Shucheng LIU)

From: sfc [mailto:[email-masked]] On Behalf Of Jiangyuanlong
Sent: Friday, April 25, 2014 7:35 PM
To: [email-masked]<mailto:[email-masked]>; BOUCADAIR Mohamed IMT/OLN; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] IPR related to draft-ietf-sfc-problem-statement

+1, Section 3 addresses the architectural elements, which should be considered in a separate architecture document.

From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, April 25, 2014 2:23 PM
To: BOUCADAIR Mohamed IMT/OLN; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] IPR related to draft-ietf-sfc-problem-statement

WG,

I’d like to second Med’s comment: an IPR disclosure is a bit incongruous for a document that is supposed to document a problem statement and only a problem statement. From this perspective, the current Section 3 is no less misplaced.

Cheers,

Christian.

De : sfc [mailto:[email-masked]] De la part de [email-masked]<mailto:[email-masked]>
Envoyé : jeudi 24 avril 2014 08:27
À : [email-masked]<mailto:[email-masked]>
Objet : [sfc] IPR related to draft-ietf-sfc-problem-statement

Dear all,

When checking the tracker, I found there is an IPR disclosure for the problem statement document:
https://datatracker.ietf.org/ipr/search/?option=document_search&id=draft-ietf-sfc-problem-statement

I’m surprised to see such disclosure for a document that is supposed to describe only problems (except section 3).

I’m re-iterating my comment to remove section 3 from the PS draft as it seems this is the only part that is close to the solution part than the problem discussion.

Cheers,
Med

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Loa Andersson <[email-masked]>
Date: Mon, 05 May 2014 07:06:01 +0200

Carlos,

On 2014-05-05 05:18, Carlos Pignataro (cpignata) wrote:
> More importantly, there is really not full consensus (to my knowledge,
> ADs please clarify otherwise) regardless the transitive nature of IPR
> disclosures and their terms. The disclosure applies to
> draft-quinn-sfc-problem-statement-02, and there is no explicit
> disclosure for any version of draft-ietf-sfc-problem-statement. That
> ought to be clarified. See for example the discussion at
> http://www.ietf.org/mail-archive/web/ipr-wg/current/msg06187.html

As a working group I think we need to be conservative and assume that
a blanket IPR disclosure will be applicable to the working group
document.

After all there is only a very simple statement from the IPR holder
to say that this is the case.

But - yes I think from a legal point of view "transitveness" is a very
messy issue. I think that the ADs and lawyers can say that they are not
transitive, but as long as that is legally tested we simply don't know.

/Loa

--

---

From: <[email-masked]>
Date: Mon, 5 May 2014 09:21:17 +0200

Thomas,

It is not up to me to assess the validity of an IPR disclosure.

The main point is to revisit the draft to make hard to apply an IPR on it: this means exclude any solution discussion (i.e. section 3). 

Cheers,
Med

>-----Message d'origine-----
>De : Thomas Narten [mailto:[email-masked]]
>Envoyé : vendredi 2 mai 2014 19:11
>À : BOUCADAIR Mohamed IMT/OLN
>Cc : [email-masked]
>Objet : Re: [sfc] IPR related to draft-ietf-sfc-problem-statement
>
>> Iʼm surprised to see such disclosure for a document that is supposed to
>> Iʼm re-iterating my comment to remove section 3 from the PS draft as it
>seems

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 5 May 2014 07:38:43 -0400

That is a bit of a red herring, isn't it?  If the entire technology/ies is/are encumbered, shouldn't we look at that issue on the whole?  Simply removing a paragraph from one problem statement isn't going to properly address that issue.  Frankly, IPR claims on problem statements are useless other than they indicate there is IPR hiding elsewhere. Where IPR claims will really matter is around the solutions. Based on the claim in question, it is highly likely that there is IPR in this space. I'd venture that there is anyways given that many proprietary implementations have existed for some time. Given that, the question is one of what terms are they under and are they agreeable to the IETF for the solutions?  

	--Tom

> I agree with Loa - RAND on a problem statement implies that the entire technology is possibly encumbered. It would be best if the draft could be revised such that the IPR claim no longer applies, if that's even possible. That said, it's difficult to recommend specific changes without knowing why the IPR claim was made. Looking at the patent itself, "Creating distributed proxy configurations" at http://www.google.com/patents/US7200679 and looking at Figure 3 and Claim 1 in particular, the implication to me is that it's the entire technology that's being claimed. If that's the case, then our choices to look to be:
> 
> - Accept that the entire technology is encumbered with a RAND claim, and continue on.
> 
> - Ask the claimant to fill in section V.C. of the IPR claim, or otherwise clarify exactly what they are claiming.
> 
> - Ask the claimant to change their claim from RAND licensing to free licensing with reciprocity.
> 
> Cheers,
> Andy
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 05 May 2014 15:24:05 +0200

Tom,

Well, and I can't really make heads and tails of it!

If we are going down a path were we know that there are an IPR holder
does not tell us what his IPR applies to or what in their mind is a
reasonable fee for implementing.

Normally I agree that IPRs are useless, in this case I'm not sure. It
could be that disclose against the problem statement is a way to
announce that it is a blanket IPR, all implementations are effected.

I hope there is some duck paddling going on to figure out.

/Loa

On 2014-05-05 13:38, Thomas Nadeau wrote:
>
> That is a bit of a red herring, isn't it?  If the entire technology/ies
> is/are encumbered, shouldn't we look at that issue on the whole?  Simply
> removing a paragraph from one problem statement isn't going to properly
> address that issue.  Frankly, IPR claims on problem statements are
> useless other than they indicate there is IPR hiding elsewhere. Where
> IPR claims will really matter is around the solutions. Based on the
> claim in question, it is highly likely that there is IPR in this space.
> I'd venture that there is anyways given that many proprietary
> implementations have existed for some time. Given that, the question is
> one of what terms are they under and are they agreeable to the IETF for
> the solutions?
>
> --Tom
>
>
>
>> technology is possibly encumbered. It would be best if the draft could
>> be revised such that the IPR claim no longer applies, if that's even
>> possible. That said, it's difficult to recommend specific changes
>> without knowing why the IPR claim was made. Looking at the patent
>> itself, "Creating distributed proxy configurations" at
>> http://www.google.com/patents/US7200679 and looking at Figure 3 and
>> Claim 1 in particular, the implication to me is that it's the entire
>> technology that's being claimed. If that's the case, then our choices
>> to look to be:
>>
>> - Ask the claimant to fill in section V.C. of the IPR claim, or
>> otherwise clarify exactly what they are claiming.
>>
>> On Sat, May 3, 2014 at 2:45 AM, Loa Andersson <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>     Folks,
>>
>>
>> [email-masked] <mailto:[email-masked]>

--

---

From: David Allan I <[email-masked]>
Date: Mon, 5 May 2014 16:42:08 +0000

Hi:

Would not removing the section be simply kicking the can down the road?  Simply deferring opening the box with the cat in it....

At least that is how it looks from here...
D

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 05, 2014 12:21 AM
To: Thomas Narten
Cc: [email-masked]
Subject: Re: [sfc] IPR related to draft-ietf-sfc-problem-statement

Thomas,

Cheers,
Med

>De : Thomas Narten [mailto:[email-masked]] Envoyé : vendredi 2 mai 
>2014 19:11 À : BOUCADAIR Mohamed IMT/OLN Cc : [email-masked] Objet : Re: 
>[sfc] IPR related to draft-ietf-sfc-problem-statement
>
>> Iʼm surprised to see such disclosure for a document that is supposed 
>Making an IPR disclosure is a legal decision, not an engineering one. 
>The IETF is quite clear about IPR -- better to be safe and disclose, 
>rather than not. And in my experience, IPR disclosures always have an 
>explicit or implicit use of the word "may" to indicate that IPR "may" 
>apply. Whether IPR does actually apply to specific technology is a 
>nuanced discussion and one involving lawyers and the courts. Different 
>people will have different opinions.
>
>> this is the only part that is close to the solution part than the 
>> problem discussion.
>
>Second, if there actually is in fact IPR that applies to SFC, that will 
>become clear when we develop solutions, and additional specific 
>document isn't enough -- disclosures need to be made for every document 
>to which IPR might apply.) Thus, tweaking the problem statement in an 
>attempt to avoid an IPR disclosure seems more like wishful thinking 
>than substance.  Any IPR that applies to the problem statement will 
>surely come up again in the context of specific a solution. IMO, it 
>would be more appropriate for the WG to discuss how to handle potential 
>IPR when discussing specific solutions -- when we can have a discussion 
>in the context of specific technical approaches that are being 
>considered.
>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 05 May 2014 20:12:37 +0200

Dave,

The issue is if there is a cat in the boc, is there?

/Loa

--

---

From: David Allan I <[email-masked]>
Date: Mon, 5 May 2014 18:33:25 +0000

HI Loa:

I was thinking of Schrödinger....
http://en.wikipedia.org/wiki/Schr%C3%B6dinger's_cat 

We are simply deferring the determination of IPR relevance, as presumably if the IPR was claimed to possibly apply in the problem statement, it likely "may" apply to derivative works...

So excluding text from the draft does not make the IPR go away, and if the deleted section was what the IPR actually applied to, it leaves it in some limbo indeterminate state w.r.t. SFC and if it did not resolve the IPR issue then what do we do?  All we know is we've had some vague shot across our bow sailing in a fog....

My opinion was from the POV of the IPR issue, deleting text from the draft was an administrative expedient that actually did nothing...

And while not being a lawyer, I would observe that one does not "build" problem statements, so proving infringement is somewhat difficult. 

Dave

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]] 
Sent: Monday, May 05, 2014 11:13 AM
To: David Allan I; [email-masked]; Thomas Narten
Cc: [email-masked]
Subject: Re: [sfc] IPR related to draft-ietf-sfc-problem-statement

Dave,

/Loa

On 2014-05-05 18:42, David Allan I wrote:
>>> the
>> nuanced discussion and one involving lawyers and the courts. 
>> Different people will have different opinions.
>>
>> A number of folk on this thread have added a "+1". It would be 
>> helpful to get additional clarity as to whether the agreement is 
>> about the surprise at the IPR statement and a desire to try and avoid 
>> having the problem statement document have an IPR disclosure 
>> statement associated with it, or whether there is a support to remove 
>> section 3 for other reasons than the IPR disclosure (there have been 
>> earlier/separate threads on this question).
>>
>> Thomas
>>
>>>
>>> Cheers,
>>>
>>> Med
>>>
>>>

--

---

From: Loa Andersson <[email-masked]>
Date: Tue, 06 May 2014 08:00:39 +0200

Dave,

Yes I understood the Schrödinger analogy...

What i meant was that in a Schrödinger experiment we know that
there is a cat in the box, we just need to find if it is alive
or dead. Of course a real cat could have died of other reasons
than decaying atom.

In our case we need also decide if there is a cat from the beginning.

a. live cat
b.1 cat dead due detected radioactivity
b.2 cat dead of other reasons
c. no cat

In our cases I think

a. corresponds to a live and kicking cat, an IPR where everyone
   implementing will have to pay fees to do so.

b.1 would correspond to the situation where we just accept the IPR
     as is and the IPR holder tries but fail draw licensing fees from
     implementers

b.2 would correspond to the case where we accept the IPR, but the
     IPR holder does not try to draw licensing fees

c. would correspond to the situation where the IPR holder more precisely
    declare the scope of the IPR - the entire technology or just some
    part of it

I would wish for the IPR holder to come back to us and tell us what the
scope is.

Yes - I agree that some type of consensus should be called soon, or the
problem booted upstairs.

/Loa

--