Subject: [sfc] Figures in draft-quinn-sfc-arch-05

From: Eric Gray <[email-masked]>
Date: Thu, 29 May 2014 15:30:30 +0000

Paul/Joel,

                Pretty sure that Figures 5 and 6 don't actually fit the width expected for an
Internet Draft (Figure 5 is more than 80 characters wide and Figure 6 is wider still).

                Depending on how a reader tries to read the draft, this can turn complicated
illustrations into a _real_ fun time.  :)

                Also, I am unsure what the figures are trying to convey with some of "dotted
lines" crossing the service functions.  If the intent is to show that a service function is
a virtual instance hosted by some network device, perhaps this will be better shown
in a separate figure and this aspect of Figures 5 and 6 can be eliminated?

I would suggest replacing Figure 5 with a figure along the lines of:

source             +-----+                   +-----+
  |            +-->| sf2 +--+            +-->| sf4 +--+
  |            |   |     |  |            |   |     |  |
  |  +------+--+   +-----+  +-->+-----+--+   +-----+  +->+-----+
  |  | sf1  |      +-----+      | sf3 |      +-----+     | sf5 |
  +->|      +----->| sf2 +----->|     |----->| sf4 +---->|     |-+
     |      |      |     |      |     |      |     |     |     | |
     +------+--+   +-----+  +-->+-----+--+   +-----+  +->+-----+ |
               |   +-----+  |            |   +-----+  |          |
               +-->| sf2 +--+            +-->| sf4 +--+     +----+
                   |     |                   |     |        |
                   +-----+                   +-----+        V
                                                          destination

                   Figure 5: Load Balancing

(67 characters?)

                Similarly, I would suggest replacing Figure 6 with a figure along the
lines of:

   source

     |               +-----+-+                   +-----+-+

 +---+           +-->| sf2 |-|+              +-->| sf4 |-|+

 |           +---|-->|     | ||          +------>|     | ||

 |   +------+|---+   +-----+ |+-->+-----+|---+   +-----+ |+-->+-----+

 |   | sf1  ||       +-----+ +--->| sf3 ||       +-----+ +--->| sf5 |

 +-->|      +|------>| sf2 |+---->|     ||------>| sf4 |+---->|     |--+

 |   |      || +---->|     |-+    |     || +---->|     |-+    |     |  |

 |   +------+|-|-+   +-----+ |+-->+-----+|-|-+   +-----+ |+-->+-----+  |

 |           | | |   +-----+ ||          | | |   +-----+ ||            |

 |   +------++ | +-->| sf2 |-|+   +-----++ | +-->| sf4 |-|+   +-----+  |

 |   | sf1' |  | +-->|     | +--->| sf3'|  | +-->|     | +--->| sf5'|  |

 +-->|      +--+ |   +-----+----->|     |--+ |   +-----+----->|     |--+

     |      |    |                |     |    |                |     |  |

     +------+----+                +-----+----+                +-----+  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

                    Figure 6: Load Balancing and HA

(72 characters?)

                In both cases, the figure has all the same connection complexity (fixed up in a few
places), but seems to be less busy.

--
Eric

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Thu, 29 May 2014 17:43:01 +0000

You could turn the whole picture right by 90 degrees.
If you don't like top to bottom instead of left to right, make a note that it's in landscape.

--Jakob

From: sfc [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, May 29, 2014 8:31 AM
To: Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: [sfc] Figures in draft-quinn-sfc-arch-05

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Eric Gray <[email-masked]>
Date: Thu, 29 May 2014 17:54:24 +0000

HaHa, funny man.  :)

From: Jakob Heitz (jheitz) [mailto:[email-masked]]
Sent: Thursday, May 29, 2014 1:43 PM
To: Eric Gray; Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: RE: Figures in draft-quinn-sfc-arch-05
Importance: High

--Jakob

Cc: [email-masked]<mailto:[email-masked]>

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Lucy yong <[email-masked]>
Date: Thu, 29 May 2014 18:11:33 +0000

For readability on these figures, propose:

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |
       enter -->sf1-->-sf2->--sf3-->-sf4->--sf5--> exit
                     |     |       |     |
                     +-sf2-+       +-sf4-+
Figure 6:

                         +-sf2-+              +-sf4-+
                         |     |              |     |
    enter -->{sf1|sf1'}-->-sf2->--{sf3|sf3'}-->-sf4->--{sf5}--> exit
                         |     |              |     |
                         +-sf2-+              +-sf4-+

lucy
From: sfc [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Thursday, May 29, 2014 12:54 PM
To: Jakob Heitz (jheitz); Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: Re: [sfc] Figures in draft-quinn-sfc-arch-05

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 29 May 2014 20:48:43 +0000

I like the Figures drawn by Lucy.

Actually why can't Figure 5 be simplified as

    enter -->{sf1}-->-{sf2|sf2'|sf2''}->--{sf3}-->-{sf4|sf4'|sf4''}->--{sf5}--> exit

??

Linda

From: sfc [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Thursday, May 29, 2014 1:12 PM
To: Eric Gray; Jakob Heitz (jheitz); Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: Re: [sfc] Figures in draft-quinn-sfc-arch-05

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Eric Gray <[email-masked]>
Date: Thu, 29 May 2014 21:18:14 +0000

Linda/Lucy,

                It's not a beauty contest.  There are trade-offs associated with using
any of these approaches.

                If the authors decide to use Lucy's approach, they will need to add a
little bit more text to explain the notation (sf1|sf1' meaning two separate
nodes providing the same service function, where packets may be processed
by either) - as it is not as intuitive as if separate boxes are used in the figure.

                Your suggestion would require even more additional text, as it is (in
effect) applying the same sort of notation recursively - especially if applied
to both figures 5 and 6.

                Either approach would be fine with me, provided the text to make
it clear what these figures mean is provided.

                For other folks - particularly those who understand things better if
they are clearly explained pictorially - having the need to add extra text to
make the picture itself more understandable may not work that well.

                I'm personally fine with any of the options discussed so far, and am
perfectly happy to let the Editors of the draft make whatever choice they
prefer, for whatever reasons they prefer that (or those) choice(s).

--
Eric

From: Linda Dunbar [mailto:[email-masked]]
Sent: Thursday, May 29, 2014 4:49 PM
To: Lucy yong; Eric Gray; Jakob Heitz (jheitz); Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: RE: Figures in draft-quinn-sfc-arch-05
Importance: High

??

Linda

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Eric Gray <[email-masked]>
Date: Thu, 29 May 2014 21:23:21 +0000

Linda,

By the way, your proposal for Figure 5 would require a column width of at least 80
characters (more than you are supposed to have in an ID), and the situation would
be worse if it were applied to figure 6.

For figure 5, you can improve the width slightly by fixing up a few of your arrows,
and even more by wrapping the figure.  Wrapping  might detract from simplicity,
however.

--
Eric

??

Linda

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 29 May 2014 21:42:07 +0000

Eric,

How about this shorter one?

->{sf1}->{sf2|sf2'|sf2''}->{sf3}->{sf4|sf4'|sf4''}->{sf5}->

The intent is pretty simple: If a service function on a chain has multiple instances, one of the service function's instances is selected to treat packets belonging to the service chain.

This is a correct mathematics expression.
There is really no need draw all those boxes.

Linda

From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, May 29, 2014 4:23 PM
To: Linda Dunbar; Lucy yong; Jakob Heitz (jheitz); Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: RE: Figures in draft-quinn-sfc-arch-05

Linda,

--
Eric

??

Linda

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Lucy yong <[email-masked]>
Date: Fri, 30 May 2014 00:21:57 +0000

Eric,

There is no contest in this discussion. We just provide suggestions and believe that editors will address them properly in next version based on the discussion and suggestions.  IMO: we have enough discussion on this subject. So I am end here. :)

Lucy

From: Eric Gray [mailto:[email-masked]]
Sent: Thursday, May 29, 2014 4:18 PM
To: Linda Dunbar; Lucy yong; Jakob Heitz (jheitz); Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: RE: Figures in draft-quinn-sfc-arch-05

Linda/Lucy,

--
Eric

??

Linda

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Eric Gray <[email-masked]>
Date: Fri, 30 May 2014 15:03:06 +0000

Linda,

                It may be a mathematically correct expression (depending on interpretation
of the notation used), but networking is not necessarily (possibly even usually) a
mathematical operation.

                There is nothing "intuitively obvious" in this expression that makes it clear
that "load sharing" is taking place between the sets of sf2 and sf4 instances, or how
the "or" operation takes place.

                One literal way to interpret this notation (as a mathematical expression) is
that each the functions sf2, sf2' and sf2" are "visited" sequentially and passed on
to sf3 as soon as it succeeds in any of the functions.  With this interpretation, since
the service function performed at each sf2 instance is presumed to be identical,
what the expression means is that either the service function will succeed at sf2
(and always skip sf2' and sf2"), or that it will fail at each sf2 instance.

                An equally legitimate "parallel computing" (not exactly mathematical, but
possibly viewed as more closely analogous to networking) interpretation would
be that processing passes (on success at sf1) to each of sf2, sf2' and sf2" in parallel
and then proceeds to sf3 on success at any of the sf2 instances.

                None of these interpretations corresponds to  "load sharing" - yet all are
perfectly legitimate interpretation of your suggested expression/notation.

                And yet, these are actually more common interpretation of the usage of
an "or" operation to computing folks (which many of us are), depending on their
specific background in computing.

                As I said before, I have no objection to the suggested notation you and
Lucy proposed - provided that the notation is explained.  I am unclear as to what
value this usage - and included explanation may have - but this is largely a style
issue, and best left up to the draft editors at this point.

                And, as I also said, there may be others who would prefer not to have too
much textual explanation necessary in order to understand a figure.

                Finally, you must realize that there are a fairly large number of folks who
read-over mathematical expressions as if they were written in a foreign language.
For this reason, even if it were a perfectly useful/correct mathematical expression,
a number of folks would still need a picture.

--
Eric

From: Linda Dunbar [mailto:[email-masked]]
Sent: Thursday, May 29, 2014 5:42 PM
To: Eric Gray; Lucy yong; Jakob Heitz (jheitz); Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: RE: Figures in draft-quinn-sfc-arch-05
Importance: High

Eric,

Linda

Linda,

--
Eric

??

Linda

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Fri, 30 May 2014 17:55:00 +0000

Here is a good example of an RFC with readable diagrams
http://www.rfc-editor.org/rfc/rfc1131.pdf

How did he upload that?

--Jakob

From: sfc [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Friday, May 30, 2014 8:03 AM
To: Linda Dunbar; Lucy yong; Jakob Heitz (jheitz); Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: Re: [sfc] Figures in draft-quinn-sfc-arch-05

Linda,

--
Eric

From: Linda Dunbar [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>

Eric,

Linda

Linda,

--
Eric

??

Linda

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric

---

From: Eric Gray <[email-masked]>
Date: Fri, 30 May 2014 18:05:37 +0000

Ah.  I see.

It appears to have come around to that time of year when we discuss the use of
other formats for writing and reading RFCs.

Normally, we have that discussion on the IETF Discussion mailing list, where I can
- along with a great many others - can generally ignore it.  :)

Let's move it to that list, shall we?

Thanks!
--
Eric

From: Jakob Heitz (jheitz) [mailto:[email-masked]]
Sent: Friday, May 30, 2014 1:55 PM
To: Eric Gray; Linda Dunbar; Lucy yong; Joel Halpern; Paul Quinn (paulq)
Cc: [email-masked]
Subject: RE: Figures in draft-quinn-sfc-arch-05
Importance: High

How did he upload that?

--Jakob

Linda,

--
Eric

Eric,

Linda

Linda,

--
Eric

??

Linda

Figure 5:
                     +-sf2-+       +-sf4-+
                     |     |       |     |

                         +-sf2-+              +-sf4-+
                         |     |              |     |

lucy

HaHa, funny man.  :)

--Jakob

Paul/Joel,

source             +-----+                   +-----+

                   Figure 5: Load Balancing

(67 characters?)

   source

     |               +-----+-+                   +-----+-+

     |      |    |                |     |    |                |     |  |

                                                                       |

                                                              +--------+

                                                              |

                                                              V

                                                         destination

(72 characters?)

--
Eric