Subject: Re: [sfc] Fwd: I-D Action: draft-ietf-sfc-nsh-06.txt

From: Dave Dolson <[email-masked]>
Date: Tue, 6 Sep 2016 18:24:45 +0000

Do the authors have a response to this question?
I'm also wondering about whether the 'C' flag might be for the administrator vs. IANA.

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, August 25, 2016 11:40 AM
To: Paul Quinn (paulq); [email-masked]
Subject: Re: [sfc] Fwd: I-D Action: draft-ietf-sfc-nsh-06.txt

Hi Paul,

I have a comment about this text:

   Type: the Type field is split into two ranges - 0 to 127 for non-
   critical options and 128-255 for critical options.  While the value
   allocation is the responsibility of the MD Class owner, critical
   options MUST NOT be allocated from the 0 to 127 range and non-
   critical options MUST NOT be allocated from the 128-255 range.

* Do you have an example of metadata that is critical for all chains, all deployments?
* Wouldn't be more appropriate to have one single registry for "type" with C-bit be a configurable parameter to be set by the administrator of the SFC-enabled domain?

Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : sfc [mailto:[email-masked]] De la part de Paul Quinn (paulq)
> Envoyé : mardi 23 août 2016 16:02
> À : [email-masked]
> Objet : [sfc] Fwd: I-D Action: draft-ietf-sfc-nsh-06.txt
> 
> Dear WG,
> 
> This version includes much of the feedback/review/comments from this list.
> 
> 
> 
> > Begin forwarded message:
> >
> > From: [email-masked]
> > Subject: [sfc] I-D Action: draft-ietf-sfc-nsh-06.txt
> > Date: August 23, 2016 at 9:54:21 AM EDT
> > To: <[email-masked]>
> > Cc: [email-masked]
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Service Function Chaining of the IETF.
> >
> >        Title           : Network Service Header
> >        Authors         : Paul Quinn
> >                          Uri Elzur
> > 	Filename        : draft-ietf-sfc-nsh-06.txt
> > 	Pages           : 37
> > 	Date            : 2016-08-23
> >
> > Abstract:
> >   This document describes a Network Service Header (NSH) inserted onto
> >   packets or frames to realize service function paths.  NSH also
> >   provides a mechanism for metadata exchange along the instantiated
> >   service path.  NSH is the SFC encapsulation required to support the
> >   Service Function Chaining (SFC) Architecture (defined in RFC7665).
> >
> >
> > The IETF datatracker status page for this draft is:
> > https://datatracker.ietf.org/doc/draft-ietf-sfc-nsh/
> >
> > There's also a htmlized version available at:
> > https://tools.ietf.org/html/draft-ietf-sfc-nsh-06
> >
> > A diff from the previous version is available at:
> > https://www.ietf.org/rfcdiff?url2=draft-ietf-sfc-nsh-06
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > Internet-Drafts are also available by anonymous FTP at:
> > ftp://ftp.ietf.org/internet-drafts/
> >
> > _______________________________________________
> > sfc mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/sfc
> 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc

---

From: <[email-masked]>
Date: Tue, 27 Sep 2016 12:52:51 +0000

Re-,

Unless I'm mistaken, I didn't see any follow-up for this issue. 

Cheers,
Med

> De : Dave Dolson [mailto:[email-masked]]
> Envoyé : mardi 6 septembre 2016 20:25
> À : BOUCADAIR Mohamed IMT/OLN; Paul Quinn (paulq); [email-masked]
> Objet : RE: [sfc] Fwd: I-D Action: draft-ietf-sfc-nsh-06.txt
> 
> * Wouldn't be more appropriate to have one single registry for "type" with
> C-bit be a configurable parameter to be set by the administrator of the
> SFC-enabled domain?
> 
> Thank you.
> 
> Cheers,
> Med
>