Subject: [sfc] Subscriber and policy context headers: draft-sfc-serviceid-headers

From: <[email-masked]>
Date: Thu, 18 Oct 2018 06:12:23 +0000

Hi all, 

We prepared an updated version of this specification to take into account the comments received on the list. This version specifies two opaque identifiers: subscriber and policy. We do think this version is much more simple and stable; we renamed the file on purpose to make it clear this is an enhanced specification.

As a reminder, this I-D is an updated version of draft-sarikaya-sfc-hostid-serviceheader which received some adoption support from the WG. We defer to our chairs whether they can build on that or not. 

Please review and share comments you may have on this version. 

Comments, suggestions, and questions are more than welcome. 

Thank you. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mardi 16 octobre 2018 09:51
> À : [email-masked]
> Objet : I-D Action: draft-sfc-serviceid-header-01.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : Service Function Chaining: Subscriber and Policy
> Identification Variable-Length Network Service Header (NSH) Context Headers
>         Authors         : Behcet Sarikaya
>                           Mohamed Boucadair
>                           Dirk von Hugo
> 	Filename        : draft-sfc-serviceid-header-01.txt
> 	Pages           : 8
> 	Date            : 2018-10-16
> 
> Abstract:
>    This document discusses how to inform Service Functions about
>    subscriber- and service-related information for the sake of policy
>    enforcement and appropriate service function chaining operations.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-sfc-serviceid-header/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-sfc-serviceid-header-01
> https://datatracker.ietf.org/doc/html/draft-sfc-serviceid-header-01
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-sfc-serviceid-header-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Trossen, Dirk" <[email-masked]>
Date: Thu, 18 Oct 2018 13:01:49 +0000

Hi Med,

Very interesting draft and nice update! I see a lot of relevance for conveying this context information in a number of scenarios, particularly related to mobile networks. 

I furthermore see a strong linkage to our updated draft on named SFF (https://www.ietf.org/internet-drafts/draft-trossen-sfc-name-based-sff-01.txt) where the selection of the appropriate next hop, i.e., the SF instance, in the named SFF could be based on such subscriber and/or policy information provided through the context headers. Likely, use cases overlap here, e.g., with mobile networks and specifically the routing of control plane service requests. 

Best,

Dirk

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 18 October 2018 07:12
To: [email-masked]
Subject: [sfc] Subscriber and policy context headers: draft-sfc-serviceid-headers

Hi all, 

Thank you. 

Cheers,
Med

> [email-masked] Envoyé : mardi 16 octobre 2018 09:51 À : 
> [email-masked] Objet : I-D Action: 
> draft-sfc-serviceid-header-01.txt
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc