Subject: [sfc] Philosophical question about MD types 1 and 2

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 17 Feb 2021 22:39:56 -0000

Hi,

Sorry if this re-opens old wounds...

If I define something to go in a fixed length MD type 1 context header,
should I also define how it is carried in an MD type 2 header?

Thanks,
Adrian

---

From: <[email-masked]>
Date: Thu, 18 Feb 2021 15:18:52 +0000

Hi Adrian, 

The agreement was that you can (not a should, though):

"the documents defining MD-1 formats can also define a MD-2 Type code for carrying the same block of information with the same structure."

Please note that a standard track document is needed for MD#2, while defining MD#1 context can be in an informational RFC.

Cheers,
Med

> -----Message d'origine-----
> De : sfc [mailto:[email-masked]] De la part de Adrian Farrel
> Envoyé : mercredi 17 février 2021 23:40
> À : [email-masked]
> Cc : [email-masked]
> Objet : [sfc] Philosophical question about MD types 1 and 2
> 
> Hi,
> 
> If I define something to go in a fixed length MD type 1 context
> header, should I also define how it is carried in an MD type 2
> header?
> 
> Thanks,
> Adrian
> 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 18 Feb 2021 11:17:54 -0500

Med, you are almost correct.  The assignment policy for class 0 is 
Standards track.  The assignment policy for classes 0x0001-0x01FF are 
IETF Review.  Classes 0x0201-0xFFF5 are expert review.  So if we need a 
class code and subsequent variable-length metadata type, there are ways 
we could do it even for an Informational Document or an Independent 
Stream document.  (We gave BBF an entire class.)

If the WG wants to, we can spin a document to create an FCFS class by 
IETF Action.

Yours,
Joel

---

From: <[email-masked]>
Date: Thu, 18 Feb 2021 18:08:30 +0000

Re-,

You are right, Joel. I was referring to the IETF Class. 

Cheers,
Med

> De : Joel M. Halpern [mailto:[email-masked]]
> Envoyé : jeudi 18 février 2021 17:18
> À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>;
> [email-masked]; [email-masked]
> Objet : Re: [sfc] Philosophical question about MD types 1 and 2
> 
> IETF Review.  Classes 0x0201-0xFFF5 are expert review.  So if we need
> a class code and subsequent variable-length metadata type, there are
> ways we could do it even for an Informational Document or an
> Independent Stream document.  (We gave BBF an entire class.)
> 
> > "the documents defining MD-1 formats can also define a MD-2 Type
> code for carrying the same block of information with the same
> structure."
> >
> > Please note that a standard track document is needed for MD#2,
> while defining MD#1 context can be in an informational RFC.
> >
> > Cheers,
> > Med
> >
> >> Envoyé : mercredi 17 février 2021 23:40 À : [email-masked] Cc :
> >> [email-masked] Objet : [sfc] Philosophical question about
> MD
> >> types 1 and 2
> >>
> >> Hi,
> >>
> _____________________________________________________________________
> _
> > ___________________________________________________
> >
> > Ce message et ses pieces jointes peuvent contenir des informations
> > confidentielles ou privilegiees et ne doivent donc pas etre
> diffuses,
> > exploites ou copies sans autorisation. Si vous avez recu ce message
> > par erreur, veuillez le signaler a l'expediteur et le detruire
> ainsi que les pieces jointes. Les messages electroniques etant
> susceptibles d'alteration, Orange decline toute responsabilite si ce
> message a ete altere, deforme ou falsifie. Merci.
> >
> > This message and its attachments may contain confidential or
> > privileged information that may be protected by law; they should
> not be distributed, used or copied without authorisation.
> > If you have received this email in error, please notify the sender
> and delete this message and its attachments.
> > As emails may be altered, Orange is not liable for messages that
> have been modified, changed or falsified.
> > Thank you.
> >