Subject: Re: [sfc] Regarding last call for draft-ietf-sfc-multi-layer-oam

From: Linda Dunbar <[email-masked]>
Date: Tue, 23 Nov 2021 19:29:23 +0000

I support the WGLC for the draft-ietf-sfc-multi-layer-oam-16

I have some questions though:

The Req #1 says that Active SFC OAM should traverse the same path .. in the transport layer as the SFC data packet.
Is the "Transport Layer" refers to TCP/QUIC/UDP transport layer? Or referring to the underlay network path?

Is it necessary for all functions on the SFC to process the Active SFC OAM data packets? The Req#3 says that Egress node must send the "Remote Defect Indication" to the ingress node. Is it necessary for the intermediate Functions to send "Remote Defect Indication" to the ingress node?

Thank you
Linda Dunbar

On Mon, Nov 1, 2021 at 2:50 PM Joel Halpern Direct
<[email-masked]><mailto:&lt;[email-masked]&gt;> wrote:
>
> I have received a polite request with explanation for delay asking for
> more time to read and review the subject document.  Given the state of
> the working group, i want to encourage any and all review.  So I am
> extending the last call by two additional weeks.
>
> Please read and review the document.
> Also, if you are willing to serve as shepherd for this, please let the
> chairs know.  (Don't worry if you have not shepherded a document before.
>   The chairs are more than happy to help you with the process.)
>
> Thank you,
> Joel
>
> _______________________________________________
> sfc mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sfc

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 23 Nov 2021 13:05:12 -0800

Hi Linda,
thank you for supporting this work and sharing your comments. Please find
my notes in-lined below under the GIM>> tag. I hope the proposed update
addresses your concerns.

Regards,
Greg

On Tue, Nov 23, 2021 at 11:29 AM Linda Dunbar <[email-masked]>
wrote:

> The Req #1 says that Active SFC OAM should traverse the same path .. in
> the transport layer as the SFC data packet.
>
> Is the “Transport Layer” refers to TCP/QUIC/UDP transport layer? Or
> referring to the underlay network path?
>
GIM>> Thank you for pointing this out. You're right, the terminology is not
accurate and I propose s/transport/underlay network/. (I've noticed one
more place where this update is needed.)

>
>
> Is it necessary for all functions on the SFC to process the Active SFC OAM
> data packets?
>
GIM>> This document is to apply to Classifiers, SFFs. We don't require SF
and SF Proxy to process SFC Active OAM. If we consider an intermediate SFF,
then it is required to process Active SFC OAM packets without passing it to
an SF/SF Proxy.

> The Req#3 says that Egress node must send the “Remote Defect Indication”
> to the ingress node. Is it necessary for the intermediate Functions to send
> “Remote Defect Indication” to the ingress node?
>
GIM>> RDI, as I understand its function, is used in one-way protocols that
detect a failure in the network. An egress node sets RDI in OAM packets
notifying the ingress of a detected defect. I don't see an intermediate
node setting RDI, as it is not detecting a defect in the SFP. RDI is not
useful in FM OAM protocols that use round-trip methods, e.g., ping.

> <[email-masked]> <&lt;[email-masked]&gt;> wrote:
>
> >
>
> > [email-masked]
> [email-masked]