Subject: Small question about draft-proto v10 - update ack

From: Sébastien Barré <[email-masked]>
Date: Wed, 11 Jun 2008 13:55:31 +0200

Hi,

I have almost finished implementing support of locator updates, and have 
now a small question relative to section 10.5 (receiving update acks).

I find strange the following lines :
---
o  If I2-SENT, then send R2 and proceed to process the message.

o  If I2BIS-SENT, then send R2 and proceed to process the message.
---
Why do we need to send an R2 if we are in I2-SENT state ?
Moreover, if we send an R2, the peer will infer that we are in 
ESTABLISHED state, and thus will never send its locators !

In section 10.4 (receiving update requests), something similar is 
written, but an I2 must be sent.
I am not sure of how useful it is, but I implemented that, since it is 
in the draft and it is not harmful anyway.
But sending an R2 seems strange.

Am I missing something ?

Thanks,

Sébastien.

-- 
Sébastien Barré
Researcher,
CSE department, UCLouvain, Belgium
http://inl.info.ucl.ac.be/sbarre

---

From: Matthijs Mekking <[email-masked]>
Date: Wed, 11 Jun 2008 14:54:40 +0200

Good catch. Probably, this must be:

> o  If I2-SENT, then send I2 and proceed to process the message.
>
> o  If I2BIS-SENT, then send I2BIS and proceed to process the message.

In order to let the peer know we *need* a R2 message.

- - Matthijs

> But sending an R2 seems strange.

Delivery-date: Wed, 11 Jun 2008 12:55:43 +0000
Date: Wed, 11 Jun 2008 14:54:40 +0200
From: Matthijs Mekking <[email-masked]>
To: [email-masked]
Subject: Re: Small question about draft-proto v10 - update ack

Good catch. Probably, this must be:

> o  If I2-SENT, then send I2 and proceed to process the message.
>
> o  If I2BIS-SENT, then send I2BIS and proceed to process the message.

In order to let the peer know we *need* a R2 message.

- - Matthijs

> But sending an R2 seems strange.

Delivery-date: Wed, 11 Jun 2008 11:57:31 +0000
Date: Wed, 11 Jun 2008 13:55:31 +0200
From: =?ISO-8859-1?Q?S=E9bastien_Barr=E9?= <[email-masked]>
To: [email-masked]
Subject: Small question about draft-proto v10 - update ack

Hi,

Am I missing something ?

Thanks,

Sébastien.