Subject: [sidr] RPKI Validator for Firefox

From: Matthias Waehlisch <[email-masked]>
Date: Tue, 26 Feb 2013 17:14:50 -0800 (Pacific Normalzeit (Mexiko))

Hi all,

  just for fun and inspired by Mozilla RPKI trials, we implemented a 
Firefox Add-on that provides validation result of the web server's 
prefix.

  * https://addons.mozilla.org/addon/rpki-validator/

  IP address to prefix mapping is performed by Team Cymru Service, 
prefix validation is based on the RTRlib. If you like it, let me know 
;).

See you in Orlando
  matthias

-- 
Matthias Waehlisch
.  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST
.  Takustr. 9, D-14195 Berlin, Germany
.. mailto:[email-masked] .. http://www.inf.fu-berlin.de/~waehl
:. Also: http://inet.cpt.haw-hamburg.de .. http://www.link-lab.net

---

From: Arturo Servin <[email-masked]>
Date: Wed, 27 Feb 2013 09:42:04 +0800

Very nice!

	But it is not working properly, :(

	It says that my prefix is unknown when it is valid according to my
validation:

http://www.labs.lacnic.net/rpkitools/looking_glass/rest/all/cidr/200.3.12.0/22/

(www.lacnic.net)

	Does Team Cymru Service has all the TALs updated?

Regards
as

---

From: "Pradosh Mohapatra (pmohapat)" <[email-masked]>
Date: Wed, 27 Feb 2013 18:51:34 +0000

>prefix validation is based on the RTRlib. If you like it, let me know

I like it ;-)

Thank you!

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Wed, 27 Feb 2013 17:03:52 -0200

I definitely like it.

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Wed, 27 Feb 2013 17:39:05 -0200

Yup, LACNIC's website resides on a 'valid' prefix. I'm trying other
prefixes from our network and they all appear as 'not-found'.

Matthias, I'd love to help you troubleshoot the issue. You can contact
me on private if you prefer.

regards

~Carlos

On 2/26/13 11:42 PM, Arturo Servin wrote:
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 28 Feb 2013 04:10:10 +0800

how do i specify my TAL set?

randy

---

From: Matthias Waehlisch <[email-masked]>
Date: Wed, 27 Feb 2013 12:14:07 -0800 (Pacific Normalzeit (Mexiko))

> how do i specify my TAL set?
  future work ;) ... actually, I would more see the question: "how to 
specify my cache server". Is this of interest?

Cheers
  matthias

---

From: Randy Bush <[email-masked]>
Date: Thu, 28 Feb 2013 04:17:19 +0800

> specify my cache server".  Is this of interest?

that would also solve my need

randy

---

From: "Osterweil, Eric" <[email-masked]>
Date: Wed, 27 Feb 2013 20:19:54 +0000

You might also check out the RPKI update Twitter feed @RPKIUpdateBot

I think there are something like 5k tweets now...

Eric

Sent from my iPhone

---

From: Andrew Chi <[email-masked]>
Date: Wed, 27 Feb 2013 15:30:18 -0500

Neat plugin.  It will be fun to see more green indicators as people 
issue ROAs for their space.

> specify my cache server". Is this of interest?

Definitely.

Also, since Firefox doesn't know the origin AS for the web page it just 
retrieved, are you using the Team Cymru service to map IP to AS? 
(http://www.team-cymru.org/Services/ip-to-asn.html)

Andrew

---

From: Andree Toonk <[email-masked]>
Date: Wed, 27 Feb 2013 14:19:03 -0800

.-- My secret spy satellite informs me that at 2013-02-27 12:30 PM

> (http://www.team-cymru.org/Services/ip-to-asn.html)

If the plugin using whois to do this, then you can also do it in one query:

Easy to parse:

whois -h whois.bgpmon.net " -m 200.3.12.0/22"
BGP Prefix|CC|Origin AS| Origin AS Name| Prefix Description|RPKI
status|First seen|Last seen|#peers
200.3.12.0/22|UY|28001|LACNIC - Latin American and Caribbean IP
address|LACNIC|ROA validation successful|2011-10-19|2013-02-27|152

Or more verbose:

whois -h whois.bgpmon.net 200.3.12.0/22

Prefix:              200.3.12.0/22
Prefix description:  LACNIC
Country code:        UY
Origin AS:           28001
Origin AS Name:      LACNIC - Latin American and Caribbean IP address
RPKI status:         ROA validation successful
First seen:          2011-10-19
Last seen:           2013-02-27
Seen by #peers:      152

Cheers,
 Andree

---

From: Matthias Waehlisch <[email-masked]>
Date: Wed, 27 Feb 2013 14:26:55 -0800 (Pacific Normalzeit (Mexiko))

Hi Andree,

On Wed, 27 Feb 2013, Andree Toonk wrote:

> > Also, since Firefox doesn't know the origin AS for the web page it 
> > just retrieved, are you using the Team Cymru service to map IP to 
> > AS? (http://www.team-cymru.org/Services/ip-to-asn.html)
> 
  true, but we also looked for a funny application for our RTRlib, which 
is doing prefix validation in the background.  

Cheers
  matthias

---

From: Matthias Waehlisch <[email-masked]>
Date: Wed, 27 Feb 2013 14:29:16 -0800 (Pacific Normalzeit (Mexiko))

Hi Andrew,

> (http://www.team-cymru.org/Services/ip-to-asn.html)
  yes, for the IP to prefix mapping we are using the Team Cymru service.

  Hope to come up with a more configurable version before IETF.

Cheers
  matthias

---

From: Matthias Waehlisch <[email-masked]>
Date: Wed, 27 Feb 2013 14:39:30 -0800 (Pacific Normalzeit (Mexiko))

Hi Carlos,

  this should be fixed now. There was a problem with the RTR cache and 
validating LACNIC data.

Cheers
  matthias

---

From: Arturo Servin <[email-masked]>
Date: Thu, 28 Feb 2013 11:08:45 +0800

Or WEIRDS servers and receive the data in json.

	At least ours is using the latests WEIRDS drafts for query and response.

Regards,
as