Subject: Re: [sidr] WGLC for drained ft-ietf-sidr-rpki-rtr-rfc6810-bis-03

From: Sandra Murphy <[email-masked]>
Date: Thu, 16 Jul 2015 07:05:41 -0400

Could you please reply to the list and say whether you believe that the draft-ietf-sidr-rpki-rtr-rfc6810-bis-04.txt version satisfies your comments?  It would help with the process.

--Sandy

On Mar 25, 2015, at 5:13 PM, "Borchert, Oliver" <[email-masked]> wrote:

> David,
> 
> A correction for my previous email, I mixed up session id and serial
> number.
> I think to keep it simple for version 0 - 1 switches and future changes, a
> change
> Within the session id and version id should trigger a “Cache Reset” by the
> cache
> And the client must resynch with the server.
> And yes, wording in this matter might need to be added - but still it also
> could
> Be an implementation issue.
> 
> Oliver
> 
> -------------------------------------------------------------
> Oliver Borchert, Computer Scientist
> National Institute of Standards and Technology
> (Phone) 301.975.4856 , (Fax) 301.975.6238
> 
> 
> 
> 
> 
> On 3/24/15, 10:58 AM, "Borchert, Oliver" <[email-masked]> wrote:
> 
>> Isn¹t this an implementation issue? The client either speaks 0 or 1. As
>> long as the server
>> keeps track of the version for the session IMHO it does not matter if the
>> session id is
>> shared? The client doesn¹t know about it. Lets say one encounter a new key
>> and this
>> Only triggers a PDU 9, the server sends send out the notification. The
>> client can but must not
>> React to it anyhow. If the client reacts, the server sends an end of
>> update to a version 0
>> session and all pdu 9 updates to a version 1 session.
>> I don¹t see a needed wording here. Not yet but IŒm open for enlightenment.
>> 
>> Oliver
>> -------------------------------------------------------------
>> Oliver Borchert, Computer Scientist
>> National Institute of Standards and Technology
>> (Phone) 301.975.4856 , (Fax) 301.975.6238
>> 
>> 
>> 
>> 
>> 
>> On 3/24/15, 10:36 AM, "David Mandelberg" <[email-masked]> wrote:
>> 
>>> Rob and I were talking about rpki-rtr, and I came up with another
>>> potential issue with switching between protocol versions. I don't see
>>> any text about whether a single session (session id and serial numbers)
>>> can be used for both version 0 and 1. If a router has a valid version 0
>>> session, upgrades to version 1, and issues a serial query with the same
>>> session id and serial number, it's unclear what the server should do.
>>> Could we add text to the document saying that the cache MUST maintain a
>>> separate session for each protocol version it supports, and a router
>>> MUST NOT attempt to reuse session information across multiple protocol
>>> versions?
>>> 
>>> --
>>> David Eric Mandelberg / dseomn
>>> http://david.mandelberg.org/
>>> 
>>> _______________________________________________
>>> sidr mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/sidr
>> 
>> _______________________________________________
>> sidr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sidr
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: "Borchert, Oliver" <[email-masked]>
Date: Thu, 23 Jul 2015 21:06:27 +0000

Sandy,

Yes I do believe the comments are satisfied,
Oliver

On 7/16/15 1:05 PM, "Sandra Murphy" <[email-masked]> wrote:

>Could you please reply to the list and say whether you believe that the
>draft-ietf-sidr-rpki-rtr-rfc6810-bis-04.txt version satisfies your
>comments?  It would help with the process.
>
>--Sandy
>