Subject: Re: [sidr] New Version Notification for draft-kklf-sidr-route-server-rpki-light-00.txt

From: Thomas King <[email-masked]>
Date: Tue, 26 Apr 2016 09:25:28 +0000

Hi all,

Following up on the discussion we had during the last IETF meeting I would like to discuss with you how we proceed with the “Did not perform validation” value. I think this value is very important and should be added to ietf-sidr-origin-validation-signaling.

Best regards,
Thomas

---

From: Matthias Waehlisch <[email-masked]>
Date: Tue, 26 Apr 2016 13:32:16 +0200

There was a quite similar discussion in 2013, for the thread see

https://mailarchive.ietf.org/arch/msg/sidr/zvSP_-iiEfu_acYInK5lOMnys5U

As far as I remember w/o a final conclusion (or the conclusion was 
leave it as is).

Cheers
  matthias

On Tue, 26 Apr 2016, Thomas King wrote:

> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
> 

-- 
Dr. Matthias Waehlisch
.  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST
.  Takustr. 9, D-14195 Berlin, Germany
.. mailto:[email-masked] .. http://www.inf.fu-berlin.de/~waehl
:. Also: http://inet.haw-hamburg.de .. http://www.link-lab.net

---

From: Thomas King <[email-masked]>
Date: Tue, 26 Apr 2016 12:33:59 +0000

I would like to come back to a solution that was discussed already: If the route-server is not able to perform the origin prefix validation the BGP community is not added to the BGP update. The BGP community is only added if the origin prefix validation could be executed.

This solution allows a clear signalling. This would also be compatible with the current ietf-sidr-origin-validation-signaling document and could be easily stated in draft-kklf-sidr-route-server-rpki-light.

Best regards,
Thomas

---

From: Randy Bush <[email-masked]>
Date: Wed, 27 Apr 2016 00:06:25 +0900

> I would like to come back to a solution that was discussed already: If
> the route-server is not able to perform the origin prefix validation
> the BGP community is not added to the BGP update. The BGP community is
> only added if the origin prefix validation could be executed.
> 
> This solution allows a clear signalling. This would also be compatible
> with the current ietf-sidr-origin-validation-signaling document and
> could be easily stated in draft-kklf-sidr-route-server-rpki-light.

you're welcome

randy