Subject: Re: [sidr] Current document status && directionz

From: Christopher Morrow <[email-masked]>
Date: Wed, 30 Nov 2016 13:33:25 -0500

And again, restarting... post meeting and post travel refocusing :)

On Wed, Oct 26, 2016 at 11:35 AM, Christopher Morrow <
[email-masked]> wrote:

> Restarting this thread, with some updates :)
>
> Preparing for Seoul in a few weeks time, with the intent that we do not
> meet face-to-face in Chicago, have all current 'protocol' related docs to
> the IESG/done and meet instead in sidr-ops if there are agenda items at
> that time :)
>
> Currently we have the following in IESG/pub-request status (13 documents):
> draft-ietf-sidr-adverse-actions
> draft-ietf-sidr-as-migration
> draft-ietf-sidr-bgpsec-algs
> draft-ietf-sidr-bgpsec-ops
> draft-ietf-sidr-bgpsec-overview
> draft-ietf-sidr-bgpsec-pki-profiles
> draft-ietf-sidr-bgpsec-protocol
>
    draft-ietf-sidr-delta-protocol (10/26 sent forward)

> draft-ietf-sidr-origin-validation-signaling
> draft-ietf-sidr-publication
> draft-ietf-sidr-rpki-oob-setup
> draft-ietf-sidr-rpki-rtr-rfc6810-bis
>

I had thought I sent validation-reconsidered forward for processing, I'm
doing that today:

> draft-ietf-sidr-rpki-validation-reconsidered
>

 Currently still active documents (6 documents):

> draft-ietf-sidr-bgpsec-rollover
> draft-ietf-sidr-lta-use-cases
> draft-ietf-sidr-route-server-rpki-light
> draft-ietf-sidr-rpki-tree-validation
> draft-ietf-sidr-rtr-keying
> draft-ietf-sidr-slurm
>
> (this reflects the changes since the last email, included below)
>
> I believe we're still planning to move (and have agreement from authors):
>  draft-ietf-sidr-bgpsec-rollover
>  draft-ietf-sidr-lta-use-cases
>  draft-ietf-sidr-route-server-rpki-light
>  draft-ietf-sidr-rtr-keying
>

draft-ietf-sidr-rpki-tree-validation

> which leaves to be dealt with by Chicago 2 documents:
> draft-ietf-sidr-slurm
>
> I think this is good, I believe (and of course I should be corrected if
> wrong)
>   slurm - more work inbound and discussion planned in Seoul
>   tree-validation - I thought moved to sidr-ops, but don't have docs to
> back that up.
>
>
I still think this is good, I will be sending a request to the OPS-AD folk
today to move:
 draft-ietf-sidr-bgpsec-rollover
 draft-ietf-sidr-lta-use-cases
 draft-ietf-sidr-route-server-rpki-light
 draft-ietf-sidr-rtr-keying
 draft-ietf-sidr-rpki-tree-validation

to sidr-ops... If there are corrections/additions please send them along :)

-chris

> -chris
>
> On Fri, Sep 2, 2016 at 4:56 PM, Chris Morrow <[email-masked]>
> wrote:
>
>>
>> Howdy SIDR peeps,
>> (+bonus ops ad)
>>
>> Following on the Berlin meeting we were trying to accomplish two
>> things:
>>
>>   1) get all documents related to sidr protocols into wglc and then
>>   publication
>>
>>   2) get all documents which are more operationally focused moved
>>   along to an ops group (sidr-ops or something akin to that)
>>
>> With that in mind there are 8 documents in the publication queue:
>>   draft-ietf-sidr-as-migration
>>   draft-ietf-sidr-bgpsec-algs
>>   draft-ietf-sidr-bgpsec-ops
>>   draft-ietf-sidr-bgpsec-overview
>>   draft-ietf-sidr-bgpsec-pki-profiles
>>   draft-ietf-sidr-bgpsec-protocol
>>   draft-ietf-sidr-origin-validation-signaling
>>   draft-ietf-sidr-rpki-rtr-rfc6810-bis
>>
>> and 11 still in progress. Of the 11 left Sandy and I think they
>> roughly break down like:
>>
>> Documents which should move to the ops group:
>>   draft-ietf-sidr-bgpsec-rollover
>>   draft-ietf-sidr-lta-use-cases
>>   draft-ietf-sidr-route-server-rpki-light - authors notified/queried
>> about this
>>   draft-ietf-sidr-rtr-keying
>>
>> documents which should finish out in sidr:
>>   draft-ietf-sidr-delta-protocol
>>   draft-ietf-sidr-publication
>>   draft-ietf-sidr-rpki-oob-setup - pub request in flight
>>   draft-ietf-sidr-rpki-tree-validation
>>   draft-ietf-sidr-rpki-validation-reconsidered
>>   draft-ietf-sidr-slurm - authors recently updated
>>   draft-ietf-sidr-adverse-actions - wglc imminent
>>
>> I think if there's no meaningful discussion on change for these
>> between now and 9/16/2016 (Sept 16th) we will assume this list is
>> correct. For documents in the 'move' list, if progress to publication
>> happens 'good!'. For all documents in the 'stays' list:
>>   1) we aim to have wglc by Seoul
>>   2) publication requests started on as many as possible
>>
>> We plan to meet in Seoul, but not in Chicago (Mar 2017) where we
>> expect the ops group to exist and meet. We can progress documents in
>> SIDR after Seoul, but the WG should close out shortly after the new
>> year. (or that's the goal).
>>
>> Thoughts?
>> -chris
>>
>> _______________________________________________
>> sidr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sidr
>>
>
>

---

From: Randy Bush <[email-masked]>
Date: Wed, 30 Nov 2016 21:01:53 -0800

>> draft-ietf-sidr-bgpsec-ops

waiting to rev when iesg and whomever reviews are in.  if someone wants
an earlier push, shout.

>> draft-ietf-sidr-lta-use-cases

i thought this was post last call

>> draft-ietf-sidr-rtr-keying

i thought this was done

randy

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 1 Dec 2016 01:15:39 -0500

> waiting to rev when iesg and whomever reviews are in.  if someone wants
I'm not in a rush, I believe we're just waiting on process so that's fine.

> i thought this was post last call

Hrm, I still see mail that's calling it drafts, up to version 7, but not
wglc ... perhaps that's on our schedule to start though (sandy may have
this, I'll have to check my notes.. or I may :) )

> >> draft-ietf-sidr-rtr-keying
this one maybe done, but has not hit WGLC. we can do that here, or there...
I'm agnostic at this point.

---

From: Declan Ma <[email-masked]>
Date: Thu, 1 Dec 2016 14:51:59 +0800

Chris,

I would like to take this thread to request for comments on how to move on SLURM.

During the Seoul meeting, Tim suggested moving it to SIDROPS since SIDR is being closed. 

Yet I had the impression that the AD hopes keeping the list/structure going until current work items are done. 

Considering the only issue facing SLURM is the file format that Tim and Rudiger mentioned in the MIC, IMHO, if this WG won’t plan to move SLURM to SIDROPS, WGLC is desirable to bring about inputs and comments to conclude this work.

Di 

> 在 2016年12月1日，02:33，Christopher Morrow <[email-masked]> 写道：
> 
> On Wed, Oct 26, 2016 at 11:35 AM, Christopher Morrow <[email-masked]> wrote:
> Preparing for Seoul in a few weeks time, with the intent that we do not meet face-to-face in Chicago, have all current 'protocol' related docs to the IESG/done and meet instead in sidr-ops if there are agenda items at that time :)
> 
> I had thought I sent validation-reconsidered forward for processing, I'm doing that today:
> I think this is good, I believe (and of course I should be corrected if wrong)
>   tree-validation - I thought moved to sidr-ops, but don't have docs to back that up.
> 
> 
> I still think this is good, I will be sending a request to the OPS-AD folk today to move:
> On Fri, Sep 2, 2016 at 4:56 PM, Chris Morrow <[email-masked]> wrote:
> 
> Howdy SIDR peeps,
> (+bonus ops ad)
> 
>   draft-ietf-sidr-route-server-rpki-light - authors notified/queried about this