Subject: [sidr] Agenda Upload

From: Chris Morrow <[email-masked]>
Date: Mon, 07 Nov 2016 15:26:33 -0800

Draft Agenda was uploaded moments ago.

I'm sure I missed something(s)

I'm also sure I signed Tim up for at least 2 things he wasn't prepared
for (and may not be required)

it's a draft :)

-chris

---

From: Randy Bush <[email-masked]>
Date: Tue, 08 Nov 2016 14:26:28 +0900

i stil think we should be doing some rigorous interoperability testing,
inter CA, caches and routers, routers applying origin validation, ...

yes, we should be doing this in sidrops, but we all know that it will be
populated by the usual suspects, barring voter suppression.  so it would
be nice to discuss this next week, irresptive of the air cover and hats.

randy, already in seoul noc

---

From: Chris Morrow <[email-masked]>
Date: Mon, 07 Nov 2016 23:46:58 -0800

At Tue, 08 Nov 2016 14:26:28 +0900,
> be nice to discuss this next week, irresptive of the air cover and hats.

I can add an item to the agenda I'm happy to discuss.

-chris

---

From: Tim Bruijnzeels <[email-masked]>
Date: Tue, 8 Nov 2016 10:22:34 +0100

Hi Chris,

> On 08 Nov 2016, at 00:26, Chris Morrow <[email-masked]> wrote:
> 

I see one item with my name, and two others that might have my name implied. 

As far as I am concerned I don't need to talk about any of them. But if the WG feels differently I am happy to - then I would like a bit more guidance though on what to address exactly. Quoting below:

> 3- RRDP/HTTPS - Tim Bruijnzeels                   15 min

The document went through last call and was sent to the IESG on 26 October. If the WG feels it's useful to give an overview of this work once more then I can certainly do so - but I expect it's not needed and it's better to use face to face time for other things. Of course I would be more than happy to discuss this work in person as well.

> 4- Updates to ROA/BGPSEC Router Cert Profiles     20 min

I am confused by this item. Is this because of the updates to these documents we included in reconsidered, which is #6?

> 6- Validation Reconsidered mish/mash              10 min

We went through last call, and then I indicated I would be more confident if people reviewed the ASN.1 and OID changes. Sean Turner did a quick check - thanks :) I want to be really careful here and not take a seat on the chair, but.. it seems to me that unclarities and concerns were addressed.

If not, then I am of course willing to talk about this once more, but would ask the WG to be specific about which aspect should be re-discussed or presented.

> it's a draft :)

no worries, appreciated.

One other thing that I may want to discuss is the future of tree-validation. Not so much the content, but the idea of having (a) document(s) in this WG (or SIDR-OPS in future) that describes a specific implementation. There are two issues: 1) implementation is a moving target, so we will need updates in future, 2) the implementation is not generic (would individual submission be more appropriate? WG feedback was very valuable).

We recently uploaded a version that reflects our 2.23 validator implementation. We indicated that we want to go for last-call on this as soon as possible (I understand that IETF process will mean this will probably be after Seoul). And we indicated that for future updates we plan to document small changes just as notes in the README/RELEASE NOTES of the code, but that we would seek to document more substantial changes through the IETF again in future.

My questions to the WG would be:
= Does the proposal make sense to you?
= Do you agree that these documents can be WG documents?
    - We value the feedback
    - We include the feedback in the document - currently in security considerations
    - But the content of the document reflects actual implementation, not desired implementation.
= Is there a useful parallel to IETF documents describing other open-source implementations?

..or -- I have a preference for having RFCs for this, because I think the review will be more thorough and independent, but -- we can also just discuss this in the WG, but not as an IETF document, and then just include the documents with our validator releases instead?

Cheers
Tim

> 
> -chris
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: Tim Bruijnzeels <[email-masked]>
Date: Tue, 8 Nov 2016 10:23:28 +0100

> On 08 Nov 2016, at 08:46, Chris Morrow <[email-masked]> wrote:
> 

+1 I agree this would be useful to discuss.

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Tue, 08 Nov 2016 11:46:35 -0300

Same here. An interesting and relevant topic.

---

From: Chris Morrow <[email-masked]>
Date: Tue, 08 Nov 2016 11:23:06 -0800

At Tue, 8 Nov 2016 10:22:34 +0100,
> I see one item with my name, and two others that might have my name implied. 

noting that i said: 'draft agenda' :)

> 
> As far as I am concerned I don't need to talk about any of them. But

I'm happy to yield time back to the randy-proposed-content, it's also
interesting to me.

> if the WG feels differently I am happy to - then I would like a bit
> more guidance though on what to address exactly. Quoting below:
> 
> The document went through last call and was sent to the IESG on 26
> October. If the WG feels it's useful to give an overview of this
> work once more then I can certainly do so - but I expect it's not
> needed and it's better to use face to face time for other things. Of
> course I would be more than happy to discuss this work in person as
> well.
> 
> I am confused by this item. Is this because of the updates to these
> documents we included in reconsidered, which is #6?
> 
> We went through last call, and then I indicated I would be more
> confident if people reviewed the ASN.1 and OID changes. Sean Turner
> did a quick check - thanks :) I want to be really careful here and
> not take a seat on the chair, but.. it seems to me that unclarities
> and concerns were addressed.
> 

excellent. (I agree things seem settled)

> If not, then I am of course willing to talk about this once more,
> but would ask the WG to be specific about which aspect should be
> re-discussed or presented.
> 

let's skip your bits then and concentrate on the newly proposed
interop discussion.

> > it's a draft :)
> 
> no worries, appreciated.
> 
> One other thing that I may want to discuss is the future of
> tree-validation. Not so much the content, but the idea of having (a)
> document(s) in this WG (or SIDR-OPS in future) that describes a
> specific implementation. There are two issues: 1) implementation is
> a moving target, so we will need updates in future, 2) the
> implementation is not generic (would individual submission be more
> appropriate? WG feedback was very valuable).
> 

happy to add this to the 'draft agenda'.

> We recently uploaded a version that reflects our 2.23 validator
> implementation. We indicated that we want to go for last-call on
> this as soon as possible (I understand that IETF process will mean
> this will probably be after Seoul). And we indicated that for future
> updates we plan to document small changes just as notes in the
> README/RELEASE NOTES of the code, but that we would seek to document
> more substantial changes through the IETF again in future.
> 
> My questions to the WG would be: = Does the proposal make sense to
> you?  = Do you agree that these documents can be WG documents?  - We
> value the feedback - We include the feedback in the document -
> currently in security considerations - BUT the content of the
> document reflects actual implementation, not desired implementation.
> ..or -- I have a preference for having RFCs for this, because I
> think the review will be more thorough and independent, but -- we
> can also just discuss this in the WG, but not as an IETF document,
> and then just include the documents with our validator releases
> instead?
> 
> 

this bit does sound like good topic for the meeting discusion.
let's add this to the 'draft agenda' as well. (as i say above)

---

From: Declan Ma <[email-masked]>
Date: Wed, 9 Nov 2016 11:00:56 +0800

+1.

Intriguing! 

I was considering how inter-chche works. 

Di

> 在 2016年11月8日，13:26，Randy Bush <[email-masked]> 写道：
>

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 9 Nov 2016 12:57:25 -0800

FYI: Draft Agenda updated, happy to accept changes still :)