Subject: [sidr] draft-ietf-sidrops-signed-tal-00

From: Russ Housley <[email-masked]>
Date: Thu, 22 Mar 2018 13:02:21 -0400

Is the intent to use CMS to sign the trust anchor list?  Since ROAs are signed with CMS, I was expecting these signatures to follow the same convention.  However, there is no reference to CMS in the draft.

Russ

---

From: Tim Bruijnzeels <[email-masked]>
Date: Thu, 22 Mar 2018 17:07:07 +0000

Hi Russ,

Yes, this is a CMS object. Section 3 describes this. It’s an extension of RPKI Signed Object - which is CMS.- and specifies the relevant content type (3.1) and eContent (3.2).

Tim

> On 22 Mar 2018, at 17:02, Russ Housley <[email-masked]> wrote:
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 22 Mar 2018 13:44:56 -0400

Tim:

I think that a statement in Section 3 that it uses CMS SignedData [RFC5652] would make this very clear.

Russ

> On Mar 22, 2018, at 1:07 PM, Tim Bruijnzeels <[email-masked]> wrote:
> 
> Hi Russ,
>

---

From: Tim Bruijnzeels <[email-masked]>
Date: Tue, 27 Mar 2018 11:38:15 +0200

Hi Russ, all,

How about:

OLD:
A signed TAL is an RPKI signed object, as specified in [RFC6488].

NEW:
The signed TAL object uses the standard template for
specifying signed objects that can be validated using the
RPKI [RFC6488], which is based on Cryptographic
Message Syntax (CMS) [RFC5652] as a standard
encapsulation format.

(Relevant text included and paraphrased from 6488)

Tim

> On 22 Mar 2018, at 18:44, Russ Housley <[email-masked]> wrote:
> 
> Tim:
>

---

From: Russ Housley <[email-masked]>
Date: Tue, 27 Mar 2018 10:48:14 -0400

Tim:

Works for me.  Thanks for considering my suggestion.

Russ

> On Mar 27, 2018, at 5:38 AM, Tim Bruijnzeels <[email-masked]> wrote:
> 
> Hi Russ, all,
> 
> How about:
> 
> OLD: