Subject: [sidr] [Technical Errata Reported] RFC8360 (5870)

From: RFC Errata System <[email-masked]>
Date: Fri, 4 Oct 2019 13:25:45 -0700 (PDT)

The following errata report has been submitted for RFC8360,
"Resource Public Key Infrastructure (RPKI) Validation Reconsidered".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5870

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: 4.2.3

Original Text
-------------
       ext-pe-autonomousSysIds-v2 EXTENSION ::= {
         SYNTAX ASIdentifiers
         IDENTIFIED BY id-pe-autonomousSysIds-v2
       }

       id-pe-autonomousSysIds OBJECT IDENTIFIER ::= { id-pe 29 }

Corrected Text
--------------
       ext-pe-autonomousSysIds-v2 EXTENSION ::= {
         SYNTAX ASIdentifiers
         IDENTIFIED BY id-pe-autonomousSysIds-v2
       }

       id-pe-autonomousSysIds-v2 OBJECT IDENTIFIER ::= { id-pe 29 }

Notes
-----
The "-v2" is missing from the identifier.  It is needed for the ASN.1 module to compile properly.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8360 (draft-ietf-sidr-rpki-validation-reconsidered-10)
--------------------------------------
Title               : Resource Public Key Infrastructure (RPKI) Validation Reconsidered
Publication Date    : April 2018
Author(s)           : G. Huston, G. Michaelson, C. Martinez, T. Bruijnzeels, A. Newton, D. Shaw
Category            : PROPOSED STANDARD
Source              : Secure Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Geoff Huston <[email-masked]>
Date: Sat, 5 Oct 2019 02:42:27 +0000

yep - that looks like a genuine error - well spotted Russ!

Geoff

> On 5 Oct 2019, at 6:25 am, RFC Errata System <[email-masked]> wrote:
>

---

From: Chris Morrow <[email-masked]>
Date: Mon, 07 Oct 2019 21:34:49 -0400

On Fri, 04 Oct 2019 16:25:45 -0400,
> "Resource Public Key Infrastructure (RPKI) Validation Reconsidered".

seems legit.

---

From: Carlos Martinez <[email-masked]>
Date: Mon, 07 Oct 2019 20:56:35 -0500

Indeed.

Sent from a mobile device. Mis disculpas. Enviado desde un dispositivo 
movil. On Mon, Oct 07, 2019 at 8:45pm, Chris Morrow < 
[email-masked] [[email-masked]] > wrote:
On Fri, 04 Oct 2019 16:25:45 -0400,

seems legit.