Subject: mutli-line strings (again)

From: Tim Showalter <[email-masked]>
Date: Tue, 20 May 1997 23:13:14 -0400 (EDT)

I never saw what I'd consider concensus, so I'd like to hash this out
again.

There are at least three proposals for multi-line strings:
| ANSI-C style:
| "This is a multi-line string.\n"  "It is spread over several lines.\n"
| "\"This is a quoted string.\"\n"

This is a second try; I think LISP lets you get away with this:
| "This is a multi-line string.
| There is a line break. \"I suppose this is a quoted string.\"
| "

And Chris' modification of what's in the draft:
| text:
| This is a multi-line string.
| .. This line begins with a single dot.
| .

-- 
                                           Tim Showalter [email-masked]

---

From: Rob Earhart <[email-masked]>
Date: Tue, 20 May 1997 23:36:12 -0400 (EDT)

Referring to them ANSI-C, LISP, and Chris...

  The ANSI-C way is ugly, but manageable.

  In both the LISP and Chris mechanisms, a missed terminator hoses the
rest of the file, but at least with Chris's the terminator's easy to
see; it's harder to leave it off.  The LISP mechanism offers no win
over the Chris mechanism.

  I think I'd prefer the Chris mechanism; the ANSI-C way works; I
really don't like the LISP mechanism at all.

  )Rob

---

From: Thomas Down <[email-masked]>
Date: Wed, 21 May 1997 09:10:21 +0100 (BST)

> really don't like the LISP mechanism at all.

Chris' mechanism works for me, on the condition that instead of 
differentiating between quoted strings and messages, we just have a
single type of string in the grammer, and _always_ allow either a 
quoted string or a Chris-string.

Anyone else?

Thomas
-- 
The aim of science is not to open
the door to infinite wisdom, but to
set limits to infinite error.                       -- Brecht

---

From: Rob Earhart <[email-masked]>
Date: Wed, 21 May 1997 11:54:46 -0400 (EDT)

> quoted string or a Chris-string.

  Me.  (Sorry for not saying anything about it in the first post...)

  )Rob

---

From: Steve Hole <[email-masked]>
Date: Mon, 26 May 1997 10:27:10 -0600 (MDT)

> | .. This line begins with a single dot.

I'll have to vote for this one.   None of them really impress me, but this 
is the most "script like".   One can write a simple interface that 
displays this without having to be too clever.

---  
Steve Hole			VP,  Research and Development  
The Esys Corporation		EMail: [email-masked]
900 10040 - 104 St.		Phone: 403-424-4922  
Edmonton, AB, Canada		Fax:   403-424-4925  
T5J 0Z6