Subject: managesieve's HAVESPACE changed from v03 to v04?

From: Marc Mutz <[email-masked]>
Date: Fri, 4 Oct 2002 19:56:31 +0200

Hi!

I'm currently working on a client implementation of the ManageSieve 
protocol for KMail. We have come across a problem with the HAVESPACE 
command. With timsieved 1.1.0 we always get:
C: HAVESPACE "scriptname" 74
S: NO "Expected number"

Now, we only have v03 of the I-D here; is there an incompatible change 
in v04 in this area? Does anyone rememember?

Marc

-- 
Ein Grundrecht auf Sicherheit steht bewusst nicht in der Verfassung.
  -- Sabine Leutheusser-Schnarrenberger (ehem. Bundesjustizministerin)

---

From: Ken Murchison <[email-masked]>
Date: Fri, 04 Oct 2002 16:57:23 -0400

> in v04 in this area? Does anyone rememember?

There was a bug in the parser in timsieved.  I have fixed it in CVS. 
You can apply the following patch to continue your development/testing.

http://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/cyrus/timsieved/lex.c.diff?r1=1.19&r2=1.20&sortby=date

Any further discussion about this problem should be taken off list.

Ken
-- 
Kenneth Murchison     Oceana Matrix Ltd.
Software Engineer     21 Princeton Place
716-662-8973 x26      Orchard Park, NY 14127
--PGP Public Key--    http://www.oceana.com/~ken/ksm.pgp