Subject: [managesieve] setactive "" semantics questions

From: Marc Mutz <[email-masked]>
Date: Tue, 04 Feb 2003 15:10:26 +0100

Hi!

from draft-martin-managesieve-04:
2.8.  SETACTIVE Command
    This command sets a script active. If the script name is the empty
    string (i.e. "") then any active script is disabled. If the script
    does not exist on the server then the server MUST reply with a NO
    response.
<snip>

What does that mean for
  setactive ""
when no script is active? Should it fail or succeed? (The latter would 
be a PITA for client implementors, since I need to LISTSCRIPTS before 
any SETACTIVE "").

And:
Do I need to issue
 setactive ""
between
  setactive "foo"
  setactive "bar"
or will the second command implicitely set "foo" to inactive?

Marc

-- 
They that can give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety.      -- Benjamin Franklin

---

From: Lawrence Greenfield <[email-masked]>
Date: Tue, 4 Feb 2003 16:16:09 -0500

Date: Tue, 04 Feb 2003 15:10:26 +0100
   From: Marc Mutz <[email-masked]>

   What does that mean for
     setactive ""

Our server repsonds with a "No" when there is no active script. I
don't think a server that responds with an "Ok" would be that far out
of line.

   And:
   Do I need to issue
    setactive ""
   between
     setactive "foo"
     setactive "bar"

You can send

     setactive "foo"
     setactive "bar"

without any intervening commands.

Larry