Subject: Editorial editheader comment

From: Simon Josefsson <[email-masked]>
Date: Sat, 03 May 2003 20:48:47 +0200

Quoting the document:

,----
| 3. Action addheader
| 
|    Syntax:
|    	"addheader" <name: string> <value: string>
| 
|    The addheader action appends a header field to the existing
|    message header.
...
|    The header field MUST be added at the end of the existing
|    header.
`----

It isn't clear if a Sieve statement

   addheader "To" "[email-masked]";

invoked on a message that have a header

...
To: [email-masked]
...
To: [email-masked]
...

will result in:

1) A message header that looks like:

...
To: [email-masked] [email-masked]
...
To: [email-masked]
...

2) A message header that looks like: (somewhat unrealistic interpretation)

...
To: [email-masked], [email-masked]
...
To: [email-masked]
...

3) A message header that looks like:

...
To: [email-masked]
To: [email-masked]
...
To: [email-masked]
...

4) A message header that looks like:

...
To: [email-masked]
...
To: [email-masked]
...
To: [email-masked]

Honestly I'm not sure what is intended, otherwise I would have
provided clarified text.

I suspect 4 may be what was intended, but I'm not sure it is the best
choice.

---

From: Philip Guenther <[email-masked]>
Date: Sat, 03 May 2003 12:43:49 -0700

...
>4) A message header that looks like:

Given the meanings layed out in rfc2822 for "header" and "header field",
I don't see how the text can be interpreted as permitting anything
besides #4.  The other choices all either appended text *to* a header
field or added the header field somewhere besides the end of the
existing header, neither of which match the text of the draft.

Philip Guenther
[email-masked]

---

From: Simon Josefsson <[email-masked]>
Date: Sat, 03 May 2003 22:12:18 +0200

> existing header, neither of which match the text of the draft.

I agree, but I was using the RFC 3028 terminology.  3028 sometimes
uses the word "header" as referring to (in RFC 2822 terminology)
header fields.  E.g., from "2.4.2.2 Headers":

   A header name never contains a colon.  The "From" header refers to a
   line beginning "From:" (or "From   :", etc.).  No header will match
   the string "From:" due to the trailing colon.

Given this, it was unclear (to me) which definition was used.  But if
it is clear for everyone else, ignore my message.

---

From: Jutta Degener <[email-masked]>
Date: Mon, 5 May 2003 11:14:03 -0700

On Sat, May 03, 2003 at 10:12:18PM +0200, Simon Josefsson wrote:
> 3028 terminology.  3028 sometimes

I think you have a point; there's a clash of vocabularies going
on, and a sentence of clarification wouldn't be too much to ask.

+  The term "header field" is used here as in [RFC-2822] to mean
+  a logical line of an email message header.

Privately, I will almost always use "header" to mean a line of an
email message header, just like RFC 3028 does.  I did that unthinkingly
and consistently in the very first internal version of the draft, but
was then asked by one of my internal reviewers to use the more accurate,
but to me unfamiliar, "header field" language from RFC 2822.

It is a source of quiet satisfaction to me that this has now created
misunderstandings in the _other_ direction.

Jutta