Subject: FW: Body test

From: Rick Updegrove <[email-masked]>
Date: Fri, 08 Aug 2003 15:05:59 -0700

FYI - I sent this to [email-masked]  yesterday but that list 
seems to be down.  The last post was:  I will try and send it agin now 
with you as the Cc:  Just a short answer would be very much appreciated.

/postfix/sieve configuration, Manfred Friedrich, Sat, 19 Jul 2003 
11:31:29 -0700 (PDT)(envelope-from [email-masked])

Hi,

I am currently conducting a Procmail vs. SIEVE test on an account that
gets roughly 1000-1500 messages per day.  The most useful tool I have
with Procmail is the "Body test" which seems to be absent from SIEVE.
Please correct me if I am wrong.

I was reading the following RFC, and wondered if someone could elaborate
on the second paragraph for me (namely which vendors).

http://www.ietf.org/internet-drafts/draft-degener-sieve-body-01.txt

1. Introduction

    The proposed "body" test checks for the occurrence of one
    or more strings in the body of an e-mail message.
    Such a test was initially discussed for the [SIEVE] base
    document, but was subsequently removed because it was
    thought to be too costly to implement.

    Nevertheless, several server vendors have implemented
    some form of the "body" test.

    This document reintroduces the "body" test as an extension,
    and specifies it syntax and semantics.

The reason I ask is I have been unsuccessfully trying the following
syntax with no success.  The script is active.

> list
myscript  <- active script
> get myscript
require ["body", "fileinto"];

# Save any message with any text MIME part that contains the
# worlds "missile" or "coordinates" in the "secrets" folder.

if body :content "text" :contains ["missile", "coordinates"] {
         fileinto "INBOX.secrets";
}

if body :raw :contains "missile" {
     fileinto "INBOX.secrets";
}

I *need* to filter based on body test and Any additional info would be
greatly appreciated.  I would be willing to implement alpha and beta
versions of SIEVE if they implement the "body test" and are available
somewhere.

Thanks in advance,

Rick

P.S.

I would also like to know how to enable the most verbose logging for
SIEVE if anyone has some suggestions they would be greatly appreciated.

---

From: "Nigel Swinson" <[email-masked]>
Date: Sat, 9 Aug 2003 10:09:44 +0100

> http://www.ietf.org/internet-drafts/draft-degener-sieve-body-01.txt

www.mailsite.com supports a body test.  It's not quite the same as the I-Draft, it just treats the entire body as one long string.  You can use regex and contains to match inside it which allows you to do pretty much whatever you want to search for, but obviously isn't "ideal" as the test isn't yet MIME aware, nor does it do transfer decoding or do anything with character sets.  These are obviously things which we will be looking into in the future (when I'm successful in twisting product managements arm ;o) )

> SIEVE if anyone has some suggestions they would be greatly appreciated.

The tools in Mailsite permitting you to get your scripts right include a regular expression test dialog, and a sieve script test dialog which will run your script against every message in a folder and tell you which rules matched each message.

Cheers

Nigel

From: "Nigel Swinson" <[email-masked]>
To: "Rick Updegrove" <[email-masked]>
Cc: <[email-masked]>
Subject: Re: Body test
Date: Sat, 9 Aug 2003 10:09:44 +0100
Sender: [email-masked]

> http://www.ietf.org/internet-drafts/draft-degener-sieve-body-01.txt

www.mailsite.com supports a body test.  It's not quite the same as the I-Draft, it just treats the entire body as one long string.  You can use regex and contains to match inside it which allows you to do pretty much whatever you want to search for, but obviously isn't "ideal" as the test isn't yet MIME aware, nor does it do transfer decoding or do anything with character sets.  These are obviously things which we will be looking into in the future (when I'm successful in twisting product managements arm ;o) )

> SIEVE if anyone has some suggestions they would be greatly appreciated.

The tools in Mailsite permitting you to get your scripts right include a regular expression test dialog, and a sieve script test dialog which will run your script against every message in a folder and tell you which rules matched each message.

Cheers

Nigel

From: "Mark E. Mallett" <[email-masked]>
Date: Fri, 8 Aug 2003 18:29:56 -0400
To: [email-masked]
Subject: sieve action: pipe
Sender: [email-masked]

Hi-

I have a little sieve implementation that I have been tinkering with.
Using it I've managed to almost completely abandon my old .procmailrc .
The only remaining things in .procmailrc are those that pipe to a
script.  e.g.:

:0 W: $REPORTS/news-rep.lock
* ^From: .*news@news-server-name
* ^Subject: .*Daily Usenet report
| $REPORTS/news-rep.sh

I would like to make something like a "pipeinto" action similar to
"fileinto" -- e.g.:

    if allof (
       address :is "from" "news@news-server-name",
       header :is "subject" "daily usenet report" ) {
        pipeinto :lockfile "news-rep.lock" "news-rep.sh";
    }

Have there been any thoughts about such a facility?  I'd rather
use an agreed-upon format than make something up, but I wasn't
able to find anything.

mm

Date: Fri, 08 Aug 2003 15:05:59 -0700
From: Rick Updegrove <[email-masked]>
To: [email-masked]
CC: [email-masked]
Subject: FW: Body test
Sender: [email-masked]

Hi,

1. Introduction

Thanks in advance,

Rick

P.S.