Subject: Re: New Sieve extension "refuse" proposal - draft-elvey-refuse-sieve-01h

From: [email-masked]
Date: Fri, 13 Feb 2004 13:01:20 -0800

I would argue that there is a need, or at least desire, to have both "reject" and "refuse".

For one thing, you can't internationalize "refuse".  We have people who want to ensure for some
more "friendly" bounces that the original sender will see some "friendly" explanatory text.  So they
want to use "reject" so that they can: (a) ensure that their own text is presented to the original sending 
user (SMTP rejection text, in contrast, may or may not end up getting presented to the original sender),
and possibly (b) use another language/charset (language-appropriate subset of  UTF8) for their rejection
text, possibly customizing the choice of language/characters based on characteristics of the message
being rejected.

But in other cases, with more "unfriendly" bounces, rejecting the message at the SMTP level is more
desirable.  When it's more important to limit load on or protect your own server vs. being "friendly" to 
the original sender, then "reject" can be more appealing. 

I can therefore envision cases of Sieve scripts that might wish to use both.

Regards,

Kristin
[email-masked]
----- Original Message -----
From: Cyrus Daboo <[email-masked]>
Date: Friday, February 13, 2004 7:59 am
Subject: Re: New Sieve extension "refuse" proposal - draft-elvey-refuse-sieve-01h

> 
> Hi Matthew,
> 
> --On Thursday, February 12, 2004 11:59 AM -0800 "Matthew Elvey 
> (FM)" 
> <[email-masked]> wrote:
> 
> | Hello, folks.  Please review and provide feedback on the "refuse"
> | extension, designed to mostly replace Sieve's "reject" command.
> 
> Question - is there any situation where you would want both reject 
> and 
> refuse available at the same time? i.e. couldn't we just get away 
> with an 
> extension that simply indicates that the existing reject command 
> will 
> actually run during the SMTP transaction and will generate an SMTP 
> error 
> instead of an MDN? Or, if modifying the base-spec reject behaviour 
> is 
> really not allowed in this way, how about having refuse do either 
> SMTP 
> error or MDN as appropriate for the system? That would mean that 
> users can 
> write one script using a single command and have it work on any 
> SIEVE 
> system, whether SIEVE runs at SMTP time or post-SMTP. I would hate 
> to have 
> to change reject<->refuse every time I moved or copied a script 
> across 
> different systems.
> 
> -- 
> Cyrus Daboo
> 
>

---

From: Serge Knystautas <[email-masked]>
Date: Fri, 13 Feb 2004 17:34:39 -0500

> I can therefore envision cases of Sieve scripts that might wish to use both.

This isn't specific to just Kristin's comment, but if you're talking 
about using sieve in the SMTP transaction, when does this happen?  After 
MAIL FROM?  After each RCPT TO?  After HELO? (the last is a bit 
far-fetched, but it can be used as a more structured way of rejecting 
servers on DNS RBL).

-- 
Serge Knystautas
President
Lokitech >>> software . strategy . design >> http://www.lokitech.com
p. 301.656.5501
e. [email-masked]

---

From: [email-masked]
Date: Fri, 13 Feb 2004 15:18:42 -0800 (PST)

> about using sieve in the SMTP transaction, when does this happen?

I suppose it could happen anywhere in the dialogue, but as a practical matter,
any script that uses header tests (and the majority of them do) can only
after the message has been transferred.

Of course this runs into problems when there are multiple recipients.
But remember: The majority of messages have a single recipient. And there's
also LMTP to consider - a sieve implementation operating in the context
of an LMTP server has no problem returning per-recipient failures after
the data.

				Ned