Subject: I-D Action:draft-ietf-sieve-notify-08.txt

From: [email-masked]
Date: Fri, 06 Jul 2007 11:50:01 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Sieve Mail Filtering Language Working Group of the IETF.

        Title           : Sieve Extension: Notifications
        Author(s)       : A. Melnikov, et al.
        Filename        : draft-ietf-sieve-notify-08.txt
        Pages           : 19
        Date            : 2007-07-06
                                                                                           
Users go to great lengths to be notified as quickly as possible that
they have received new mail.  Most of these methods involve polling
to check for new messages periodically.  A push method handled by the
final delivery agent gives users quicker notifications and saves
server resources.  This document does not specify the notification
method but it is expected that using existing instant messaging
infrastructure such as XMPP, or SMS messages will be popular.  This
draft describes an extension to the Sieve mail filtering language
that allows users to give specific rules for how and when
notifications should be sent.
                                                                                           
A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sieve-notify-08.txt
                                                                                           
To remove yourself from the I-D Announcement list, send a message to
[email-masked] with the word unsubscribe in the body of 
the message.
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then
        "get draft-ietf-sieve-notify-08.txt".
                                                                                           
A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.
                                                                                           
Send a message to:
        [email-masked].
In the body type:
        "FILE /internet-drafts/draft-ietf-sieve-notify-08.txt".
                                                                                           
NOTE:   The mail server at ietf.org can return the document in
        MIME-encoded form by using the "mpack" utility.  To use this
        feature, insert the command "ENCODING mime" before the "FILE"
        command.  To decode the response(s), you will need "munpack" or
        a MIME-compliant mail reader.  Different MIME-compliant mail readers
        exhibit different behavior, especially when dealing with
        "multipart" MIME messages (i.e. documents which have been split
        up into multiple messages), so check your local documentation on
        how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 06 Jul 2007 10:06:34 -0600

> http://www.ietf.org/internet-drafts/draft-ietf-sieve-notify-08.txt

What is the changelog from -07?

Peter

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 06 Jul 2007 17:29:12 +0100

>What is the changelog from -07?
Hi Peter,
In the draft you can find:

Changes since draft-ietf-sieve-notify-07

   o  Added a new "set" modifier for URL percent-encoding.

   o  Clarified that notification methods must address notification
      loops.

   o  Added an implementation consideration for implementations that use
      URIs internally.

;-)

[Plus a couple of minor editorial changes from Barry]

Or do you want to see a more detailed list of changes?