Subject: Re: Naming conventions for Sieve RFCs

From: Aaron Stone <[email-masked]>
Date: Mon, 03 Dec 2007 19:15:01 -0800

Reviving this thread from the last message (not necessarily replying to
this one specifically)...

I am converting refuse-reject to xml2rfc. I have this:

    <!-- The abbreviated title is used in the page header -
         it is only necessary if the full title is longer
         than 39 characters -->

    <title abbrev="Sieve Extension: Reject">
      Sieve Email Filtering: Reject Extension
    </title>

I like Nigel's suggestion not to imply the functionality via the
possibly jargony extension name, but rather to state the purpose of the
extension in the title. This may result in long titles.

For example, "Sieve Email Filtering: Extensions for Message Rejection".

I think we should use both Nigel's and Kjetil's suggestions:
"Sieve Email Filtering: Extensions for Foo" on the front page.
"Sieve Extension: Foo" on top of each inner page.

Aaron

On Mon, 2007-08-13 at 15:27 +0200, Kjetil Torgrim Homme wrote:
> On Sun, 2007-08-12 at 11:13 +0100, Alexey Melnikov wrote:
> > Nigel Swinson wrote:
> > >RFC3894 Sieve Extension: Copying Without Side Effects. J. Degener.
> > >     October 2004. (Format: TXT=9018 bytes) (Status: PROPOSED STANDARD)
> 
> > I can change the title, but I think that:
> >  SIEVE Email Filtering Extension: Notifications
> > 
> > is slightly more informative than:
> > 
> >  SIEVE Email Filtering: Enotify Extension
> > 
> > (who would know that enotify is about notifications?)
> > 
> > Opinions?
> 
> I don't think it is necessary to use the capability string in the title,
> cf. RFC 3894 above, but you need to write it differently so as not to
> imply it, e.g. "Sieve Email Filtering: Extension for Notifications"
> 
> as previously stated, I prefer the title stays as "Sieve Extension:
> Notifications".
>

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 04 Dec 2007 14:15:22 +0000

>"Sieve Extension: Foo" on top of each inner page.
Fine with me.
I've just updated sieve-notify to use the same convention.

---

From: Ned Freed <[email-masked]>
Date: Tue, 04 Dec 2007 13:07:12 -0800 (PST)

> I've just updated sieve-notify to use the same convention.

Vaction currently has:

<title abbrev="Sieve Vacation Extension">
Sieve Email Filtering: 
Vacation Extension
</title>

Should I send in an update that changes this to:

<title abbrev="Sieve Extension: Vacation">
Sieve Email Filtering: 
Vacation Extension
</title>

				Ned

---

From: Philip Guenther <[email-masked]>
Date: Tue, 4 Dec 2007 14:18:45 -0800

On Tue, 4 Dec 2007, Ned Freed wrote:
...
> Sieve Email Filtering: Vacation Extension
> </title>
>
> Sieve Email Filtering: Vacation Extension
> </title>

For the drafts that's already in the RFC editor queue, I suspect this is 
best done by settling on the format, then Alexey swinging by the RFC 
editor table and asking them how they would like to get the request.

Philip Guenther

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 04 Dec 2007 23:01:55 +0000

Philip Guenther wrote:

> For the drafts that's already in the RFC editor queue, I suspect this 
> is best done by settling on the format, then Alexey swinging by the 
> RFC editor table and asking them how they would like to get the request.

Agreed.

Just pick a format.

---

From: Philip Guenther <[email-masked]>
Date: Tue, 4 Dec 2007 18:25:09 -0800

On Tue, 4 Dec 2007, Philip Guenther wrote:
> For the drafts that's already in the RFC editor queue, I suspect this is best 
> done by settling on the format, then Alexey swinging by the RFC editor table 
> and asking them how they would like to get the request.

Alexey and I chatted with the RFC editor and they said "yes, please put 
all title updates in a single request and have your AD bless it".

Philip Guenther

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 11 Dec 2007 18:54:32 +0000

Philip Guenther wrote:

> Alexey and I chatted with the RFC editor and they said "yes, please 
> put all title updates in a single request and have your AD bless it".

Have we settled on the format?
I just received a message from RFC editors saying that documents will go 
to AUTH48 shortly...

---

From: Ken Murchison <[email-masked]>
Date: Wed, 12 Dec 2007 07:10:53 -0500

> I just received a message from RFC editors saying that documents will go 

Indeed.  If/when we decide on a format, am I supposed to send in the 
title change(s) myself, or will the chairs do so?  I'm putting together 
some other changes as we speak.

-- 
Kenneth Murchison
Systems Programmer
Project Cyrus Developer/Maintainer
Carnegie Mellon University

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 12 Dec 2007 18:21:52 +0000

Ken Murchison wrote:

>>>> For the drafts that's already in the RFC editor queue, I suspect 
>>>> this is best done by settling on the format, then Alexey swinging 
>>>> by the RFC editor table and asking them how they would like to get 
>>>> the request.
>>>
>> I just received a message from RFC editors saying that documents will 
>> go to AUTH48 shortly...
>
> title change(s) myself, or will the chairs do so?  I'm putting 
> together some other changes as we speak.

As nobody seems to be able to make a decision on this, chairs decided 
that all RFCs should use the following title:

Sieve Email Filtering: <Foo> Extension

I will send RFC editor messages for each affected RFC-to-be.

---

From: "Aaron Stone" <[email-masked]>
Date: Wed, 12 Dec 2007 19:18:30 -0000

> I will send RFC editor messages for each affected RFC-to-be.

Ok, so long as we've got all our ducks in a row :-)

Aaron