Subject: forward mail to a local user

From: Mester <[email-masked]>
Date: Sat, 29 Nov 2008 10:12:09 +0100

Hi,

I have a Debian 4.0 server with Sieve enabled Cyrus IMAP and Exim4.
I have one e-mail address at my internet provider with two aliases. I
use fetchmail to download the e-mail account to a local user, but I want
to forward the messages arrived with one alias to another local user.

I wrote a small script but it sais invalid e-mail address. How can I
correct it? (sendmail localuser < ... works just fine)

My script looks like this:

if header :contains ["received"] "for EMAIL@ALIAS" {
	forward localuser;
}

Attila Mesterhazy

---

From: Arnt Gulbrandsen <[email-masked]>
Date: Sat, 29 Nov 2008 10:30:55 +0100

> if header :contains ["received"] "for EMAIL@ALIAS" {

Try forward "[email-masked]";

Some software does not have the concept of local users at all.

Arnt

---

From: Mester <[email-masked]>
Date: Sat, 29 Nov 2008 11:08:47 +0100

Hi,

I also tried it but it has the same resault.
I tried localuser@localdomain but it sais invalid e-mail address.

Attila

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 29 Nov 2008 18:08:21 +0000

>I tried localuser@localdomain but it sais invalid e-mail address.
I think you want to use:

 redirect "[email-masked]";

I.e. there is no such Sieve action as 'forward'. Also the email address must be quoted (as suggested by Arnt).