Subject: Re: SUAv7 : General Comments

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 Aug 2001 10:58:22 -0500

John,

I don't believe we were discussing a particular issue in this
thread which hasn't already been idenitified as such.

--brian

John Loughney wrote:                                         (Fri, 31 Aug 2001 16:48:27)
>
> Hi Brian & Sandeep,
> 
> With all due respect, this thread has gone on quite long.
> I am not sure what issue you are discussing with regards to
> SUA.  
> 
> I believe you were discussing the possibility of text for 
> chapter 1 of SUA and/or an Applicability Statement.
> 
> Could you summarize the discussion & your needs?
> 
> thanks,
> JOhn
> 
> > -----Original Message-----
> > From: ext Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: 30 August, 2001 14:19
> > To: sigtran
> > Subject: Re: SUAv7 : General Comments
> > 
> > 
> > Sandeep,
> > 
> > That is one possible solution.  We are agreed.
> > 
> > The only minor addition to SUA would be to provide the ASP 
> > the ability to
> > optionally register a connection identification with alternate SGs for
> > decoupled non-final multiple SG as STP situations.
> > 
> > --brian
> > 
> > [email-masked] wrote:                     (Thu, 30 Aug 
> > 2001 16:42:12)
> > > 
> > > 
> > > 
> > > Brian ,
> > > 
> > > Just to make sure I did not misunderstood you ,if the 
> > problem is How to
> > > support the case when SEP sends SCCP message to SG that is 
> > not addressed to
> > > SG's point code but addressed to ASP point code that is 
> > accessible via SG.
> > > Should MTP3 be passing messages to NIF and NIF passes then to SUA ?
> > > 
> > > You are suggesting that solution to this can be Assign ASP 
> > point code as
> > > alias point code to SG. MTP3 will then pass all messages 
> > destined to ASP
> > > point code to SCCP running at SG. And there is not need of 
> > MTP3 passing
> > > messages to NIF.
> > > 
> > > If that is the solution , I agree this does not require any 
> > extra support in
> > > SUA
> > > 
> > > Best Regards,
> > > -Sandeep
> > > 
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 
> > 
> > ---
> > You are currently subscribed to sigtran as: [email-masked]
> > To unsubscribe send a blank email to 
> > [email-masked]
> > 
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 Aug 2001 13:24:10 -0500

John,

Sandeep, Gery and I have been discussing whether it is possible to
implement SCCP's full range of functionality to meet SUA's SCCP
transparency claims and still meet SUA's objectives of not needing
to modify (or "enhancing") either the SG's SCCP or the SCCP/SCCP-User
interface.

Two issues remain from this thread (but they are already logged
issues).  Support for decoupled operation without final GTT at the
SG (Issue 14), and IPSP Condsiderations.

You have assured us that you, Ken and Greg are working on a proposal
which might resolve IPSP Considerations.  Issue 14 has a standing
proposal for resolution (REG REQ procedure) which has not been adopted
and as such is still an open issue.

Sandeep and Gery's comments and insights on this thread have helped to
frame these issues.  Much discussion has been focused on possible
functional placement of SUA functions, whether all functions required
by SUA of the NIF can be contained in the NIF between existing SCCP
implementation or whether it requires dipping into the SCCP on the SG.
Much discussion has also focussed on whether SCCP functionality must
be spread to the ASP as well.  Additional discussion has talked about
whether modificiations are required at the SCCP/SCCP-User interface
at the ASP.

Consider this thread an inspection.  I believe that all issues which
have developed from this thread have already been logged with issue
numbers.

--brian

On Fri, 31 Aug 2001, John Loughney wrote:

> > > Just to make sure I did not misunderstood you ,if the problem is How to
> > > support the case when SEP sends SCCP message to SG that is not addressed to
> > > SG's point code but addressed to ASP point code that is accessible via SG.
> > > You are suggesting that solution to this can be Assign ASP point code as
> > > alias point code to SG. MTP3 will then pass all messages destined to ASP
> > > point code to SCCP running at SG. And there is not need of MTP3 passing
> > > messages to NIF.
> > > 
> > > If that is the solution , I agree this does not require any extra support in
> > > SUA
> > > 
> > > Best Regards,
> > > -Sandeep
> > > 
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 
> > 
> > ---

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---