Subject: Decision needed! [SUA Issue] SS7 Hop Counter

From: [email-masked]
Date: Fri, 31 Aug 2001 16:43:45 +0300

Hi all,

The IP header has a Hop Counter.  While I am not stating that these
are interchangable, a point has been made that the SS7 Hop Counter
is redundant.  

Additionally, if we are looking at a backhaul of SCCP-users, it is
doubtful that there will be many hops in which the SS7 hop counter 
would be decremented.

The discussion between Brian & Gery has moved the support of the
SS7 Hop Counter to a weak MAY.

I know Brian will support the removal of the SS7 Hop Counter 
Field.  Does anyone else think that there will be problems if
SUA does not use this parameter?

I am wavering on the support of this parameter.

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Verwimp Gery <[email-masked]>
Date: Fri, 31 Aug 2001 16:23:29 +0200

John,

Both hop counters are unrelated. What IP routing does is invisible to SUA,
which assumes end-to-end communication over a SCTP association. The SUA-AMF
is something different : it ties a number of SCTP associations together to
form a route/path towards the final end node. There's nothing the IP hop
counter can do here to avoid loops on this level.

So I strongly urge for the hop counter to be there. We do not have to
restrict ourselves to backhaul architectures. Personally I'd like it to be
mandatory in CLDT, CLDR and CORE. There's no interoperability issues when
both SUA on SG and ASP support it; there's only an (artifial) issue when
some implementations refuse to have it based on (limited) views of network
architectures. If the same reasoning be followed, we could also put the
address parameters in the CLDT/CLDR messages as optional ...

Also, some SS7 networks require the use of XUDT (esp. GSM networks will
require it).

I already agreed a compromise to make it optional; so it can be left to
regulators/operators to make a stronger requirement on it's use. I
definitely won't support the removal !!

Regards,

____________________________

Gery Verwimp
> SIEMENS ATEA
> ICN D CS D5
> Tel. : +32 14 25 3424
Fax : +32 14 25 3212
mailto:[email-masked]
____________________________________

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: vrijdag 31 augustus 2001 15:44
To: sigtran
Subject: Decision needed! [SUA Issue] SS7 Hop Counter

Hi all,

John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: Coene Lode <[email-masked]>
Date: Fri, 31 Aug 2001 16:30:37 +0200

> are interchangable, a point has been made that the SS7 Hop Counter

SUA doesnt know anything about the IP hopcounter. As far as I can see even
SCTP(or far the same TCP or UDP) provide access to the hopcounter of IP. 
The IP hopcounter has nothing to do with the SUA hopcounter.

> SUA does not use this parameter?

Then Brian will have introduced an interoperability problem. 
Care to introduce a follow up draft on this one, Brian?
Removing the hop counter all together will lead to interoperability
problems.
So I am perfectly at ease with a MAY

> I am wavering on the support of this parameter.

I am not. Let's keep it in and move on. We have talked far too much about
this simple issue. Enough is enough.

> 
> John
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 Aug 2001 11:24:19 -0500

John,

I absolutely do not support the removal of the SS7 Hop Counter.
It must be there as it needs to be exchanged in support of
the optional parameter in CR and mandatory parameter in (XL)UDT(S).
It is orthoginal to IP Hop Counter.

--brian

John Loughney wrote:                                         (Fri, 31 Aug 2001 16:43:45)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 Aug 2001 11:26:44 -0500

Gery,

I support keeping the SS7 Hop Counter.

--brian

Verwimp Gery wrote:                                       (Fri, 31 Aug 2001 16:23:29)
> Fax: +32 14 25 3212

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 31 Aug 2001 11:26:11 -0500

Coene,

Please see comments below...

Coene Lode wrote:                                           (Fri, 31 Aug 2001 16:30:37)
> So I am perfectly at ease with a MAY

I do not support removing SS7 hop counter.  I don't know where John
could have gotten that idea.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---