Subject: [SUA Issue 26] N-COORD Primitive

From: [email-masked]
Date: Fri, 24 Aug 2001 11:33:25 +0300

Hi all,

Here is an new issue. It would be an implementation dependent.
SMI would need to be included DUNA/DAVA & a new SNMM message.

I'd appreciate comments.  At the moment, I am wanting to avoid
additional messages, etc. in SUA.

John

-----Original Message-----
From: ext Brian F. G. Bidulock [mailto:[email-masked]]
Sent: 24 August, 2001 11:06
To: Loughney John (NRC/Helsinki)
Subject: SUA: N-COORD Primitive

John,

Please add this as an issue for SUA Last Call:

    SUA: Support for N-COORD

Last January we had a discussion concerning the requirement
for N-COORD representation in SUA.  We got distracted by
other things (like NA, yes, that's how old the NA issues is).

Because it is possible to implement two separate SGs connected
to two disjoint sets of ASPs (one set for eacn SG) and represent
each of these as one of a mated pair of SCPs in the SS7 network,
an equivalent of the N-COORD primitive will be required so that
the SG can pass the information to the ASP and the ASP can pass
it to the SCCP-User as an N-COORD primitive.  Also, the N-COORD
primitive needs to be accepted from the SCCP-User and passed to
the SG.

SUA needs support for N-COORD which it currently does not have.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Verwimp Gery <[email-masked]>
Date: Tue, 28 Aug 2001 16:16:47 +0200

Hello,

This is in fact an old issue. For management interworking, it was decided
(at that time) that DUNA, DAVA, SCON, DRST can make sense, to inform ASPs of
the status of SS7 destinations.

However, no support for anything else was deemed useful (coordinated status
change, traffic mix procedures etc.)

For one thing, it is not recommended to provide loadsharing over an SS7 node
and an AS. You have either 2 SS7 nodes or an AS, consisting of loadsharing
ASPs. No mixture of both please. This eliminates the use of N_COORD between
SG and ASP; here the ASPTM procedures should be sufficient.

The same applies to the traffic mix procedures in ANSI/Telcordia : SRT, SBR,
SNR ...

SMI is also replaced by Traffic Mode Type. The RC and address information in
the DUNA, ... should be enough to provide proper interworking. So IMHO, no
change to SUA is required.

Best regards,

____________________________

Gery Verwimp
> SIEMENS ATEA
> ICN D CS D5
> Tel. : +32 14 25 3424
Fax : +32 14 25 3212
mailto:[email-masked]
____________________________________

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: vrijdag 24 augustus 2001 10:33
To: [email-masked]
Subject: [SUA Issue 26] N-COORD Primitive

Hi all,

John

-----Original Message-----
From: ext Brian F. G. Bidulock [mailto:[email-masked]]
Sent: 24 August, 2001 11:06
To: Loughney John (NRC/Helsinki)
Subject: SUA: N-COORD Primitive

John,

    SUA: Support for N-COORD

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 Aug 2001 14:43:35 -0500

Gery,

Here is the configuration I intend to support (for AIN):

         _____               _____            _____ 
        |     |             |     |          |     |
        | STP |_____________| SG  |__________|ASPS |
        |_____|\           /|_____|          |_____|
           |    \         /                         
           |     \ ______/                          
           |      X______                           
         __|__   /       \   _____            _____ 
        |     | /         \ |     |          |     |
        | STP |/___________\| SG  |__________|ASPS |
        |_____|             |_____|          |_____|

Each SG/ASP combination acts as one of a mated pair of SCP
databases and appears to the SS7 network as such.

Each of the mated pair needs to generate and respond to
SOR.  The SG cannot do this on the ASP's behalf: it lacks
the information (load, management) necessary to grant the
request.  The SG needs some way of providing providing
N-COORD to the ASPs to permit the ASPs to refuse or grant
the request.

How did you propose that this be done with SNMM?

--brian

Verwimp Gery wrote: (Tue, 28 Aug 2001 16:16:47)
> Fax: +32 14 25 3212

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Wed, 29 Aug 2001 14:02:40 +0300

Brian,

> Here is the configuration I intend to support (for AIN):

As you are the one requesting this kind of functionality,
can you propose some text?

John

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 29 Aug 2001 06:45:27 -0500

John,

If nobody objects to including the functionality, I will
propose text changes as already discussed: addition of
messages for SOR/SOG and addition of SMI parameter to
SNMM.

Does anyone object?

--brian

John Loughney wrote: (Wed, 29 Aug 2001 14:02:40)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Wed, 29 Aug 2001 16:00:07 +0300

Hi Brian,

> messages for SOR/SOG and addition of SMI parameter to

Right now, I my motivation to support this is lacking.  As 
there has been silence on support for this (except for
Gery) .. so my feeling is that this will be left out of
SUA.  

John

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 29 Aug 2001 08:19:14 -0500

John,

If you are to leave it out, I request that you place in the
overview of SUA that SUA does not support transparent or
seamless operation with SCCP in this regard:

  SUA does not support transparent interworking with the
  SS7 network: mated pair configurations of any sort,
  either in the SS7 network or IP domain, cannot be
  supported by SUA.  All subsystems which interact with
  SUA MUST be non-duplicated subsystems.

I think that it would be better to place the support in the
draft.  No interworking with mated pair subsystems would rule
out entire networks of interesting applications of SUA
(probably most AIN and LNP applications).

--brian

John Loughney wrote:  (Wed, 29 Aug 2001 16:00:07)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Schantz, John" <[email-masked]>
Date: Wed, 29 Aug 2001 07:59:53 -0700

Your joking about SMI (Subsystem Multiplicity Indicator), right?  It has
very little meaning and use today.  Why carry it forward?

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, August 29, 2001 6:45 AM
> To: sigtran
> Subject: Re: [SUA Issue 26] N-COORD Primitive
> 
> 
> John,
> 
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: Verwimp Gery <[email-masked]>
Date: Wed, 29 Aug 2001 14:03:01 +0200

resend ...

Brian,

Aha, an excercise !

Hm, I agree we don't cover this right now.

But I'd rather have an ASPTM message requesting removal from active duty
w.r.t. a RC (AS) and send it to the mated ASP directly (or whatever ASP who
decides in case of n+k redundancy). Once this is agreed, an ASPIA can be
sent to the SG.

If the ASPTM msg is sent to SG1, the NIF-SUA is triggered to send SOR (AIN
is configured locally at the SGs, they have to know about the mated pair
configuration) to SG2. The NIF-SUA there is then triggered to send the ASPTM
message to ASP2 which responds pos. or neg. to SG2. Based on this response,
a SOG is sent back from SG2 to SG1.

SG1 responds pos. to the ASPTM if SOG is received (the ASP is marked
inactive), or neg. when the wait_for_SOG timer expires.

Is there any interest for such a ASPTM message in other UA's ?

Regards,

Gery Verwimp
Fax : +32 14 25 3212

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: dinsdag 28 augustus 2001 21:44
To: sigtran
Subject: Re: [SUA Issue 26] N-COORD Primitive

Gery,

         _____               _____            _____ 
        |     |             |     |          |     |

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: Verwimp Gery <[email-masked]>
Date: Wed, 29 Aug 2001 12:00:32 +0200

Brian,

Aha, an excercise !

Regards,

Gery Verwimp
Fax : +32 14 25 3212

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: dinsdag 28 augustus 2001 21:44
To: sigtran
Subject: Re: [SUA Issue 26] N-COORD Primitive

Gery,

         _____               _____            _____ 
        |     |             |     |          |     |

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 29 Aug 2001 14:36:20 -0500

Gery,

Please see commments below...

Verwimp Gery wrote:                                       (Wed, 29 Aug 2001 14:03:01)
> a SOG is sent back from SG2 to SG1.

What ASPTM message would be sent to request(SOR) and what ASPTM message
would be sent to grant(SOG) or refuse?

> Is there any interest for such a ASPTM message in other UA's ?

I think that a refusable ASPDN or ASPIA might suffice at the requesting
side, but what ASPTM message is going to be used at the granting/refusing
side?

The problem with ASPTM messages is that their granularity is way too
fine for what is needed here.  SOR/SOG fall firmly in the SNMM catergory.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 29 Aug 2001 16:19:01 -0500

John,

I'm not joking.  The reason for carrying it forward is the same
reason for carring other parameters forward: transparent transport
of SCCP.

It is certainly not within the scope of SUA to question the very
protocol that it claims to transport with full transparency.

SUA must either drop its full transparency claims and list
restrictions (pointless if all that is required is a parameter
definition), or provide definitions for the transport of parameters
which may appear useless to some but which have not yet been removed
from SS7 specifications.

Existing SCCP application written to use SMI should be able to be
ported to an SUA implementation with minimal modification.  It is
easier to define an SMI parameter in SUA than to otherwise ensure
and describe how these applications are to be ported transparently
without an SUA SMI parameter.

--brian

John Schantz wrote: (Wed, 29 Aug 2001 07:59:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 30 Aug 2001 08:45:37 +0300

Hi Brian,

How about this.  You submit a reasonable text for this functionality
& I will do my best at including this in the draft.

best regards,
John

> Sent: 30 August, 2001 00:19
> To: sigtran
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 Aug 2001 00:52:18 -0500

John,

Works for me if it works for others.

--brian

John Loughney wrote:                                  (Thu, 30 Aug 2001 08:45:37)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 30 Aug 2001 08:57:41 +0300

Hi Brian,

> Works for me if it works for others.

The proof is in the pudding, as the saying goes.  Lets see the
pudding & if anyone objects or asks for more :)

John

---

---

From: Verwimp Gery <[email-masked]>
Date: Thu, 30 Aug 2001 10:59:43 +0200

Brian,

No problem with putting 2 new messages in the SSNM category. But, since RC
is also a parameter of the SSNM messages, I don't get your ASPTM granularity
argument ...

Gery Verwimp
Fax : +32 14 25 3212

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: woensdag 29 augustus 2001 21:36
To: sigtran
Subject: Re: [SUA Issue 26] N-COORD Primitive

Gery,

Verwimp Gery wrote:                                       (Wed, 29 Aug 2001
14:03:01)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 30 Aug 2001 04:38:06 -0500

Gery,

Good point.  I didn't see that.

--brian

Verwimp Gery wrote:                                (Thu, 30 Aug 2001 10:59:43)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 31 Aug 2001 16:19:45 +0300

Hi all,

This issue seems not to have much support at the moment.

I am looking forward to Brian's proposal for additional 
functionality.  

Any comments on this issue would be helpful.

John

---