Subject: M3UA08: Message distribution at the ASP

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 22 Aug 2001 14:53:44 -0500

Greg,

If RKs don't always have an obvious ASP to SG equivalent, how can we choose among SGs for traffic in ASP-SG direction? ASP can sent ASPAC for different ASs to different SGs, and at some point (in user application or in MTP3 User or in NIF or in M3UA)on ASP side any data should be classified in a RK. Could you please give some comments?

     Tolga

>>>The AS is where the traffic is coming from.  The AS does not need to be
>>>selected for outgoing traffic: it is the MTP-User.  The RC can be implicit to
>>>the MTP/MTP-User interface at the AS and, therefore, ASP does not need to
>>>maintain RK.  It is not always possible to apply an SG RK to an outgoing
>>>message at an ASP anyway.  RKs are stated in terms of traffic in the SG to ASP
>>>direction and, as Greg pointed out, don't always have an obvious ASP to SG
>>>equivalent.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Aug 2001 15:34:38 -0500

Tolga,

This issue was discussed at great length in the thread "SGP Management".
The issues have been resolved for the other UAs by tagging ASP to SG
messages with the IID/RC associated with the AS that generated the message
where it is not implicit.  The ASP only sends AS to SGP messages to SGPs
for which the ASP is active for the AS (otherwise the SG will discard).
For multiple SGP with which the ASP is active for the sending AS, a
distribution mechanism (override, loadshare, broadcast) may be used.

M3UA has not adopted this approach.  M3UA says that any SGP which has
an open association with the ASP must be prepared to accept any and
all messages.  Because of lack of RC in DATA, the SGP cannot even
identify which AS the message came from and determine whether to dicard
it per ASPTM procedures (when the ASP is inactive for the AS), in the
case of multiple ASs per association.

It is still an outstanding issue with M3UA, which can be resolved by
placing RC in DATA and SNMM from ASP to SG where it is not implicit.

--brian

Asveren, Tolga wrote:                                    (Wed, 22 Aug 2001 14:53:44)
> Greg,
> 
> If RKs don't always have an obvious ASP to SG equivalent, how can we choose
> among SGs for traffic in ASP-SG direction? ASP can sent ASPAC for different
> ASs to different SGs, and at some point (in user application or in MTP3 User
> or in NIF or in M3UA)on ASP side any data should be classified in a RK.
> Could you please give some comments?
> 
>      Tolga
> 
> 
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Tue, 28 Aug 2001 12:21:49 -0400

Brian,

You are wrong when you say that "M3UA says that any SGP which has an open association with the ASP must be 
prepared to accept any and all messages."

Section 4.2.34 states "If the SGP or IPSP receives any Data messages before an ASP Active message 
is received, the SGP or IPSP MAY discard them."

Barry Nagelberg
Software Engineer
RadiSys, Corp.
Signaling Products Design Center
[email-masked]
+1-856-642-9229 x237

"Brian F. G. Bidulock" <[email-masked]>
08/22/01 04:34 PM
Please respond to sigtran

        To:     "sigtran" <[email-masked]>
        cc: 
        Subject:        Re: M3UA08: Message distribution at the ASP

Tolga,

--brian

Asveren, Tolga wrote:                                    (Wed, 22 Aug 2001 
14:53:44)

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 28 Aug 2001 14:57:57 -0500

Barry,

Just because some are discarded does not mean that the SGP doesn't
have to be ready to accept all of them.

--brian

[email-masked] wrote:                (Tue, 28 Aug 2001 12:21:49)
> Brian,
> 
> You are wrong when you say that "M3UA says that any SGP which has an open
> association with the ASP must be prepared to accept any and all messages."
> 
> Section 4.2.34 states "If the SGP or IPSP receives any Data messages before
> an ASP Active message is received, the SGP or IPSP MAY discard them."
> 
> Barry Nagelberg
> Software Engineer
> RadiSys, Corp.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---