Subject: Re: Suggestion for easy standardization of defs.

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Aug 2001 21:19:57 -0500

Jacques,

This proposal goes way beyond SIGTRAN and dips into the
Internet Standards Process.  Perhaps you could present
this proposal in the POISSON WG, but you should read
RFC 2418 first.  I think that you'll find that it is
highly unlikely that such a rigid structure as you propose
would even be imposed on a IETF WG.

This working group is for discussion of items within or
closely related to the SIGTRAN charter.

--brian

Jacques Rajchgod wrote:                                   (Thu, 23 Aug 2001 16:49:41)
> 
>    I have a suggestion for the alleviation of ambiguous and/or
>    dual-meaning defs. Suggestion is as follows:
>    
>    
>    
>     1. That a database of terms/defs be started and maintained at all
>        times by all IETF chairs or a designated one.
>     2. Before attempting to define a new def, or attempting to re-use a
>        potentially-existing one in a particluar context, that the author
>        of a such doc first check the (to-get-born) database for the
>        existence of such def. One of two actions would trigger from such
>        database search result:
>           + Def is found as already-existing.
>           + Def is not found.
>     3. If def is NOT found, author is free to generate a required def.
>     4. If def is YES found as already-existing, then the author may NOT
>        use or re-use the exact def in the same context in his/her new
>        doc.
>           + If author does wish to re-use the already-existing def for a
>             particular needed context such that author feels he must use
>             the exact, same abbreviations/acronyms, that a modification
>             be done, so the already-existing def acquires a different
>             meaning. Example:
>           + The term "SG" (Signaling Gateway) is found by a search_DB to
>             already exist in a def DB (database). However the author
>             wishes to re-use that native def (denoting a Signaling
>             Gateway) to refer to a SG now doing Broadband. Then, such
>             author might COPY the already-existing def to make it a new
>             one ("SAVE_AS") such as "BSG" which would stand for
>             "Broadband Signaling Gateway - A SG used in Broadband
>             technologies".
>           + Another example:
>           + A search_DB yields that the def "IPSP" already exists that
>             denotes an "IP Signaling Point....doing SS7-over-IP" (M2PA)
>           + Now then, the author wishing to use the same close-proximity
>             abbreviations/acronym to denote an "IP Server Process" (M3UA)
>             would COPY the def from the DB to save it as a new one
>             (SAVE_AS) "IPSPr" (<--Notice the LC "r"..). Everyone would
>             instantly pick-up the minute difference between an "IPSP" and
>             an "IPSPr"...and would know exactly what it is that is beingv
>             referred-to. How easy!
>     5. The DB would have to be empowered to refuse the re-use of an
>        already-existing def...It would have to do all the great things
>        that good and secure DB's do...
>        
>    Advantages:
>    
>     1. Very simple (Check-and-see the DB: Is the def already there?)
>     2. Secure (Cannot ever again cause ambiguity or dual meaning or wrong
>        meaning emanating thereof)
>     3. Order in the term/def ranks and elimination of confusion...
>     4. Efficient and time-saving (imagine the elimination of so many
>        E-mails...!)
>     5. Most important: An absolute clear understanding of what the def is
>        pointing to!
>        
>    Jacques Rajchgod
>    MCI Worldcom
>    Next Generation System Evaluation
>    Tel: [972] 729-1487
>    E-mail: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Fri, 24 Aug 2001 08:10:36 +0300

Hi Jacques,

> closely related to the SIGTRAN charter.

I agree.  

John

---