Subject: SCTP "Not Straem-Oriented"

From: Jacques Rajchgod <[email-masked]>
Date: Wed, 22 Aug 2001 14:02:08 -0500

Hi, SIGTRAN...

In all the IETF docs related to the definition of SCTP, the definition for
SCTP is wrong. It says that SCTP is NOT stream-oriented, matter which is
false. The reverse is what is true: SCTP was invented because of its
stream-oriented operations. Therefore, all RFC's and drafts related to that
definition of SCTP must be corrected. I suggest we do a "Global" and
mass-correct the error, as Engineering orgs across the industry are falling
into the trap and writing erroneous Functional Specs and Requirements
because of that Global error..
 In all IETF docs, the words and parenthesis "Explicit packet-oriented
delivery (not stream-oriented)" must be removed ASAP and replaced with the
exact words of "Explicit User-Datagram-oriented/Stream-oriented delivery".
(No additional words after the word "delivery". The word "delivery" ends the
definition and statement). The sooner - the better as it negatively impacts
all the "UA" docs and the various test plans nowaday being written in the
industry.

Thanks,
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-1487
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 22 Aug 2001 12:17:10 -0700 (PDT)

Jacques,

This seems like an overreaction to me.  SCTP is
not stream-oriented in the sense of TCP, which
delivers a byte-stream with no framing of the
data.  SCTP does provide the framing of individual
PDUs within the data.  That is the sense in which
SCTP is "not stream-oriented".

Perhaps a poor choice of words, but hardly 
worth reissuing documents over.

It may be worth clarifying in the remaining 
unapproved UAs if they have this text.

Cheers,

L. Ong
--- Jacques Rajchgod <[email-masked]>
wrote:
> exact words of "Explicit
> User-Datagram-oriented/Stream-oriented delivery".
> You are currently subscribed to sigtran as:
> [email-masked]
> To unsubscribe send a blank email to
> [email-masked]
> 

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---