Subject: How can I find the MTP3 to layer 2 (say M2UA) primitives definiation?

From: Patrick Lam <[email-masked]>
Date: Fri, 10 Aug 2001 15:02:23 -0700

Hi:

I just wonder where I can find the MTP3 to layer 2 (say M2PA) primitives
definition and format?

For example, how can I find the MTP3 primitive "FLUSH BUFFERS" that is
sent to M2PA?

I have done a brief search through the Q.70x docs, but couldn't find
much information about this.

Thanks very much in advance,

Patrick.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Aug 2001 17:26:20 -0500

Patrick,

Some of the primitive (well, signals) are named differently
and have slightly different semantics is different variants
and different versions of variants.  Compare the ANSI T1.111.3
specs from different years and the ITU Q.703 specs from Blue,
White, Grey, ... books and you will see that there are differences
particularly in regard to buffer flushing procedures.  Some
versions call this "Resume", some have "Flush Buffers", some
have "Clear RTB", etc.

A clearer and more definitive definition of MTP Level 2
primitives (signals) can be found in Q.2140 (particularly
section 7) and the equivalent ANSI (ATM) documents.

Q.2140 has both AAL_CONTINUE and AAL_FLUSH_BUFFERS, but neither
are applicable to broadband signalling (but are for narrowband).
Whether these are really applicable to the M2PA environment
is left as an exercise for the reader ;)

--brian

Patrick Lam wrote:                           (Fri, 10 Aug 2001 15:02:23)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Patrick Lam <[email-masked]>
Date: Fri, 10 Aug 2001 15:51:57 -0700

Brian:

Thanks very much for your reply.

So as you implied, there is no "standard" regarding the interface between layer 3 and
layer 2.  Is that right?

Regards,

Patrick.

"Brian F. G. Bidulock" wrote:

> You are currently subscribed to sigtran as: [email-masked]

---