Subject: M2UA, M3UA, SUA and IUA common parameter allocation

From: "Jesske, R" <[email-masked]>
Date: Tue, 7 Aug 2001 12:43:19 +0200

Dear all,
There are inconsistencies within the M2UA v09, M3UAv08, SUAv07 drafts and IUA RFC concerning the common parameters. In the following table all common parameters (I sorted out, therefore please check again)are listed. Some of them have a double allocation of the value or the name. Now its up to the editors to align the drafts/RFC.

Parameter Name                        M2UA      M3UA      SUA       IUA       Comment
Reserved                              0x0000    0x0000    0x0000    0x0000 
Interface Identifier (Integer)        0x0001    Not used  Not used  0x0001 
Interface Identifier (Integer Range)  0x0002    Not used  Not Used  Not Used 
Interface Identifier (Text)           0x0003    Not used   ----     0x0003   Double allocation of Value
DATA                                  ------    ------    0x0003    ------   Double allocation of Value
Info String                           0x0004    0x0004    0x0004    0x0004 
Affected Point Code                   Not used  Not used  0x0005    ------   Double allocation of Value
DLCI                                  ------    ------    ------    0x0005   Double allocation of Value
Routing Context                       Not used  0x0006    0x0006    Not used 
Diagnostic Info                       0x0007    0x0007    0x0007    0x0007 
Interface Identifiers (integer range) Not used  Not used  Not Used  0x0008   M2UA within the description of Parameters
Heartbeat Data                        0x0009    0x0009    0x0009    0x0009 
Reason                                0x000A    0x000A    0x000A    0x000A   Double allocation of Parameter Name
Traffic Mode Type                     0x000B    0x000B    0x000B    0x000B 
Error Code                            0x000C    0x000C    0x000C    0x000C 
Status Type                           0x000D    0x000D    0x000D    0x000D   Double allocation of Parameter Name ?
ASP Identifier                        0x000E    0x000E    0x000E    ------   Double allocation of Value
Protocol Data                         ------    ------    ------    0x000E   Double allocation of Value
Congestion Level                      Not used  Not used  0x000F    ------   Double allocation of Value
Reason                                ------    ------    ------    0x000F   Double allocation of Value and Parameter
                                                                                                            Name
Status                                Not used  Not used  Not Used  0x0010   Double allocation of Parameter Name ?

Best Regards 

Roland

Roland Jesske 
Gateways and Signalling 
T-Nova Deutsche Telekom Innovationsgesellschaft mbH 
Technologiezentrum 
Section E36o 
Am Kavaleriesand 3 
64295 DARMSTADT, GERMANY 
Phone:  +49 6151 83-5940 
Fax:    +49 6151 83-4577 
mailto: [email-masked] 
http://www.t-nova.de 

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Ken Morneault <[email-masked]>
Date: Sat, 11 Aug 2001 16:30:05 -0400

Roland,

Thanks for building this table.  I want to note that the M2UA issue with
Interface Identifiers (integer range) has already been fixed (will be
out in version 10).  

Regards,

Ken

At 12:43 PM 8/7/01 +0200, Jesske, R wrote:
>You are currently subscribed to sigtran as: [email-masked]

---