Subject: M3UAv8: Routing Context Definition

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 15 Aug 2001 14:01:33 -0500

Greg,

As Barry an some others seem rather confused as to the role
of Routing Context, I propose that the text for the definition
of Routing Context in M3UA be updated to match that of SUA as
follows:

M3UA definition:

   Routing Context - A value that uniquely identifies a Routing Key.
   Routing Context values are either configured using a configuration 
   management interface, or by using the routing key management procedures 
   defined in this document.

SUA definition:

   Routing Context - An Application Server Process may be configured to 
   process traffic within more than one Application Server.  In this 
   case, the Routing Context parameter is exchanged between the SGP and 
   the ASP (or between two ASPs), identifying the relevant Application 
   Server.  From the perspective of an SGP/ASP, the Routing Context 
   uniquely identifies the range of traffic associated with a 
   particular Application Server, which the ASP is configured to 
   receive. There is a 1:1 relationship between a Routing Context value 
   and a Routing Key within an AS.  Therefore the Routing Context can 
   be viewed as an index into an AS Table containing the AS Routing 
   Keys. The Routing Context also uniquely identifies an SS7 entity 
   (point code) into a SS7 network, as presented by the SG.   

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Wed, 15 Aug 2001 15:32:44 -0400

Greg,

I object to Brian's proposal. The SUA definition is too vague. 

The main problem is the phrase "... the Routing Context parameter is exchanged between the SGP and the ASP". 

This must be expanded to state " ... the Routing Context parameter is exchanged between the SGP and the ASP using only the Routing Key Management (RKM) messages, or is configured at both the ASP and SGP".

Without this expansion, Brian's proposed definition would allow him to 
sneak in his "RC in DATA message" proposal.

Barry Nagelberg
Software Engineer
RadiSys, Corp.
Signaling Products Design Center
[email-masked]
+1-856-642-9229 x237

"Brian F. G. Bidulock" <[email-masked]>
08/15/01 03:01 PM
Please respond to sigtran

        To:     "sigtran" <[email-masked]>
        cc:     Greg Sidebottom <[email-masked]>
        Subject:        M3UAv8: Routing Context Definition

Greg,

M3UA definition:

SUA definition:

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to 
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 15 Aug 2001 16:01:51 -0500

Barry,

[email-masked] wrote:                (Wed, 15 Aug 2001 15:32:44)
> This must be expanded to state " ... the Routing Context parameter is
> exchanged between the SGP and the ASP using only the Routing Key Management
> (RKM) messages, or is configured at both the ASP and SGP".
> 

Your definition is too restrictive: Routing Context is also
exchanged in ASPTM messages.  Would you have us remove RC
from ASPTM messages?

> sneak in his "RC in DATA message" proposal.

Now there's a professional argument based on the technical facts. ;)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 15 Aug 2001 14:13:33 -0700

Folks,

Let's reexamine the text AFTER we've resolved the main
issues in M3UA.  That should make people a bit more 
comfortable.

Cheers,

L. Ong 
--

On Wed, 15 Aug 2001 15:32:44   Barry.Nagelberg wrote:
>You are currently subscribed to sigtran as: [email-masked]

Join 18 million Eudora users by signing up for a free Eudora Web-Mail account at http://www.eudoramail.com

---