Subject: Need to standardize the defs for "AS" and "ASP".

From: Jacques Rajchgod <[email-masked]>
Date: Wed, 22 Aug 2001 14:50:53 -0500

Hi, SIGTRAN...

In all the IETF docs related to SIGTRAN, there is a sore need to standardize
and "make-it-stick" -- the following defs that relate to the abbreviations
"AS" and "ASP". The otherwise lack of such standardization invites errors of
interpretation. Taking a look at SUA and IUA, one can easily take it that an
"AS" is a database in SUA (section 1.2 - terminoilogy) and then again a real
Process (not a database) in IUA - same section.

An "AS" is the same logical "AS" everywhere. Its def must be consistent
across all docs.
If we have in mind to denote different services or functions (such as a
database in one case whilst a real Process - in another) then we need to
define them exactly per their intended individual functionality, but we may
not otherwise dump everything inside the same basket of "AS" or "ASP". There
is a need for careful consistency across all IETF operations. If we define
an "AS" in IUA as "A logical entity serving a specific application instance"
and bring examples of such def as an MGC, then we cannot define "AS" in SUA
as "...a logical entity serving a specific routing Key with example of a
Virtual IP database..." as that invites confusion at Planning and testing
orgs!

The first def "A logical entity serving a specific application instance" is
the correct one and need be carried across all IETF docs with consistence.

If a def has a multiplicity of meanings, then such multiplicity need be
carefully stated and described in the "Terminology" sections of IETF's.
Usually, the IETF does an excellent job at defining or stating the meanings
of terms. We want to keep it that way. Consistence.

Thanks,
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-1487
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Schantz, John" <[email-masked]>
Date: Thu, 23 Aug 2001 07:52:49 -0700

Actually this is a great topic because AS and ASP are the most confusing
concepts in all of these documents.  I know I wrestled with for a while and
so have many others, and people are still struggling with them.  
 
The name is very misleading, Application Server.  It is not an application
and it is not a server.  The real applications/servers sit on top of the
protocol stack, away from any UA.  Many of the documents imply that it is a
real signalling node or at least part of one, this is perception is wrong
too.
 
Actually, I think the definition that you quote from SUA might be the
closest one:  "...a logical entity serving a specific routing key".  You can
also dig this meaning out of M3UA.
 
Maybe we can generate a good definition from the facts about AS:
 
1)  Has a 1-1 correspondence with an RK (i.e., it is bounded by a single RK
and the traffic defined by the RK),
2)  It only exists within the specific UA in question,
3)  Its traffic is handled by a collection of SCTP end-points, these have
been defined as ASPs.  AS has also been defined as the collection ASPs
serving this specific set of traffic.
 
I can only conclude that an AS is only a routing concept (logical entity)
association with a specific set of signalling traffic (RK) that only exists
within the specific UA in question and has an assigned collection of SCTP
end-points handling it traffic.
 
John

-----Original Message-----
From: Jacques Rajchgod [mailto:[email-masked]]
Sent: Wednesday, August 22, 2001 2:51 PM
To: sigtran
Subject: Need to standardize the defs for "AS" and "ASP".

Hi, SIGTRAN...

 

Thanks,

Jacques Rajchgod
MCI Worldcom

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked] 

---

---

From: Lyndon Ong <[email-masked]>
Date: Thu, 23 Aug 2001 17:20:36 -0700 (PDT)

There's a book in here somewhere.  Maybe
several.

Anyway, can we try to close the issues in 
M3UA instead of opening new ones?

Thanks folks.

L. Ong

--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
> ......resend
> 
> John,
> 
> IUA and M2UA have no "Routing Keys".
> 
> In M2UA is is possible to have more than one Link
> associated with a
> single AS.
> 
> In SUA and M3UA AS is identified by RC.
> In M2UA AS is idenitified by a list or sublist of
> IIDs.
> 
> Please see other comments below...
> 
> --brian
> 
> John Schantz wrote:                           (Thu,
> 23 Aug 2001 07:52:49)
> > 
> >    Actually this is a great topic because AS and
> ASP are the most
> >    confusing concepts in all of these documents. 
> I know I wrestled with
> >    for a while and so have many others, and people
> are still struggling
> >    with them.
> >    
> >    
> >    
> >    The name is very misleading, Application
> Server.  It is not an
> >    application and it is not a server.  The real
> applications/servers sit
> >    on top of the protocol stack, away from any UA.
>  Many of the documents
> >    imply that it is a real signalling node or at
> least part of one, this
> >    is perception is wrong too.
> >    
> >    
> >    
> >    closest one:  "...a logical entity serving a
> specific routing key".
> >    You can also dig this meaning out of M3UA.
> >    
> >    
> >    
> >    1)  Has a 1-1 correspondence with an RK (i.e.,
> it is bounded by a
> >    single RK and the traffic defined by the RK),
> 
> The RK only defines the traffic in the SG --> AS
> direction.  Basing
> the definition of AS on RK is not sufficient.  The
> definition of RK
> relies on AS.  (In M3UA: RK when applied to a
> message in the
> SG --> AS direction must result in a single AS). 
> The 1:1 correspondence
> is the result of this restriction placed on RK, and
> is not part of the
> definition of an AS.
> 
> IUA and M2UA have no Routing Key.
> 
> >    
> This is a implementation depedent restriction which
> does not currently
> exist.  There is nothing stopping me as things stand
> from, say, assigning
> the same RC-value in both M3UA and SUA to indicate a
> single AS which
> has "appearances" both in M3UA and SUA.  Also,
> nothing is acheived by
> this restriction.
> 
> >    
> >    3)  Its traffic is handled by a collection of
> SCTP end-points, these
> >    have been defined as ASPs.  AS has also been
> defined as the collection
> >    ASPs serving this specific set of traffic.
> 
> What do you mean by "serving"?  An ASP which is in
> STANDBY or INACTIVE
> with respect to an AS is not "handling traffic" but
> is still involved
> with both the AS and the SGP with respect to an AS.
> 
> I think that the relationship between AS and ASP
> regarding traffic is
> clearly defined by the AS and ASP states and
> procedures.  These procedures
> have been made common in the remaining drafts and
> there are no
> contradictions between UAs.
> 
> >    I can only conclude that an AS is only a
> routing concept (logical
> >    entity) association with a specific set of
> signalling traffic (RK)
> >    that only exists within the specific UA in
> question and has an
> >    assigned collection of SCTP end-points handling
> it traffic.
> 
> This may be because your definition of AS is based
> on routing.  The current
> definitions place requirements on routing based on
> the definition of AS.
> 
> On the contrary, your description is close to
> fitting SUA's definition of
> Routing Context:
> 
>    "Routing Context - An Application Server Process
> may be configured to 
>    process traffic within more than one Application
> Server.  In this 
>    case, the Routing Context parameter is exchanged
> between the SGP and 
>    the ASP (or between two ASPs), identifying the
> relevant Application 
>    Server.  From the perspective of an SGP/ASP, the
> Routing Context 
>    uniquely identifies the range of traffic
> associated with a 
>    particular Application Server, which the ASP is
> configured to 
>    receive. There is a 1:1 relationship between a
> Routing Context value 
>    and a Routing Key within an AS.  Therefore the
> Routing Context can 
>    be viewed as an index into an AS Table containing
> the AS Routing 
>    Keys. The Routing Context also uniquely
> identifies an SS7 entity 
>    (point code) into a SS7 network, as presented by
> the SG."
> 
> When it was proposed that this definition be used
> for M3UA it was
> strongly opposed by some people.  Were you not one
> of them?
> 
> Based on your current comments, I would like to
> repropose that the
> SUA definition of Routing Context also be used in
> M3UA.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> 
> ---
> You are currently subscribed to sigtran as:
> [email-masked]

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Aug 2001 19:48:08 -0500

Lyndon,

I agree.  AS does not need redefinition.

--brian

Lyndon Ong wrote: (Thu, 23 Aug 2001 17:20:36)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---