Subject: Re: M2UAv0, M3UAv8, SUAv7: Traffic Mode Type

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 11 Aug 2001 23:57:08 -0500

Ken,

I am faced with cases in implementation where the ASP does
not know the traffic mode type of the ASP it is replacing.
It is equally capable of operating in all modes.  If the
TMT is mandatory, I need one more TMT: "Unspecified", or
"Default", or "Whatever the AS is currently set to."

--brian

Ken Morneault wrote:                                          (Sat, 11 Aug 2001 20:20:29)
> 
> 
> Greg,
> 
> I don't think we have consensus to change TMT to optional in
> ASP Active.  I think the ASP should send the TMT in the ASP
> Active since the ASP will know the traffic mode.  There is no 
> need for TMT in ASP Active Ack.
> 
> If it was optional, how would the ASP know when it was 
> appropriate to send TMT in ASP Active?
> 
> Regards,
> 
> Ken
> 
> At 03:37 AM 8/10/01 -0400, you wrote:
> >Hi Brian,
> >
> >I believe we have agreed on the list to change Traffic Mode Type to optional
> >in ASP-Up (and REG REQ).  So it is consistent to change it to optional in
> >the ASP Active Ack.  I'd already made the change for M3UA.
> >
> >But I guess with everything being optional now some things are now open.  Do
> >we want to support all the following permutations?
> >
> >1) TMT included in ASP Active, TMT included in ASP Active Ack.
> >
> >2) TMT included in ASP Active, TMT not included in ASP Active Ack.
> >
> >3) TMT not included in ASP Active, TMT included in ASP Active Ack.
> >
> >4) TMT not included in ASP Active,  TMT not included in ASP Active Ack.
> >
> >I suppose 2 and 4 are easy enough but do people see a use for 1 and/or 3?
> >If so for each case what is the TMT value in the ACK?
> >
> >Cheers,
> >
> >    Greg
> >
> >----- Original Message -----
> >From: "Brian F. G. Bidulock" <[email-masked]>
> >To: "sigtran" <[email-masked]>
> >Cc: "Greg Sidebottom" <[email-masked]>; "Ken Morneault"
> ><[email-masked]>; "John Loughney" <[email-masked]>
> >Sent: Friday, August 10, 2001 2:42 AM
> >Subject: Re: M2UAv0, M3UAv8, SUAv7: Traffic Mode Type
> >
> >
> > > Greg, Ken, John,
> > >
> > > What is the status of this issue?
> > >
> > > --brian
> > >
> > > Brian F. G. Bidulock wrote:                               (Wed, 25 Jul
> >2001 13:20:32)
> > > > Ken, Greg, John,
> > > >
> > > > In addition, what is the purpose of a mandatory Traffic Mode Type in
> > > > the ASP Active Ack?  Was it expected that this Traffic Mode Type would
> > > > reflect the Traffic Mode of the SGP to the ASP?  (Which would be
> > > > excellent!)  Or was it just an echo of the ASP Active message?  What
> > > > does an ASP do if the mandatory Traffic Mode Type in the ASP Active Ack
> > > > message does not match what was sent?  Should not this parameter be
> > > > Optional?
> > > >
> > > > --Brian
> > > >
> > > >
> > > > Brian F. G. Bidulock wrote:                 (Wed, 25 Jul 2001 12:36:29)
> > > > > Ken, Greg, John,
> > > > >
> > > > > Traffic Mode Type is a mandatory paramter of ASPAC and REG REQ in all
> > > > > the UAs.  Because the Traffic Mode Type has only a restricted range
> > > > > of modes, does it not make sense to permit ASPs and SGPs to use other
> > > > > traffic modes other than those specified in the drafts?  In the case
> > > > > where SGP and ASP have been configured for the traffic mode by other
> > > > > means, shouldn't the Traffic Mode Type be Optional in these messages?
> > > > >
> > > > > The text says that they MUST match, but if it is left out and the
> > > > > ASP and SGP agree by prior arrangement, it doesn't need to be in the
> > > > > message at all.
> > > > >
> > > > > --Brian
> > > > >
> > > > > --
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > >
> > > > >
> > > > > ---
> > > > > You are currently subscribed to sigtran as: [email-masked]
> > > > > To unsubscribe send a blank email to
> >[email-masked]
> > > >
> > > > --
> > > > Brian F. G. Bidulock
> > > > [email-masked]
> > > > http://www.openss7.org/
> > > >
> > > >
> > > > ---
> > > > You are currently subscribed to sigtran as: [email-masked]
> > > > To unsubscribe send a blank email to
> >[email-masked]
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> 
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 12 Aug 2001 00:09:20 -0500

Hi Ken,

There are two other attributes of the AS which are not being
communicated in the ASP Activce message: the `n' value in `n+k' and
the loadsharing algorithm for a loadshare AS.  Because all ASs
except Override need the `n' value provisioned at the SG, it is
simple to require the TMT to be provisioned with it.  The SG,
therefore, always knows the TMT of the AS.  It should be optional
because, as it stands, the ASP never has to send it.

If the ASP Active message contained the loadsharing algorithm (for
loadshare mode) and the `n' value in `n+k' for loadshare and
broadcast modes, then it might not be necessary to statically
provision AS attributes at the SG.

Actually, the AS at the SG still has to be statically provisioned
(with a Routing Context value or Interface Identifier list) unless
dynamic registration is used.  TMT, the `n' value, and loadsharing
algorithm selection need only be communicated to the SG in in the
REG REQ message.

The current procedures do not really allow for a switch of TMT
during operation.  Unless dynamic registration is used, the SG needs
to be statically provisioned with the other AS attributes (IIDs/RC,
`n', loadsharing algorithm) anyway, why not TMT?  When dynamic
registration is used, where attributes must either all be
communicated in the REG REQ, or the SG will still have to be
statically provisioned with them.

For M3UA the TMT in the ASP Active Ack is required for standby
modes.  M2UA got rid of those: that is why there is not a need for
TMT in the ASP Active Ack.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---