Subject: Re: M3UA: Packing of Routing Label into DATA Payload

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 15 Aug 2001 10:30:59 -0500

John,

John Schantz wrote:                                          (Wed, 15 Aug 2001 07:45:21)
> What is your problem with looking at the RL?  Any receiving node must look
> at the RL to do the discrimination function (i.e., is it mine or not).  This
> is expected!!!If the node supports multiple PCs, then a distribution
> function is also needed, BUT this is a local implementation issue.  The RL
> is there, use it.

M3UA tells me that the M3UA does not implement MTP itself,
as such, M3UA should be able to be implemented without the
HMDC.  It is not the intent of M3UA (nor SIGTRAN) to
recreate MTP functions in M3UA.  Pure transport of M3UA
should be possible as stated in the draft.  Forcing an
M3UA implementation to examine RL (and maintain undefined
Routing Keys for which to analyze it) is against these
guarantees already laid out in the draft.

It being perceived as a better approach (by others, not
just myself), it fully fits the RFC 2119 definition of
"MAY" and "OPTIONAL".

<skip abusive tone>
> Stop making up excuses that you need the same information
> in other parameters so that your implementation has an easier time in
> processing the messages.
</skip abusive tone>

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 15 Aug 2001 14:21:29 -0500

Hi John,

I'm interested to know just what were you going to put
in the RL in the IPSP case:  Which national variant would
one use?  Would one include MP bits, or not?  Should it
be Data 1 or 2?  What are you going to use for a point
code in the IP domain?

--brian

> is expected!!!  If the node supports multiple PCs, then a distribution
> is there, use it. Stop making up excuses that you need the same information

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---