Subject: UA:one SG(P)-ASP association serves for multiple ASes

From: Ming Lin <[email-masked]>
Date: Sat, 18 Aug 2001 09:05:32 +0800

This mail is a resent mail since the previous mail to old mail list address.
----------------------------------------------------------------------------
-----------------------
Hi all,

I know that one SG(P)-ASP association (SCTP association) can serve for
multiple ASes from the beginning of UAs(M3UA,M2UA,IUA,SUA).

But I am not always clear why UAs need this functionality, especially for
M2UA and IUA.

Why not use different SG(P)-ASP association (SCTP association) when MGC has
multiple ASes?

Are there some defect if this functionality is removed.

Thanks&Regards
Ming Lin

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 17 Aug 2001 20:45:03 -0500

Ming,

One reason that I have for using one association for multiple AS in
contrast to one association per AS is that each SCTP association
requires retraining after it is formed (that is, each SCTP association
goes through a period of slow start and RTO adjustment from RTO.initial
down to either RTO.min or the prevailing RTT of the connection).  I
would prefer for performance reasons that this be done once for each
SGP/ASP pair and as quickly as possible (by loading the association as
heavily as possible by placing all ASs on the same association).

In addition, because an SCTP association supports 2^16 relatively
independent streams, why open more than one?  When a file descriptor is
required for each SCTP association, but only one file descriptor is
required for 2^16 independent streams, using a single association is
less consumptive of operating system resources.  This was always on of
the intentions of SCTP over TCP (which requires a socket file descriptor
per "stream).  If there are 32 SGPs each in two SGs and 32 ASPs serving
the same set of ASs, each ASP requires 32 x 2 or 64 associations for
fully mesh.  If I support 6 ASs on the ASPs and open a separate
association for each, I need 384 associations per ASP.  My file
descriptors run out at 1024.  Polling 384 associations has far poorer
performance than polling 64 associations.

The 32 SGPs and 32 ASPs are pretty small numbers for embedded systems.
6 ASs is pretty reasonable for SI routing with multiple point codes, for
CIC-range routing, the number of ASs could reach towards 32 cic ranges x
3 point codes = 96.  Then I would need 32 x 2 x 96  = 6144 associations
per ASP for full mesh with an AS per association.  The system set
maximum number of open file descriptors on my OS is set at 1024 and is a
system-wide definition.  If I up this value to 6144 it will have serious
impact on system performance.  It I try to spread the ASP over multiple
processes, it will require extensive coordination between processes (and
pipes or fifos or othe interprocess communication and synchronization)
which is bound to break.

Additional associations per AS just does not scale.  In contrast, I do
not intend to support multiple associations between the ASP and the SGP
for the same reason.

Please do not remove the ability to have multiple AS per association.
It would make the make the "streams" of SCTP almost useless (might as
well use TCP) and would scale extremely bad on some systems.

Now, Ming, assume that someone goes and shoves the requirement that
separate network attachments need to be represented by separate
associations.  I have an SP which is F-link attached in an European
network and sits in 9 private PC numbering spaces and 1 public PC
numbering space.  I will need 10 associations per ASP for just to handle
the point codes, couple this with the needs above and I will need 61,440
associations per ASP.  Now it is not a matter of file descriptor
exhaustion, it is becoming a matter of SCTP port number exhaustion...

This was an example for M3UA.  M2UA could require hundreds of
associations if they are not permitted to be grouped.  Because SUA can
map an AS to a very narrow global title range (even down to a 10-digit
phone number) there could be 10's of thousands of ASs.  The SCTP 16-bit
port number space would be exhausted for multiple ASPs/SGPs very
rapidly.  The 32-bit numbering space of Routing Contexts is very wide
and streams can be reused within SCTP (don't really need more than one
per SLS anyway), so multiple AS per association can handle this case,
and one assocation per AS cannot.  Again, multiple associations does
not scale.  Please do not remove this capability.

--brian

Ming Lin wrote:                                              (Sat, 18 Aug 2001 09:05:32)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ming Lin <[email-masked]>
Date: Sat, 18 Aug 2001 16:38:16 +0800

Hi,

If you want to load the association as heavily as possible,
you can define the AS as wide as possible.

For M2UA and IUA, you can define all interfaces for one MGC
as one AS.
For M3UA, you can define all traffic for one MGC
within same PC as on AS, and maybe you have upto 16 PC on MGC,
so maybe you have upto 16 AS.

And, I think it doesn't need so many associations for between
MGC and SG. For on AS, I think two associations maybe ok,
because the bandwidth of one SCTP association is very width,
and mesh configuration will not be used actually.

So I think 16*2 = 32 SCTP associations between
MGC and SG are enough normally.

Thanks
Ming Lin

-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: sigtran <[email-masked]>
日期: 2001年8月18日 9:40
主题: Re: UA:one SG(P)-ASP association serves for multiple ASes

>> To unsubscribe send a blank email to
[email-masked]
>
>--
>Brian F. G. Bidulock
>[email-masked]
>http://www.openss7.org/
>
>
>---
>You are currently subscribed to sigtran as: [email-masked]
>To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 18 Aug 2001 12:50:09 -0500

Ming,

Please do not restrict my implementation with your
implementation decisions.  Please leave multiple AS
per association in the draft.  Thank you.

--brian

Ming Lin wrote:                     (Sat, 18 Aug 2001 16:38:16)
> ·¢¼þÈË: Brian F. G. Bidulock <[email-masked]>
> ÊÕ¼þÈË: sigtran <[email-masked]>
> ÈÕÆÚ: 2001Äê8ÔÂ18ÈÕ 9:40
> Ö÷Ìâ: Re: UA:one SG(P)-ASP association serves for multiple ASes
> 
> 
> >Ming,
> >
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 20 Aug 2001 08:00:13 -0500

Hi Everybody,

Related with this topic, I want to bring up  the issue of to have multiple SCTP associations between ASP and SG and to multiplex among them based on RK. In fact in draft08 in 1.2 for ASP it is said "An ASP contains an SCTP endpoint and may be configured to process signalling traffic within more than one Application Server. " Does this sentence put the restriction that an ASP has only one SCTP endpoint? 
The reason why I am against multiplexing among SCTP associations between ASP and SG is that it can create interoperability problems. Some of SGs,ASPs will use this feature and some won't. 
I think some people are using multiplexing among SCTP associations approach -that's my impressions from some posts on this forum-. So is everybody sure that this won't create interoperability problems?

   Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Friday, August 17, 2001 9:45 PM
To: sigtran
Subject: Re: UA:one SG(P)-ASP association serves for multiple ASes

Ming,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Aug 2001 08:14:33 -0500

Tolga,

I see no problems.  What interoperability problems do you foresee?

--brian

Asveren, Tolga wrote:                             (Mon, 20 Aug 2001 08:00:13)
>
> Hi Everybody,
> 
> Related with this topic, I want to bring up  the issue of to have multiple
> SCTP associations between ASP and SG and to multiplex among them based on
> RK. In fact in draft08 in 1.2 for ASP it is said "An ASP contains an SCTP
> endpoint and may be configured to process signalling traffic within more
> than one Application Server. " Does this sentence put the restriction that
> an ASP has only one SCTP endpoint?  The reason why I am against multiplexing
> among SCTP associations between ASP and SG is that it can create
> interoperability problems. Some of SGs,ASPs will use this feature and some
> won't. 
>
> I think some people are using multiplexing among SCTP associations approach
> -that's my impressions from some posts on this forum-. So is everybody sure
> that this won't create interoperability problems?
> 
>    Tolga
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 20 Aug 2001 09:02:41 -0500

Brian,

For example:
ASP1 is working with SCTP association per AS approach but SG is not. ASP establishes multiple SCTP associations to SG with the hope that it will receive traffic of every AS on a different association. First, how does SG know, which association corresponds to which route key? Probaby one can think that ASP will send ASPAC on different association for different ASs but then SG should have the logic, that it should send traffic of AS from the association, from which it received ASPAC. For a SG which does not follow multiple association approach, it is not guaranteed that it will send messages of different ASs by using different SCTP associations.

   Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, August 20, 2001 9:15 AM
To: sigtran
Subject: Re: UA:one SG(P)-ASP association serves for multiple ASes

Tolga,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Aug 2001 09:57:44 -0500

Tolga,

Asveren, Tolga wrote:                                    (Mon, 20 Aug 2001 09:02:41)
> Brian,
> 
> For example:
>
> ASP1 is working with SCTP association per AS approach but SG is not.

I don't believe that this can occur.  Either the ASP is statically configured
or it registers.  If it is statically configured, I suggest that one doesn't
statically configure their ASP to be incompatible with the SG.  If it has
registered, and if static port assignment has not been performed, the ASP
must identify itself with an ASP Id and obtain the necessary RC values per
association with REG REQ.  This appears to only be an example of why one
should not mis-configure the SG or ASP.

> ASP establishes multiple SCTP associations to SG with the hope that it will
> receive traffic of every AS on a different association. First, how does SG
> know, which association corresponds to which route key?

By static port assignment or ASP Id.

> Probaby one can think that ASP will send ASPAC on different association for
> different ASs but then SG should have the logic, that it should send traffic
> of AS from the association, from which it received ASPAC. For a SG which
> does not follow multiple association approach, it is not guaranteed that it
> will send messages of different ASs by using different SCTP associations.

Yes, basically, an SG which does not support multiple associations (one per
AS) will not work with an ASP which requires single associations (one per
SGP).  An SG implementation which wants to work with both should support both.

I still don't see an interoperability issue.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 20 Aug 2001 10:17:53 -0500

Brian,

What I want to say is that if ASP is using multiple association approach
then it can only use SGs built with this approach. So such an ASP can't work
with other SGs, which is according to me an interworking problem, because
this means that it is possible that one ASP and one SG, which claim to be
compliant with M3UA standard can't work together.

   Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, August 20, 2001 10:58 AM
To: sigtran
Subject: Re: UA:one SG(P)-ASP association serves for multiple ASes

Tolga,

Asveren, Tolga wrote:                                    (Mon, 20 Aug 2001
09:02:41)
> ASP1 is working with SCTP association per AS approach but SG is not.

I don't believe that this can occur.  Either the ASP is statically
configured

Yes, basically, an SG which does not support multiple associations (one per
AS) will not work with an ASP which requires single associations (one per
SGP).  An SG implementation which wants to work with both should support
both.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Aug 2001 11:18:19 -0500

Tolga,

This is certainly not the only respect in which an ASP and SG can
choose a different subset of M3UA.  For example, an ASP or SG is
only required to support one management method: static assignment
or registration.  An ASP which only supports registration will not
work with an SG which only supports static assignment.

It don't believe that this is such a flaw in the draft.  Certainly
in implementating an interoperable ASP or an interoperable SG, the
ASP or SG which provides all functions will interoperate with more
implementations of the other.

I suppose what I'm saying is, yes, it is an interoperability issue,
but one better addressed in implementation rather than specification.
Optional behaviors always lead to these issues, but the implementation
should have the choice to determine the marketability of these options
and include them or not.

In implementing multiple associations (one per AS) or multiple AS per
association, the implementer needs to decide the IP network specifics
of a given configuration and deterine the value (marketability) of
either approach.

Requiring an implementation to do one or the other or both will not
meet all applications.

For maximum interoperability, I suggest that an implementation should
support all options.

Regarding what an implementation claims to do (be compliant), rest
assured that buyers of this equipment fully understand that options
exist in the specification and that the support of specific options
is one of the considerations which they will normally place into RFP
requirments and use to determine award.  This is certainly where the
marketability of an option may have more importance to an implementer
than technical considerations.  I believe that both these cases:
multiple AS per association and dynamic registration, clearly fit
the IETF meaning of OPTIONAL.

--brian

Asveren, Tolga wrote:                                    (Mon, 20 Aug 2001 10:17:53)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ming Lin <[email-masked]>
Date: Tue, 21 Aug 2001 09:09:39 +0800

Hi all,

The reason why I bring up this issue, is not based on my
implementation decisions, but to resolve these issues
of RC in DATA and SSNM, and Network Appearance.

If one association serves one AS, all these issues will
be closed.
No RC is in ASPTM(AC/IA), DATA, SSNM,
perhaps no NA is needed,
and no interoperability issue.

And I still don't find any defect of one association serves one AS.

Please correct me.

Ming Lin
-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: sigtran <[email-masked]>
日期: 2001年8月19日 1:46
主题: Re: UA:one SG(P)-ASP association serves for multiple ASes

Ming,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Aug 2001 21:09:06 -0500

Ming,

Please see comments below...

Ming Lin wrote:                                              (Tue, 21 Aug 2001 09:09:39)
> If one association serves one AS, all these issues will

I disagree: it will simply open up a whole new set of issues, some
of which I have already touched on.

> and no interoperability issue.

It would make M3UA even less consistent with IUA, M2UA and SUA, all
of which permit multiplexing over a single association.

> And I still don't find any defect of one association serves one AS.

There is no defect with one association serving multiple AS.  There
is only a defect in how M3UA goes about multiplexing.  IUA, M2UA
and SUA acheive this multiplexing on IID/RC without flaw.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ming Lin <[email-masked]>
Date: Wed, 22 Aug 2001 13:35:27 +0800

Hi Brian,

As I said before, IUA，M2UA and SUA could also remove this
feature, so all UAs align again.

Ken,
it is ok to define that one SG-ASP association
serves for one AS in M2UA and IUA,
because this AS could include all
the interface for one MGC on SG.

And SUA is same as M3UA.

And after that, many issues for UAs are all closed.
The simplest is the best.

Thanks
Ming Lin
-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: sigtran <[email-masked]>
日期: 2001年8月21日 10:16
主题: Re: UA:one SG(P)-ASP association serves for multiple ASes

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Aug 2001 01:41:11 -0500

Ming,

For M3UA, because it is not possible to define a dynamic
routing key for more than a set of a trunks between signalling
points (NA/OPC/DPC/CIC-range), each ISUP signalling point
will require multiple AS.  If, as these things happen, CIC-ranges
become fragmented due to thrash on circuit assignment, it is
possible to have some 40000 ASs for a single signalling point.

For SUA, because it is possible to define a RK at the level of
the GT address digits, the number of ASs could be as large as
the phone book.

Your proposal does not scale.

IUA and M2UA are done deals.  I don't think that restricting
obvious capabilities in M2UA or existing capabilities in IUA
makes any sense at this point.

--brian

Ming Lin wrote:                                              (Wed, 22 Aug 2001 13:35:27)
> Hi Brian,
> 
> As I said before, IUA£¬M2UA and SUA could also remove this
> ÈÕÆÚ: 2001Äê8ÔÂ21ÈÕ 10:16

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ming Lin <[email-masked]>
Date: Wed, 22 Aug 2001 15:08:20 +0800

Brian,

As the m3ua draft says,
it is not necessary for the parameter range values
within a particular Routing Key to be contiguous.
For example, an AS could be configured to support call processing
for multiple ranges of PSTN trunks that are not represented
by contiguous CIC values.

And there is no restriction for MGC has multiple ASes,
just one SGP-ASP association could only serves for one AS.

So why the proposal doesn't scale?

Thanks
Ming Lin
-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: sigtran <[email-masked]>
日期: 2001年8月22日 14:36
主题: Re: UA:one SG(P)-ASP association serves for multiple ASes

Ming,

--brian

Ming Lin wrote:                                              (Wed, 22 Aug
2001 13:35:27)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Aug 2001 02:17:15 -0500

Ming,

Ming Lin wrote:                                              (Wed, 22 Aug 2001 15:08:20)
> within a particular Routing Key to be contiguous.

Iff you don't use registration.  Registration in M3UA has
no way of representing multiple disjoint CIC-ranges, yet
only returns a single RC value.

> by contiguous CIC values.

But would have to be statically assigned, which kind of
defeats the purpose of circuit assignment for ISUP.

> just one SGP-ASP association could only serves for one AS.

There is no restriction to one SGP-ASP association.

> So why the proposal doesn't scale?

See last notes: >40000 CIC-ranges for ISUP, phone book for SUA.
Only 16-bit port value for SCTP and a limited number of open
file descriptors.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ming Lin <[email-masked]>
Date: Wed, 22 Aug 2001 19:27:20 +0800

Brian,

It is requirement of Routing Key,
and if dynamic registeration procedure could not support this
the procedure should be changed.

But actually the RKM defined now can support this requirement.
This is the format of Routing Key parameter
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                       Local-RK-Identifier                     |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                       Traffic Mode Type                       |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                     Destination Point Code                    |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                  Network Appearance (optional)                |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                       SI (optional)                           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                         SSN (optional)                        |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |              Origination Point Code List (optional)           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                   Circuit Range List (optional)               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
There are OPC list and CIC range list.

I think SUA could also support it.

Cheer
Ming Lin
-----Original Message-----
发件人: Brian F. G. Bidulock <[email-masked]>
收件人: sigtran <[email-masked]>
日期: 2001年8月22日 15:12
主题: Re: UA:one SG(P)-ASP association serves for multiple ASes

>Ming Lin wrote:                                              (Wed, 22 Aug
2001 15:08:20)

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 22 Aug 2001 09:22:03 -0700 (PDT)

Perhaps this represents a flaw in the registration
procedures if it cannot accept multiple ranges of 
CIC - it would be easier to define an RK that
takes in multiple ranges of CIC than having to
define multiple RKs, one for each range.

Or I may be misinterpreting the format of the RK -
can Circuit Range List include multiple ranges?

Thanks,

Lyndon

--- Ming Lin <[email-masked]> wrote:
>     0                   1                   2       
>            3
>    |                       Local-RK-Identifier      
>               |
>    |                       Traffic Mode Type        
>               |
>    |                       SI (optional)            
>               |
>    |                         SSN (optional)         
>               |
> ������: Brian F. G. Bidulock <[email-masked]>
> �ռ���: sigtran <[email-masked]>
> ����: 2001��8��22�� 15:12
> ����: Re: UA:one SG(P)-ASP association serves for
> multiple ASes
> 
> 
> >Ming,
> >
> >Ming Lin wrote:                                    
>          (Wed, 22 Aug
> 2001 15:08:20)
> >> Brian,
> >>
> >> As the m3ua draft says,
> You are currently subscribed to sigtran as:
> [email-masked]

__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/

---

---

From: Lyndon Ong <[email-masked]>
Date: Wed, 22 Aug 2001 10:57:49 -0700 (PDT)

Actually, the format in v8 already appears to support 
non-contiguous ranges of CICs within one 
Routing Key, Ming is correct.  That may eliminate
the need for multiple AS per SG-ASP association
for this case.

Cheers,

Lyndon

--- Lyndon Ong <[email-masked]> wrote:
> >     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2
> 3
> > 4 5 6 7 8 9 0 1
> >   
> >
>
> >    |                     Destination Point Code   
> >    |                  Network Appearance
> (optional) 
> >    |                   Circuit Range List
> (optional)
> > >Ming Lin wrote:                                  
> >          (Wed, 22 Aug
> > >> For example, an AS could be configured to
> support
> > call processing
> > >> And there is no restriction for MGC has
> multiple
> > ASes,
> > [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Aug 2001 13:38:26 -0500

Lyndon,

Yes, it supports multiple ranges, but anyone familiar with
circuit assignment will know that ranges get fragmented.
It is not acceptable to have to take an entire range of
circuits out of service to add a single circuit to group
just so that M3UA can assign a single AS value.  Trunk
groups grow in small increments.  Each additional increment
will require a new AS value to avoid disrupting operational
circuits.

Even if disruption were acceptable on a circuit group level
or span (which it is not), the CIC-Ranges would have to be
fragmented initially into one AS per span.

It is still the case that AS fragmentation could become
as bad as 1 AS per CIC.  How is the operator to even groom
this once it this these levels?  Take all trunks between
to SPs out of service, reasssign CIC-ranges, and then put
them back in service?  Serious 3:00 am stuff?

Please keep multiple AS per association in the model.

--brian

Lyndon Ong wrote:                            (Wed, 22 Aug 2001 10:57:49)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ken Morneault <[email-masked]>
Date: Wed, 22 Aug 2001 14:17:50 -0400

Ming,

I agree with Brian.  We should allow multiple ASes per
SG(P)-ASP association.

Regards,

Ken

At 01:41 AM 8/22/01 -0500, you wrote:
>You are currently subscribed to sigtran as: [email-masked]

---

---

From: Lyndon Ong <[email-masked]>
Date: Thu, 23 Aug 2001 11:43:09 -0700 (PDT)

Resending - I agree with Ken, I don't see
why fragmented ranges would necessarily 
result in having to create additional ASes.

In any case, the protocol will allow multiple
AS per association or single AS per association,
so we should be OK either way.

Let's move on to other issues.

Cheers,

Lyndon
--- Ken Morneault <[email-masked]> wrote:
> 
> 
> Brian,
> 
> I'm certainly not arguing against multiple AS per
> association,
> but I don't agree with your description of the use
> of CIC ranges
> in RKs.
> 
> For example, an AS (say AS1) would be defined for a
> CIC
> range of 1 to 1000 for a particular OPC-DPC pair. 
> The ASP 
> defined to support that AS would have TG for that
> OPC-DPC
> pair that could contain fragmented ranges of CICs
> between
> 1 and 1000.  However, it is the Trunk Group and not
> the
> Routing Key that gets groomed.  Further, the ASP
> would want
> to receive messages for CICs that were not defined
> within
> the Trunk Group.  Let's say that CIC 100 was not in
> the Trunk
> Group.  If the SG received and IAM for CIC 100, the
> ASP
> would want to receive that message so that it could 
> properly respond with a UCIC.
> 
> Ken
> 
> At 01:38 PM 8/22/01 -0500, you wrote:
> >Lyndon,
> >
> [email-masked]

---

---

From: Ken Morneault <[email-masked]>
Date: Thu, 23 Aug 2001 07:51:11 -0400

Brian,

I'm certainly not arguing against multiple AS per association,
but I don't agree with your description of the use of CIC ranges
in RKs.

For example, an AS (say AS1) would be defined for a CIC
range of 1 to 1000 for a particular OPC-DPC pair.  The ASP 
defined to support that AS would have TG for that OPC-DPC
pair that could contain fragmented ranges of CICs between
1 and 1000.  However, it is the Trunk Group and not the
Routing Key that gets groomed.  Further, the ASP would want
to receive messages for CICs that were not defined within
the Trunk Group.  Let's say that CIC 100 was not in the Trunk
Group.  If the SG received and IAM for CIC 100, the ASP
would want to receive that message so that it could 
properly respond with a UCIC.

Ken

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Aug 2001 19:27:20 -0500

Lyndon,

If multiple AS per association is not remove from
the drafts, there is no issue here for me.

--brian

Lyndon Ong wrote: (Thu, 23 Aug 2001 11:43:09)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 24 Aug 2001 08:42:13 +0300

Lyndon,

> Let's move on to other issues.

I suggest that this is a closed issue for all the
UAs - they should allow multiple AS per association.

John

---