Subject: M3UA 08 - ASP State Machine

From: "Asveren, Tolga" <[email-masked]>
Date: Mon, 20 Aug 2001 18:42:31 -0500

Hi everybody,

ASP state machine has states, which are per AS, like ASP-ACTIVE, ASP-STANDBY and ASP-INACTIVE. I propose to define two state machines for ASP, one consisting of pure ASP states and the other one per-AS states. I think most of the implementations are following a similar approach. 
So I propose an ASP-State machine, with states ASP-DOWN and ASP-UP (for ASP state machine, I think UP fits better than INACTIVE) and an ASP-per-AS state machine with states ASP-INACTIVE, ASP-ACTIVE or ASP-STANDBY.

  		 +---------------+
   		 |   ASP-UP      |
   		 |               |
   		 |               |
   		 |               |
   		 +------------+--+
      	    ^         |
     	ASP-UP    |         |  ASP-DOWN/SCTP CDI/ SCTP RI
      	    |         |
      	    |         |
      	    |         |
      	    |         V
   		 +--+-------------+
   		 |                |
   		 |  ASP-DOWN      |
   		 |                |
   		 |                |
   		 |                |
   		 +----------------+

		    +-----------------+
    		    |                 |
    		    |    ASP-ACTIVE   |
    		    |        or       |
    		    |    ASP-STANDBY  |
    		    |                 |
    		    |                 |
    		    +-------------+---+
       		 ^          |
       		 |          |
       ASP-ACTIVE  |          |    ASP-INACTIVE/SCTP CDI/SWCTP RI
       		 |          |
       		 |          |
       		 |          |
       		 |          |
       		 |          V
    		    +--+--------------+
    		    |                 |
    		    |                 |
    		    |   ASP-INACTIVE  |
    		    |                 |
    		    |                 |
    		    |                 |
    		    +-----------------+

     Regards,
     Tolga

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Aug 2001 19:15:36 -0500

Tolga,

It is quite an implementation dependent matter as to which states
are kept on what basis within the implementation.  ASP state is not
revealed to the peer in the same manner as AS state.  Also, I keep
track of ASP-ACTIVE, ASP-INACTIVE and ASP-DOWN on a per AS basis.
The reason for doing this is that the sum of the number of ASPs in
each state for the AS equals the number of ASPs currently assigned
to the AS.

I keep track of the ASP-DOWN state on a per AS basis only for ASPs
which have are initially in the ASP-DOWN state and have been
assigned to an AS, or which are in the ASP-DOWN state as a result of
the ASPDN req/ack or SCTP RI.  When SCTP CDI occurs, the ASP is
deallocated from the AS.

Therefore, although "Figure 4: ASP State Transition Diagram" is a
logical view, it is quite possible to implement that logical view
directly.

I think that the management text is quite clear that an ASP when
moved to the ASP-INACTIVE state is either assigned to an AS if it is
known to which AS it belongs, or held waiting for AS assignment.
This is also true the initial ASP-DOWN state.  Because it is always
possible to have an ASP allocated to an AS for any state
(ASP-ACTIVE/ STANDBY, ASP-INACTIVE and ASP-DOWN) because of static
port assignment (arrangements not requiring ASP Id) it is always
possible for an ASP to be in the ASP-DOWN state with respect to an
AS an, thus, it is possible to implement an ASP-DOWN state on a
per-AS basis.

The current diagram and logical states of the AS handle this
situation just fine and there is no reason to exclude ASP-DOWN state
on a per-AS basis.

Thus, I would prefer if things were left as they are in the draft,
but (of course) I don't mind if you make your implementation operate
the way you propose.

--brian

Asveren, Tolga wrote:                                    (Mon, 20 Aug 2001 18:42:31)
> Hi everybody,
> 
> ASP state machine has states, which are per AS, like ASP-ACTIVE, ASP-STANDBY
> and ASP-INACTIVE. I propose to define two state machines for ASP, one
> consisting of pure ASP states and the other one per-AS states. I think most
> of the implementations are following a similar approach.  So I propose an
> ASP-State machine, with states ASP-DOWN and ASP-UP (for ASP state machine, I
> think UP fits better than INACTIVE) and an ASP-per-AS state machine with
> states ASP-INACTIVE, ASP-ACTIVE or ASP-STANDBY.
> 
> 
>   		 +---------------+
>    		 |   ASP-UP      |
>    		 |               |
>    		 |               |
>    		 |               |
>    		 +------------+--+
>       	    ^         |
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 21 Aug 2001 07:10:46 -0500

Brian,

In fact just now I have also noticed that ASP-DOWN is necessary. I also
think that it should be on the ASP-per-AS state machine. 
But also now I have a noticed a sentence, which makes my proposal
unnecessary:
"4.2.1.1. ASP States
The state of each remote ASP, in each AS that it is configured to operate,
is maintained in the M3UA layer in the SGP"
So, this sentence tells me that the state machine in the draft is kept per
AS. Maybe caption of Figure4 on  can be changed a lit bit to reflect that
the state machine is per AS.

     Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, August 20, 2001 8:16 PM
To: sigtran
Subject: Re: M3UA 08 - ASP State Machine

Tolga,

--brian

Asveren, Tolga wrote:                                    (Mon, 20 Aug 2001
18:42:31)
> To unsubscribe send a blank email to
[email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 21 Aug 2001 08:13:55 -0500

seems the first copy was lost so resending .......

Brian,

In fact just now I have also noticed that ASP-DOWN is necessary. I also think that it should be on the ASP-per-AS state machine. 
But also now I have a noticed a sentence, which makes my proposal unnecessary:
"4.2.1.1. ASP States
The state of each remote ASP, in each AS that it is configured to operate, is maintained in the M3UA layer in the SGP"
So, this sentence tells me that the state machine in the draft is kept per AS. Maybe caption of Figure4 on  can be changed a lit bit to reflect that the state machine is per AS.

     Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, August 20, 2001 8:16 PM
To: sigtran
Subject: Re: M3UA 08 - ASP State Machine

Tolga,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 21 Aug 2001 14:44:29 -0500

Brian,

I agree that ASP-DOWN should be there for the ASP-per-AS state machine. In
fact when I read the draft more carefully, there it is said in 4.2.1.1
"The state of each remote ASP, in each AS that is configured to operate is
maintained in the M3UA layer in the SGP"
So the state machine there is already an ASP-per-AS state machine. I think
if caption for Figure4 is changed to indicate that this state machine is per
AS, it could be better.
And still I think another pure-ASP state machine can make sense.  For
example when dynamic registeration is used, after ASP-UP is sent and when
this ASP is serving no ASs, no state change can be reflected unless there is
an AS independent ASP state machine after ASP-UP is received.

      Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, August 20, 2001 8:16 PM
To: sigtran
Subject: Re: M3UA 08 - ASP State Machine

Tolga,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: [email-masked]
Date: Wed, 22 Aug 2001 04:59:04 +0300

There is another sentence that means it should be  ASP-per-AS state 
machine.
"3.7.1 ASP Active
The ASP Active message affects only the ASP state for the Routing Keys
identified by the Routing Contexts, if present."

So I propose to change the caption of Figure4 too.

Qu Qun

-----Original Message-----
From: ext Asveren, Tolga [mailto:[email-masked]]
Sent: 21. August 2001 20:11
To: sigtran
Subject: RE: M3UA 08 - ASP State Machine

Brian,

     Tolga

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, August 20, 2001 8:16 PM
To: sigtran
Subject: Re: M3UA 08 - ASP State Machine

Tolga,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Srivats P." <[email-masked]>
Date: Wed, 22 Aug 2001 9:28:8 +0500

Brian,

I need a clarification ...

Irrespective of whether the ASP-DOWN state is maintained on a ASP
basis or on a per AS basis, if the ASP is configured to serve 5 ASes,
at the SG, the ASP can *not* go down selectively for only some of
those ASes. If it sends a ASPDN, the SG makes it down in *all* the
ASes it is configured to serve.

Right ?

Srivats

At 8/22/01 4:59:00 AM, you wrote:
>You are currently subscribed to sigtran as: [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 22 Aug 2001 01:30:02 -0500

Srivats,

That's correct.  Neither ASPUP nor ASPDN have RC as a parameter,
so they both affect all ASs configured for the ASP.

--brian

Srivats P. wrote:                        (Wed, 22 Aug 2001 09:28:08)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Tue, 28 Aug 2001 11:07:53 -0400

Tolga,

There is no need to differentiate between "pure" and "per-AS" ASP states. 
All ASP states are, by definition, "per-AS":

4.2.1.1 ASP States

The state of each remote ASP, in each AS that it is configured to operate, is maintained in the M3UA layer in the SGP.

Barry Nagelberg
Software Engineer
RadiSys, Corp.
Signaling Products Design Center
[email-masked]
+1-856-642-9229 x237

"Asveren, Tolga" <[email-masked]>
08/20/01 07:42 PM
Please respond to sigtran

        To:     "sigtran" <[email-masked]>
        cc: 
        Subject:        M3UA 08 - ASP State Machine

Hi everybody,

ASP state machine has states, which are per AS, like ASP-ACTIVE, 
ASP-STANDBY and ASP-INACTIVE. I propose to define two state machines for 
ASP, one consisting of pure ASP states and the other one per-AS states. I 
think most of the implementations are following a similar approach. 
So I propose an ASP-State machine, with states ASP-DOWN and ASP-UP (for 
ASP state machine, I think UP fits better than INACTIVE) and an ASP-per-AS 
state machine with states ASP-INACTIVE, ASP-ACTIVE or ASP-STANDBY.

                                  +---------------+
                                  |   ASP-UP      |
                                  |               |
                                  |               |
                                  |               |
                                  +------------+--+
                     ^         |

                                     +-----------------+
                                     |                 |
                                     |    ASP-ACTIVE   |
                                     |        or       |
                                     |    ASP-STANDBY  |
                                     |                 |
                                     |                 |
                                     +-------------+---+
                                  ^          |
                                  |          |

     Regards,
     Tolga

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to 
[email-masked]

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 28 Aug 2001 10:20:32 -0500

Barry,

I agree but still I think it could be better if the caption of figure4 is changed to reflect this. And still in the case where dynamic registeration is used and an ASP has sent an ASPUP, at that time it does not serve any AS (no REGREQ is sent yet), so there is no state machine for it. This sounds strange to me....

    Tolga

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, August 28, 2001 11:08 AM
To: sigtran
Subject: Re: M3UA 08 - ASP State Machine

Tolga,

4.2.1.1 ASP States

Barry Nagelberg
Software Engineer
RadiSys, Corp.

Hi everybody,

                                  +---------------+
                                  |   ASP-UP      |
                                  |               |
                                  |               |
                                  |               |
                                  +------------+--+
                     ^         |

                                     +-----------------+
                                     |                 |
                                     |    ASP-ACTIVE   |
                                     |        or       |
                                     |    ASP-STANDBY  |
                                     |                 |
                                     |                 |
                                     +-------------+---+
                                  ^          |
                                  |          |

     Regards,
     Tolga

---

---

---