Subject: M2UAv09: automatic allocation of Signaling Terminals

From: [email-masked]
Date: Thu, 9 Aug 2001 10:44:42 -0500

Hi guys,

Section 4.4 of M2UA v09 talks about automatic allocation of Signaling 
Terminals or Signaling Data 
Links.

The SG, on receiption of the Registration Request from the ASP, has to map 
the parameters given
in the Link Key to an existing (provisioned) Link Terminal and will then 
return the Interface Identifier to the
ASP. Based on the (mandatory) parameters of the Link Key, I conclude that 
the SG must have knowledge
- beside others - of Signaling Data Link Id's. I don't see a need or 
purpose for that and suggest to remove
the SDLI parameter from the Link Key, unless I missed something very 
important. (In that case please tell
me).

Furthermore, I get the impression, that the Section 4.4 mixes automatic 
allocation of Signaling Terminals
(ITU Q704 12.5) and  automatic allocation of Signaling Data Links (12.6). 
IMHO,automatic allocation of
 Signaling Data Links is a peer to peer negotiation using signalling data link connection order messages, 
which should be transparent to M2UA. It is a MTP3 message sent from MTP3 
to MTP3. M2UA has 
nothing to do with it. All what M2UA can provide for is the alloc of 
Terminals. Where automatic allocation
 of Signaling Terminals does not need any 12 or 14 bit standard 
restrictions. The Terminal Id is not part
 of any standard protocol message. Why not make it 32 bit?

I can imagine someone will correct me.

Cheers, Heinz

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Aug 2001 12:06:42 -0500

Heinz,

Please see comments below...

[email-masked] wrote:                  (Thu, 09 Aug 2001 10:44:42)
> Terminals or Signaling Data Links.
> 
> The SG, on receiption of the Registration Request from the ASP, has to
> map the parameters given in the Link Key to an existing (provisioned)
> Link Terminal and will then return the Interface Identifier to the
> ASP. Based on the (mandatory) parameters of the Link Key, I conclude
> that the SG must have knowledge - beside others - of Signaling Data
> Link Id's. I don't see a need or purpose for that and suggest to
> remove the SDLI parameter from the Link Key, unless I missed something
> very important. (In that case please tell me).

The SDTI parameter identifies a Signalling Terminal of all the
Signalling Terminals provided by an SG.  It in conjunction with SDLI is
used by MTP3 to request the allocation (connection) of a Signalling
Terminal to a Signalling Data Link.

The SDLI parameter identifies a Signalling Data Link to be associated
with that Signalling Terminal and also provides the capability of the L1
CONNECT primitive of Q.704 which tells the SG to connect a specified
channel.

In fitting with the SS7 reference model in Q.702, both an identifier of
the Signalling Terminal and the Signalling Data Link are required to
fully specify the interface.

In SGs where there is a fixed relationship between Signalling Terminals
and Signalling Data Links (e.g. no backplane TDM switching and
hard-wired facilities) there is a one to one relationship between SDTI
and SDLI.  But, to maintain interoperability with system which have a
degree of freedom between to two (e.g. H.110 switching across the
backplane between links and terminal), both need to be specified.

> 
> Furthermore, I get the impression, that the Section 4.4 mixes
> automatic allocation of Signaling Terminals (ITU Q704 12.5) and
> automatic allocation of Signaling Data Links (12.6).  IMHO,automatic
> allocation of Signaling Data Links is a peer to peer negotiation using
> signalling data link connection order messages, which should be
> transparent to M2UA. It is a MTP3 message sent from MTP3 to MTP3. M2UA
> has nothing to do with it. All what M2UA can provide for is the alloc
> of Terminals. Where automatic allocation of Signaling Terminals does
> not need any 12 or 14 bit standard restrictions. The Terminal Id is
> not part of any standard protocol message. Why not make it 32 bit?

I understand that some implementations may have restrictions on the
range of SDTI provided, also it didn't make much sense to me that an
SG supporting more than a trillion links would be required.  It also
parallels SDLI nicely and permits both to be packed into a single 32
bit value in the implementation.

Do you see a need for all 32 bits?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 9 Aug 2001 13:00:25 -0500

Hello Brian,

seem's you have a lot of fun last time...., well, let me have some share 
of it...

I failed to find any evidence in the cited Q702 document, that "both an identifier of
the Signalling Terminal and the Signalling Data Link are required to
fully specify the interface", as you put it.

"Brian F. G. Bidulock" <[email-masked]>
08/09/01 12:06 PM
Please respond to sigtran

        To:     "sigtran" <[email-masked]>
        cc: 
        Subject:        Re: M2UAv09: automatic allocation of Signaling Terminals

Heinz,

[email-masked] wrote:                  (Thu, 09 Aug 2001 
10:44:42)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to 
[email-masked]

---

---

From: [email-masked]
Date: Thu, 9 Aug 2001 13:09:28 -0500

Sorry Brian, I was not ready yet....

I see your point for interoperabilty. Can we, should we, make the SDLI 
parameter optional?

I do not see a need for more than 12 bits, but it seemed misleading to me. 
Without your
explanation it looked like demanded by the standard. And it even says 
that.

Cheers, Heinz

[email-masked]
08/09/01 01:00 PM
Please respond to sigtran

        To:     "sigtran" <[email-masked]>
        cc:     [email-masked]
        Subject:        Re: M2UAv09: automatic allocation of Signaling Terminals

Hello Brian,

I failed to find any evidence in the cited Q702 document, that "both an 
identifier of
the Signalling Terminal and the Signalling Data Link are required to
fully specify the interface", as you put it.

        To:     "sigtran" <[email-masked]>
        cc: 
        Subject:        Re: M2UAv09: automatic allocation of Signaling 
Terminals

Heinz,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Aug 2001 13:31:54 -0500

Heinz,

Q.702 defines two references points, one at the Signalling
Terminal and one at the Signalling Data Link.  That to
specify a signalling channel requires and identifier at each
reference point is a given (and in fitting with the reference
model).

--brian

[email-masked] wrote:                  (Thu, 09 Aug 2001 13:00:25)
> Hello Brian,
> 
> seem's you have a lot of fun last time...., well, let me have some share of
> it...
> 
> 
> identifier of the Signalling Terminal and the Signalling Data Link are
> required to fully specify the interface", as you put it.
> 
> 
> 
> 
> 
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Aug 2001 13:35:28 -0500

Heinz,

[email-masked] wrote:                  (Thu, 09 Aug 2001 13:09:28)
> I see your point for interoperabilty. Can we, should we, make the
> SDLI parameter optional?

It toyed with that.  If it is made optional, we will have to
add an error for the SG to indicate when it is required but
not provided.  If it is left mandatory, the SG can ignore it
if it doesn't need it.  I think mandatory is simpler and more
interoperable (it does not require and error procedure).

> 
> I do not see a need for more than 12 bits, but it seemed
> misleading to me.  Without your explanation it looked like
> demanded by the standard. And it even says that.

Text error.  How about we say "SDTI MAY only be significant to
12 bits--unused bits are coded `0'".

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Aug 2001 18:49:10 -0500

Heinz,

I also though that if both SDLI and SDTI were kept at 16-bits
or less, they could be concatenated to form an IID.  This
would permit passive monitoring of M2UA and avoid having to
provision IIDs at the ASP.

--brian

Brian F. G. Bidulock wrote:                               (Thu, 09 Aug 2001 13:35:28)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 9 Aug 2001 19:04:52 -0500

Brian,

Maybe that might be worth to consider a rewording of the paragraph and
restructuring of the message. It would put both the terminal allocation 
and
the iid assignment to the asp side and all the SG has to do is to have a
link terminal and if so to confirm the allocation, iid assignment.

Heinz

08/09/01 06:49 PM

Heinz,

--brian

Brian F. G. Bidulock wrote:                               (Thu, 09 Aug 
2001 13:35:28)
> [email-masked] wrote:                  (Thu, 09 Aug 2001 
13:09:28)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: Lyndon Ong <[email-masked]>
Date: Fri, 10 Aug 2001 00:04:22 -0700

Folks,

Did not notice this earlier, but given that M2UA is already past WG Last Call, let's try to hold our comments to things that are real errors and
resist the temptation to keep adding features.
Otherwise we'll never get anything out.

Thanks,

Lyndon 
--

On Thu, 9 Aug 2001 10:44:42    Heinz.Prantner wrote:
>You are currently subscribed to sigtran as: [email-masked]

Join 18 million Eudora users by signing up for a free Eudora Web-Mail account at http://www.eudoramail.com

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Aug 2001 02:21:38 -0500

Lyndon,

It was certainly no problem clarifying the text in the draft
to Heinz.  Any resulting minor edits could have been caught
during IESG last call.

--brian

Lyndon Ong wrote:                                          (Fri, 10 Aug 2001 00:04:22)
> Folks,
> 
> Did not notice this earlier, but given that M2UA is already past WG Last
> Call, let's try to hold our comments to things that are real errors and

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Aug 2001 02:31:44 -0500

Heinz,

I don't quite know what your getting at here, but if you
are talking about just concatenating SDTI/SDLI in IID
and using ASPAC and ASPIA instead of RKM, I considered
that.  ASPAC does not have the error types or two stage
semantics which are easily provided by RKM consistent
with the other UAs.

--brian

[email-masked] wrote:                  (Thu, 09 Aug 2001 19:04:52)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---