Subject: Re: M2UAv0, M3UAv8, SUAv7: Traffic Mode Type

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Aug 2001 01:42:04 -0500

Greg, Ken, John,

What is the status of this issue?

--brian

Brian F. G. Bidulock wrote:                               (Wed, 25 Jul 2001 13:20:32)
> Ken, Greg, John,
> 
> In addition, what is the purpose of a mandatory Traffic Mode Type in
> the ASP Active Ack?  Was it expected that this Traffic Mode Type would
> reflect the Traffic Mode of the SGP to the ASP?  (Which would be
> excellent!)  Or was it just an echo of the ASP Active message?  What
> does an ASP do if the mandatory Traffic Mode Type in the ASP Active Ack
> message does not match what was sent?  Should not this parameter be
> Optional?
> 
> --Brian
> 
> 
> Brian F. G. Bidulock wrote:                 (Wed, 25 Jul 2001 12:36:29)
> > Ken, Greg, John,
> > 
> > Traffic Mode Type is a mandatory paramter of ASPAC and REG REQ in all
> > the UAs.  Because the Traffic Mode Type has only a restricted range
> > of modes, does it not make sense to permit ASPs and SGPs to use other
> > traffic modes other than those specified in the drafts?  In the case
> > where SGP and ASP have been configured for the traffic mode by other
> > means, shouldn't the Traffic Mode Type be Optional in these messages?
> > 
> > The text says that they MUST match, but if it is left out and the
> > ASP and SGP agree by prior arrangement, it doesn't need to be in the
> > message at all.
> > 
> > --Brian
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 
> > 
> > ---
> > You are currently subscribed to sigtran as: [email-masked]
> > To unsubscribe send a blank email to [email-masked]
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Greg Sidebottom <[email-masked]>
Date: Fri, 10 Aug 2001 03:37:16 -0400

Hi Brian,

I believe we have agreed on the list to change Traffic Mode Type to optional
in ASP-Up (and REG REQ).  So it is consistent to change it to optional in
the ASP Active Ack.  I'd already made the change for M3UA.

But I guess with everything being optional now some things are now open.  Do
we want to support all the following permutations?

1) TMT included in ASP Active, TMT included in ASP Active Ack.

2) TMT included in ASP Active, TMT not included in ASP Active Ack.

3) TMT not included in ASP Active, TMT included in ASP Active Ack.

4) TMT not included in ASP Active,  TMT not included in ASP Active Ack.

I suppose 2 and 4 are easy enough but do people see a use for 1 and/or 3?
If so for each case what is the TMT value in the ACK?

Cheers,

   Greg

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Cc: "Greg Sidebottom" <[email-masked]>; "Ken Morneault"
<[email-masked]>; "John Loughney" <[email-masked]>
Sent: Friday, August 10, 2001 2:42 AM
Subject: Re: M2UAv0, M3UAv8, SUAv7: Traffic Mode Type

> > > To unsubscribe send a blank email to
[email-masked]
> > To unsubscribe send a blank email to
[email-masked]

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Fri, 10 Aug 2001 12:31:22 -0500

I have a question related with this topic. Does the following scenario make
sense or is it not supported?

        SG1                       ASP1                        ASP2
         | ----NTFY(AS1 Pending)-> |                           |
         | ------------------------+-----NTFY(AS1 Pending)---->|
         |                         |                           |
         |                         |                           |
         |<---ASPAC(AS1 TM=ACT)----|                           |
         |<------------------------+-------ASPAC(AS1 TM=ACT)---|
         |                         |                           |
         |                         |                           |
         |---ASPACACK(AS1 TM=ACT)->|                           |
         |-------------------------+---ASPACACK(AS1 TM=STDBY)->|

In that scenario SG sends NTFY in parallel to a group of ASPs, instead of
sending the NTFY in a serial way.

If the situation in that scenario is valid, then I think TM will be required
for 1) 2) 3) and 4).
 
    Regards,
    Tolga 

-----Original Message-----
From: Greg Sidebottom [mailto:[email-masked]]
Sent: Friday, August 10, 2001 3:37 AM
To: sigtran
Cc: Ken Morneault; John Loughney
Subject: Re: M2UAv0, M3UAv8, SUAv7: Traffic Mode Type

Hi Brian,

Cheers,

   Greg

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Cc: "Greg Sidebottom" <[email-masked]>; "Ken Morneault"

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: Ken Morneault <[email-masked]>
Date: Sat, 11 Aug 2001 20:20:29 -0400

Greg,

I don't think we have consensus to change TMT to optional in
ASP Active.  I think the ASP should send the TMT in the ASP
Active since the ASP will know the traffic mode.  There is no 
need for TMT in ASP Active Ack.

If it was optional, how would the ASP know when it was 
appropriate to send TMT in ASP Active?

Regards,

Ken

---

---

From: Ken Morneault <[email-masked]>
Date: Mon, 13 Aug 2001 09:12:29 -0400

Brian,

In regards to 'n' value and loadsharing algorithm, I agree
that these need to be addressed.  I raised this concern
at the one of the meetings.

My preference was to remove the 'n' attribute from the
SG.  The ASPs know what 'n' is so they can coordinate
amongst themselves.  In most cases, I would
imagine that 'n' would be set to one.  (Note:  if this
is the case, then we should get rid of 'n').  Further, I hate
to bother the operator of the equipment with configuring 
'n' for each different ASP/AS product connected to a SG.

My preference for the loadsharing algorithm was to
have it sent by the ASP in ASP Active/REG REQ.
Again, why force the operator to have to figure out the
correct value to set for a particular vendor's product when
the product "knows" which loadsharing algorithm it 
desires/supports.

Of course, for the example you mentioned in your
previous email, it would be necessary to add a
"Unspecified", "Default" or "Whatever AS is 
current set to" TMT value.

Regards,

Ken

At 12:09 AM 8/12/01 -0500, you wrote:
>Hi Ken,
>
>There are two other attributes of the AS which are not being
>communicated in the ASP Activce message: the `n' value in `n+k' and
>the loadsharing algorithm for a loadshare AS.  Because all ASs
>except Override need the `n' value provisioned at the SG, it is
>simple to require the TMT to be provisioned with it.  The SG,
>therefore, always knows the TMT of the AS.  It should be optional
>because, as it stands, the ASP never has to send it.
>
>If the ASP Active message contained the loadsharing algorithm (for
>loadshare mode) and the `n' value in `n+k' for loadshare and
>broadcast modes, then it might not be necessary to statically
>provision AS attributes at the SG.
>
>Actually, the AS at the SG still has to be statically provisioned
>(with a Routing Context value or Interface Identifier list) unless
>dynamic registration is used.  TMT, the `n' value, and loadsharing
>algorithm selection need only be communicated to the SG in in the
>REG REQ message.
>
>The current procedures do not really allow for a switch of TMT
>during operation.  Unless dynamic registration is used, the SG needs
>to be statically provisioned with the other AS attributes (IIDs/RC,
>`n', loadsharing algorithm) anyway, why not TMT?  When dynamic
>registration is used, where attributes must either all be
>communicated in the REG REQ, or the SG will still have to be
>statically provisioned with them.
>
>For M3UA the TMT in the ASP Active Ack is required for standby
>modes.  M2UA got rid of those: that is why there is not a need for
>TMT in the ASP Active Ack.
>
>--brian
>
>
>Ken Morneault wrote:               (Sat, 11 Aug 2001 20:20:29)
> > 
> > 
> > Greg,
> > 
>You are currently subscribed to sigtran as: [email-masked]

---

---

From: [email-masked]
Date: Mon, 13 Aug 2001 11:24:23 -0400

Ken,

The SG must know what 'n' is so that it knows when to send a Notify 
message with Status = 'Insufficient ASP Resources Active in AS'.

Barry Nagelberg
Software Engineer
RadiSys, Corp.
Signaling Products Design Center
[email-masked]
+1-856-642-9229 x237

Ken Morneault <[email-masked]>
08/13/01 09:12 AM
Please respond to sigtran

        cc: 

Regards,

Ken

---

---

From: Ken Morneault <[email-masked]>
Date: Mon, 13 Aug 2001 12:10:27 -0400

That wouldn't be necessary if the ASPs coordinated amongst
themselves to determine how many ASPs should be active.

Ken

---

---

From: [email-masked]
Date: Mon, 13 Aug 2001 13:12:00 -0400

Ken,

If don't think that it is wise to delete existing functions from our 
drafts, as you are suggesting, and replace them with vague statements such 
as "the ASPs will coordinate amongst themselves".

We must cover the case in which the ASPs are from different vendors. In 
such a case, to ensure interoperability, the draft must specify the 
inter-ASP messages and procedures that will be used to replace the 
functions that are now in our drafts.

Barry Nagelberg
Software Engineer
RadiSys, Corp.

08/13/01 12:10 PM

Ken

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to 
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Aug 2001 12:40:20 -0500

Ken,

Ken Morneault wrote:                               (Mon, 13 Aug 2001 09:12:29)
> 'n' for each different ASP/AS product connected to a SG.

You could get rid of `n' in this fashion as long as
you get ride of "Standby" modes in M3UA and SUA as well.

In opposition I believe that there is a school of though
that believes that the SG should have ultimate control
over these decisions, rather than ASPs which may be
partitioned from each other.

Also, how will the SG know when to remove traffic?  If there
are `n-1' ASPs active, the SG could easily overload the
works.

Could you propose some text?

> the product "knows" which loadsharing algorithm it 

I have an extension draft for a "load selector" parameter
which would do the trick.

> current set to" TMT value.

Hah!  Caught you! :) I don't see the difference between a TMT
with the value "Unspecified" and the lack of TMT in the message.
They are just two forms of "Optional".  If one form is more
palatable then let it be so.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Aug 2001 12:42:14 -0500

Barry,

Are you calling for ASP-to-ASP communications to be specified?

--brian

[email-masked] wrote:                (Mon, 13 Aug 2001 13:12:00)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ken Morneault <[email-masked]>
Date: Mon, 13 Aug 2001 13:55:44 -0400

Barry,

Pls see comments below.

Ken

>as "the ASPs will coordinate amongst themselves".

There are devices in the SS7 network today that work in loadsharing
mode and I know of no value similar to 'n' that must be configured.  We
should think carefully before introduce parameters that an SS7 operator
must understand and provision.  I think it is reasonable to question
the value of the 'n' parameter.

>functions that are now in our drafts.

M3UA cannot cover the case in which ASPs supporting an AS can
come from different vendors.  Communication between ASPs is out-of-
scope.  

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Aug 2001 13:00:59 -0500

Ken,

If the ASP-to-ASP communication is "out of scope,"
should the UAs severally require it and continually
depend on it?  I have the same question for SGP-to-SGP
communication...

--brian

Ken Morneault wrote:                                          (Mon, 13 Aug 2001 13:55:44)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Mon, 13 Aug 2001 14:10:43 -0400

Brian,

Yes, if they replace existing SG-ASP communications.

Barry Nagelberg

"Brian F. G. Bidulock" <[email-masked]>
08/13/01 01:42 PM
Please respond to sigtran

Barry,

--brian

[email-masked] wrote:                (Mon, 13 Aug 2001 
13:12:00)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: Ken Morneault <[email-masked]>
Date: Mon, 13 Aug 2001 15:10:22 -0400

Brian,

Pls see comments below.

Ken

>you get ride of "Standby" modes in M3UA and SUA as well.

I have proposed this in the past.

>are `n-1' ASPs active, the SG could easily overload the

Do STPs have a concept of 'n' when loadsharing traffic across
SCPs?

>Could you propose some text?

First, I'm not sure text is needed at this point in the discussion.

>which would do the trick.

I'd be interested in seeing the draft.

>palatable then let it be so.

hmm..I believe I misinterpreted the meaning of your list
of values.  I believed that you were offering three possible names
for the same action on the SG.  The action being that the
SG would use "whatever the AS is current set to".  This implied
(in my mind) that the SG must have received a TMT with 
Override, Loadshare or Broadcast from an ASP.

If "Unspecified" means that the TMT must be provisioned
on the SG, then there is no gain in making TMT mandatory
in ASP Active.  TMT still has to be provisionable on the
SG and there is an opportunity for provisioning errors.

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Aug 2001 17:12:55 -0500

Ken,

Ken Morneault wrote:                                  (Mon, 13 Aug 2001 15:10:22)
[snip]
> I have proposed this in the past.

I have no love of Standby modes.  But I'll leave you to slug
this one out with Greg. ;)

> Do STPs have a concept of 'n' when loadsharing traffic across

Yes.  The fact that 'n' is a trivial '1' and 'k' is a trivial
'1' doesn't change the fact that the STPs are aware of the
cardinality and multiplicity of SCPs.

Would you have it that the redundancy model of the ASPs be
reduced to '1+1' sparing, loadsharing and broadcast?

> First, I'm not sure text is needed at this point in the discussion.

Fair enough.

> I'd be interested in seeing the draft.

I'll submit it.  It is my first attempt at an extension draft,
so be gentle.

> SG and there is an opportunity for provisioning errors.

I wasn't distinguishing.  What is the difference between an ASP
sending an ASPAC without a TMT and an ASP sending an ASPAC with
a TMT set to "whatever the AS is currently set to":  particularly
if the SGP interprets the lack of a TMT to mean "whatever the AS
is currently set to"? :P

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ken Morneault <[email-masked]>
Date: Mon, 13 Aug 2001 19:54:56 -0400

>reduced to '1+1' sparing, loadsharing and broadcast?

Yes, but is awareness equivalent to a provisioned value 'n'.  Does
the STP stop sending traffic to loadshare SCPs if the number
of available SCPs drop below a provisioned value 'n'? 

>if the SGP interprets the lack of a TMT to mean "whatever the AS

fine, as long as lack of TMT is defined as such, i agree there
is no difference.

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Aug 2001 19:38:06 -0500

Ken,

Please see comments below...

Ken Morneault wrote:                                          (Mon, 13 Aug 2001 19:54:56)
[snip]
> of available SCPs drop below a provisioned value 'n'? 

Yes, with `n' being 1, the STPs stop sending traffic to loadshare SCPs
when the number of available SCPs drops below the provisioned value of
`n', being `1'.

I think that whay you are objecting to is values of `n' greater than 1.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Ken Morneault <[email-masked]>
Date: Mon, 13 Aug 2001 21:37:35 -0400

Brian,

Pls see below.

Ken

>So, I ask the question again:

I'm not objecting to values of 'n' greater than 1.  I'm objecting to
the creation of the provisioned object 'n'.  An provisioned object
that must be understood and set correctly by the operator.
Therefore, I'm not sure the question below applies; though, I would 
be interested in finding out if anyone is developing an ASP with a 
redundancy model not listed below.

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 14 Aug 2001 00:23:42 -0500

Ken,

Please see commments below...

Ken Morneault wrote:                                          (Mon, 13 Aug 2001 21:37:35)
[snip]
> redundancy model not listed below.

Well, I suppose the answer to the question is `no' then.

Yes, I am developing an ASP with a redudancy model not listed.  It is
a combination of load-sharing and broadcast mode (striped and mirrored).
The ASPs load-share between broadcast groups but broadcast within a
group.  That was the purpose of writing the "load selector" draft: to
permit the ASP to identify which stripe (load-share group) and which
mirror (broadcast group) it operates in.  This is performed using a
"load selector".  ASPs which register for the same "load selector" are
in the same broadcast group, whereas, ASPs which register for different
"load selector" have a different load-share group.  Override is accomplished
by routing key alone.  Traffic Mode Type becomes unnecessary and it is a
bother to use it.  Thus the desire to make it optional.

I have no need yet for configurations where n > 1, or k > 1.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---