Subject: Handling out of order SSN.

From: [email-masked]
Date: Mon, 6 Aug 2001 20:28:39 +0530

Hi All,
    I have question regarding mismatched SSN.  The RFC does not specify the
action to be
taken when SSN is out of order. Consider a situation where in the TSN
matches the next expected
TSN and SSN is same as the previous packet received.  In that case what is
the suggested action
to be taken ?? Since SACK has only TSN, I would assume that implementations
will send SACK
even though there is mismatch in SSN.

-thanks in advance,
Umesh.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Jacob Heitz <[email-masked]>
Date: Mon, 06 Aug 2001 09:21:16 -0700

I think that is a "should never happen" and therefore a protocol error.
The same entity that assigns the TSN also assigns the SSN, therefore
in a correctly functioning SCTP, this cannot happen.

You should abort the association.

---

---

From: Vinay Kashyap <[email-masked]>
Date: Thu, 7 Jun 2001 09:55:58 +0530

Hai Umesh r u from Dayananda Sagar College of Engg Bangalore
----- Original Message -----
From: <[email-masked]>
To: sigtran <[email-masked]>
Sent: Monday, August 06, 2001 8:28 PM
Subject: Handling out of order SSN.

> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---