Subject: M3UA is supposed to support streams

From: Jacques Rajchgod <[email-masked]>
Date: Fri, 17 Aug 2001 13:58:58 -0500

M3UA uses the services of SCTP, and SCTP is stream-oriented. Reference:
"draft...sctp-over-01.text", section "3", the 5th and 6th paragraphs talking
about multi-streaming. SCTP is stream-oriented since it contains STREAM_ID
headers as part of its delivery mechanism. However,
"draft...sigtran-M3UA-06.txt" states that SCTP is "explicit packet-oriented
delivery and not stream-oriented". - Section 1.3.1 at the bottom, the 6
bullets (hyphens...)

I believe the words "not stream-oriented" are in error...?
I would have expected the 6 bullets (hyphens) to be be really 7, the first
two ones of which, to say as follows:
  a.. Explicit packet-oriented delivery
  b.. Stream-oriented delivery
Please kindly advise...
Tks,
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-1487
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Greg Sidebottom <[email-masked]>
Date: Fri, 17 Aug 2001 15:24:29 -0400

Greetings  Jacques,

For M3UA and SCTP the term "not stream oriented" in this context refers to the fact that SCTP employs record marking and not the octet streaming of TCP. It is not to say that the SCTP does not support streams.  I think this wording was stolen from the SCTP draft at some point - the term is still in the SCTP RFC Section 1.1.

Any proposal for a better term would be welcome.

Thanks,

   Greg
  ----- Original Message ----- 
  From: Jacques Rajchgod 
  To: sigtran 
  Sent: Friday, August 17, 2001 2:58 PM
  Subject: M3UA is supposed to support streams

  M3UA uses the services of SCTP, and SCTP is stream-oriented. Reference: "draft...sctp-over-01.text", section "3", the 5th and 6th paragraphs talking about multi-streaming. SCTP is stream-oriented since it contains STREAM_ID headers as part of its delivery mechanism. However, "draft...sigtran-M3UA-06.txt" states that SCTP is "explicit packet-oriented delivery and not stream-oriented". - Section 1.3.1 at the bottom, the 6 bullets (hyphens...)

  I would have expected the 6 bullets (hyphens) to be be really 7, the first two ones of which, to say as follows:

  ---
  You are currently subscribed to sigtran as: [email-masked]
  To unsubscribe send a blank email to [email-masked] 

---

---

From: Jacques Rajchgod <[email-masked]>
Date: Fri, 17 Aug 2001 14:47:56 -0500

Thanks Greg, my appreciation for a quick come-back.
Herewith my easy and quick proposal: From the 6 bullets that exist, to make
it 7 bullets.

...The bulleting would be changed as follows:
  1.. Explicit pack-oriented...
  2.. Stream-oriented delivery: All packets belonging to a specific stream
are each marked with a common STREAM_ID header for that stream. THE COMPLETE
STREAM is delivered as one unit of work. Mutiple individual streams can
exist on one SCTP PORT association.
  3.. Sequenced delivery of user messages within multiple streams.
  4.. Optional MUXing...
  5.. N/W-level...
  6.. Resistance...
  7.. Dat Segmentation...
Kindly,
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-1487
E-mail: [email-masked]

  -----Original Message-----
  From: Greg Sidebottom [mailto:[email-masked]]
  Sent: Friday, August 17, 2001 2:24 PM
  To: sigtran
  Subject: Re: M3UA is supposed to support streams

  Greetings  Jacques,

  For M3UA and SCTP the term "not stream oriented" in this context refers to
the fact that SCTP employs record marking and not the octet streaming of
TCP. It is not to say that the SCTP does not support streams.  I think this
wording was stolen from the SCTP draft at some point - the term is still in
the SCTP RFC Section 1.1.

  Thanks,

     Greg
    ----- Original Message -----
    From: Jacques Rajchgod
    To: sigtran
    Sent: Friday, August 17, 2001 2:58 PM
    Subject: M3UA is supposed to support streams

    I believe the words "not stream-oriented" are in error...?
    I would have expected the 6 bullets (hyphens) to be be really 7, the
first two ones of which, to say as follows:
      a.. Explicit packet-oriented delivery
      b.. Stream-oriented delivery
    Please kindly advise...
    Tks,
    Jacques Rajchgod
    MCI Worldcom
    Next Generation System Evaluation
    Tel: [972] 729-1487
    E-mail: [email-masked]

    ---
    You are currently subscribed to sigtran as: [email-masked]
    To unsubscribe send a blank email to
[email-masked]
  ---
  You are currently subscribed to sigtran as: [email-masked]
  To unsubscribe send a blank email to
[email-masked]

---

---

From: Lyndon Ong <[email-masked]>
Date: Fri, 17 Aug 2001 12:59:01 -0700

"byte-stream" might be a better term.

Cheers,

Lyndon 
--

On Fri, 17 Aug 2001 14:47:56   Jacques Rajchgod wrote:
>You are currently subscribed to sigtran as: [email-masked]

Join 18 million Eudora users by signing up for a free Eudora Web-Mail account at http://www.eudoramail.com

---

---

From: Jacques Rajchgod <[email-masked]>
Date: Fri, 17 Aug 2001 15:22:13 -0500

...Wouldn't be a good idea, as the word "byte" might again smack of
"packets"...What we are attempting to convey here is the concept of
streams - entire streams -  like "whole envelopes", rather than "bytes"
streams or "pack" streams. We want to make sure the developer/tester seizes
on both crucial natures of SCTP:
1) SCTP "builds" individual packets made-up of "bytes". OK.
2) Then it "groups" these individual packs into streams - streams that are
manageable as STREAMS - doesn't matter what's inside that stream (bytes or
packs). That's the idea that should be emphasized, as streams - are the
novelty that SCTP has now brought...

Thanks,

Jacques Rajchgod
MCI Worldcom

> From: Lyndon Ong [mailto:[email-masked]]
> Sent: Friday, August 17, 2001 2:59 PM
> To: sigtran
> Subject: RE: M3UA is supposed to support streams
>
>
> Join 18 million Eudora users by signing up for a free Eudora
> Web-Mail account at http://www.eudoramail.com
>
>
> ---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 17 Aug 2001 15:48:07 -0500

Greg,

I think you just proposed a better term: "record marking".

--brian

Greg Sidebottom wrote:                                       (Fri, 17 Aug 2001 15:24:29)
> 
>    Greetings  Jacques,
>    
>    
>    
>    For M3UA and SCTP the term "not stream oriented" in this context
>    refers to the fact that SCTP employs record marking and not the octet
>    streaming of TCP. It is not to say that the SCTP does not support
>    streams.  I think this wording was stolen from the SCTP draft at some
>    point - the term is still in the SCTP RFC Section 1.1.
>    
>    
>    

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Lyndon Ong <[email-masked]>
Date: Fri, 17 Aug 2001 16:33:39 -0700

Actually, I meant in the sense of "SCTP is NOT byte-stream-oriented".

Whatever.

Lyndon
 
--

---