Subject: Re: M3UA07: Network Appearance

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Aug 2001 10:23:58 -0500

John,

Figure 8/T1.111.5.

All SP's are permitted to have the "transfer function".  They do
not have to be STPs.  The sponsor of this reflector has been selling
software for their switches for over 15 years which provides for
this arrangement.  Get another excuse.  You must address the
diagram.  It is a real situation.

--Brian

John Schantz wrote:                                          (Thu, 09 Aug 2001 07:07:44)
> Brian,
> 	You will find NO picture of an F-link going through an STP in
> T1.111.5.  I should know, I drew all the pictures in T1.111.5, I was the
> original editor for this standard.  Therefore, I think you had better come
> up with another excuse.
> 
> John
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Wednesday, August 08, 2001 6:35 PM
> > To: sigtran
> > Subject: Re: M3UA07: Network Appearance
> > 
> > 
> > John,
> > 
> > The example is directly from Q.705/ANSI T1.111.5.  It is
> > more than valid.  E-link arrangements are similar and
> > exhibit the same problem.  You'll have to come up with
> > another excuse.
> > 
> > --brian
> > 
> > John Schantz wrote:                             (Wed, 08 Aug 
> > 2001 15:04:38)
> > > Brian,
> > > 	It would help a lot if this was a valid example.  F-links are
> > > point-to-point.  No STPs or SGs involved.  Maybe you have 
> > it set up wrong.
> > > You can't expect us to solve every drawing if they are 
> > incorrect to begin
> > > with.
> > > 
> > > Do you really want the SG to do its job as an STP.  Then 
> > AS1 would know that
> > > its signalling is coming via the SG.  But in this case, the 
> > SG has B-links
> > > (or D-links or G-links) to the network and an E-link to 
> > 200.1.4.  Hence, the
> > > primary route for all ASs behind the SG to 200.1.4 is the 
> > E-link, the
> > > B-links would be the alternate route for 200.1.4.  If the 
> > link from the SG
> > > to 200.1.4 fails, then the SG uses the alternate route to 
> > 200.1.4.  Only if
> > > the E-link failed and TFPs were received from both STPs 
> > would the SG send a
> > > DUNA to AS1 about 200.1.4.
> > > 
> > > John
> > > 
> > > > -----Original Message-----
> > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > Sent: Wednesday, August 08, 2001 2:25 PM
> > > > To: sigtran
> > > > Subject: Re: M3UA07: Network Appearance
> > > > 
> > > > 
> > > > John,
> > > > 
> > > > It does not work for this example which has already been
> > > > presented:
> > > > 
> > > > 
> > > > 
> > > >                       200.1.4    __________
> > > >                         ___     /          \     ___
> > > >                        /   \   |            |   /   \
> > > >                       | SEP |__|____________|__| SEP |  AS1
> > > >                        \___/   |            |   \___/
> > > >                       //       |            |
> > > >                      / |       | Signalling |  5.255.3
> > > >                     / /        |   Gateway  |
> > > >                    /  |        |            |
> > > >                   /  /         |            |
> > > >           _____  /   |         |            |
> > > >          |     |/   /          |            |
> > > >     -----| STP |____|__________|______      |
> > > >         /|_____|   /           |      \___  |  5.255.4
> > > >        /    |      |           |          \_|_   ___
> > > >     \ /     |     /            |            | \ /   \
> > > >      X      |     |            |            |  | SEP |  AS2
> > > >     / \     |    /             |           _|_/ \___/
> > > >        \  __|__ /              |       ___/ |
> > > >         \|     |_______________|______/     |       5.255.5
> > > >     -----| STP |               |            |       (alias)
> > > >          |_____|               |            |
> > > >                                |            |
> > > >                                 \__________/
> > > > 
> > > > When the F-link to 200.1.4 fails, how can the SG present a single
> > > > view towards the AS?  The network is inaccessible from 5.255.3 and
> > > > 5.255.3 is inaccessible from the network.  5.255.5 is still has
> > > > access to the network and the network still has access to 5.255.5.
> > > > 
> > > > If you tell 5.255.3 that the network is still accessible 
> > (presumably
> > > > via the STPs) you can still not tell the SS7 network that 
> > 5.255.3 is
> > > > accessible to it.  The SS7 network will not route any messages to
> > > > 5.255.3, it has already broadcast TFP(5.255.3).
> > > > 
> > > > If you tell 5.255.4 that the network is inaccessible, the entire
> > > > system will fail every time the F-link fails, which is ridiculous.
> > > > 
> > > > Option (4) is not an option because it does not address the
> > > > situation which has been the point of dicussion all along.
> > > > 
> > > > Please address further "solutions" to this diagram.
> > > > 
> > > > 
> > > > --Brian
> > > > 
> > > > 
> > > > 
> > > > John Schantz wrote:                                          
> > > > (Wed, 08 Aug 2001 11:54:13)
> > > > > Brian,
> > > > > 	Option (4) does work and you also seem to have 
> > confused in which
> > > > > direction the single view is being presented.
> > > > > 
> > > > > 	For Option (4) to work, it may mean that the SG 
> > has to support a
> > > > > extra PC for its single PC view to the ASs (figure 1 below) 
> > > > or one of its
> > > > > supported PCs needs to be a master to present a single PC 
> > > > view to the ASs
> > > > > (figure 2 below).  I don't care, either way works but it 
> > > > depends on the
> > > > > implementation.
> > > > > 
> > > > > Figure 1
> > > > >                           SG                _________
> > > > >                    +------+------+         (         ) 
> > > > >   +----+           |      | PC-A |--------(           )
> > > > >   | AS |-----------| PC-D |------|       ( SS7 Network )
> > > > >   +----+           |      | PC-B |--------(           )
> > > > >                    +------+------+         (_________)
> > > > > 
> > > > > 
> > > > > Figure 2
> > > > >                           SG                _________
> > > > >                    +------+------+         (         ) 
> > > > >   +----+           |    PC-A     |--------(           )
> > > > >   | AS |-----------|      +------|       ( SS7 Network )
> > > > >   +----+           |      | PC-B |--------(           )
> > > > >                    +------+------+         (_________)
> > > > > 
> > > > > John
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > > Sent: Wednesday, August 08, 2001 1:18 PM
> > > > > > To: sigtran
> > > > > > Subject: Re: M3UA07: Network Appearance
> > > > > > 
> > > > > > 
> > > > > > Hong,
> > > > > > 
> > > > > > John's Option (4) does not work.  M3UA cannot force a single
> > > > > > network attachment view on the SS7 network.  See my example
> > > > > > earlier on this thread which does not include gateway 
> > screening.
> > > > > > 
> > > > > > --brian
> > > > > > 
> > > > > > Hong Liu wrote:                                (Wed, 08 Aug 
> > > > > > 2001 20:31:01)
> > > > > > > Hi, John,
> > > > > > >  
> > > > > > > I also had to  have the air conditioning unit fixed last 
> > > > > > night. It is
> > > > > > > getting hot in NJ area, -:)
> > > > > > >  
> > > > > > > Thanks for the explanation. Option (2) was kind of a kludge 
> > > > > > coming off
> > > > > > > the top of my "sweating" head at the time. I realized that 
> > > > > > there will be
> > > > > > > problems with it...
> > > > > > >  
> > > > > > > I think both of your solutions should work. If I am to pick 
> > > > > > one, I would
> > > > > > > prefer option (4). As for option (5), we are back to the 
> > > > > > initial debate
> > > > > > > about the semantics of "Network Appearance". If I remember 
> > > > > > correctly, a
> > > > > > > number of people on the list would like to use it only 
> > > > to identify
> > > > > > > different networks, not different attachments to the same 
> > > > > > network. As
> > > > > > > long as we agree to extend the semantics to include the 
> > > > > > latter, I see no
> > > > > > > problem making the scenario work. Of course, the texts in 
> > > > > > the spec need
> > > > > > > to be modified in order to accommodate the new semantics.
> > > > > > >  
> > > > > > > Cheers,
> > > > > > >  
> > > > > > > --Hong
> > > > > > > 
> > > > > > 
> > > > > > 
> > > > > > -- 
> > > > > > Brian F. G. Bidulock
> > > > > > [email-masked]
> > > > > > http://www.openss7.org/
> > > > > > 
> > > > > > 
> > > > > > ---
> > > > > > You are currently subscribed to sigtran as: 
> > > > [email-masked]
> > > > > > To unsubscribe send a blank email to 
> > > > > > [email-masked]
> > > > > > 
> > > > > 
> > > > > 
> > > > > ---
> > > > > You are currently subscribed to sigtran as: [email-masked]
> > > > > To unsubscribe send a blank email to 
> > > > [email-masked]
> > > > 
> > > > -- 
> > > > Brian F. G. Bidulock
> > > > [email-masked]
> > > > http://www.openss7.org/
> > > > 
> > > > 
> > > > ---
> > > > You are currently subscribed to sigtran as: 
> > [email-masked]
> > > > To unsubscribe send a blank email to 
> > > > [email-masked]
> > > > 
> > > 
> > > 
> > > ---
> > > You are currently subscribed to sigtran as: [email-masked]
> > > To unsubscribe send a blank email to 
> > [email-masked]
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 
> > 
> > ---
> > You are currently subscribed to sigtran as: [email-masked]
> > To unsubscribe send a blank email to 
> > [email-masked]
> > 
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 9 Aug 2001 11:01:34 -0500

John, since you editted the T1 specs, perhaps you should refresh
your memory by looking at Figure 4/T1.111.1 where it is
explicitly shown that a signalling point may have both the user
function and the transfer function.  The diagram also shows such
a node permiting the network to act in a mix of fully associated
and quasi-associated modes.

My point code 200.1.4 is such a switch: it has the transfer
function as well as the user function.

You are incorrect in your assertions: the diagram is in full
accordance with the standards.

--Brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---