Subject: Non-Existent vs Invalid

From: Jacques Rajchgod <[email-masked]>
Date: Tue, 30 Oct 2001 11:42:25 -0600

I checked some archives (current and September) and then again M3UA-09 for
results of a faulty DE-REG, and still have to ask the question:

Two results for a faulty DE-REG are:

1) Non-Existent RC
2) Invalid RC

From the perspective of a SG, isn't the receipt of an invalid RC - the same
as a non-existing RC? Both result in exact same thing: The DEREG is
denied...

Or does the SG run a check to see whether there is DATA in the RC area vs
empty space and then make a corresponding decision for:

Empty Space -->  Error = Non-existent RC
DATA exists but doesn't match --> Error = Invalid RC

How else does the SG make the distinction and corresponding decision?
The matter is important for groups that design Test Cases...

Thanks,
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-7180
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 30 Oct 2001 12:30:47 -0600

Jacques,

An example of an Invalid RC in response to DEREG REQ is an RC
value that 1) exists, but 2) is an RC that the requesting ASP
has not previously registered for with a successful REG REQ.

--brian

Jacques Rajchgod wrote:                                   (Tue, 30 Oct 2001 11:42:25)
> 
>    I checked some archives (current and September) and then again M3UA-09
>    for results of a faulty DE-REG, and still have to ask the question:
>    
>    
>    
>    From the perspective of a SG, isn't the receipt of an invalid RC - the
>    same as a non-existing RC? Both result in exact same thing: The DEREG
>    is denied...
>    
>    
>    
>    Or does the SG run a check to see whether there is DATA in the RC area
>    vs empty space and then make a corresponding decision for:
>    
>    
>    
>    You are currently subscribed to sigtran as: [email-masked]
>    To unsubscribe send a blank email to
>    [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---