Subject: Re: M2PA association establishment(Apology)

From: [email-masked]
Date: Thu, 18 Oct 2001 10:47:38 +0530

My sincere apologies...this mail was not intended to be sent on the mailing
list.

regards
Harsh

----------------------------------------
Hi Avi,

A threashold may be set for the retries at m2pa level.

But there is no need for a timeout at m2pa level because of the following
mechanism:
Precondition(server socket is not setup)

....
....
...
thanks
harsh

"Avi Chibotaro" <[email-masked]> on 10/18/2001 12:00:53 AM

To:   "Sigtran (E-mail)" <[email-masked]>
cc:   R. C. Monee/HSS@HSS, Manish Sharma/HSS@HSS, Sandeep Mahajan/HSS@HSS,
      "Ruthy Chaouat" <[email-masked]>, "Roie Geron" <[email-masked]>,
      "Ofer Gottfried" <[email-masked]>, "Erez Kirshenbaum"
      <[email-masked]>, Vivek Pachaury/HSS@HSS, Harsh Bhondwe/HSS@HSS

Subject:  M2PA association establishment

Hi all,

When M2PA gets a Power-Up request from its user:

"The client M2PA establishes an association by sending the SCTP
ASSOCIATE primitive to SCTP. The client should attempt to establish
the association periodically until it is successful."
draft-m2pa-03 section 4.1.2.

I think a mechanism should be added to time-out this procedure.

A mechanism, similar to the one used by SCTP, can be embraced.
In such a case, the following definitions would be added:
1. A threshold for the number of association establishment tries.
2. A timer for the period between each association establishment try.

Nevertheless, another mechanism can be added, but I think this issue
must be dealt with.

Best regards,
Avi

Avi Chibotaro
RT Software Engineer
Airslide Systems Inc.
www.airslide.com

---- the invisible revolution ----

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 18 Oct 2001 00:27:53 -0500

Harsh,

Ooops.  Then I shouldn't have responded to it?  Still, your
implementation approach sounds reasonable and the "should"
in the draft should be changed to, say, "could, for example,"
to illustrate that it is implementation dependent.

--brian

[email-masked] wrote:                              (Thu, 18 Oct 2001 10:47:38)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---