Subject: T(r) expity in case of SG, consisting of multople SGPs

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 23 Oct 2001 08:38:25 -0500

Hi   Greg, Javier, John,

It was highly possible that you missed that part so I wanted to resend. Are
there any arguments against this change request?

   Tolga

> >  
> > I agree with you that the sentence "It T(r) expires before 
> an ASP becomes
> > ASP-ACTIVE, the SGP stops queueing messages and discards 
> all previously
> > queued messages." does not make sense too much. I think, if 
> one speaks of a
> > SG consisting of multiple SGPs, inter-SGP communication is 
> unavoidable. What
> > was the objection to change it like what you described (instead of
> > discarding , trying to send it from another SGP)? Why not 
> to change it that
> > way?
> 
> Greg, Javier, John?  Can we change this passage to indicate 
> that the SGP
> can take whatever other course of action is available to it 
> before discarding
> messages?
> 
> 

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 23 Oct 2001 17:32:34 +0200

Hi Tolga, 

I was reading your previous mail...  :-)

It seems the text belongs to the AS-PENDING state description in section 4.3.2. 

Since we are dealing with a per-SGP ASP status maintenance, it could happen that another SGP has the same RK active and traffic allowed. In that sense, I think it would be better to rephrase that sentence as you propose.

What about...

"If T(r) expires before an ASP becomes ASP-ACTIVE, the SGP MAY either take any action before discarding all previously queued messages (e.g. communication with other SGP that could have the same RK active) or stop queuing new messages and discard all of the previously queued ones."

Cheers // Javier.

> -----Original Message-----
> From: Asveren, Tolga [mailto:[email-masked]]
> Sent: Tuesday, October 23, 2001 3:38 PM
> To: sigtran
> Subject: T(r) expity in case of SG, consisting of multople SGPs
> 
> 
> Hi   Greg, Javier, John,
> 
> 
> You are currently subscribed to sigtran as: 
> [email-masked]
> To unsubscribe send a blank email to 
> [email-masked]
> 

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 23 Oct 2001 10:56:03 -0500

Hi Javier,

It is O.K. for me but maybe it is better to say "the same AS active" instead
of "the same RK active", just editorial :)

    Tolga 

> From: Javier Pastor-Balbas (ECE)
> [mailto:[email-masked]]
> Sent: Tuesday, October 23, 2001 11:33 AM
> To: sigtran
> Subject: RE: T(r) expity in case of SG, consisting of multople SGPs
> 
> 
> Hi Tolga, 
> 
> Since we are dealing with a per-SGP ASP status maintenance, 
> it could happen that another SGP has the same RK active and 
> traffic allowed. In that sense, I think it would be better to 
> rephrase that sentence as you propose.
> 
> What about...
> 
> 
> "If T(r) expires before an ASP becomes ASP-ACTIVE, the SGP 
> MAY either take any action before discarding all previously 
> queued messages (e.g. communication with other SGP that could 
> have the same RK active) or stop queuing new messages and 
> discard all of the previously queued ones."
> 
> 
> Cheers // Javier.
> 
> 
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Oct 2001 12:59:05 -0500

Javier,

Javier Pastor-Balbas (ECE) wrote:                     (Tue, 23 Oct 2001 17:32:34)
> Since we are dealing with a per-SGP ASP status maintenance, it could happen
> that another SGP has the same RK active and traffic allowed. In that sense,
> I think it would be better to rephrase that sentence as you propose.
> 
> What about...
> 
> 
> "If T(r) expires before an ASP becomes ASP-ACTIVE, the SGP MAY either take
> any action before discarding all previously queued messages (e.g.
> communication with other SGP that could have the same RK active) or stop
> queuing new messages and discard all of the previously queued ones."

There is no need for an RFC keyword here.  This is not an options really:
it is always up to the SG what it does with these messages and when.
Also, the sentence is cumbersome.  "[T]ak[ing] any action" may result in
no need to "[discard] all previously queued messages".  I think maybe
you mean "instead" instead of "before".  How about:

"If T(r) expires before an ASP becomes ASP-ACTIVE, and the SGP has no
 other alternative, the SGP may stop queueing messages and discard all
 previously queued messages."

> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 24 Oct 2001 09:20:37 +0200

Sounds good to me.  :-D

Cheers // Javier.

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, October 23, 2001 7:59 PM
> To: sigtran
> Subject: Re: T(r) expity in case of SG, consisting of multople SGPs
> 
> 
> Javier,
> 
> > It seems the text belongs to the AS-PENDING state 
> description in section
> > 4.3.2. 
> > 
> it could happen
> MAY either take

---