Subject: M3UA9/SUAv8: Common Parameter IDs

From: [email-masked]
Date: Fri, 26 Oct 2001 13:16:59 +0300

Hi Brian,

> This was already caught per attached on the thread:
> "Common parameters in SUA and M3UA: DATA"

Not exactly - I think that both M3UA & SUA need to pick a new
common ID value as not to conflict with IUA.

0x0013 is free ...

John
 
> --brian
> 
> ARCHIBALD,JOYCE (A-Scotland,ex1) wrote: (Thu, 25 Oct 2001 11:47:19)
> > Hi John,
> > 
> > I expect this is an oversight, but in SUAv8, the common 
> parameter ID 0x0003
> > is defined as the Data parameter, however this ID is 
> already used by M2UA
> > and IUA as 'Interface Identifier (Text)'.
> > 
> > Since the SUA Data parameter is different to any other UA 
> (i.e. it contains
> > the SS7 SCCP-User Application message) it should logically be an
> > SUA-specific parameter.
> > 
> > Cheers,
> > Joyce
> > 
> 
> John Loughney wrote:                          (Tue, 02 Oct 
> 2001 10:50:20)
> > Hi Greg,
> > 
> > > M3UA Data 1 and 2 was already in the M3UA-specific range in 
> > > Issue 8 as its
> > > payload content is different from SUA - I only noticed in 
> > > discussion with
> > > John L that the SUA Data parameter was in the common UA 
> > > assignment range.
> > > (M2UA Data parameter Tags are also on the M2UA-specific 
> > > range.)  So if SUA
> > > moves its assignment to be consistent, then the Tags will be 
> > > completely
> > > self-identifying.   It is true that you could have a common 
> > > Data parameter
> > > and use the message header to tell SUA and M3UA Data 
> > > parameters apart but we
> > > felt this was cleaner.   RC is different in my eyes as it 
> is identical
> > > foramt and content between the UAs (32-bit integer).
> > 
> > I've moved the (SUA) Data parameter to the SUA parameter list.
> > Unless someone tells me a good reason, I don't see a reason
> > to move it back to a common parameter.
> > 
> > John
> > 
> 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to 
> [email-masked]
> 

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 26 Oct 2001 05:22:28 -0500

John,

I thought SUA data parameter was moved to SUA specific parameter
range per your note.  Has this not been done?

--brian

John Loughney wrote:                                         (Fri, 26 Oct 2001 13:16:59)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Fri, 26 Oct 2001 13:30:20 +0300

Hi Brian,

> range per your note.  Has this not been done?

It was done, but after it was done, Greg had suggested that
in M3UA it could be moved to a common parameter.

For me, I could live with either solution - Greg, how do you have it
in M3UA?

John

---

---

From: Greg Sidebottom <[email-masked]>
Date: Fri, 26 Oct 2001 13:18:05 -0400

Hi John,

My apologies - I didn't mean to propose that SUA or M3UA should move to a
common Data parameter, only mused that it was technically possible.  I'd
prefer the Data parameters stay in the UA-specific ranges.

M3UA Data parameter is in the M3UA-specific range (0x210).

Cheers,

   Greg

----- Original Message -----
From: <[email-masked]>
To: "sigtran" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, October 26, 2001 6:30 AM
Subject: RE: M3UA9/SUAv8: Common Parameter IDs

> You are currently subscribed to sigtran as: [email-masked]

---

---

From: [email-masked]
Date: Mon, 29 Oct 2001 12:54:21 +0200

Hi Greg,

> My apologies - I didn't mean to propose that SUA or M3UA 
> should move to a common Data parameter, only mused that it 
> was technically  possible.  I'd prefer the Data parameters 
> stay in the UA-specific ranges.

OK, works for me.

John

---