Subject: M3UA-06: Over-ride and ASPIA

From: Jacques Rajchgod <[email-masked]>
Date: Wed, 03 Oct 2001 12:34:41 -0500

Hi, Sigtran...

We are cutting Test Cases for M3UA-06 and have the following questions:

1) Section 4.3.3.4 of M3UA , about seven paragraphs down, discusses the
OVERRIDE mode of traffic. The section explains that an ASP (ex: A MGC)
takes-over all traffic by commanding "OVERRIDE" mode in a first ASPAC
message. Therafter, that is - after having received a first ASPAC=Over-ride
from someone - the SG sends a NOTIFY-ALTERNATE to all other ASPs under its
control, to notify them that someone has taken-over all traffic and that
because of that, no other entity will receive traffic from that SG until
further notice. At this time, all entities are considered INACT by the SG.
Is this correct? If this is correct, then:

2) Why, in section 4.3.3.5 - second paragraph, is there a statement to
indicate that someone else is liable to send an ASPIA? If everyone has been
notified that traffic has been taken-over (by implication from
NOTIFY-ALTERNATE, as the NOTIFY-ALT can only be sent in a case of Override),
then everybody is already aware that no one can receive traffic. So why
would anyone attempt to sent an ASPIA knowing that no one can receive
traffic?

3) Or:
Is it that despite knowing that traffic cannot ever be received until
further notice, an entity can still send STATE messages such INACT,
ACT...etc...?

4) why would the SG have to ensure that traffic is already stopped at the
out-of-nowhere ASPIA source (2nd paragraph in 4.3.3.5), knowing that it (the
SG) has already notified everyone under its control...?

Please kindly advise...
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-1487
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Wodarz Juergen <[email-masked]>
Date: Thu, 4 Oct 2001 14:30:51 +0200

Hi Jacques,

my understanding of this second paragraph in section 4.3.3.5 is the following situation:
The currently ACTIVE ASP1 wants to deactivate itself by sending an ASPIA, but the SG has already received
an ASPAC(OVERRIDE) from another ASP2. For the SG the ASP1 is now already considered as INACTIVE, but
the NOTIFY(ALTERNATIVE...) and the ASPIA_ACK still has to be sent to ASP1 to fullfill the protocol.
The NOTIFY is the result of the received ASPAC. The ASPIA_ACK the result of the received ASPIA.

Kind regards

	Juergen

> -----Urspr> üngliche Nachricht-----
> Von:	Jacques Rajchgod [SMTP:[email-masked]]
> Gesendet am:	Mittwoch, 3. Oktober 2001 19:35
> An:	sigtran
> Betreff:	M3UA-06: Over-ride and ASPIA
> 
> Hi, Sigtran...
>  
> 1) Section 4.3.3.4 of M3UA , about seven paragraphs down, discusses the OVERRIDE mode of traffic. The section explains that an ASP (ex: A MGC) takes-over all traffic by commanding "OVERRIDE" mode in a first ASPAC message. Therafter, that is - after having received a first ASPAC=Over-ride from someone - the SG sends a NOTIFY-ALTERNATE to all other ASPs under its control, to notify them that someone has taken-over all traffic and that because of that, no other entity will receive traffic from that SG until further notice. At this time, all entities are considered INACT by the SG. Is this correct? If this is correct, then:
>  
> 2) Why, in section 4.3.3.5 - second paragraph, is there a statement to indicate that someone else is liable to send an ASPIA? If everyone has been notified that traffic has been taken-over (by implication from NOTIFY-ALTERNATE, as the NOTIFY-ALT can only be sent in a case of Override), then everybody is already aware that no one can receive traffic. So why would anyone attempt to sent an ASPIA knowing that no one can receive traffic?
>  
> 3) Or:
> Is it that despite knowing that traffic cannot ever be received until further notice, an entity can still send STATE messages such INACT, ACT...etc...?
>  
> 4) why would the SG have to ensure that traffic is already stopped at the out-of-nowhere ASPIA source (2nd paragraph in 4.3.3.5), knowing that it (the SG) has already notified everyone under its control...?
>  
> Please kindly advise...
> 
> Jacques Rajchgod
> MCI Worldcom
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: Jacques Rajchgod <[email-masked]>
Date: Thu, 04 Oct 2001 08:39:15 -0500

So then, it is a matter of timing...? Whereby a race condition would exist
between two competitors:
1) The ASPACT(Override) and...
2) The ASPIA just next to it...?
Whoever got to the SG first would command the appropriate SG response per
your answer?

Thereafter, I would not expect any other ASP to wake-up and say "ASPIA"...Is
this correct?
It looks like if there was a number of pending ASPIAs on their way to the SG
at the very same time as an ASPACT(Override), then there would be a number
of corresponding ACKs being owed, past the ASPACT(Override) so the protocol
is completed?

Also:
If any ASP were to send an ASPIA following a certain time past the
NOTIFY-ALT, the sender of that ASPIA would be violating protocol because it
would not have unbderstood the NOTIFY-ALT? Is that "certain time"
configurable?

Thanks.

Jacques Rajchgod
MCI Worldcom

> -----Original Message-----
> From: Wodarz Juergen [mailto:[email-masked]]
> Sent: Thursday, October 04, 2001 7:31 AM
> To: sigtran
> Subject: AW: M3UA-06: Over-ride and ASPIA
>
>
> Hi Jacques,
>
> The currently ACTIVE ASP1 wants to deactivate itself by sending
> an ASPIA, but the SG has already received
> > 1) Section 4.3.3.4 of M3UA , about seven paragraphs down,
> discusses the OVERRIDE mode of traffic. The section explains that
> an ASP (ex: A MGC) takes-over all traffic by commanding
> "OVERRIDE" mode in a first ASPAC message. Therafter, that is -
> after having received a first ASPAC=Over-ride from someone - the
> SG sends a NOTIFY-ALTERNATE to all other ASPs under its control,
> to notify them that someone has taken-over all traffic and that
> because of that, no other entity will receive traffic from that
> SG until further notice. At this time, all entities are
> considered INACT by the SG. Is this correct? If this is correct, then:
> >
> > 2) Why, in section 4.3.3.5 - second paragraph, is there a
> statement to indicate that someone else is liable to send an
> ASPIA? If everyone has been notified that traffic has been
> taken-over (by implication from NOTIFY-ALTERNATE, as the
> NOTIFY-ALT can only be sent in a case of Override), then
> everybody is already aware that no one can receive traffic. So
> why would anyone attempt to sent an ASPIA knowing that no one can
> receive traffic?
> >
> > 3) Or:
> > Is it that despite knowing that traffic cannot ever be received
> until further notice, an entity can still send STATE messages
> such INACT, ACT...etc...?
> >
> > 4) why would the SG have to ensure that traffic is already
> stopped at the out-of-nowhere ASPIA source (2nd paragraph in
> 4.3.3.5), knowing that it (the SG) has already notified everyone
> under its control...?
> >
> > Please kindly advise...
> >
> > Jacques Rajchgod
> > MCI Worldcom
> > To unsubscribe send a blank email to
> [email-masked]
>
>
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
> [email-masked]
>

---

---

From: Wodarz Juergen <[email-masked]>
Date: Thu, 4 Oct 2001 16:05:49 +0200

Exactly that's it.
Sending an ASPIA after reception of the NOTIFY(ALTERNATIVE...) is not a plausible behaviour, but
it's a long time between transmission at the source and reception at the receiver.
So the ASPIA may have already been sent, when the NOTIFY is received.
It is one of the many situations, which can happen when two protocol sequences occur nearly at
the same time.
I like descriptions of those special situations. They clarify the normal behaviour.

Juergen

> Gesendet am:	Donnerstag, 4. Oktober 2001 15:39
> An:	sigtran
> Betreff:	RE: M3UA-06: Over-ride and ASPIA
> 
> > why would anyone attempt to sent an ASPIA knowing that no one can> 
> > receive traffic?
> > >
> > > 3) Or:

---