Subject: Processor outage - handling by M2PA

From: [email-masked]
Date: Wed, 17 Oct 2001 14:56:32 -0400

M2pa - 03.txt section says; 

4.1.4 Processor Outage

"M2PA should periodically send a Link Status Processor Outage message
as long as there is a local processor outage.

The peer M2PA, upon receiving the Link Status Processor Outage
message, shall report Remote Processor Outage to its MTP3."

Is it not sufficient M2PA indicates only the first time about RPO enter 
indication or it needs to indicate every time it receives the peer 
message?

Please clarify,

-Deepa

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 17 Oct 2001 14:20:11 -0500

Deepa,

Depends only on your MTP L2 state machines.  Some require continuous
RPO signal, some do not.

--brian

[email-masked] wrote:                        (Wed, 17 Oct 2001 14:56:32)
>    Is it not sufficient M2PA indicates only the first time about RPO
>    enter indication or it needs to indicate every time it receives the
>    peer message?
>    Please clarify,
>    -Deepa --- You are currently subscribed to sigtran as:
>    [email-masked] To unsubscribe send a blank email to
>    [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 18 Oct 2001 10:09:00 +0530

Hi Deepa,
 I am agree with brian, but here i have a doubt .Suppose M2PA
sees LPO  when it is in OOS (and association is established).
and as draft says "M2PA should periodically send a
Link Status Processor Outage message as long as
there is a local processor outage."
So do we have to send LPO to peer if we are in OOS also.
Will the peer entertain this message in OOS state.(see that is all
implementation
dependent).

brian and tomG please clarify.

regards
Manish

"Brian F. G. Bidulock" <[email-masked]> on 10/18/2001 01:50:11 AM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:   [email-masked] (bcc: Manish Sharma/HSS)

Subject:  Re: Processor outage - handling by M2PA

Deepa,

--brian

[email-masked] wrote:                        (Wed, 17 Oct 2001
14:56:32)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 18 Oct 2001 00:22:54 -0500

Manish,

An SS7 link does not send SIPO when it is out of service
and LPO is set: it sends SIOS.  I don't see any reason
why M2PA should act differently.

For a reference see Q.781 Test Cases 1.8(a) and 1.8(b).

[email-masked] wrote:                                (Thu, 18 Oct 2001 10:09:00)
> there is a local processor outage."

As we have just asked for Out of Service Status Indication to
be added, we should probably also change this statement to:

 "M2PA should periodically send a Link Status Processor
  Outage message when the link is otherwise in service
  and there is a local processor outage condition."

Changes might be required to the state diagram.  Changes need
to be made to this diagram to add the processor outage state.

> So do we have to send LPO to peer if we are in OOS also.

Not if we follow what an SS7 link does.  We should send OOS.

> Will the peer entertain this message in OOS state. (see that
> is all implementation dependent).

Normally for an SS7 link receiving SIPO means that the link
is otherwise in service (has completed alignment and proving)
but there is a remote processor outage condition.  The processor
referred to here, by the way, is the L3 processor.

> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Thu, 18 Oct 2001 11:06:03 +0530

But brian draft does not say this.

"Brian F. G. Bidulock" <[email-masked]> on 10/18/2001 11:52:54 AM

Manish,

[email-masked] wrote:                                (Thu, 18 Oct 2001
10:09:00)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: Tom George <[email-masked]>
Date: Mon, 22 Oct 2001 15:38:40 -0500

I think the text is OK on this point, unless someone thinks this needs
to be clarified. Brian's comment is correct - this is an implementation
matter. 

tomG. 

-- 
* Tom George        972-519-3168         [email-masked]   *
* PB2-1323       Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel USA, Inc.; 1000 Coit Rd, MS PB2-STPA; Plano TX 75075-5813   *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *

---

---

From: Tom George <[email-masked]>
Date: Mon, 22 Oct 2001 15:54:35 -0500

If I add the Out of Service state to M2PA  (very likely) in draft 4,
this issue will need to be addressed. I think we want to imitate MTP2,
so M2PA would send Link Status Out of Service when there is a Processor
Outage while the link is out of service. 

tomG.

"Brian F. G. Bidulock" wrote:
> 
> Manish,
> 
> I suppose that's why we call it a draft.  There are a lot of
> issues outstanding from M2PA v2 which have not been addressed
> in M2PA v3.  M2PA v3 has some new issues, but the WG has been
> more focussed on M3UA and SUA which are ahead of M2PA in the
> work queue.
> 
> Tom?
> 
> --brian
> 
> [email-masked] wrote:                                (Thu, 18 Oct 2001 11:06:03)
> >
  [...]

---

---

From: [email-masked]
Date: Tue, 23 Oct 2001 03:04:44 +0530

Thanks Tom ,
       Adding out Of service as message will give lot of clarity to m2pa.
thanks again
regards
Manish

Tom George <[email-masked]> on 10/23/2001 03:24:35 AM

To:   "sigtran" <[email-masked]>
cc:    (bcc: Manish Sharma/HSS)

tomG.

> [email-masked] wrote:                                (Thu, 18 Oct 2001
11:06:03)
  [...]

---

---