Subject: M2PA - Protocol Identifier

From: [email-masked]
Date: Thu, 4 Oct 2001 12:40:41 -0500

Hello M2PA

The M2PA protocol identifier is not specified by the current draft (V03). 
Michael Tuexens ethereal modul for M2PA specifies 5. I recommend to use 
that for the upcomming bkoff. The spec also mentions that is subject to 
IANA, but it is not. Only the port numbers are defined by IANA.

note other Protocol Id's:

M2UA 0x10
M3UA 3
SUA    4

Michael Tuexen,

are you currently working on packet-m2pa.c updating to version 3? If not, 
we (Deepa Tonse and I) volunteer to do so.

Heinz

PS: apologies if anything mentioned here has been discussed on the list 
already. I was cut off the list for several weeks. Lyris must have dropped 
me and others in our company.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Joe Keller <[email-masked]>
Date: Thu, 4 Oct 2001 13:57:29 -0400

Heinz,

    I don't understand your comment about IANA.
M2PA is defined as 5 in the SCTP parameters document.

http://www.iana.org/assignments/protocol-numbers

Joe

[email-masked] on 10/04/2001 01:40:41 PM

Please respond to [email-masked]

To:   "sigtran" <[email-masked]>
cc:   [email-masked] (bcc: Joe Keller/Raleigh/TEKELEC)
Subject:  M2PA - Protocol Identifier

Hello M2PA

M2UA 0x10
M3UA 3
SUA    4

Michael Tuexen,

Heinz

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 4 Oct 2001 20:06:11 +0200

Dear all,

the right URL is

http://www.iana.org/assignments/sctp-parameters

I think it is OK, that such numbers are not mentioned in RFCs.
For example, RFC 2960, does not mention, that 132 is as an identifier
for SCTP.

Best regards
Michael

On Thursday, October 4, 2001, at 07:57  Uhr, Joe Keller wrote:

> You are currently subscribed to sigtran as: 
> [email-masked]
> To unsubscribe send a blank email to leave-
> [email-masked]
>
[email-masked]

---

---

From: Michael Tuexen <[email-masked]>
Date: Thu, 4 Oct 2001 20:01:29 +0200

Dear Heinz, Dear all,

I'm not the author of the M2PA module. The header of packet-m2pa.c reads

/* packet-m2pa.c
  * Routines for MTP2 Peer Adaptation Layer dissection
  * It is hopefully (needs testing) compliant to
  * http://www.ietf.org/internet-drafts/draft-ietf-sigtran-m2pa-02.txt
  *
  * Copyright 2001, Jeff Morriss <jeff.morriss[AT]ulticom.com>
...
*/

So you should contact the author directly or submit a unified diff file
to the ethereal development list which is available under  
http://www.ethereal.com/mailman/listinfo/ethereal-dev

The participants of the bakeoff have to use a nighly build, because I'm
not sure that a new release will be available before the bakeoff. Another
possibility is to distribute the file packet-m2pa.c among the 
participants
and recompile the code. This might be easier if you have not a full 
installed
development machine.

If you have any problems feel free to contact me.

Best regards
Michael

On Thursday, October 4, 2001, at 07:40  Uhr, [email-masked] 
wrote:

>
> Hello M2PA
>
> The M2PA protocol identifier is not specified by the current draft 
> (V03). Michael Tuexens ethereal modul for M2PA specifies 5. I recommend 
> to use that for the upcomming bkoff. The spec also mentions that is 
> subject to IANA, but it is not. Only the port numbers are defined by 
> IANA.
>
> are you currently working on packet-m2pa.c updating to version 3? If 
> not, we (Deepa Tonse and I) volunteer to do so.
>
> Heinz
>
> already. I was cut off the list for several weeks. Lyris must have 
> dropped me and others in our company. --- You are currently subscribed 
> to sigtran as: [email-masked] To unsubscribe send a 
> blank email to [email-masked]

---

---

From: [email-masked]
Date: Thu, 4 Oct 2001 16:34:20 -0400

Thank You Jeff,

We will start modifying your packet-m2pa.c. There is no hurry now to 
submit it to ethereal. We will distribute the updated sniffer to the 
bakeoff participants - as suggested by Michael Tuexen. I suggested to have 
different protocol Identifiers for version 2 and version 3 - again, that 
is only for the bakeoff (which is eof october). The *bkoff-ethereal * will 
support both versions. Ultimatly, Ulticom may want to consider to upgrade 
to version 3 (or 4?)

Hope you dont mind I cc'd to the sigtran list.

Cheers, Heinz

Jeff Morriss <[email-masked]>
10/04/01 03:26 PM

        To:     [email-masked]
        cc: 
        Subject:        Re: M2PA - Protocol Identifier

Hello Heinz,

Actually I found out that Draft 3 was out only fairly recently. 
Updating the M2PA dissector to draft 3 is on my (quite long) list of
things to do, but I don't know (can't guarantee) that I'll be able to
before the bakeoff (of course, I don't know when the bakeoff is, either,
but...).

Also, I must admit that my primary purpose in writing the dissector was
to be able to better support our M2PA product (which is compliant to
draft 2), so my "inspiration" isn't as high as it could be.  ;)

If you want/need, go ahead and do the update.  Unfortunately the draft
versions don't appear to be compatible which of course means that once
the update is done it won't really work for draft 2 any more (unless an
option is put in to select the version), but hey...  Such is the life of
changing specs!

Regards,
-Jeff

[email-masked] wrote:
> 
> Jeff,
> 
> Not only the authorship, but then mis-spelled the name....
> 
> please see below
> 
> ----- Forwarded by Heinz Prantner/Radisys_Corporation/US on 10/04/01
> 03:06 PM -----
>   Heinz Prantner
>                             To:        [email-masked]
>   10/04/01 01:40 PM         cc:
>                             Subject:        Re: M2PA - Protocol
>                     Identifier
> 
> Jeff,
> 
> sorry for goofing the authorship (below). Are you planning to support
> m2pa version 3 for the bakeoff?
> 
> Heinz
> 
> ----- Forwarded by Heinz Prantner/Radisys_Corporation/US on 10/04/01
> 02:55 PM -----
>  Michael Tuexen
>  <[email-masked]>          To:        "sigtran"
>                                      <[email-masked]>
>  10/04/01 01:01 PM                           cc:
>  Please respond to sigtran            [email-masked]
>                                              Subject:        Re: M2PA -
>                                      Protocol Identifier
> 
> Dear Heinz, Dear all,
> 
> You are currently subscribed to sigtran as: [email-masked]