Subject: M3UA V9: Routing Key Parameter

From: Angermayr Manfred <[email-masked]>
Date: Thu, 11 Oct 2001 12:05:07 +0200

Hello!
I'm a little bit confused about the picture of the Routing Key Parameter (page 50). 
According to chapter 1.2 a Routing Key cannot extend accross more than a single SPMC. 
An SPMC is a set of Application Servers represented to the SS7 network under a single SPC in one specific Network Appearance.
Therefore an RK can not contain more than one DPC within exactly one network.
In the picture of the RK parameter however not only the DPC but also the NA can be found more than once. This is not correct. If the ASP wants to register an additional DPC it has to use a second RK parameter.

Best regards,
Manfred Angermayr

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 14 Oct 2001 17:42:15 -0500

Manfred,

We had decided to let SPMC's span SPCs.  The reason that one will want
multiple SPCs per SPMC is where "alias" SPCs have been assigned to a
single MTP entity.  The SPMC is still a single MTP entity from a manaement
view and thus is a single SPMC.  It just has multiple point codes.

However, you are correct in that it was never intended that an SPMC span
network appearances.  "Alias" point codes are assigned within a single
newtork.  It is essential that RC not span SPMC and not span NA.  Multiple
NA in RK needs to be deleted.  This was discussed in detail at last call.

Therefore, RK should be able to contain more than one DPC but no more
than one NA.  The draft needs to be changed to reflect this.

--brian

Angermayr Manfred wrote:                       (Thu, 11 Oct 2001 12:05:07)
>
> Hello!
>
> I'm a little bit confused about the picture of the Routing Key Parameter
> (page 50).  According to chapter 1.2 a Routing Key cannot extend accross
> more than a single SPMC.  An SPMC is a set of Application Servers
> represented to the SS7 network under a single SPC in one specific Network
> Appearance.  Therefore an RK can not contain more than one DPC within
> exactly one network.  In the picture of the RK parameter however not only
> the DPC but also the NA can be found more than once. This is not correct. If
> the ASP wants to register an additional DPC it has to use a second RK
> parameter.
> 
> Best regards,
> Manfred Angermayr
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Angermayr Manfred <[email-masked]>
Date: Tue, 16 Oct 2001 09:53:40 +0200

Brian,
thanks for the clarification!

Not only the multiple NAs must be deleted from the RK, but also the SPMC definition in chapter 1.2. should be updated.

Regards,
Manfred

-----Ursprüngliche Nachricht-----
Von: Brian F. G. Bidulock [mailto:[email-masked]]
Gesendet: Montag, 15. Oktober 2001 00:42
An: sigtran
Betreff: Re: M3UA V9: Routing Key Parameter

Manfred,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 16 Oct 2001 03:12:54 -0500

Manfred,

What did you think needed updating in the definition of SPMC?  It was already
changed from v7 or so to v8 to read "Signalling Point" and "MTP Entity"
instead of "Point Code".  As it stands, the SPMC is a single MTP Entity (which
is must be) and a single Signalling Point (which is must be), but it is
not restricted to a single Point Code as it was in previous versions.

Could you point out a problem with the existing definition of SPMC?

--brian

Angermayr Manfred wrote:                                (Tue, 16 Oct 2001 09:53:40)
> Not only the multiple NAs must be deleted from the RK, but also the SPMC
> definition in chapter 1.2. should be updated.
> 
> Regards,
> Manfred
> 
> To unsubscribe send a blank email to [email-masked]
> 
> 
> ---
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Angermayr Manfred <[email-masked]>
Date: Tue, 16 Oct 2001 10:45:05 +0200

Hello Brian,
it seems to be, that I have problems with the terms 'MTP entity' respectively 'Signalling Point'. For me it was clear, that a 'Signalling Point' has exactly 1 point code. Perhaps such mis-interpretations could be avoided, if it is explicitly mentioned, that a Signalling Point can be referenced by the alias point codes as well as by the primary point code.
Maybe the 'Signalling Point' should be also explained as a separate point in chapter 1.2.

Regards,
Manfred

-----Ursprüngliche Nachricht-----
Von: Brian F. G. Bidulock [mailto:[email-masked]]
Gesendet: Dienstag, 16. Oktober 2001 10:13
An: sigtran
Betreff: Re: M3UA V9: Routing Key Parameter

Manfred,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 16 Oct 2001 04:01:12 -0500

Manfred,

Angermayr Manfred wrote:                                (Tue, 16 Oct 2001 10:45:05)
>
> Hello Brian,
>
> it seems to be, that I have problems with the terms 'MTP entity'
> respectively 'Signalling Point'. For me it was clear, that a 'Signalling
> Point' has exactly 1 point code.

SS7 does not define a signalling point as having exactly one point code.
Why do you think the DPC is given to the MTP-User in the MTP-TRANSFER
primitive?  If a MTP entity can only have one point code then that would
be a very redundant argument.

It is clear from recommendations concerning GT functions in STPs that
a associated pair of STPs can be given an "alias" point code which they
share between them to address the GTT (relay) function.  This means that
it is indeed possible that an MTP Entity have more than one point code.

Providing alias or multiple point codes for SSP is a matter of course and
is normal practice, far from such a radical exception.

> Perhaps such mis-interpretations could be avoided, if it is explicitly
> mentioned, that a Signalling Point can be referenced by the alias point
> codes as well as by the primary point code.  Maybe the 'Signalling Point'
> should be also explained as a separate point in chapter 1.2.

I don't think that the draft needs to explaing SS7 to the reader.  It would
have to be much longer to achieve that.  More than one point code per SPMC
is obviously an "alias" as it does not affect management of the MTP Entity.

It is also possible to have multiple MTP Entities in the SPMC if they can
be treated as one from a management view.  Of course this can only be done
if they are equally connected to the SS7 network.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Greg Sidebottom <[email-masked]>
Date: Tue, 16 Oct 2001 15:54:22 -0400

Hi Brian, Manfred

See below ...

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Sunday, October 14, 2001 6:42 PM
Subject: Re: M3UA V9: Routing Key Parameter

> NA in RK needs to be deleted.  This was discussed in detail at last call.

[Greg] Yes this is correct.  It is my mistake - I was looking at an email
from Maria-Cruz that showed RK pictures with both possibilities (with and
without multiple NA parameters) and I referenced the wrong one while
editing.  I have removed the second Network Appearance parameter in the
picture.

Thanks,

   Greg

> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to
[email-masked]

---