Subject: SUAv8: Common Parameter IDs

From: "ARCHIBALD,JOYCE (A-Scotland,ex1)" <[email-masked]>
Date: Thu, 25 Oct 2001 11:47:19 +0200

Hi John,

I expect this is an oversight, but in SUAv8, the common parameter ID 0x0003
is defined as the Data parameter, however this ID is already used by M2UA
and IUA as 'Interface Identifier (Text)'.

Since the SUA Data parameter is different to any other UA (i.e. it contains
the SS7 SCCP-User Application message) it should logically be an
SUA-specific parameter.

Cheers,
Joyce

==================================================================
Joyce Archibald, TSD R&D     | Phone:    +44 (0) 131 3317521 
Agilent Technologies UK Ltd  | Telnet:   313 2521
South Queensferry,           | Mailstop: SQFRD3A
EH30 9TG, Scotland.          | E-mail: [email-masked]
==================================================================

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 25 Oct 2001 04:57:23 -0500

Joyce,

This was already caught per attached on the thread:
"Common parameters in SUA and M3UA: DATA"

--brian

ARCHIBALD,JOYCE (A-Scotland,ex1) wrote: (Thu, 25 Oct 2001 11:47:19)
> the SS7 SCCP-User Application message) it should logically be an

John Loughney wrote:                          (Tue, 02 Oct 2001 10:50:20)
> Hi Greg,
> 
> > M3UA Data 1 and 2 was already in the M3UA-specific range in 
> > Issue 8 as its
> > payload content is different from SUA - I only noticed in 
> > discussion with
> > John L that the SUA Data parameter was in the common UA 
> > assignment range.
> > (M2UA Data parameter Tags are also on the M2UA-specific 
> > range.)  So if SUA
> > moves its assignment to be consistent, then the Tags will be 
> > completely
> > self-identifying.   It is true that you could have a common 
> > Data parameter
> > and use the message header to tell SUA and M3UA Data 
> > parameters apart but we
> > felt this was cleaner.   RC is different in my eyes as it is identical
> > foramt and content between the UAs (32-bit integer).
> 
> I've moved the (SUA) Data parameter to the SUA parameter list.
> Unless someone tells me a good reason, I don't see a reason
> to move it back to a common parameter.
> 
> John
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---