Subject: Redundancy of errors in 3.8.1

From: Jacques Rajchgod <[email-masked]>
Date: Tue, 23 Oct 2001 15:36:42 -0500

M3UA-09, Page 61, section 3.8.1:

There is a redundancy in error messages: Either "PROTOCOL_ERROR" is
not needed, or UNEXPECTED message is not needed.
UNEXPECTED message already takes care of INCORRECT PROTOCOL.

Consider this:

1) "Unexpected Message" -- def(inition) is "....not expected in current
state".
2) "Protocol Error" -- def is "....not expected in current state".

Both are "....messages not expected in current state".

Also, since these two message s are not further defined by a Diagnostic
byte,
it will not be possible to differentiate between the two errors. Reality is
that
functionally, "Unexpected Message" is the exact same as "Protocol Error" and
vice-versa...
But to be accurate, "PROTOCOL_ERROR" is the right message - not "UNEXPECTED
message".

PROTOCOL_ERROR is standard across the industry and covers both  - messages
in wrong state and wrong params.
Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-7180
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Jacques Rajchgod <[email-masked]>
Date: Fri, 26 Oct 2001 09:29:47 -0500

Resend...
Would appreciate prevailing thoughts...Thanks.

 -----Original Message-----
From: Jacques Rajchgod [mailto:[email-masked]]
Sent: Tuesday, October 23, 2001 3:37 PM
To: sigtran
Subject: Redundancy of errors in 3.8.1

Consider this:

---