Subject: M2UA/M3UA/SUA: Redundancy of errors in 3.8.1

From: [email-masked]
Date: Mon, 29 Oct 2001 13:32:47 +0200

Jacques,
 
I have not problem about using 'PROTOCOL ERROR' only.  However,
we should bake it consistant across all UAs.
 
Greg & Ken, what do you think?
 
John

-----Original Message-----
From: ext Jacques Rajchgod [mailto:[email-masked]]
Sent: 26 October, 2001 17:30
To: sigtran
Subject: FW: Redundancy of errors in 3.8.1

 Resend...
Would appreciate prevailing thoughts...Thanks.
 
 -----Original Message-----
From: Jacques Rajchgod [mailto:[email-masked]] 
Sent: Tuesday, October 23, 2001 3:37 PM
To: sigtran
Subject: Redundancy of errors in 3.8.1

M3UA-09, Page 61, section 3.8.1:
 
There is a redundancy in error messages: Either "PROTOCOL_ERROR" is 
not needed, or UNEXPECTED message is not needed.
UNEXPECTED message already takes care of INCORRECT PROTOCOL.
 
Consider this:
 
1) "Unexpected Message" -- def(inition) is "....not expected in current
state".
2) "Protocol Error" -- def is "....not expected in current state".
 
Both are "....messages not expected in current state".
 
Also, since these two message s are not further defined by a Diagnostic
byte, 
it will not be possible to differentiate between the two errors. Reality is
that 
functionally, "Unexpected Message" is the exact same as "Protocol Error" and
vice-versa...
But to be accurate, "PROTOCOL_ERROR" is the right message - not "UNEXPECTED
message".
 
PROTOCOL_ERROR is standard across the industry and covers both  - messages
in wrong state and wrong params.

Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-7180
E-mail: [email-masked] 

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked] 

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Jacques Rajchgod <[email-masked]>
Date: Mon, 29 Oct 2001 09:58:00 -0600

Thanks, John.

Indeed. this is the proper manner to handle wrong states.
I would also recommend that the particular sections dealing with incorrect
states, where "unexpected message" is explained, such as section 3.8.1 page
61 M3UA-09, be edited and that only "Protocol Error" be mentioned. I guess
we would need to do a "Global" in that doc to ensure consistency. And, yes-
"Protocol Error" must be consistant across all docs, as States are States
everywhere regardless of industry products.

My appreciation.

Jacques Rajchgod
MCI Worldcom

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]
  Sent: Monday, October 29, 2001 5:33 AM
  To: sigtran
  Subject: M2UA/M3UA/SUA: Redundancy of errors in 3.8.1

  Jacques,

  John
    -----Original Message-----
    From: ext Jacques Rajchgod [mailto:[email-masked]]
    Sent: 26 October, 2001 17:30
    To: sigtran
    Subject: FW: Redundancy of errors in 3.8.1

     Resend...

     -----Original Message-----
    From: Jacques Rajchgod [mailto:[email-masked]]
    Sent: Tuesday, October 23, 2001 3:37 PM
    To: sigtran
    Subject: Redundancy of errors in 3.8.1

    Consider this:

    Also, since these two message s are not further defined by a Diagnostic
byte,
    it will not be possible to differentiate between the two errors. Reality
is that
    functionally, "Unexpected Message" is the exact same as "Protocol Error"
and vice-versa...
    But to be accurate, "PROTOCOL_ERROR" is the right message - not
"UNEXPECTED message".

    PROTOCOL_ERROR is standard across the industry and covers both  -
messages in wrong state and wrong params.
    Jacques Rajchgod
    MCI Worldcom
    Next Generation System Evaluation
    Tel: [972] 729-7180
    E-mail: [email-masked]

    ---
    You are currently subscribed to sigtran as: [email-masked]
    To unsubscribe send a blank email to
[email-masked]
  ---
  You are currently subscribed to sigtran as: [email-masked]
  To unsubscribe send a blank email to
[email-masked]

---