Subject: Data Traffic from ASP

From: [email-masked]
Date: Mon, 29 Oct 2001 19:22:35 +0530

Hi...

Section 4.3.4.4 of M3UA Draft v9 says that
"The ASP SHOULD NOT send Data messages for the related Routing Context(s) before

receiving an ASP Active Ack message, or it will risk message loss."

Consider the Scenario where the ASP is in Inactive state in the SG. The ASP has
received a
DAVA for Point Code X. At this time, the ASP should be able to send all Data for
PC X from its
users to the SG, irrespective of whether it is active in the corresponding AS
(reverse RK).
This is because the DAVA from SG implies that the SG can relay all Data for PC X
to the SS7 destination.
So how is there a Message Loss Risk ?

          -------------                                 --------------
         |    SG       |                               |              |
      -- |             |     DAVA for PC X ->          |              |
   SS7-- |             |<------------------------------|    ASP       |
      -- |             |  <- Data for PC X             | (State INAC) |
          -------------                                 --------------

   Regards
   Anshoo.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 29 Oct 2001 08:09:37 -0600

Anshoo,

The SG shouldn't be sending DAVA to an inactive AS.  (DAVA
has an RC in the message, and the SG won't send DAVA for
inactive RCs.)

ASPAC is sent by the ASP to indicate that it wants to
send traffic to the SG for a particular AS.  (DATA has an
RC in the message, and the SG will reject DATA with an
inactive RC in the message.)

This is the ASPTM procedures.  SNMM are not used for
ASP Traffic Management.

--brian

[email-masked] wrote:                            (Mon, 29 Oct 2001 19:22:35)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Mon, 29 Oct 2001 20:15:21 +0530

Hi Brian,

Thanks for the clarification, but...
The Draft says that SG sends SSNM to all the Inactive ASPs in
the AS that are in the same Network Appearance as the SSNM.

Section 4.5.1 Draft v9 says that...
"The SGP M3UA layer determines the set of concerned ASPs to be informed
based on the specific SS7 network for which the primitive indication
is relevant. In this way, all ASPs configured to send/receive traffic
within a particular network appearance are informed.  If the SGP
operates within a single SS7 network appearance, then all ASPs are
informed. "

The RC in SSNM as well as DATA is optional is optional, so rejecting Data
on the basis of Inactive RC at the SG is not always possible.

Moreover if the destination point code is reachable through SG then
there is no need for SG to check for RC/AS State?

Thanks
Anshoo.

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Monday, October 29, 2001 7:39 PM
Subject: Re: Data Traffic from ASP

Anshoo,

--brian

[email-masked] wrote:                            (Mon, 29 Oct 2001
19:22:35)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 29 Oct 2001 08:57:37 -0600

Anshoo,

[email-masked] wrote:                            (Mon, 29 Oct 2001 20:15:21)
> the AS that are in the same Network Appearance as the SSNM.

Needs to be updated to reflect agreement on MTP-Restart
procedures which includes not sending SNMM to inactive AS.

--brian

> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Anshoo Sharma <[email-masked]>
Date: Tue, 30 Oct 2001 14:44:23 +0530

Brian,

This would imply that there would be RK Analysis
at the ASP for sending the Data.
When the ASP receives the Data from the Local User,
it would find the SGPs through which the DPC in Data is
reachable ,then it would need to parse the
Routing Label to find an AS with the Reverse Routing Key
and check the state of the ASP in this RC and in the SGP
to which this Data is being sent.
The Data is sent only if the the State of the AS is Active.
should be clearly defined in the Draft.

Also the Draft should clearly specify the method for finding
the AS with the Reverse Routing Key. There might be cases where
this can get tricky (for e.g. RK type DPC + SSN when there isn't
any SSN (in some cases) in the messages from the ASP side).

Regards
Anshoo.

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Monday, October 29, 2001 8:27 PM
Subject: Re: Data Traffic from ASP

> [email-masked] wrote:                            (Mon, 29 Oct 2001
20:15:21)
> > > "The ASP SHOULD NOT send Data messages for the related Routing
Context(s)
> > before
> > > Consider the Scenario where the ASP is in Inactive state in the SG.
The ASP
> > has
> > > received a
> > > DAVA for Point Code X. At this time, the ASP should be able to send
all Data
> > for
> > > This is because the DAVA from SG implies that the SG can relay all
Data for PC
> >  X
> > >          |    SG       |                               |
|

---

---

From: [email-masked]
Date: Tue, 30 Oct 2001 14:57:35 +0530

Brian,

Regards
Anshoo.

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Monday, October 29, 2001 8:27 PM
Subject: Re: Data Traffic from ASP

20:15:21)
Context(s)
The ASP
all Data
Data for PC
|

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Tue, 30 Oct 2001 07:35:54 -0600

Hi ,
Please see comments below.

   Tolga

> -----Original Message-----
> From: Anshoo Sharma [mailto:[email-masked]]
> Sent: Tuesday, October 30, 2001 4:14 AM
> To: sigtran
[TOLGA] On ASP side, you somehow should fill RC for outgoing messages. The
method you are describing is only one of the options. It is implementation
dependent, how to figure out the RC value. So, that RC is to be found is
already required to fill it in DATA.
> any SSN (in some cases) in the messages from the ASP side).
[TOLGA] I disagree that the draft should say how to find out RK. This is
implementation dependent. And if you rimplementation has problems with
ceratin route key types (e.g. DPC + SSN) then you should look for other
alternatives (like changing your implementation or using SUA )
> > > The RC in SSNM as well as DATA is optional is optional, 
> so rejecting
> Data
> > > [email-masked] wrote:                            
> (Mon, 29 Oct
> 2001
> > > 19:22:35)
> > > >
> > > >
> > > >
> > > > Hi...
> > > >
> > > >       -- |             |  <- Data for PC X             
> | (State INAC)
> You are currently subscribed to sigtran as: [email-masked]

---

---

From: [email-masked]
Date: Wed, 31 Oct 2001 11:04:40 +0530

Hi Tolga,

Pls see comments inline...

Regards
Anshoo.

----- Original Message -----
From: "Asveren, Tolga" <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Tuesday, October 30, 2001 7:05 PM
Subject: RE: Data Traffic from ASP

> > should be clearly defined in the Draft.
  [ANSHOO] You are right... we somehow do need to find the RC, but the only way
           for doing this can be a Reverse Routing Key Analysis. I can't think
           of any other way to do that.
           This would require a lot of processing on the ASP side and then
           again on the SG side for RC State Validation.
           Can you please explain... as to why do we need this.
           In my understanding if a PC is reachable through the SG, it means the
           SG can relay the DATA to the Destination PC. So, at the ASP side we
           find the SG through which the PC is reachable and dispatch the DATA
           without bothering about the RC State in that SG/SGP.
> > (Mon, 29 Oct 2001

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 31 Oct 2001 10:17:37 -0600

Hi Anshoo,

Please see comments below....

   Tolga

> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, October 31, 2001 12:35 AM
> To: sigtran
[TOLGA] I can think :) If you use different interfaces for different RKs,
between M3UA and user of M3UA (this approach is first mentioned by Brian,
not my invention :) ), just from the interface a message is coming, you can
know RK. This was discussed long before deciding to put RC in DATA.
>            without bothering about the RC State in that SG/SGP.
[TOLGA] For me, the main reason is to make communication path between two
signalling points either on in both directions or off in both directions.
Otherwise you can have unidirectional traffic. And also, please note that
SSNM is per SG, not per SGP. You use information whether a point code is
reachable via a SG  or not to select SG, then you need ASPTM (whihc is per
SGP) information, to choose among SGPs.
> > > > > >    SS7-- |             
> |<------------------------------|    ASP
> > > |
> > > > > >       -- |             |  <- Data for PC X
> > > | (State INAC)
> > > |
> > > > > >           -------------
> > > --------------
> > > > > >
> > > > > >
> > > > > >
> > > > > >    Regards
> > > > > >    Anshoo.
> > > > > >
> > > > >
> > > > > --
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > >
> > > > >
> > > > > ---

---