Subject: m2pa interop test case

From: [email-masked]
Date: Mon, 8 Oct 2001 11:50:05 +0530

hi all,
             I think the test case A3 is not conforming M2PA draft03.
 test case A3
 "Align a link between two nodes. Have one side send a Stop to M2PA.
  Use a packet sniffer to watch for the ABORT of the SCTP association.
  Link should go back to OOS on both ends. This test should be done
  before any data is transmitted as changeover is covered in a later test.
  The test driver should be set so that it doesn't attempt an automatic
changeover."

  As draft 03 says for STOP primitive "deactivate link" This does not mean
making the association down.
  because START primitive "activate link"means starts Alignment procedure. So
when M2PA gets STOP from MTP3 it will take link to OutOf Service
  but it will not close the association.

   please clarify

    regards
    Manish Sharma

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 8 Oct 2001 02:14:07 -0500

Manish,

I agree, the association should not ABORT under M2PA-03.

--brian

[email-masked] wrote:                                (Mon, 08 Oct 2001 11:50:05)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: [email-masked]
Date: Tue, 16 Oct 2001 14:11:38 +0530

hi Brian,
              But draft03 says in section4.2.3
"4.2.3  Link deactivation
When MTP3 requests that M2PA deactivate a link by a Stop command, M2PA
shall send an ABORT primitive to SCTP."

I am not at all getting this insted of this Link state OOS message should be
there. The Stop Link should not close the assocation.
                                                                                                                    
So to make the m2pa in sink the link state OutOfService message should be added
in and 4.2.3 section should be changed.

TOM please break the silence.

regards
Manish Sharma

"Brian F. G. Bidulock" <[email-masked]> on 10/16/2001 02:48:50 PM

Please respond to [email-masked]

To:   Manish Sharma/HSS@HSS
cc:   Tom George <[email-masked]>

Subject:  Re: m2pa interop test case

Manish,

You are correct.  M2PA needs a Link Status - Out of Service.

--brian

On Tue, 16 Oct 2001, [email-masked] wrote:

>
>
> hi brian,
> but in m2pa we don't have any message to tell peer that we are in
> OOS except we take association DOWN. How to convey this message to peer
> that my m2pa is in OOS.
>
> regards
> manish
>
>
>
>
> "Brian F. G. Bidulock" <[email-masked]> on 10/16/2001 01:52:51 PM
>
> Please respond to [email-masked]
>
> To:   Manish Sharma/HSS@HSS
> cc:
>
> Subject:  Re: m2pa interop test case
>
>
>
>
> Manish,
>
> What does the other side care if our side is in retrieval or not.  Even a
> real SS7 link only knows that the far side is OOS, (SIOS) it never knows
> when the other side is in retrieval.
>
> In the SS7 case, the link would not normally attempt to align before
> given the start signal (and would stay SIOS).
>
> Does that help?
>
> --brian
>
> On Tue, 16 Oct 2001, [email-masked] wrote:
>
> >
> >
> > hi brian,
> > i would like to know if we should not ABORT the association
> > how peer side come to know that i am in retrival or in OOS.
> >
> > regards
> > Manish
> >
> >
> >
> >
> > "Brian F. G. Bidulock" <[email-masked]> on 10/08/2001 01:44:07 PM
> >
> > Please respond to [email-masked]
> >
> > To:   Manish Sharma/HSS@HSS
> > cc:   sigtran <[email-masked]>
> >
> > Subject:  Re: m2pa interop test case
> >
> >
> >
> >
> > Manish,
> >
> > > To unsubscribe send a blank email to
> > [email-masked]
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> >
> >
> >
> >
> >
>
> --
> Brian F. G. Bidulock
>
> 

¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                         ¦ Therefore  all  progress  depends on the ¦
>                         ¦ unreasonable man. -- George Bernard Shaw ¦
>
>
>
>

--
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 16 Oct 2001 03:53:02 -0500

Manish,

Yes, I agree with you 100%.  When the Stop signal is issue to the M2PA link,
it should sent Link Status - Out of Service and NOT (I repeat NOT) abort
the SCTP association.  There is absolutely no need to abort a perfectly good
SCTP association which has already gone through slow start and its SRTTs have
settled.  All that either side need do is wait for a start signal and then
begin alignment and proving.  Emergency procedures might apply there.

Section 4.2.3 should say "send a Link Status - Out of Service to the peer"
instead of "send an ABORT primitive to SCTP".

There have obviously been some oversights in convering v2 to v3 and making
the SCTP association available at provisioning time rather than at alignment.

The change was made to more closely resemble Q.2140/SSCOP behavior, where the
ATM VC is established long before the SSCOP connection is established and does
not disappear when the SSCOP connection is released.  In M2PA's case, the SCTP
association is like the VC and the alignment procedure is like the SSCOP
connection.

--brian

[email-masked] wrote:                                (Tue, 16 Oct 2001 14:11:38)
> >                         ¦ unreasonable man. -- George Bernard Shaw ¦

Content-Description: footer
> To unsubscribe send a blank email to [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---