Subject: No STATE Change on Errors?

From: Jacques Rajchgod <[email-masked]>
Date: Tue, 23 Oct 2001 14:35:13 -0500

Hi, SIGTRAN...

Referring to the latest M3UA (=09), section 3.8.1 - Error:

Nowhere is there a statement that says what happens STATE-WISE if an error
is generated in response to a bad message from a peer.
Would it be safe to assume that nothing happens state-wise such that all
states are maintained?
Usually in the industry (ITU), there are various degrees of state
violations, some of which would trigger various RESETS...etc. unless SIGTRAN
is not as rigid as the ITU world (was told that, a while ago)...

Suggest there should be a clear statement to that effect so as to plug the
hole for State Machine wizzards...

Ex: A peer gets "Unexpected Message". Nothing happens on that right? The
offending peer mends its way (fixes it and retransmits) and all is cool
after that?

Tks.

Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-7180
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Oct 2001 15:01:54 -0500

Jacques,

You will see statements in the draft regarding state in relation
to error messages, just not in the error message section.  The
ASPSM procedures, for example, say that the state remains at
"such and such" and an error message is sent.

For example: at the end of section 4.3.4.1 ASP Up Procedures:

  "If an ASP UP message is received and internally the remote ASP
   is in the ASP-ACTIVE state, an ASP-Up Ack message is returned,
   as well as an Error message ("Unexpected Message), and the
   remote ASP stat is changed to ASP-INACTIVE in all relevant
   Application Servers."

You just have to look a little harder.

--brian

Jacques Rajchgod wrote:                                   (Tue, 23 Oct 2001 14:35:13)
>    Nowhere is there a statement that says what happens STATE-WISE if an
>    error is generated in response to a bad message from a peer.
>    
>    Would it be safe to assume that nothing happens state-wise such that
>    all states are maintained?
>    
>    violations, some of which would trigger various RESETS...etc. unless
>    SIGTRAN is not as rigid as the ITU world (was told that, a while
>    ago)...
>    
>    
>    
>    Suggest there should be a clear statement to that effect so as to plug
>    the hole for State Machine wizzards...
>    
>    
>    
>    Ex: A peer gets "Unexpected Message". Nothing happens on that right?
>    The offending peer mends its way (fixes it and retransmits) and all is
>    cool after that?
>    
>    
>    
>    Tks.
>    
>    
>    
>    Jacques Rajchgod
>    MCI Worldcom
>    You are currently subscribed to sigtran as: [email-masked]
>    To unsubscribe send a blank email to
>    [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---