Subject: Illogical Section 4.4.1 for "Permission Denied'

From: Jacques Rajchgod <[email-masked]>
Date: Mon, 29 Oct 2001 16:31:45 -0600

SIGTRAN,

M3UA-09, Section 4.4.1, Page 81 - Permission Denied.

Seems to me this section is illogical.

The possible Registration problems in existence can only be due to:

1) Wrong paramater received from ASP
2) Invalid Key received from ASP
3) SG unable to receive anymore REG_REQ's
4) SG not supporting Dynamic

Each of above four problems engenders a corresponding return-error that is
already documented and which translates into a "Permission being denied"...
So, what's left?
Surely a SG cannot deny permission for no reason?

I think that "Permission Denied" on a REG_REQ is a duplicate (Just like the
"Unexpected Message" and "Protocol Error" duplication) as any one of above
four types of Registration Errors already translates into a "Permission
being denied"...and if the SG chokes-up, it says "Insufficient Resources"
not - Pernmission Denied...So,  can't see where that "Perm Denied" comes-in
on...

Please kindly advise...

Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-7180
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 30 Oct 2001 00:25:44 -0600

Jacques,

We have gone over this several times: grep the archive
for "[Pp]ermission".

Permission Denied is for the situation where not all ASPs
are permitted to access all RKs.  Think customer group.

The SG receives a REG REQ and 1) supports dynamic registration,
2) has the internal resources to answer the requrest, 3) receives
a correct key, and 4) has correct parameters, but 5) refuses
the REG REQ because the specific ASP that made the request does
not have sufficient permission to use that RK.

If I have two separate ASP pools served by the same SG, I don't
want to permit one group of ASPs using the SG to access RKs
assigned only to another group of ASPs.

None of the other errors fit the bill.

Can we add a comment to the draft so that this question does
not come up again and again.

--brian

Jacques Rajchgod wrote:                                   (Mon, 29 Oct 2001 16:31:45)
>    Each of above four problems engenders a corresponding return-error
>    that is already documented and which translates into a "Permission
>    being denied"... So, what's left?
>    
>    I think that "Permission Denied" on a REG_REQ is a duplicate (Just
>    like the "Unexpected Message" and "Protocol Error" duplication) as any
>    one of above four types of Registration Errors already translates into
>    a "Permission being denied"...and if the SG chokes-up, it says
>    "Insufficient Resources" not - Pernmission Denied...So,  can't see
>    where that "Perm Denied" comes-in on...
>    
>    
>    
>    Please kindly advise...
>    
>    
>    
>    Jacques Rajchgod
>    MCI Worldcom
>    You are currently subscribed to sigtran as: [email-masked]
>    To unsubscribe send a blank email to
>    [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---