Subject: M2PA association establishment

From: Avi Chibotaro <[email-masked]>
Date: Wed, 17 Oct 2001 20:30:53 +0200

Hi all,

When M2PA gets a Power-Up request from its user:

"The client M2PA establishes an association by sending the SCTP
ASSOCIATE primitive to SCTP. The client should attempt to establish
the association periodically until it is successful."
draft-m2pa-03 section 4.1.2.

I think a mechanism should be added to time-out this procedure.

A mechanism, similar to the one used by SCTP, can be embraced.
In such a case, the following definitions would be added:
1. A threshold for the number of association establishment tries.
2. A timer for the period between each association establishment try.

Nevertheless, another mechanism can be added, but I think this issue
must be dealt with.

Best regards,
Avi

Avi Chibotaro
RT Software Engineer
Airslide Systems Inc.
www.airslide.com

---- the invisible revolution ----

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Thu, 18 Oct 2001 10:34:35 +0530

Hi Avi,

A threashold may be set for the retries at m2pa level.

But there is no need for a timeout at m2pa level because of the following
mechanism:
Precondition(server socket is not setup)

m2pa (at client) asks sctp to connect
sctp times out ,retries ...
sctp finally reports connection down when its retries fail
m2pa when it gets this down indication, asks sctp to connect again

So, m2pa can very well retry when SCTP reports connection down.

We can make this max_m2pa_assoc_retries a hash define which may be changed by
you if required.
We can set it to a default value of say 100.

Is this proposal ok with you?

thanks
harsh

"Avi Chibotaro" <[email-masked]> on 10/18/2001 12:00:53 AM

To:   "Sigtran (E-mail)" <[email-masked]>
cc:   R. C. Monee/HSS@HSS, Manish Sharma/HSS@HSS, Sandeep Mahajan/HSS@HSS,
      "Ruthy Chaouat" <[email-masked]>, "Roie Geron" <[email-masked]>,
      "Ofer Gottfried" <[email-masked]>, "Erez Kirshenbaum"
      <[email-masked]>, Vivek Pachaury/HSS@HSS, Harsh Bhondwe/HSS@HSS

Subject:  M2PA association establishment

Hi all,

Best regards,
Avi

Avi Chibotaro
RT Software Engineer
Airslide Systems Inc.
www.airslide.com

---- the invisible revolution ----

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 18 Oct 2001 00:25:57 -0500

Harsh,

Establishment of the SCTP association is a function of the local
layer management.  There is no need to specify it in the draft.

Perhaps "The client should attempt..." should be changed to "The
client may attempt...".

--brian

[email-masked] wrote:                              (Thu, 18 Oct 2001 10:34:35)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: Tom George <[email-masked]>
Date: Mon, 22 Oct 2001 15:19:55 -0500

I think Brian is right. This will say "may" in M2PA draft version 4. 

tomG.

> Perhaps "The client should attempt..." should be changed to "The
  [...]

-- 
* Tom George        972-519-3168         [email-masked]   *
* PB2-1323       Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel USA, Inc.; 1000 Coit Rd, MS PB2-STPA; Plano TX 75075-5813   *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *

---