Subject: m2ua v10: Broadcast mode

From: [email-masked]
Date: Fri, 19 Oct 2001 13:08:35 -0400

Is the following paragraph, which appears in Section 4.3.4.4 (ASP Active Procedures) of m2ua v10, really applicable to broadcast mode? It seems to be 
applicable only to Loadsharing mode.

An SGP, upon reception of an ASP Active message for the first 
ASP in a Broadcast AS, MAY choose not to direct traffic to a newly 
active ASP until it determines that there are sufficient resources to 
handle the expected load (e.g., until there are "n" ASPs in state 
ASP-ACTIVE in the AS). 

Barry Nagelberg
Software Engineer
RadiSys, Corp.
Signaling Products Design Center
[email-masked]
+1-856-642-9229 x237

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Oct 2001 14:07:25 -0500

Barry,

Broadcast can be viewed as a different kind of loadsharing.
Just as in the loadsharing case, there can be a minimum
number of ASPs necessary to handle load in broadcast mode.
In this case, the SGP would not start broadcasting traffic
until there were "n" ASPs available.  An implementation not
interested in this feature would simply set n=1, both for
loadsharing and broadcast.

I suppose what I'm saying is that this procedure is as applicable
to broadcast as it is to loadsharing.  It probably only has
marginal value to both.

I think the procedure was intended for cases where ASPs had
limited capacity, not necessarily for limiting traffic load
placed on associations.  SCTP flow control and congestion
control can handle that.

--brian

[email-masked] wrote:                (Fri, 19 Oct 2001 13:08:35)
> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Vats, Umesh" <[email-masked]>
Date: Fri, 19 Oct 2001 12:39:49 -0700

Hi  Brian

Sorry, I am late on this. But why exactly broadcast
is needed ? What do we do in this ?

thanx in advance 
Umesh 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Friday, October 19, 2001 12:07 PM
To: sigtran
Subject: Re: m2ua v10: Broadcast mode

Barry,

--brian

[email-masked] wrote:                (Fri, 19 Oct 2001
13:08:35)
> Is the following paragraph, which appears in Section 4.3.4.4 (ASP Active
Procedures) of m2ua v10, really applicable to broadcast mode? It seems to be

> To unsubscribe send a blank email to
[email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to
[email-masked]

---

---

From: [email-masked]
Date: Fri, 19 Oct 2001 15:37:10 -0400

Brian,

I don't understand how "broadcast can be viewed as a different kind of loadsharing". Please explain this. 

Actually, none of the latest versions of m2ua/m3ua/sua really explain what 
is the purpose of broadcast mode. I think an explanation should be added 
to the specs.

Barry Nagelberg

"Brian F. G. Bidulock" <[email-masked]>
10/19/01 03:07 PM
Please respond to sigtran

        To:     "sigtran" <[email-masked]>
        cc: 
        Subject:        Re: m2ua v10: Broadcast mode

Barry,

--brian

> Is the following paragraph, which appears in Section 4.3.4.4 (ASP Active 
Procedures) of m2ua v10, really applicable to broadcast mode? It seems to 
be 

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Oct 2001 14:49:16 -0500

Barry,

[email-masked] wrote:                (Fri, 19 Oct 2001 15:37:10)
> is the purpose of broadcast mode. I think an explanation should be added 

Sounds like AS material to me.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 19 Oct 2001 15:03:56 -0500

Umesh,

See the thread "M2UAv0, M3UAv8, SUAv7: Traffic Mode Type" from
July-August 2001, the thread "M3UA-07: Broadcast mode changes"
from July and "m2ua AS broadcast mode" from July.

This question has been repeatedly asked and answered.  You will
find the archive a useful resource.

BTW: What is the use of active/standy mode?  It is just 1+m
loadsharing.

--brian

Vats, Umesh wrote:                                          (Fri, 19 Oct 2001 12:39:49)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---