Subject: Superfluous text in section 4.4.1 M3UA-09

From: Jacques Rajchgod <[email-masked]>
Date: Mon, 15 Oct 2001 14:54:12 -0500

[Page 81] Internet Draft       SS7 MTP3-User Adaptation Layer         Oct
2001
Section 4.4.1:

If the SGP does not authorize the registration request, the SGP returns
a REG RSP message to the ASP containing the Registration Result "Error
- Permission Denied".
------------------------------------

From Jacques:
---------------------
Subject text seems to be superfluous:

All the listed errors (Invalid RK, non-existing RK and-no-dynamic-config
possible...etc)
cause a result where the permission to register is denied. So why that
particular paragraph?
Or, is it that the SG returns two error messages in-tandem for each of the
specified ASP
improprieties?  Example would be:

a) An Invalid RK is sent to SG.
b) SG gives a burst of two shots:
        1) "Invalid RK"
        2) "Permission denied"..

Is this how it would work? If not, subject text is superfluous...

Jacques Rajchgod
MCI Worldcom
Next Generation System Evaluation
Tel: [972] 729-7180
E-mail: [email-masked]

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 18 Oct 2001 02:10:51 -0500

Jacques,

The intention of the "Permission Denied" error is for when permission
is denied, not when invalid RK or other things occur.

For example, say I have two ASPs.  One (ASP A) serves users of PC A
and the other (ASP B) serves users of PC B.  At the SG I can give
the ASP permission to use PC A but not to use PC B.  If ASP A attempts
to register an RK including PC B, even though the RK is valid and
the SG could otherwise register ASP A for PC B, ASP A has been denied
permission to register agains PC B.  The SG would then send "Permission
Denied".

This is largely intended for configurations where the ASP and SG are
across a demarcation point.  The purpose of including it is so that
the ASP does not attempt to reregister and can properly inform local
management of the reason for refusal of the SG to register the RK.

Anyway, that's why we asked for it to be included.  Maybe more description
is called to explain this error.

--brian

Jacques Rajchgod wrote:                                   (Mon, 15 Oct 2001 14:54:12)
> 
>    
>    
>    [Page 81] Internet Draft       SS7 MTP3-User Adaptation Layer
>    Oct 2001
>    Section 4.4.1:
>    All the listed errors (Invalid RK, non-existing RK
>    and-no-dynamic-config possible...etc)
>    
>    Or, is it that the SG returns two error messages in-tandem for each of
>    the specified ASP
>    
>    You are currently subscribed to sigtran as: [email-masked]
>    To unsubscribe send a blank email to
>    [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---