Subject: M3UA/SUA: ASPDOWN (was: SUA v8 - Conflicting statements)

From: [email-masked]
Date: Fri, 26 Oct 2001 15:51:51 +0300

Hi Ben,

> If the ASP connects to the SGP and immediatley sends and ASPDN message
> what should happen?
> 
> Section 4.3.4.1  - end of 3rd to last paragraph
> 
> "If the SGP receives any other SUA messages before ASPUP message is
> received, the SGP SHOULD discard them."
> 
> Section 4.3.4.2 - paragraph 4
> 
> "The SGP MUST send an ASPDN ACK message in response to a 
> received ASPDN message from the ASP, even if the ASP is already marked 
> as down at the SGP."
> 
> I assume the MUST supercedes the SHOULD?   Still should be cleaned up
> I think.

Agreed. I guess this needs to be addressed for M3UA as well.  How
about this:

"If the SGP receives any other SUA messages before ASPUP message is
received (other than ASPDN - see section 4.3.4.2), the SGP SHOULD 
discard them."

Is this better?

thanks,
John

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Greg Sidebottom <[email-masked]>
Date: Fri, 26 Oct 2001 13:30:39 -0400

Hi Ben,

   Good catch.  John's solution works for me (changing the term SUA to M3UA
of course!).

Cheers,

    Greg

----- Original Message -----
From: <[email-masked]>
To: "sigtran" <[email-masked]>
Sent: Friday, October 26, 2001 8:51 AM
Subject: M3UA/SUA: ASPDOWN (was: SUA v8 - Conflicting statements)

---