Subject: RE: CIC registration

From: [email-masked]
Date: Tue, 2 Oct 2001 11:07:03 +0300

Hi Greg,

> [Greg2] I looked at the current reasons in the REG RSP and it 
> didn't seem clean.  In this case the SG is not refusing the 
> registration, it is refusing a change to the RK data.  I was 
> thinking that the ASP that sent the REG REQ is sitting on two 
> RKs, the "old and the "new" one.   Its not a big deal but
> I thought an explict reason of "Routing Key change refused" 
> might be useful to the management system at the ASP.

I've added the error reason you suggested to SUA.  See my text:

Routing Key Change Refused					 0x15

[some text clipped]

The "Routing Key Change Refused" error is sent when the SG refuses a change
in the Routing Key parameters.  

===== Complete list of SUA error codes, M3UA should be aligned =====

The Error Code parameter indicates the reason for the Error Message.  The
Error parameter value can be one of the following values:

Error Code	                                    Value
Invalid Version                                 0x01
Invalid Interface Identifier                    0x02  
Unsupported Message Class       			 	 0x03
Unsupported Message Type                        0x04  
Unsupported Traffic Handling Mode               0x05
Unexpected Message                              0x06  
Protocol Error                                  0x07
Unsupported Interface Identifier Type           0x08 *
Invalid Stream Identifier                       0x09  
Unassigned TEI                                  0x0a *
Unrecognized SAPI                               0x0b *
Invalid TEI, SAPI combination                   0x0c *
Refused - Management Blocking                   0x0d  
Missing, Duplicated or Invalid ASP Identifier   0x0e  
Invalid Network Appearance                      0x0f 
Invalid Routing Context                         0x10
Invalid Parameter Value                         0x11  
Parameter Field Error                           0x12
Unexpected Parameter                            0x13
Missing Parameter
0x14
Routing Key Change Refused					 0x15

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: [email-masked]
Date: Tue, 2 Oct 2001 12:53:51 +0300

Greg & Brian,

I have added the following paragraph to section 4.4.1 (for M3UA & SUA) as
the 2nd to last paragraph in the section.  This deals with the proposed
functionality of allowing modification during the REG REQ procedure.

====

An ASP MAY modify an existing Routing Key by including a Routing Context
parameter in the REG REQ.  If the SGP determines that the Routing Context
applies to an existing Routing Key, the SG MAY adjust the existing Routing
Key to match the new information provided in the Routing Key parameter.  A
Registration Response "Routing Context Registionation Refused" is returned
if the SGP does not accept the modification of the Routing Key.

====

Is this sufficient?

John

---