Subject: FW: M3UA v09 changes

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Thu, 11 Oct 2001 08:56:53 +0200

Trying to resend with a little bit of reformatting...
(almost 1 day waiting for it to appear in the list)

-----Original Message-----
From: Javier Pastor-Balbas (ECE) 
Sent: Wednesday, October 10, 2001 4:38 PM
To: 'sigtran'
Subject: M3UA v09 changes

Hi everyone, 

This is a summary of the main changes that have been done in M3UAv09 related with the Open Points. Any addition to this, Greg? Anything I skipped ?

Here is the list:

1) Change Network Appearance semantics/format. 
The new definition provided has been added.
V09. New text Section 1.2

2) Add Routing Context in Data & SSNM messages. 
Added as optional parameter. 
V09. New text Section 3.4

3) SSNM messages semantics at the SGP or SG level. 
Section to be revised to be SG level, plus the 
addition of ASPIA Ack for graceful shutdown.
V09. New text Section 3.4

4) Format of Routing Label/SIO in DATA message. 
New general Protocol Data parameter instead of Protocol Data 1 or 2.
V09. New text Section 3.3.1 and 3.4

5) Add optional Correlation Id parameter to DATA message
V09. Text deleted in Sections 3.2, 3.3.1 and 4.3.4.4

6) Delete SSN in Routing Key parameter and TRId from example. 
V09. Text deleted in Section 3.6.1

7) Change-over / Change-back support. 
Addition for the case of Broadcast using Message Id to be synchronized. 
V09. Text added in Section 4.3.4.4

8) Delete the restriction on Heartbeat to allow any time
V09. Text deleted in Sections 4.3.1, 4.3.4.7

9) Change Traffic Mode to optional in REG REQ, ASP Active, ASP Active Ack
V09. New text in Sections 3.6.1, 3.7.1, 3.7.2

10) User Part Unavailable support - STP-mode, SEP Mode
Whether to support UPU at SG using STP model. Also SEP model. Nothing added or deleted so far.
 
11) IPSP cases supported or not. 
At least, needed to explain double ASPAC scenario and update IPSP scenarios to reflect this. This would happen in v10

12) REG Response Message Format 
Add Tags/Lengths to parameters
V09. New text Section 3.6.2 and 3.6.4

13) Lining up of value assignments in UA Common parameters
V09. New text Section 3.2 and 3.8

14) Error response to DAUD for "Invalid" destination
Allow an SG to refuse to give the status of a Point
Code for security reasons. Agreed to add error codes and procedures.
V09. New text Section 4.5.3
 
15) Open up RK format to allow NA range, multiple DPCs etc
v09. New text: Multiple parameters set in Section 3.6.1
 
16) Routing Context Definition 
It is not clear that people is interested in changing this one...

17) MTP3 Restart at the SG
v09. New text Section 4.6

Others:
-------
 - Standby Traffic Mode deleted in 3.7
 - Editorial changes

BR // Javier.  

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 11 Oct 2001 08:07:53 -0500

Hi Javier,

Was there really an agreement for 15) (especially for NA ranges)? Although there weren't message exchanges related with this topic for some time, my impression was (which of course can be wrong :) ) the decision is to keep RK inside one SPMC (at least for now).

  Tolga

> [mailto:[email-masked]]
> Sent: Thursday, October 11, 2001 2:57 AM
> To: sigtran
> Subject: FW: M3UA v09 changes
> 
> 
> This is a summary of the main changes that have been done in 
> M3UAv09 related with the Open Points. Any addition to this, 
> Greg? Anything I skipped ?
> 
> Here is the list:
> 
> At least, needed to explain double ASPAC scenario and update 
> IPSP scenarios to reflect this. This would happen in v10
> 
>  
> You are currently subscribed to sigtran as: [email-masked]
> To unsubscribe send a blank email to 
> [email-masked]
> 

---

---

From: "Asveren, Tolga" <[email-masked]>
Date: Thu, 11 Oct 2001 09:15:06 -0500

Hi,

Small comment (maybe half editorial) on definition of NA:
"The Network Appearance is a M3UA local reference shared by SG and AS
(typically an integer) that together with an Signaling Point Code uniquely
identifies an SS7 node by indicating the specific SS7 network it belongs
to."
Because NA can have different values for different ASP-SG pairs for the same
network, IMHO it is better to say "that together with an Signaling Point
Code and Association ID uniquely identifies an SS7 node"

   Tolga

---