Subject: Re: NA definition

From: reshma <[email-masked]>
Date: Tue, 11 Dec 2001 11:41:24 +0530

Hi Javier,

----- Original Message -----
From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
To: "sigtran" <[email-masked]>

> As the definition says, NA is a local reference shared by SG and AS. If an
M3UA user at AS wants to communicate to an SS7 node it should give to the
M3UA layer the corresponding SPC (Signaling Point Code). The problem arises
when that SPC is assigned to two different national networks that can be
accessed by the SG.
>
> The M3UA layer knows that all the traffic to that SPC from that particular
user has to be sent to National Network A.

[reshma] How is the M3UA layer at the ASP supposed to know this..? Should it
be configured..?

> Then, it will assigned the NA corresponding to that network to all the
messages from that particular user.
> It can either send NA with the messages in the SG-AS path or send RC if NA
has been defined as part of the RK.

[reshma]  This sending of RC makes sense only when we send messages from SG
to AS. What about the messages sent from AS to SG?

 > If the same M3UA user wants to send traffic to a specific  SPC in both
networks (the assigned SPC is the same for the
> two nodes), it should be specified what NA (or RC if NA included in RK)
has to be used for each message. Here
> implementation dependant options can be implemented:
> - The user can elect the network by itself
> - M3UA layer has a discrimination function
> - etc.

thanks,
Reshma.

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 11 Dec 2001 11:54:05 +0100

Hi Reshma, 

Answers below...

Cheers // Javier.

> -----Original Message-----
> From: reshma [mailto:[email-masked]]
> Sent: Tuesday, December 11, 2001 7:11 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: NA definition
> 
> 
> Hi Javier,
> 

M3UA layer can figure out the national network that an SS7 outcoming message must go to from the NA that it receives from the ASP. If you have two national networks accessible for the same AS, you would have at least two different Signaling Links (one per National Network). Althought the same SPC can be shared by both networks, at the time receiving a new message from the SS7 side, you assign a preconfigured NA to that message and send it to the ASP. Each time the ASP wants to send a message to an especific National Network, ASP will use the corresponding NA to indicate the SG the right link to send messages to the SS7 network. This means that the ASP needs some configuration to deal with differents NAs.  :-)

> to AS. What about the messages sent from AS to SG?

In that case you can use the RC to check that the ASP where the message come from is the right one, it is defined inside the AS that corresponds to that RC and it is in ASP_ACTIVE state. This checking is optional.

---

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 11 Dec 2001 14:55:56 +0100

Hi Brian, 

Some day I'll ask you about what academy you attend to improve your good manners....  ;-)

See below for comments.... 

Cheers // Javier.

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Tuesday, December 11, 2001 1:10 PM
> To: Javier Pastor-Balbas (ECE)
> Cc: sigtran
> Javier,
> Javier Pastor-Balbas (ECE) wrote:                   (Tue, 11 
> Dec 2001 11:54:05)
> > Hi Reshma, 
> > 
> > Answers below...
> > 
> > Cheers // Javier.
> > 
> > M3UA layer can figure out the national network that an SS7 
> outcoming message
> > must go to from the NA that it receives from the ASP. If 
> you have two
> > national networks accessible for the same AS, you would 
> have at least two
> > different Signaling Links (one per National Network). 
> Althought the same SPC
> > can be shared by both networks, at the time receiving a new 
> message from the
> > SS7 side, you assign a preconfigured NA to that message and 
> send it to the
> > ASP. Each time the ASP wants to send a message to an 
> especific National
> > Network, ASP will use the corresponding NA to indicate the 
> SG the right link
> > to send messages to the SS7 network. This means that the 
> ASP needs some
> > configuration to deal with differents NAs.  :-)
> > 
> > 
> > In that case you can use the RC to check that the ASP where 
> the message come
> > from is the right one, it is defined inside the AS that 
> corresponds to that
> > RC and it is in ASP_ACTIVE state. This checking is optional.
> 
> How soon we forget here too...
> 
> "The ASP SHOULD NOT send Data or SNMM messages for the related Routing
> Context(s) before receiving and ASP Active Ack message, or it 
> will risk
> message loss."
> 
> I don't think that I would call checking "optional".
> 

Well if it is not optional a MUST should be writen. It is optional in the sense that you can find good reasons to no implement it. Read RFC2119. I reproduce it for your convinience:

SHOULD NOT   This phrase, or the phrase "NOT RECOMMENDED" mean that
   there may exist valid reasons in particular circumstances when the
   particular behavior is acceptable or even useful, but the full
   implications should be understood and the case carefully weighed
   before implementing any behavior described with this label.

It is up to you to implement it since it does not affect to interoperatibility. Some implementations can consider it is not needed. Some others simply doesn't implement it for simpleness.

If you don't implement it your SG would be weaker against possible attacks. But, is this really important in an intranet dedicated to signaling transport? From my point of view it is not for these particular scenarios. Maybe in yours is compulsory, but it is a fact that you SHOULD balance.

Cheers // Javier.

> > You are currently subscribed to sigtran as: [email-masked]
> > To unsubscribe send a blank email to 
> [email-masked]
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

---

---

From: Tolga Asveren <[email-masked]>
Date: Tue, 11 Dec 2001 06:11:18 -0800 (PST)

Hi Javier,

Please see a short comment below.

  Tolga
--- "Javier Pastor-Balbas (ECE)"
<[email-masked]> wrote:
> > > > > As the definition says, NA is a local
> reference shared by 
> > > > SG and AS. If an
> > > > M3UA user at AS wants to communicate to an SS7
> node it should 
> > > > give to the
> > > > M3UA layer the corresponding SPC (Signaling
> Point Code). The 
> > > > problem arises
> > > > when that SPC is assigned to two different
> national networks 
> > > > that can be
> > > > accessed by the SG.
> > > > >
> > > > > The M3UA layer knows that all the traffic to
> that SPC from 
> > > > that particular
> > > > [reshma] How is the M3UA layer at the ASP
> supposed to know 
> > > > this..? Should it
> > > > be configured..?
> > > > 
> > > 
> > > 
> > > > > Then, it will assigned the NA corresponding
> to that network 
> > > > to all the
> > > > > It can either send NA with the messages in
> the SG-AS path 
> > > > or send RC if NA
> > > > [reshma]  This sending of RC makes sense only
> when we send 
> > > > messages from SG
> Well if it is not optional a MUST should be writen.
> It is optional in the sense that you can find good
> reasons to no implement it. Read RFC2119. I
> reproduce it for your convinience:
> 
> It is up to you to implement it since it does not
> affect to interoperatibility. Some implementations
> can consider it is not needed. Some others simply
> doesn't implement it for simpleness.
> 
> If you don't implement it your SG would be weaker
> against possible attacks. But, is this really
> important in an intranet dedicated to signaling
> transport? From my point of view it is not for these
> particular scenarios. Maybe in yours is compulsory,
> but it is a fact that you SHOULD balance.
>
[TOLGA] If you see the things from SG point of view,
maybe you are right. But what about ASP? If I
implement an ASP, which sends messages to SGs, without
checking whether it is active or not for that SG, and
if SG validates whether the sender is ACTIVE ot not
for the RK then we have an interoperability issue.
Such an ASP can work only with SGs, which don't do
this check. 
> Cheers // Javier.

__________________________________________________
Do You Yahoo!?
Check out Yahoo! Shopping and Yahoo! Auctions for all of
your unique holiday gifts! Buy at http://shopping.yahoo.com
or bid at http://auctions.yahoo.com

---

---

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 11 Dec 2001 15:31:10 +0100

Hi Tolga, 

The original question was from the SG point of view, but I agree with your point.

Cheers // Javier.

> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Tuesday, December 11, 2001 3:11 PM
> To: sigtran
> Cc: [email-masked]
> Subject: RE: NA definition
> 
> 
> Hi Javier,
> 
> You are currently subscribed to sigtran as: 
> [email-masked]

---

---

From: Pathangi N Janardhanan <[email-masked]>
Date: Wed, 12 Dec 2001 20:40:46 +0530

Hi,

  One basifc doubt. The RK is defined so that the SG can filter the
incoming message based on the values of the RK to the correct ASP.
Any ASP can send messages to any PC on any network in the outoging
direction, i.e. from the ASP to the SG side, and the SG would forward
that out on the SS7 links based on the NA and the DPC in the message.

 If that is the case, then the RC in the data message from the ASP to
the SG, can only be used to check if this ASP is active and is allowed
to send the message, but the NA in that or the parameters of the RK
cannot be used to determine the outgoing link at the SG.

  Is this correct?

Thanks
Jana

---