Subject: SUA09, M3UA-10, M2UA-11, RFC2057: Common parameters.

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 30 Dec 2001 06:26:07 -0600

SUA-09:

> 3.9 Common Parameters 
>     
>    These TLV parameters are common across the different adaptation 
>    layers. 
>     
>    Parameter Name                     Parameter ID 
>    ==============                     ============ 
>    Reserved                             0x0000 
>    Not used in SUA                      0x0001 
>    Not used in SUA                      0x0002 
>    Not used in SUA                      0x0003 
>    Info String                          0x0004  
>    Not used in SUA                      0x0005 
>    Routing Context                      0x0006 
>    Diagnostic Info                      0x0007 
>    Not used in SUA                      0x0008 
>    Heartbeat Data                       0x0009 
>    Not Used in SUA                      0x000A 
>    Traffic Mode Type                    0x000B 
>    Error Code                           0x000C 
>    Status                               0x000D 
>    Not used in SUA                      0x000E 
!    Congestion Level                     0x000F 
>    Not used in SUA                      0x0010 
>    ASP Identifier                       0x0011 
>    Affected Point Code                  0x0012 

The parameter id assignment for Congestion Level in SUA-09 conflicts
with RFC 3057 (Reason parameter).  Please move Congestion Level to a
non-conflicting slot.

M3UA-10:
    
>  M3UA-Specific parameters.  These TLV parameters are specific to the 
>  M3UA protocol:
>
>  Network Appearance                    0x0200
>  Reserved                              0x0201
>  Reserved                              0x0202
>  Reserved                              0x0203
>  User/Cause                            0x0204
!  Congestion Indications                0x0205
>  Concerned Destination                 0x0206
>  Routing Key                           0x0207
>  Registration Result                   0x0208
>  Deregistration Result                 0x0209
>  Local_Routing Key Identifier          0x020a
>  Destination Point Code                0x020b
>  Service Indicators                    0x020c
>  Subsystem Numbers                     0x020d
>  Originating Point Code List           0x020e
>  Circuit Range                         0x020f
>  Protocol Data                         0x0210
>  Correlation Id                        0x0211
>  Registration Status                   0x0212
>  Deregistration Status                 0x0213

Called Congestion Indications here but Congestion Level elsewhere.
Can we move Congestion Level into the common range?  Also Network
Appearance, User/Cause, Routing Key, Registration Result, Deregistration
Result, Local Routing Key Identifier, Correlation Id, Registration Status and
Deregistration Status which are almost all shared by M2UA, M3UA and SUA?

That goes for M2UA as well which has Link Key, Local-LK-Identifier,
Registration Result, Registration Status, Deregistration Result and
Deregistration Status, Correlation Id and Correlation Id Ack.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Ken Morneault <[email-masked]>
Date: Mon, 31 Dec 2001 10:20:46 -0500

Pls see comment at bottom.

R-

Ken

>Deregistration Status, Correlation Id and Correlation Id Ack.

Correlation ID has been moved into common area and Correlation ID
Ack has been removed.  The others should stay in the M2UA specific
parameter area.

>You are currently subscribed to sigtran as: [email-masked]

---