Subject: clarifications on M3UA draft 10

From: Pathangi N Janardhanan <[email-masked]>
Date: Mon, 3 Dec 2001 21:57:09 +0530

Hi,

 Some clarifications on the M3UA draft 10

a) How does the M3UA layer at an ASP convey the availability status
   of a user part to the M3UA at the SG?  The description of the DUPU
   message says it is only from a SG to the ASP.

b) There is a contradiction in the draft on what messages can be sent
     to the ASP which is in inactive stage.

   sec. 3.5.1 says after ASP UP message the ASP can receive SSNM and
   ASPSM/ASPTM messages

   sec 4.3.1 in the description of the ASP-INACTIVE state says that 
   data and SNMM messages should not be sent to an ASP in 
   this state.

   should the sec 4.3.1 be modified and say only data messages should
   not be sent to an ASP in ASP-INACTIVE state?

Thanks
Jana

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

From: Tolga Asveren <[email-masked]>
Date: Mon, 3 Dec 2001 18:31:41 -0800 (PST)

Hi,

Please see comments below.

   Tolga
--- Pathangi N Janardhanan <[email-masked]>
>    message says it is only from a SG to the ASP.
[TOLGA] ASP does not tell anything about availability
of a user part to SG. It is SGs responsibility, to
collect and interprete information from ASPs (AS
active/inactive status of ASPs) belonging to one SPMC.
>    not be sent to an ASP in ASP-INACTIVE state?
[TOLGA] As you pointed out a change is necessary in
the draft. But I think 3.5.1 is going to be changed to
disallow SSNM messages in ASP-INACTIVE state. 
> 
> Thanks
> Jana
> 
> 
> 
> ---
> You are currently subscribed to sigtran as:
> [email-masked]
> To unsubscribe send a blank email to
[email-masked]

__________________________________________________
Do You Yahoo!?
Buy the perfect holiday gifts at Yahoo! Shopping.
http://shopping.yahoo.com

---

---

From: "Srivats P." <[email-masked]>
Date: Tue, 4 Dec 2001 8:9:29 +0500

Jana,

>   message says it is only from a SG to the ASP.

It doesn't. Even if it did ... what do you expect the M3UA at the SG to 
do with it ?

>   not be sent to an ASP in ASP-INACTIVE state?

The other way round, rather. I think the latest consensus on the list is that
SSNM messages are also not sent in ASP-INACTIVE state.

Srivats

---

---

From: Pathangi N Janardhanan <[email-masked]>
Date: Tue, 4 Dec 2001 08:50:27 +0530

Hi,

> It doesn't. Even if it did ... what do you expect the M3UA at the SG
to

  The SG could send a MTP3 UPU message to the remote peer.

  Using the AS UP/Active messages for this would not be able to
capture the granularity of the user part, if the ASP is handling more
then
one user part. If the DUPU message could be sent from the ASP to
the SG, along with the affected point code tag,
 then the ASP could send this, if it detects that some user part
is unavailable, and the SG could in turn generate the MTP3 UPU
message toward the peer.

Thanks
Jana

---

---

From: "Srivats P." <[email-masked]>
Date: Tue, 4 Dec 2001 9:39:21 +0500

Jana,

My apologies about that second line ... "even if it did ... what do you ... "
I was actually referring to the case where userpart becomes available -
since Userpart availability tests are performed by the userparts themselves ...

See additional comments below ...

Srivats

>is unavailable, and the SG could in turn generate the MTP3 UPU

[Srivats] As Tolga pointed out, it is the responsibility of the SG to derive
userpart availability status based on the AS State and its routing key.

Srivats

---

---

From: "Dirk Kampmann (EED)" <[email-masked]>
Date: Tue, 4 Dec 2001 09:55:30 +0100

Hi Srivats

The SGP monitors the state of the ASP. If a user part dies, in general the ASP is not informed about this and so the SGP. At least in SS7 MTP3 is not monitoring the availability of its user parts on a periodic base and my assumption is that M3UA does not do this as well. Once it is not described in the draft second I see no reason to add this additional functionality.

If a node is sending a message to the (unknown) dead user part the SGP passes the message to the ASP and the ASP cannot deliver it. In SS7 the MTP3 has to response with a UPU message towards the sender of the message. Is this SS7 feature implemented in M3UA as well or shall M3UA deviate from SS7 in this point?

If the feature shall be implemented the ASP could response with a DUPU message that is translated in the SGP to an UPU message. If this shall work the DUPU should have a parameter for the destination of the DUPU message, which is the  sender of the original message.

If the DPC is not added to the DUPU message the ASP is not able to address the response on the undelivered message to the appropriate sender and the result is not compliant with the SS7 protocol.

Br.
	Dirk

-----Original Message-----
From: Srivats P. [mailto:[email-masked]]
Sent: Tuesday, December 04, 2001 5:39 AM
To: sigtran
Subject: Re: Re: clarifications on M3UA draft 10

Jana,

Srivats

Srivats

---
You are currently subscribed to sigtran as: [email-masked]
To unsubscribe send a blank email to [email-masked]

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 4 Dec 2001 04:21:15 -0600

Dirk,

Dirk Kampmann (EED) wrote:                                   (Tue, 04 Dec 2001 09:55:30)
> Hi Srivats
> 
> The SGP monitors the state of the ASP. If a user part dies, in general the
> ASP is not informed about this and so the SGP. At least in SS7 MTP3 is not
> monitoring the availability of its user parts on a periodic base and my
> assumption is that M3UA does not do this as well. Once it is not described
> in the draft second I see no reason to add this additional functionality.
> 
> If a node is sending a message to the (unknown) dead user part the SGP
> passes the message to the ASP and the ASP cannot deliver it. In SS7 the MTP3
> has to response with a UPU message towards the sender of the message. Is
> this SS7 feature implemented in M3UA as well or shall M3UA deviate from SS7
> in this point?
> 
> If the feature shall be implemented the ASP could response with a DUPU
> message that is translated in the SGP to an UPU message. If this shall work
> the DUPU should have a parameter for the destination of the DUPU message,
> which is the  sender of the original message.
> 
> If the DPC is not added to the DUPU message the ASP is not able to address
> the response on the undelivered message to the appropriate sender and the
> result is not compliant with the SS7 protocol.

DPC is not required in the DUPU message.  A user part cannot be available
to one DPC and not available to others.  DUPU is only sent from SG to ASP,
it is not sent from ASP to SG.  (Even if it were, the SG would know to turn
back all messages destined to the user part and DUPU would still not need
a DPC.)

If your RC has SI granularity, AS state and user-part availability are
identical and the SG knows the state of each user.  If the RC has PC
granularity, the SG can still know the user state from the AS state.  It
might not be possible to have one user be unavailable in such an AS while
another is available.  If that is what you need, make your RC SI granularity.

--brian

> You are currently subscribed to sigtran as: [email-masked]

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

---

From: "Srivats P." <[email-masked]>
Date: Wed, 5 Dec 2001 8:14:12 +0500

Dirk,

I hope Brian's mail has answered your question. If you wish to emulate the SS7
behaviour of sending a UPU back to the SP in case of a dead userpart, you need
to use SI granularity. 

Srivats

At 12/4/01 4:21:00 AM, you wrote:
>You are currently subscribed to sigtran as: [email-masked]

---