Subject: [Sigtran] Backhaul and Q.931

From: "Panagiotis Galiotos" <[email-masked]>
Date: Thu, 7 Mar 2002 11:22:32 +0200

Hi Subhodeep,

I am afraid that I may have misunderstood somethging in the backhaul operation. When we say backhaul, do we mean that, the "unified MG/SG will receive a Q.931 message Setup and then proceed it as is (or using a different protocol ??) to the Call Agent ???? Then the Call Agent will respond by Sending a CRCX command to the MG and by forwarding a Q.931 Call Proceeding message to the PSTN network ???? Am I right ? What exactly is happening?

Thank you again,

Panagiotis Galiotos

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Thu, 07 Mar 2002 20:59:46 +0530

Hi Panagiotis ,

Backhauling means transporting of TDM signalling information from SG to/from MGC over IP. When a Q.931 SETUP message is received from a PBX (i.e. TDM endpoint) by SG/MG, it will encapsulate it in the IUA message and send it across to the MGC. Now the Q.931 layer in the MGC (Call Agent can be seperate entity or embedded in the MGC software - i.e. implementation dependent) will process a message in the same manner as if it received from the Q.921 (LAPD) layer. Depending on the Called Party Number in the Q.931 SETUP message it will translate the number to find the desired destination. Based on the desired destination it will forward the origination message(IAM message for SS7 destination encapsulate in M3UA, SETUP for Q.931 destination encapsulate in IUA, SIP, etc.)  to the other SG/MG or MGC(for SIP) node. The device control messages (ie. CRCX, etc) is to setup bearer connection (RTP session)  between two end points (ie between two MGs orig and term). The MGC will send the CRC!
 X !
message to the orig MG based on the channel id (in case Q.931) which it receives in SETUP message and other connection informations like SDP,type of n/w, echo, etc. Similar thing will be done for terminating MG based on the resource information in the o/g signalling message. The backhauling is required since the signalling is out here out-of-band i.e. there is a dedicated signalling link (D-channel for Q.931). 

In case of CAS signalling which is inband signalling , the signalling information share the same voice links. As a result you don't have the concept of backhauling. It will use the MGCP/MEGACO packages available in the MG to communicate with the MGC. It's similar to line origination where we don't have the backhaul - rather MGCP/MEGACO packages are used to transfer the signlling infomations i.e. When the offhook is detected, the MG will send a NTFY message to MGC and may expect the digit map/dialtone signal information in RQNT message. When the digits are dialled NOTIFY messages are sent to notify the digit events as specified in the digit map and so on.

Hope this clears your doubt about backhaul, Q.931 and CAS signalling.

Subhodeep Sarkar 
Wipro Technologies 
Voice Over IP Solutions 
Ph : +91-(0)80-8411990 x 1251 

"Panagiotis Galiotos" wrote: 

Hi Subhodeep,

 

Thank you again,

Panagiotis Galiotos
Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in