Subject: RE: [Sigtran] M3UA Plugtest - Day 4 summary

From: "Vats, Umesh" <[email-masked]>
Date: Wed, 6 Mar 2002 17:55:46 -0800

Hi  Tolga

I agree with you that ASPUP and ASPUP-Ack should be sent 
by both the IPSPs in double ended mode. The figure given 
below as specified in draft 12 needs to corrected.

This is needed because the IPSPs may want to send ASP Ids
in the NOTFY messages to each other. Without dual ASPUP 
exchange, this is not possible.

But single exchange of ASPDN/ASPDN-ACK messgages is sufficient.
As  ASPDN/ASPDN-Ack messages are not related with any RC or ASP-Id, 
dual exchange is redundant.

Umesh

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 2:12 PM
To: [email-masked]
Subject: RE: [Sigtran] M3UA Plugtest - Day 4 summary

Yes, in m3uav12 5.5.2 it is shown as optional but it isn't. Because this is
a scenario for double-message approach. Similarly, ASPDN and ASPDN-ACK,
which are shown as optional are not optional but mandatory.

     Tolga

> -----Original Message-----
> From: Tomar, Nitin [mailto:[email-masked]]
> Sent: Wednesday, March 06, 2002 4:49 PM
> To: 'Tolga Asveren'; [email-masked]
> Subject: RE: [Sigtran] M3UA Plugtest - Day 4 summary
>
>
> Hi Tolga,
>   I agree that NTFY from IPSP-B to IPSP-A should be after receiving
> ASPUP-ACK (only if IPSP-B
>   sends ASPUP message) from IPSP-A,
>   but can you please explain me why ASPUP/ASPUP-ACK is not optional but
> mandatory (draft 12
>   shows it as optional).
>
> - Nitin.
>
> > -----Original Message-----
> > From: Tolga Asveren [mailto:[email-masked]]
> > Sent: Wednesday, March 06, 2002 1:12 PM
> > To: Tomar, Nitin; [email-masked]
> > Subject: RE: [Sigtran] M3UA Plugtest - Day 4 summary
> >
> >
> > Hi,
> >
> > In my opinion, the presented scenario does not follow double-message
> > approach. How can IPSP-A can send NTFY to IPSP-B, before
> > sending ASPUP and
> > receiving ASPUP-ACK from it? And also, it this scenario is
> > intended for
> > double-excahnge scenario (it says 5.5.2. Dopuble exchange) , second
> > ASPUP/ASPUP-ACK is not optional but mandatory.
> >
> >     Tolga
> >
> > > -----Original Message-----
> > > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of
> > > Tomar, Nitin
> > > Sent: Wednesday, March 06, 2002 3:43 PM
> > > To: [email-masked]
> > > Subject: RE: [Sigtran] M3UA Plugtest - Day 4 summary
> > >
> > >
> > > Hi Ken,
> > >
> > > Please find the text on Notify message (as agreed during testing at
> > > plugtest)
> > > for IPSP double exchange behavior.
> > >
> > > - Nitin.
> > >
> > >
> > > << snip>>
> > >
> > > 2)  IPSP update
> > >
> > > IPSP testing has occurred between different implementations.  Nitin
> > > from Trillium will suggest text on the list to clarify
> > Notify message.
> > >
> > >
> > > 5.5.2 Double exchange:
> > >
> > >             IPSP-A                           IPSP-B
> > >
> > >               |                                |
> > >
> > >               |<-------------ASP Up------------|
> > >
> > >               |-----------ASP Up Ack---------->|
> > >
> > >               |                                |
> > >
> > >               |---- NTFY (AS_Inactive)(RCb)--->|
> > >
> > >               |                                |
> > >
> > >               |<--- NTFY (AS-Inactive)(RCa)----|
> > >
> > >               |                                |
> > >
> > >               |-------------ASP Up------------>|  (optional)
> > >
> > >               |<----------ASP Up Ack-----------|  (optional)
> > >
> > >               |                                |
> > >
> > >               |<------- ASP Active(RCb)--------|  RC:
> > Routing Context
> > >
> > >               |-----ASP Active Ack (RCb)------>|      (optional)
> > >
> > >               |                                |
> > >
> > >               |----- NTFY (AS_Active)(RCb) --->|
> > >
> > >               |                                |
> > >
> > >               |------- ASP Active(RCa)-------->|  RC:
> > Routing Context
> > >
> > >               |<-----ASP Active Ack (RCa)------|      (optional)
> > >
> > >               |                                |
> > >
> > >               |<---- NTFY (AS_Active)(RCa)-----|
> > >
> > >               |                                |
> > >
> > >               |<=========  DATA (RCa) =========|
> > >
> > >               |==========  DATA (RCb) ========>|
> > >
> > >               |                                |
> > >
> > >               |<-----ASP Inactive (RCb)--------|  RC:
> > Routing Context
> > >               |----ASP Inactive Ack (RCb)----->|
> > >
> > >               |                                |
> > >
> > >               |----- NTFY(AS_Inactive)(RCb)--->|
> > >
> > >               |                                |
> > >
> > >               |------ASP Inactive (RCa)------->|  RC:
> > Routing Context
> > >               |<----ASP Inactive Ack (RCa)-----|
> > >
> > >               |                                |
> > >
> > >               |<---- NTFY(AS_Inactive)(RCa)----|
> > >
> > >               |                                |
> > >
> > >               |<-----------ASP Down------------|
> > >
> > >               |---------ASP Down Ack---------->|
> > >
> > >               |                                |
> > >
> > >               |------------ASP Down----------->|  (optional)
> > >
> > >               |<--------ASP Down Ack-----------|  (optional)
> > >
> > >               |                                |
> > >
> > >
> > >   Note: RC is optional in Notify message.
> > >
> > > << snip >>
> > >
> > >
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> >

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 6 Mar 2002 20:05:46 -0600

Umesh,

I think that you will find that double ASPDN/Ack is still
necessary.  This is because the sender of the ASPDN must
be still prepared to receive data before (and even for some
time after) receiving an ASPDN Ack.  Orderly shutdown in 
both directions cannot be accomplished with a simple two
message exchange.

In the AS/SG case, the SGP receiving an ASPDN will deactivate
all AS associated with the ASP before replying with an ASPDN
Ack.  This means that all traffic to and from the SGP for the
AS will stop.  That is not necessarily the case in IPSP
operation, and particularly in double-ended operation where
uni-direction traffic flow is possible.  Therefore, the
ASPDN/Ack must be double-ended as well because ASPDN can be
used in place of ASPIA.

--brian

Vats, Umesh wrote:                                          (Wed, 06 Mar 2002 17:55:46)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/