Subject: Re: [Sigtran] Mismatch in configuration in IUA

From: "Subhodeep Sarkar" <[email-masked]>
Date: Fri, 08 Mar 2002 16:12:16 +0530

If SG is configured for 1-5 IIDs(one AS) and ASP with 1-10 IIDs and ASP ACTIVE message is sent to SG with IIDs 1-10. What will SG do ?

Will it mark the AS(1-5 IIDs) as AS-ACTIVE (assume ASP is in override mode) and send back an ERR message with Cause="Unsupported IIDs" ?

Or,

The SG will only send back the ERR message with Unsupported IIDs ?

Cheers,

Subhodeep

Subhodeep Sarkar 
Wipro Technologies 
Voice Over IP Solutions 
Ph : +91-(0)80-8411990 x 1251 

"Ken Morneault" wrote:

The SG would send back an ASP Active Ack with Interface IDs
1-10. The RFC does not say the ASP should generate an Error 
(Invalid Interface ID), but it probably should (this can be
added to the IUA issues list). When the SG received the Error,
it would be useful to generate a "configuration error" alarm to the 
operator (but that is implementation dependent).

Ken

At 05:24 PM 3/5/2002 +0530, Subhodeep Sarkar wrote:

&gt;Hi,
&gt;
&gt;If there is a mismatch in interface configuration at the SG and ASP how will the ASPTM messages be handled ? 
&gt;
&gt;For example SG is configured for IIDs 1 to 10 and ASP is configured for IIDs 1 to 5 and ASP ACTIVE message is sent with IIDs 1 to 5. What are the IIDs that will be sent back in the ACTIVE ACK message ?
&gt;
&gt;Cheers,
&gt;
&gt;Subhodeep
&gt;
&gt;Subhodeep Sarkar 
&gt;Wipro Technologies 
&gt;Voice Over IP Solutions 
&gt;Ph : +91-(0)80-8411990 x 1251 
&gt;
&gt;
&gt;----------
&gt;Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com
&gt;Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in 

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: Ken Morneault <[email-masked]>
Date: Sun, 10 Mar 2002 09:56:20 -0500

Subhodeep,

Regardless of the option selected, we should enhance the Error message similar
to what was done in M3UA.  For instance, an ERR message with Cause=Invalid IID
would have to (MUST) contain the IID either in a separate parameter or Diag Info.

Once we change this text by updating the implementors guide 
(draft-morneault-sigtran-iua-issues-02.txt), I think option 1 would be best.

What is your preference?

Regards,

Ken

At 04:12 PM 3/8/2002 +0530, Subhodeep Sarkar wrote:

>>Hi, 
>>If there is a mismatch in interface configuration at the SG and ASP how will the ASPTM messages be handled ? 
>> 
>>For example SG is configured for IIDs 1 to 10 and ASP is configured for IIDs 1 to 5 and ASP ACTIVE message is sent with IIDs 1 to 5. What are the IIDs that will be sent back in the ACTIVE ACK message ? 
>> 
>>Cheers, 
>> 
>>Subhodeep 
>> 
>>Subhodeep Sarkar 
>&! 
>gt! ;Wipro Technologies 
>>Voice Over IP Solutions 
>>---------- 
>----------
>Get Your Private, Free E-mail from Indiatimes at <http://email.indiatimes.com>http://email.indiatimes.com
>Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from <http://www.planetm.co.in>http://www.planetm.co.in 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Valluru Hanumantha Rao" <[email-masked]>
Date: Mon, 11 Mar 2002 17:31:47 +0530

Hi all,

Option 1 should be the prefered. Else we can make it implementation
dependent, by making use of optional "infostr" parameter...just a
suggestion.

Regards
Hanumantha Rao
Wipro Technologies

----- Original Message -----
From: "Ken Morneault" <[email-masked]>
To: "Subhodeep Sarkar" <[email-masked]>; <[email-masked]>
Sent: Sunday, March 10, 2002 8:26 PM
Subject: Re: [Sigtran] Mismatch in configuration in IUA

> >If SG is configured for 1-5 IIDs(one AS) and ASP with 1-10 IIDs and ASP
ACTIVE message is sent to SG with IIDs 1-10. What will SG do ?
> >
> >Will it mark the AS(1-5 IIDs) as AS-ACTIVE (assume ASP is in override
mode) and send back an ERR message with Cause="Unsupported IIDs" ?
> >>For example SG is configured for IIDs 1 to 10 and ASP is configured for
IIDs 1 to 5 and ASP ACTIVE message is sent with IIDs 1 to 5. What are the
IIDs that will be sent back in the ACTIVE ACK message ?
> >Get Your Private, Free E-mail from Indiatimes at
<http://email.indiatimes.com>http://email.indiatimes.com
> >Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from
<http://www.planetm.co.in>http://www.planetm.co.in