Subject: RE: [Sigtran] Re: M3UA: Changeback Issue

From: "Garnero, Pierre" <[email-masked]>
Date: Fri, 15 Mar 2002 08:49:25 +0100

Bidulock,

some new comments:

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, March 14, 2002 8:37 PM
> To: Garnero, Pierre
> Cc: Greg Sidebottom; [email-masked]
> Subject: Re: [Sigtran] Re: M3UA: Changeback Issue
> 
> 
> Garnero,,
> 
> Garnero, Pierre wrote:                                   
> (Thu, 14 Mar 2002 13:34:12)
> > Brian,
> > 
> > some comments in your answer.
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Thursday, March 14, 2002 10:22 AM
> > > To: Garnero, Pierre
> > > Cc: Greg Sidebottom; [email-masked]
> > > Subject: Re: [Sigtran] Re: M3UA: Changeback Issue
> > > 
> > > 
> > > Pierre,
> > > 
> > > Yes, a BEAT mechanism should work when SP is changing traffic
> > > back from linkset A2 to A1.  So, in the example, linkset A1
> > > has failed and recovered and SP sends CBD on linkset A2 to SG2
> > > and SG2 sends BEAT (ordered in the necessary stream) to active
> > > ASPs possibly with the CBC and some marker in the heartbeat
> > > info.  When SG2 receives enough BEAT Acks from active ASPs, it
> > > sends CBA with the necessary CBC back to the SP and the
> > > changeback can complete correctly.
> > > 
> > > However, when the SPMC is restarting traffic on a recovered
> > > association it is changing back that traffic, say, from SG2
> > > to SG1.  There is no way for an ASP to ask an SG to send CBA
> > > to SP on its behalf so that it can perform the coordinated
> > > changeback.  Because the SPMC is viewed as a SEP in the SS7
> > > network, it must send CBD when redirecting traffic flows to
> > > the SS7 network or this "virtual" SPMC will fail SS7 (Q.782)
> > > conformance.  BEAT/Ack will not do in this case, becase the
> > > SG cannot know for which BEAT messages to send CBD and for
> > > which to not send CBD (heartbeat info is opaque to the receiver
> > > of the BEAT).
> > > 
> > 
> > This mecanism seems pretty complicated...
> > More than that, I think that even the SS7 "normal" changeback 
> > mecanism does not ensure that the adjacent PC has flushed all its 
> > data messages. 
> 
> I think you are confusing changeback with changeover.
> Although it is true in the case of changeover, in the changeback
> case there is no probability of missequencing inherent to the
> procedure.  All messages are indeed flushed on the routeset for
> the SLS value (traffic flow) being flushed for each traffic flow
> and for each routeset in the changeback.
No. I just look at Figure 31/Q.704 (sheet 1 of 2) - 
Signalling traffic management; changeback control (TCBC)
=> on receipt of CBD, the only action required is: send back a CBA.
There is no need to verify that messages have been forwarded. We could
always imagine that some messages are still in a transmit buffer in the
machine that send the CBA. In the reality, this is unlikely but...
> 
> > It just ensure that the adjacent PC has received all the 
> messages when
> > the CBD initiator receives the acknowledge.
> > Then, I think that most of the cases could be solved either by:
> >   . a timer (like ITU T3) started on AS side
> >   . or a simple flushing mecanism (like BEAT-BEAT/ACK), 
> initiated by the 
> >     AS in this case...
> 
> This would be the equivalent of controlled re-routing in SS7.  This
> would not permit an M3UA attached SEP to meet validation and 
> compatibility
> tests in one direction per Q.782 clause 4.
> 
> > 
> > And I have the filling that in the solution you propose the CBD is
> > sent with an OPC equal to the SPMC "point code" (but I 
> could be wrong). 
> > As it is possible to have multiple SPMC's behind the SGs, I 
> cannot figure
> > out how a SEP (or a legal STP) can handle that if it is not 
> M3UA aware.
> > I am quite sure that most of the current SS7 PCs will 
> discard a CHM MTP3
> > message coming from a non configured "adjacent", because I 
> think that
> > in most of current SS7 implementations, there is only one 
> adjacent on the
> > other side of a single linkset... 
> 
> On the contrary, STPs are required to pass CBD/CBA as they do 
> any other
> SS7 message.  In the quasi-associated mode, CBD/CBA are normally only
> addressed to remote signalling points.  I can't think of a situation
> in which CBD/CBA contains the OPC/DPC of a pure STP.
It is true true the CBD messages could be forwarded by an STP but 
look at Figure 31/Q.7604 (sheet 2 of 2) - Signalling traffic management;
changeback control (TCBC)
=> the CBD is sent to an adjacent PC only (comment included in the spec:
 "Is SP at remote end of newly available link accessible via alternative
link ?"
At the remote end of a link... there is an adjacent right ?
And it is possible to have the OPC of an STP in a CBD, there is no "STP function"
flag in TCBC....

> 
> --brian
> 
> > 
> > 
> > 
> > > The ASP cannot just flip traffic flows back between SGs when
> > > associations and RCs become active according to simple loadsharing
> > > rules: it must ensure that the traffic flow is flushed with
> > > a CBD before restoring traffic to a newly active or restored SG.
> > > 
> > > Now, you might think that an SG could just send CBDs on the
> > > ASPs behalf when reactivating traffic; however, the CBA does
> > > not have to take the same reverse path through the SS7 network
> > > that the CBD took.   That is, a CBD launched by SG1 could be
> > > acknowledged by the SP by sending a CBA via SG2.  In this case
> > > SG1 would never see the reply.
> > > 
> > > Getting it working in both directions might require the
> > > addition of a new message type to M3UA/SUA so that the
> > > ASP can ask an SG to launch CBD and so that it can receive
> > > the equivalent of CBA from any SG before restarting traffic
> > > on a new or restored routing context and stream.
> > > 
> > > --brian
> > > 
> > > > > > 
> > > > > >                +-------+        - - - - - 
> > > > > >                |       |       | /-----\ |
> > > > > >                |  SG1  |---------| ASP1|
> > > > > >               /| "STP" |\      |/\-----/ |
> > > > > >           A1 / |       | \     /
> > > > > >             /  +-------+  \   /|   AS    |
> > > > > >     /----\ /       |       \ /
> > > > > >     | SP |/        |        X  |  SPMC   |
> > > > > >     |    |\        |       / \
> > > > > >     \----/ \       |      /   \|         |
> > > > > >             \  +-------+ /     \
> > > > > >           A2 \ |       |/      |\/-----\ |
> > > > > >               \|  SG2  |---------| ASP2|
> > > > > >                | "STP" |       | \-----/ |
> > > > > >                |       |        - - - - -
> > > > > >                +-------+
> > > > > > 
> > > 
> > > Garnero, Pierre wrote:                                   
> > > (Thu, 14 Mar 2002 09:36:38)
> > > > Brian,
> > > > 
> > > > Yes, I think that this problem must be fixed and I suppose 
> > > that if it
> > > > is possible to use HEARTBEAT messages on a stream basis 
> > > (and not only
> > > > on stream 0), we could implement this mechanism with an already
> > > > existing M3UA (ou SUA) message (on receipt of the 
> HEARTBEAT_ACK, we
> > > > could consider that the messages send (before the 
> HEARTBEAT) on a
> > > > particular stream have been "flushed" and then received by 
> > > the ASP). 
> > > >
> > > > If I remember well, you have already proposed such a 
> mechanism...
> > > > 
> > > > 
> > > > Cheers,
> > > > 
> > > > Pierre
> > > > 
> > > > > -----Original Message-----
> > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > Sent: Wednesday, March 13, 2002 9:18 PM
> > > > > To: Greg Sidebottom; [email-masked]
> > > > > Subject: [Sigtran] Re: M3UA: Changeback Issue
> > > > > 
> > > > > 
> > > > > Sigtraners,
> > > > > 
> > > > > We never corrected this problem with M3UA/SUA.  M3UA
> > > > > cannot support interworking with the SS7 network for
> > > > > multiple SGs and will fail Q.782 conformance tests
> > > > > pertaining to changeback.
> > > > > 
> > > > > Should this be corrected in the implementors guide?
> > > > > 
> > > > > --brian
> > > > > 
> > > > > On Wed, 11 Jul 2001, Brian F. G. Bidulock wrote:
> > > > > 
> > > > > > All,
> > > > > > 
> > > > > > M3UA does not provide support for the SS7 MTP changeback
> > > > > > procedure where multiple SG are involved.
> > > > > > 
> > > > > > Here is the scenario:
> > > > > > 
> > > > > > 
> > > > > >                +-------+        - - - - - 
> > > > > >                |       |       | /-----\ |
> > > > > >                |  SG1  |---------| ASP1|
> > > > > >               /| "STP" |\      |/\-----/ |
> > > > > >           A1 / |       | \     /
> > > > > >             /  +-------+  \   /|   AS    |
> > > > > >     /----\ /       |       \ /
> > > > > >     | SP |/        |        X  |  SPMC   |
> > > > > >     |    |\        |       / \
> > > > > >     \----/ \       |      /   \|         |
> > > > > >             \  +-------+ /     \
> > > > > >           A2 \ |       |/      |\/-----\ |
> > > > > >               \|  SG2  |---------| ASP2|
> > > > > >                | "STP" |       | \-----/ |
> > > > > >                |       |        - - - - -
> > > > > >                +-------+
> > > > > > 
> > > > > > The SP loses linkset A1.  Traffic is succesfully changed
> > > > > > over to linkset A2.  Linkset A1 restores.  SP peforms
> > > > > > changeback procedure per Q.704 6.2.1 (b) (i) (that is, on
> > > > > > a per-destination basis).  It sends a CBD for each SLS
> > > > > > which is being diverted from A2 back to A1 with a DPC of
> > > > > > the SPMC.
> > > > > > 
> > > > > > What is SG2 to do with the CBD?  If it responds with a CBA
> > > > > > there may be messages between SG2 and ASP1 or ASP2 which
> > > > > > have not yet arrived at the ASP and might be overtaken by
> > > > > > the diverted traffic.
> > > > > > 
> > > > > > The SG must have a message which it can send to the each
> > > > > > ASP which has the same effect as a changeback-declaration
> > > > > > which will be responded to by the ASP with a changeback-
> > > > > > acknowledgement so that mis-sequencing can be avoided
> > > > > > during changeback procedures per Q.704 6.2.1 (b)(i).
> > > > > > 
> > > > > > I can put together proposed text if anyone is interested.
> > > > > > 
> > > > > > -- 
> > > > > > Brian F. G. Bidulock
> > > > > > [email-masked]
> > > > > > http://www.openss7.org/
> > > > > 
> > > > > -- 
> > > > > Brian F. G. Bidulock    ¦ The reasonable man adapts 
> > > himself to the ¦
> > > > > [email-masked]    ¦ world; the unreasonable one 
> > > persists in  ¦
> > > > > http://www.openss7.org/ ¦ trying  to adapt the  world  to 
> > > himself. ¦
> > > > >                         ¦ Therefore  all  progress  
> > > depends on the ¦
> > > > >                         ¦ unreasonable man. -- George 
> > > Bernard Shaw ¦
> > > > > 
> > > > > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > 
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 15 Mar 2002 02:52:23 -0600

Garnero,

I am speaking to Q.704 6.2.1(b)(i).  The SDLs only describe Q.704
6.2.1(b)(ii).  Nevertheless, CBD needs to be sent.  How does the
ASP ask an SG acting as STP to send CBD to its mate?

--brian

Garnero, Pierre wrote:                        (Fri, 15 Mar 2002 08:49:25)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/