Subject: Re: [Sigtran] informal discussion at ietf

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 27 Mar 2002 16:12:18 -0600

Lyndon,

Perhaps the editors of the imp guides could identify an
initial list of what is to be included in the guides:
what deficiencies will be addressed, and which outstanding
issues form the LC on the UAs will also be addressed.

--brian

Lyndon Ong wrote:                                          (Wed, 27 Mar 2002 13:41:26)
> Hi Brian,
> 
> I think we need to sort through what are corrections
> and what are new items.  The reaction of the folks
> at the Minneapolis meeting was that they did not see
> a strong need for items beyond the "implementors guides",
> ASs, and the IPSP-IPSP work (with possible interest in
> SG-SG work, although it sounds like this is combined 
> according to Tolga's message).
> 
> However, this only reflects the discussion in this small
> group and is not binding.  We should try to identify as
> a group if there are other strongly needed extensions.
> 
> Cheers,
> 
> Lyndon
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, March 27, 2002 1:12 PM
> To: Ong, Lyndon
> Cc: [email-masked]'
> Subject: Re: [Sigtran] informal discussion at ietf
> 
> 
> Lyndon,
> 
> I am a little confused by the statements with regard to "new work items".
> 
> There are a number of functional areas which represent technical errors
> and deficiencies in the current UA specifications which were deferred to
> "extension draft" in WG Last Call so that we could issue RFCs.  This
> was not new work: these were extension drafts to address deficiencies that
> required a significant and separable work effort.  These included IPSP,
> multiple SG as STP errors and deficiencies, registration problems and
> deficiencies (primarily in SUA), failover errors and deficiencies,
> loadsharing and traffic mode deficiencies.  These are not new work items,
> these are outstanding issues without concensus resolution.  The concensus
> resolution was to defer them to "extension drafts".
> 
> Now, we are working on an IPSP extension draft.  This is not new work?
> Then where will multiple SG as STP deficiencies, registration deficiencies,
> failover deficiencies and traffic mode deficiencies be addressed?  In 
> the Implementor's Guide (I hate that ITU term)?
> 
> What "new work" was anyone referring to?
> 
> --brian
> 
> Lyndon Ong wrote:                                          (Wed, 27 Mar 2002
> 12:21:06)
> > Folks,
> > 
> > About 8-10 people got together while in Minneapolis to discuss future
> > progress
> > on Sigtran issues.  The results of the discussion are as follows
> (presented
> > for
> > information, this was an unofficial discussion and non-binding):
> > 
> > -- there is interest in a UA bakeoff (either IUA, M2UA, M3UA and SUA, or 
> > splitting off M3UA, depending on the number of interested parties),
> proposed
> > timeframe being October/November this year.  Possible locations (being
> > checked
> > for availability) are ETSI and ATG test labs.  Assuming the RFCs are
> > available
> > by that time, the goal would be to test the RFC version, plus any
> > corrections
> > identified in the implementors guides.
> > 
> > -- we need implementors quides for the different UAs.  Separate guides
> seem
> > to be the best way to document results from bakeoffs and other testing.
> > Guides
> > for IUA and M3UA are in progress (in fact, the IUA guide is already out,
> > with a
> > different title).  IUA guide is from Ken, M3UA guide will be from Ken and
> > Javier.
> > Work on IPSP to IPSP is expected from Tolga and Brian and may be added
> > to the M3UA guide (this is a guess, Tolga and Brian were unable to
> attend).
> > 
> > -- we need an Applicability Statement explaining the different UAs and how
> > they
> > relate and would be used.  Lode and Javier are working on an updated
> draft.
> > 
> > -- we currently have 2 MIBs, SCTP and M3UA, in progress.   My
> understanding
> > is that there is no requirement to have MIBs for all of the UAs, it is up
> to
> > the
> > level of interest - if there is a lot of interest and likelihood of
> > implementation for
> > a new MIB, then this should be pursued.
> > 
> > -- as far as new work items are concerned, most people were very cautious
> > about
> > adding new items to the WG, preferring to concentrate on implementing the
> > UAs
> > as they are and evaluate what extensions might be necessary.  Also, the 
> > implementors guides and AS will fit under the current charter as
> completion
> > of
> > the adaptation layer work, new items may require rechartering (not
> > impossible,
> > but would need to convince our A-Ds that there is sufficient interest).
> > 
> > -- one area that many people expressed interest in was looking at SG-to-SG
> > transport, but again with lower priority than implementation of the
> existing
> > adaptation layer specifications.
> > 
> > -- one of the participants, representing a carrier, suggested that we
> might
> > work
> > towards testing in a mixed SS7/IP environment as opposed to only in an IP
> > environment.  This sounded like a good step, but it was not clear how to
> do
> > this in practice.
> > 
> > Cheers,
> > 
> > L. Ong
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ong, Lyndon" <[email-masked]>
Date: Wed, 27 Mar 2002 13:41:26 -0800

Hi Brian,

Cheers,

Lyndon

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Wednesday, March 27, 2002 1:12 PM
To: Ong, Lyndon
Cc: [email-masked]'
Subject: Re: [Sigtran] informal discussion at ietf

Lyndon,

--brian

(presented
proposed
seem
attend).
draft.
understanding
to
completion
existing
might
do

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/