Subject: Re:[Sigtran] Mismatch in configuration in IUA

From: "Subhodeep Sarkar" <[email-masked]>
Date: Mon, 11 Mar 2002 18:05:49 +0530

Ken,

I also do prefer the Option 1 . We have to be very clear in the description of the ASPTM procedures i.e the SG SHOULD respond with an ACTIVE ACK for the IIDs for which it's configured and ERR message reporting the unsupported IIDs.And also the ASP on reception of the ERR message MAY act accordingly like generation of alarm which can be implementation dependent. 

Cheers,

Subhodeep

Subhodeep Sarkar 
Wipro Technologies 
Voice Over IP Solutions 
Ph : +91-(0)80-8411990 x 1251 

"Valluru Hanumantha Rao" wrote:

Hi all,

Option 1 should be the prefered. Else we can make it implementation
dependent, by making use of optional "infostr" parameter...just a
suggestion.

Regards
Hanumantha Rao
Wipro Technologies

----- Original Message -----
From: "Ken Morneault" 
To: "Subhodeep Sarkar" ; 
Sent: Sunday, March 10, 2002 8:26 PM
Subject: Re: [Sigtran] Mismatch in configuration in IUA

&gt;
&gt;
&gt; Subhodeep,
&gt;
&gt; Regardless of the option selected, we should enhance the Error message
similar
&gt; to what was done in M3UA. For instance, an ERR message with Cause=Invalid
IID
&gt; would have to (MUST) contain the IID either in a separate parameter or
Diag Info.
&gt;
&gt; Once we change this text by updating the implementors guide
&gt; (draft-morneault-sigtran-iua-issues-02.txt), I think option 1 would be
best.
&gt;
&gt; What is your preference?
&gt;
&gt; Regards,
&gt;
&gt; Ken
&gt;
&gt; At 04:12 PM 3/8/2002 +0530, Subhodeep Sarkar wrote:
&gt;
&gt; &gt;If SG is configured for 1-5 IIDs(one AS) and ASP with 1-10 IIDs and ASP
ACTIVE message is sent to SG with IIDs 1-10. What will SG do ?
&gt; &gt;
&gt; &gt;Will it mark the AS(1-5 IIDs) as AS-ACTIVE (assume ASP is in override
mode) and send back an ERR message with Cause="Unsupported IIDs" ?
&gt; &gt;
&gt; &gt;Or,
&gt; &gt;
&gt; &gt;The SG will only send back the ERR message with Unsupported IIDs ?
&gt; &gt;
&gt; &gt;Cheers,
&gt; &gt;
&gt; &gt;Subhodeep
&gt; &gt;
&gt; &gt;Subhodeep Sarkar
&gt; &gt;Wipro Technologies
&gt; &gt;Voice Over IP Solutions
&gt; &gt;Ph : +91-(0)80-8411990 x 1251
&gt; &gt;
&gt; &gt;
&gt; &gt;
&gt; &gt;"Ken Morneault" wrote:
&gt; &gt;
&gt; &gt;
&gt; &gt;
&gt; &gt;
&gt; &gt;The SG would send back an ASP Active Ack with Interface IDs
&gt; &gt;1-10. The RFC does not say the ASP should generate an Error
&gt; &gt;(Invalid Interface ID), but it probably should (this can be
&gt; &gt;added to the IUA issues list). When the SG received the Error,
&gt; &gt;it would be useful to generate a "configuration error" alarm to the
&gt; &gt;operator (but that is implementation dependent).
&gt; &gt;
&gt; &gt;Ken
&gt; &gt;
&gt; &gt;At 05:24 PM 3/5/2002 +0530, Subhodeep Sarkar wrote:
&gt; &gt;
&gt; &gt;&gt;Hi,
&gt; &gt;&gt;
&gt; &gt;&gt;If there is a mismatch in interface configuration at the SG and ASP how
will the ASPTM messages be handled ?
&gt; &gt;&gt;
&gt; &gt;&gt;For example SG is configured for IIDs 1 to 10 and ASP is configured for
IIDs 1 to 5 and ASP ACTIVE message is sent with IIDs 1 to 5. What are the
IIDs that will be sent back in the ACTIVE ACK message ?
&gt; &gt;&gt;
&gt; &gt;&gt;Cheers,
&gt; &gt;&gt;
&gt; &gt;&gt;Subhodeep
&gt; &gt;&gt;
&gt; &gt;&gt;Subhodeep Sarkar
&gt; &gt;&amp;!
&gt; &gt;gt! ;Wipro Technologies
&gt; &gt;&gt;Voice Over IP Solutions
&gt; &gt;&gt;Ph : +91-(0)80-8411990 x 1251
&gt; &gt;&gt;
&gt; &gt;&gt;
&gt; &gt;&gt;----------
&gt; &gt;&gt;Get Your Private, Free E-mail from Indiatimes at
http://email.indiatimes.com
&gt; &gt;&gt;Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from
http://www.planetm.co.in
&gt; &gt;
&gt; &gt;
&gt; &gt;
&gt; &gt;----------
&gt; &gt;Get Your Private, Free E-mail from Indiatimes at
http://email.indiatimes.com
&gt; &gt;Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from
http://www.planetm.co.in
&gt;
&gt;
&gt; _______________________________________________
&gt; Sigtran mailing list
&gt; [email-masked]
&gt; https://www1.ietf.org/mailman/listinfo/sigtran

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: Ken Morneault <[email-masked]>
Date: Mon, 11 Mar 2002 11:12:15 -0500

Subhodeep,

Ok, I will add to the IUA issues list (note:  plan to rename this
draft to implementors guide) with a description of changes to 
ERR message and a sample message flow for the this scenario.

Regards,

Ken

At 06:05 PM 3/11/2002 +0530, Subhodeep Sarkar wrote:

>>> Subhodeep,
>>> Regardless of the option selected, we should enhance the Error message
>>similar
>>> to what was done in M3UA. For instance, an ERR message with Cause=Invalid
>>IID
>>> would have to (MUST) contain the IID either in a separate parameter or
>>Diag Info.
>>>
>>> Once we change this text by updating the implementors guide
>>> (draft-mor! ne! ault-sigtran-iua-issues-02.txt), I think option 1 would be
>>best.
>>>
>>> What is your preference?
>>>
>>> Regards,
>>>
>>> Ken
>>>
>>> At 04:12 PM 3/8/2002 +0530, Subhodeep Sarkar wrote:
>>>
>>> >If SG is configured for 1-5 IIDs(one AS) and ASP with 1-10 IIDs and ASP
>>> >Will it mark the AS(1-5 IIDs) as AS-ACTIVE (assume ASP is in override
>>> >Or,
>>> >The SG will only send back the ERR message with Unsupported IIDs ?
>>> >
>>> >Cheers,
>>> >
>>> >Subhodeep
>>> >
>>> >Subhodeep Sarkar
>>> >Wipro Technologies
>>> >Voice Over IP Solutions
>>> >"Ken Morneault" wrote:
>>&!
>>gt! ; >
>>> >The SG would send back an ASP Active Ack with Interface IDs
>>> >1-10. The RFC does not say the ASP should generate an Error
>>> >(Invalid Interface ID), but it probably should (this can be
>>> >added to the IUA issues list). When the SG received the Error,
>>> >it would be useful to generate a "configuration error" alarm to the
>>> >operator (but that is implementation dependent).
>>> >
>>> >Ken
>>> >
>>> >At 05:24 PM 3/5/2002 +0530, Subhodeep Sarkar wrote:
>>> >
>>> >>Hi,
>>> >>
>>> >>If there is a mismatch in interface configuration at the SG and ASP how
>>> >>For example SG is configured for IIDs 1 to 10 and ASP is configured for
>>> >! &g!
>>t;
>>> >&!
>>> >gt! ;Wipro Technologies
>>> >>----------
>>> >----------
>>> _______________________________________________
>>> Sigtran mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/sigtran
>>
>>
>>
>>
>>
>>----------
>>Get Your Private, Free E-mail from Indiatimes at <http://email.indiatimes.com>http://email.indiatimes.com
>>Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from <http://www.planetm.co.in>http://www.planetm.co.in 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran