Subject: [Sigtran] M2PA-04 Sequence Numbers

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 4 Mar 2002 18:20:32 -0600

Tom,

Is there some reason why 16-bit sequence numbers
were selected instead of, say 24-bit?

I would think that there are several reasons for
using 24-bit sequence numbers instead of 16-bit
as follows:

1)  on high speed links, 16 bit sequence numbers
    may wrap.  This would either render changeover
    useless, or flow limit the link to a 16-bit
    window.

2)  the XCO/XCA messages that M2PA recommends be
    used by MTP3 contain 24-bit FSNs, not 16-bit
    FSNs.

3)  Q.2210/2140 uses 24-bit sequence numbers.

4)  Existing MTP3 implementations supporting
    Q.2210/2140 or ANSI equivalent will have to
    be changed to 16-bit sequence number math.

5)  Q.703 Annex A (High Speed Links) uses a
    12-bit sequence number.

So, in SS7 we have a 7-bit sequence number (Q.703),
a 12-bit sequence number (Q.703 Annex A), a 24-bit
sequence number (Q.2210/2140).  These last two use
the XCO/XCA of Q.2210.

So now M2PA proposes a 16-bit sequence number?

The following table would indicate some difficulty:

	7-bits	    56kbps
	12-bits	    1.5-2Mbps
	24-bits	    1.5-155Mbps

It doesn't look like 16-bits will do it for M2PA.

Please increase the sequence number size to 24-bits
and place them in a 32-bit field for future expansion.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Fri, 08 Mar 2002 17:42:57 -0600

I think 24 bits is a good idea. I will make the change. 

tomG.

-- 
* Tom George          972-519-3168           [email-masked]   *
* PB2-1323       Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel USA, Inc.; 1000 Coit Rd, MS PB2-STPA; Plano TX 75075-5813   *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *