Subject: [Sigtran] Basic Doubts in IUA

From: Sriram Sridhar <[email-masked]>
Date: Fri, 1 Mar 2002 16:21:03 +0530

> Hi All ,
> This is Sriram Sridhar from Telesoft.
> Iam subscribed to the Sigtran Mailing List.
> I found your name in the mailing list.
> 
> Please correct me in my understanding of the IUA  layer in the SIGTRAN
> Stack.
> 
> From a Signalling Gateway point of view:
> 
> 1. Each D channel on an signalling gateway correspond to an Interface
> Identifer on the Sigtran side.
> There can be multiple D channels originating from diferent networks which
> terminates on an SG.
> Is this correct?
> 
> 2. There is a single AS concept in the Signalling Gateway that maintains
> the list of Interface Identifiers.
> Is this correct?
> 
> 3. AS has multiple ASP's where each ASP has an SCTP association.Each SCTP
> association has multiple streams.
> Is this correct?
> 
> 4. Each Interface Identifier is mapped to an SCTP Stream and a table of
> this mapping is maintained by the IUA.
> Is this correct?
> 
> 5. There can be multiple associations (ASP's) maintained by the SG (AS)
> where each association(ASP) has a table of mapping between the Interface
> Id and SCTP Stream.
> Is this correct?
> Is it possible for the table of mapping between the Interface Id and SCTP
> Stream to be made globally accessible by all the multiple associations
> (ASP's) residing in the SG (or) each association(ASP's) should maintain an
> individual table of mapping between the Interface Id and SCTP Stream?
> 
> 6.ASP sends an ASP ACTIVE message to the SG by choosing an SCTP stream. 
> SG updates its table of Interface Identifier mapped to the SCTP Stream
> sent by ASP.
> Is this correct? please give some more inputs regarding this.
> 
> 7.It is recommended in the RFC that a seperate SCTP stream is used for
> each D channel.
> 
> 8. Is it possible for each association(ASP) in an SG(AS) to have seperate
> SCTP stream for each D channel so that each ASP is capable of handling all
> the D channels terminating on the SG?
> 
> 9. Can multiple associations(ASP's) in an SG(AS) refer to the multiple
> instances of  a single host (Transport IP Address of an MGC) or does it
> mean that each association(ASP) must refer to a single physical host
> (Transport IP Address of an MGC)?
> 
> Please correct the above said statements if you feel there is something
> missing or wrong.
> 
> Thanks and Regards
> Sriram Sridhar
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Mon, 4 Mar 2002 09:28:38 +0530

PLEASE IGNORE THE DISCLAIMER TEXT FOR
THE MAILING LIST
	
*************************************************************

Hi Sriram,

See my comments inline.

Cheers,
Subhodeep

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Sriram Sridhar
Sent: Friday, March 01, 2002 4:21 PM
To: [email-masked]'
Subject: [Sigtran] Basic Doubts in IUA

> There can be multiple D channels originating from diferent networks
which
[Subhodeep] Yes.
> the list of Interface Identifiers.
[Subhodeep] Not necessarily true.
> association has multiple streams.
[Subhodeep] Yes.
> this mapping is maintained by the IUA.
[Subhodeep] Yes.
> where each association(ASP) has a table of mapping between the
Interface
[Subhodeep]Yes.
> individual table of mapping between the Interface Id and SCTP Stream?
[Subhodeep] Streams are specific to an association and ideally cannot be
shared
globally.
> Is this correct? please give some more inputs regarding this.
[Subhodeep] Any management message is sent on stream 0. So ASP ACTIVE
message will
sent across on stream zero. It will be rejected if it's sent on any
other stream. 
> 7.It is recommended in the RFC that a seperate SCTP stream is used for
[Subhodeep] Yes.
> the D channels terminating on the SG?
[Subhodeep] Yes
> (Transport IP Address of an MGC)?
[Subhodeep] It's possible to have multiple instances in a single host.
But ideally
it should be running on separate physical host. Multiple
ASPs/associations are used 
for redundancies/load sharing and it always make more sense to run them
on
separate physical hosts.