Subject: [Sigtran] Re: [Tsvwg] What is the need for defining many adaptation layers for SS7 over IP

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 6 Mar 2002 05:35:44 -0600

Umesh,

Your question should really be for sigtran, not tsvwg.

However, if you consult the SIGTRAN architecture and framework
RFC, you will find that adaptation layers at different levels
serve different signalling needs in the MGC/MG architecture.

Your argument for M3UA (because all things go through MTP3)
is equally valid for M2UA or M2PA (because all things go through
MTP2).

For an example, M3UA does not support lossless failover in
the same manner that MTP3 does over MTP2, M2UA, or M2PA.  M3UA
cannot adequately support SUA relay nodes or adequately support
SCCP in multi-SG configurations.  It is questionable whether
M3UA can adequately support ISUP routing keys.

--brian

On Wed, 06 Mar 2002, Umesh wrote:

> Hi All,
>     I am new to SIGTRAN and hence do not have much idea about the history of
> adaptation layer
> protocols. I was wondering why there are so many adaptation layers defined
> for SS7 ?? Would it not
> suffice to define adaptation layer for MTP3 (Since all user data finally
> goes through MTP3 ) ??
> 
> -thanks in advance,
> Umesh.
> 
> 
> _______________________________________________
> tsvwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/tsvwg

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Wed, 6 Mar 2002 13:39:26 +0200

Hi Umesh,

> serve different signalling needs in the MGC/MG architecture.

Just seconding Brian's point.  Basically, think of each UA
as a tool - you should select the tool that best reflects
your needs.  I think that there are a lot of issues which
are dependent upon the sort of network you are running in,
etc.

best,
John