Subject: RE: [Sigtran] ASP Identifier

From: "Goel, Soni" <[email-masked]>
Date: Wed, 6 Mar 2002 11:27:11 -0800

Hi,

I support Umesh and Nitin. 

Since the draft is not clear about the ASP Id usage, it again raised a long
discussion, though it had already been discussed earlier. The same happened
with ASP Failure and Broadcast. 

It is better such topics are made clear at some place from where they can be
finally incorporated into the M3UA standard. So that it prevents people to
take their assumptions and implement them, causing interoperability problems
later. It is wrong to say that such things cannot be captured in a draft.

- Soni

-----Original Message-----
From: Ong, Lyndon [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 10:09 AM
To: 'Vats, Umesh'; [email-masked]'; Nitin Vairagare
Cc: Sigtran (E-mail)
Subject: RE: [Sigtran] ASP Identifier

Folks,

Just clarification, M3UA and M2UA have already been
approved by IESG, so any clarifications we are talking
about should be in a separate draft, e.g., an
implementor's guide.

Cheers,

L. Ong

-----Original Message-----
From: Vats, Umesh [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 9:54 AM
To: [email-masked]'; Nitin Vairagare
Cc: Sigtran (E-mail)
Subject: RE: [Sigtran] ASP Identifier

Hi  Brian

I too believe that the description of ASP Id is
inadequate in the current M3UA draft. Similar
views have been expressed by other members also.

Some more details are needed in the draft regarding the
Need, Usage, Scope and Procedures for ASP Id. This will
obviate the need for each new implementor to dig through 
all the mailing list archives for reaching some understanding
about an ASP Id. Also, different members may arrive at
different conclusions about ASP Id if concise and clear
explanation for it is missing in the draft.

The following two usages of ASP Id need to be mentioned 
clearly in the draft :
1. Use at SGPs where the ASPs connected to it 
   use dynamic port allocation
2. USe at ASPs (e.g acting as standby for some ASPs in
   AS)

Umesh 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 9:33 AM
To: Nitin Vairagare
Cc: Goel, Soni; 'Tolga Asveren'; Sigtran (E-mail)
Subject: Re: [Sigtran] ASP Identifier

Nitin,

Nitin Vairagare wrote:                                      (Wed, 06 Mar
2002 09:55:20)
> This has been a long discussion with certain good points.
> But this clearly shows there isn't very clear text for
> use of ASP Identifier. And that is why different
> implementation tend to have different assumptions.
> 
> Can some one summarise text for ASP Identifier?
> 1) Clear definition for ASP Identifier (including usage)?

It's definition is clear: it identifiers an ASP.

> 2) what is scope of it?

It's scope is obviously the SGP receiving it.  The SGP
has two error codes: "ASP Identifier Required" and "Invalid
ASP Identifier."

> 3) What are different scenarios it can be used?

These are examples and can be address in an imp guide.

> 4) clear procedures to use it.

It is identified in which message the APS Identifier must
appear.

> 5) If it makes redundancy and take over procedure clear
>    then why can't we make it mandatory for networks
>    using more than one ASP behind SGP? And thereby define
>    clear procedure for notifications and action taken by
>    ASPs.

Because there were those in the WG strongly against making it
a mandatory field in the ASPUP, because the SGP could, by examining
IP addresses and port numbers in some cases of static allocation,
identify the ASP itself.  Please look back in the archives at the
previous discussions on ASP Identifier.

> 
> This would help to every one understand it better and
> concur in usage.

Everyone has understood it and concurred on usage: please refer
to the archives.  It may not be so well captured in the drafts,
but certainly ASP Id is not the only thing in that category.

Do you wish to delay the RFC to change these things?  Does anyone
else?

--brian

> 
> Regards,
> Nitin
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Tuesday, March 05, 2002 4:56 PM
> To: Goel, Soni
> Cc: 'Tolga Asveren'; Sigtran (E-mail)
> Subject: Re: [Sigtran] ASP Identifier
> 
> 
> Soni,
> 
> As the ASP Failure notification is not required to contain an
> RC, when an ASP is "in" an AS or not is rather moot.  It is up
> to the ASP receiving the notification to determine what action
> to take.  Sending the notification to all ASPs not in the
> ASP-DOWN state ensures that no ASP is "missed" with the
> notification without needing to calculate membership.  As
> mentioned in 4.3.4.5, "[t]he ASPs remain in control of what
> (and when) traffic action is taken."  Therefore, a policy at
> the SGP which ensures that no ASP is missed is superior to a
> policy that might miss notifying a concerned ASP, for all
> notifications.  But, the draft does not required this, because
> it is not the draft's place to tell an implementation how to
> meet the requirements.
> 
> I don't see any problem in capturing this in the
> implementation guide.
> 
> --brian
> 
> Goel, Soni wrote:                                           (Tue, 05 Mar
> 2002 13:38:34)
> >
> > Don't you think that all these assumptions have to be taken because the
> > Draft doesn't state clearly the usage of ASP Id and ASP Failure. It will
> be
> > better for the protocol to be clear because you think that an ASP which
> has
> > not been registered for an AS, is still "in" an AS....although I think
> that
> > ASP can be said "in" an AS only when it is registered
> statically/dynamically
> > in that AS.
> >
> > Soni
> >
> >
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Tuesday, March 05, 2002 1:30 PM
> > To: Goel, Soni
> > Cc: 'Tolga Asveren'; Sigtran (E-mail)
> > Subject: Re: [Sigtran] ASP Identifier
> >
> >
> > Soni,
> >
> > I send it to all ASPs that are ASP-UP within the scope of the ASP Id.
> > I do not support ASP Id scopes of less than an SGP (because ASP Id
> > is scoped on a per-SGP basis for its use in dynamic port assignment).
> > ASPs in the ASP-UP state which have not yet registered for any AS
> > also need to receive this notification, so I send it to all ASPs
> > associated with the SGP not in the ASP-DOWN state.  This does not
> > conflict with the statements in the draft, because I consider ASPs
> > that have not yet registered for an AS as being "in" the AS even
> > though they are not in the ASP-INACTIVE or ASP-ACTIVE state with
> > respect to that AS.
> >
> > --brian
> >
> >
> > Goel, Soni wrote:                                           (Tue, 05 Mar
> > 2002 13:17:04)
> > >
> > > Is it to all the ASPs associated with the SGP, or all the ASPs in the
> > > configured AS ?
> > >
> > > - Soni
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Tuesday, March 05, 2002 1:05 PM
> > > To: Goel, Soni
> > > Cc: 'Tolga Asveren'; Sigtran (E-mail)
> > > Subject: Re: [Sigtran] ASP Identifier
> > >
> > >
> > > Soni,
> > >
> > > Goel, Soni wrote:                                           (Tue, 05
Mar
> > > 2002 12:25:03)
> > > > Hi,
> > > >
> > > > Following are my comments -
> > > > 1) Notify for AS State Change - Following statement in section
4.3.4.5
> > > > should be corrected -
> > > > "A Notify message reflecting a change in the AS state MUST be sent
to
> > > > all ASPs in the AS, except those in the ASP-DOWN state, with
> > > > appropriate Status Information and any ASP Identifier of the failed
> > > > ASP."
> > > >
> > > > This should be changed to -
> > > > "A Notify message reflecting a change in the AS state MUST be sent
to
> > > > all ASPs in the AS, except those in the ASP-DOWN state, with
> > > > appropriate Status Information."
> > > >
> > > > 2) The following question remains unanswered -
> > > > > The Draft states following for "ASP Failure" -
> > > > > "For the ASP Failure case, the SGP is indicating to ASP(s)
> > > > > in the AS that one of the ASPs has transitioned to ASP-DOWN.  The
> ASP
> > > > > Identifier (if available) of the failed ASP MUST be placed in the
> > > > > message."
> > > > >
> > > > > Does it mean that if an ASP goes down and it was configured for
AS1,
> > > then
> > > > > the "ASP Failure" message will be sent to only the ASPs which are
> > > > > active/inactive in AS1 ?
> > > > >
> > > > Yes or No ? If not, then to which ASPs ?
> > >
> > > I send it to all ASPs not in the ASP-DOWN state.
> > >
> > > >
> > > > If an ASP is part of multiple RCs, and the answer to above question
is
> > > YES,
> > > > this means that ASP Failure will be sent separately for each AS the
> ASP
> > is
> > > > part of. In this case the corresponding RC can be filled in Notify.
> > > >
> > > > 3) The draft doesn't contain a open declaration that RC is required
in
> > > case
> > > > of AS State changes + Insufficient ASP Resources Active in AS +
> > Alternate
> > > > ASP Active, it is implied. It just states it is an optional
parameter
> > and
> > > > the following statement in 4.3.4.5 supports this -
> > > > "In the case where a Notify message does not contain a Routing
Context
> > > > parameter, the receiver must know, via configuration data, of which
> > > > Application Servers the ASP is a member and take the appropriate
> > > > action in each AS."
> > > >
> > > > But as per the discussions in this thread this implication doesn't
> seem
> > to
> > > > be true for ASP Failure. Therefore, the need of RC in Notify should
> also
> > > be
> > > > explicitly stated.
> > >
> > > It's fairly clear from Section 3.8.2 that RC is only required (where
not
> > > implied) for AS state changes.  There is no statement requiring RC in
> > > messages not related to an AS state change (ASP Failure).
> > >
> > > --brian
> > >
> > > >
> > > > - Soni
> > > >
> > > > -----Original Message-----
> > > > From: Tolga Asveren [mailto:[email-masked]]
> > > > Sent: Tuesday, March 05, 2002 11:20 AM
> > > > To: Goel, Soni; Sigtran (E-mail)
> > > > Subject: RE: [Sigtran] ASP Identifier
> > > >
> > > >
> > > > Soni,
> > > >
> > > > Please see comments below.
> > > >
> > > >   Tolga
> > > >
> > > > > -----Original Message-----
> > > > > From: [email-masked] [mailto:[email-masked]]On
> Behalf
> > Of
> > > > > Goel, Soni
> > > > > Sent: Tuesday, March 05, 2002 1:46 PM
> > > > > To: Sigtran (E-mail)
> > > > > Subject: RE: [Sigtran] ASP Identifier
> > > > >
> > > > >
> > > > > Hi,
> > > > >
> > > > > I have following queries -
> > > > >
> > > > > Does it mean that ASP Id is not required in following cases -
> > > > >
> > > > > 1) Notify with AS State Change - Yes or No
> > > > [TOLGA] ASP Id is not required.
> > > > > 2) Notify with Alternate ASP Active - Yes or No
> > > > [TOLGA] If available, ASP Id of the alternate ASP is required
> > > > >
> > > > > The Draft states following for "ASP Failure" -
> > > > > "For the ASP Failure case, the SGP is indicating to ASP(s)
> > > > > in the AS that one of the ASPs has transitioned to ASP-DOWN.  The
> ASP
> > > > > Identifier (if available) of the failed ASP MUST be placed in the
> > > > > message."
> > > > >
> > > > > Does it mean that if an ASP goes down and it was configured for
AS1,
> > > then
> > > > > the "ASP Failure" message will be sent to only the ASPs which are
> > > > > active/inactive in AS1 ?
> > > > >
> > > > > Does the M3UA Draft state that "Routing Context is not present in
> the
> > > ASP
> > > > > Failure notification
> > > > > message" ? Can you please give me the section number ?
> > > > [TOLGA] If the ASP, which went down was active for multiple ASs,
then
> > how
> > > > are you planning to fill RC field? It is not openly stated in the
> draft
> > > but
> > > > RC is not to be filled for ASP Failure case. Well, indirectly it is
> > still
> > > > indicated in the draft:
> > > > 1- RC is optional, which means there are cases, where it is not
> filled.
> > > > 2- For AS State changes + Insufficient ASP Resources Active in AS +
> > > > Alternate ASP Active, RC is needed
> > > > 3- So, only ASP Failure case is left, if it needed RC, then RC
> wouldn't
> > be
> > > > optional but mandatory.
> > > > >
> > > > > - Soni
> > > > >
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> 
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 6 Mar 2002 14:02:08 -0600

Soni,

I think that Lyndon's note explains why the cannot be
incorporated into the draft, because the draft has
already been approved.  I don't think anyone has a
problem with capturing this (and a bunch of other
things that could use additional clarification) in the
implementor's guide.

--brian

Goel, Soni wrote:                                           (Wed, 06 Mar 2002 11:27:11)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/