Subject: [Sigtran] Re: m2ua/m3ua difference

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 22 Mar 2002 02:22:14 -0600

Ujwal,

The last few lines were added to M3UA at the last minute.  Although
it appears that M2UA did not echo the change.  However, does loadshare
mode actually make sense for M2UA?  Can you imagine it taking more
than one ASP to handle one link?  Actually, can you imagine it taking
more than one ASP to handle a linkset?

--brian

On Fri, 22 Mar 2002, Ujwal Suri wrote:

> 
>    Hello Brian,
>    
>    M2UA 15:-
>    
>    4.3.4.4 ASP Active Procedures
>    
>    "An SGP, upon reception of an ASP Active message for the first ASP in
>    a Loadshare AS, MAY choose not to direct traffic to a newly active ASP
>    until it determines that there are sufficient resources to handle the
>    expected load (e.g., until there are "n" ASPs in state ASP-ACTIVE in
>    the AS)."M3UA-12:-
>    
>    4.3.4.3 ASP Active Procedures
>    
>    "An SGP or IPSP, upon reception of an ASP Active message for the first
>    ASP in a Loadshare AS, MAY choose not to direct traffic to a newly
>    active ASP until it determines that there are sufficient resources to
>    handle the expected load (e.g., until there are "n" ASPs in state
>    ASP-ACTIVE in the AS).  In this case, the SGP or IPSP SHOULD withhold
>    the Notify (AS-ACTIVE) until there are sufficient resources. For the
>    n+k redundancy case, ASPs which are in that AS should coordinate among
>    themselves the number of active ASPs in the AS, and should start
>    sending traffic only after n ASPs are active."
>    
>    Is there any specific reason why the last few lines of the m3ua text
>    are not included in m2ua also. Should the sgp and asp behaviour in
>    m2ua be same as in m3ua?
>    
>    Regards,
>    
>    Ujwal

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 22 Mar 2002 09:40:44 -0500

Related with this, unfortunately in m3ua12 Figure5 "AS State Transition
Diagram" is not updated accordingly. Probably, should be addressed in the
"Implementors Guide", which it seems going to be more like a correction
document to the existing m3ua draft.

    Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Friday, March 22, 2002 3:22 AM
> To: Ujwal Suri
> Cc: [email-masked]
> Subject: [Sigtran] Re: m2ua/m3ua difference
>
>
> Ujwal,
>

---

From: "Nitin Vairagare" <[email-masked]>
Date: Fri, 22 Mar 2002 09:48:15 -0500

Hi,

We have been having quite a few useful discussions
on improving/correcting/dropping/adding/addressing features
for M3UA 12 and SUA 12, which are going to RFC status. 

Most of Items we keep saying will go in Implementors guide. 
But is there really some one who is consolidating all this points
to prepare Implementors Guide? Or we will have to revisit every
discussion to draw conclusions and put them in implementors guide?

It would be nice to start working on this ASAP and come
up with some concluded text, so that implementations can adapt it.

Regards,
Nitin

---

From: Ken Morneault <[email-masked]>
Date: Fri, 22 Mar 2002 11:46:47 -0500

Nitin,

Javier and I have put together a draft of the M3UA implementors guide.  It
will be available soon.  Also, we will post a list of all of the outstanding
issues that need further discussion.

Regards,

Ken