Subject: RE: [Sigtran] Re: M3UA: Changeback Issue

From: "Garnero, Pierre" <[email-masked]>
Date: Thu, 14 Mar 2002 09:36:38 +0100

Brian,

Yes, I think that this problem must be fixed and I suppose that if it is possible to use HEARTBEAT messages on a stream basis (and not only on stream 0), we could implement this mechanism with an already existing M3UA (ou SUA) message (on receipt of the HEARTBEAT_ACK, we could consider that the messages send (before the HEARTBEAT) on a particular stream have been "flushed" and then received by the ASP). 
If I remember well, you have already proposed such a mechanism...

Cheers,

Pierre

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, March 13, 2002 9:18 PM
> To: Greg Sidebottom; [email-masked]
> Subject: [Sigtran] Re: M3UA: Changeback Issue
> 
> 
> Sigtraners,
> 
> We never corrected this problem with M3UA/SUA.  M3UA
> cannot support interworking with the SS7 network for
> multiple SGs and will fail Q.782 conformance tests
> pertaining to changeback.
> 
> Should this be corrected in the implementors guide?
> 
> --brian
> 
> On Wed, 11 Jul 2001, Brian F. G. Bidulock wrote:
> 
> > All,
> > 
> > M3UA does not provide support for the SS7 MTP changeback
> > procedure where multiple SG are involved.
> > 
> > Here is the scenario:
> > 
> > 
> >                +-------+        - - - - - 
> >                |       |       | /-----\ |
> >                |  SG1  |---------| ASP1|
> >               /| "STP" |\      |/\-----/ |
> >           A1 / |       | \     /
> >             /  +-------+  \   /|   AS    |
> >     /----\ /       |       \ /
> >     | SP |/        |        X  |  SPMC   |
> >     |    |\        |       / \
> >     \----/ \       |      /   \|         |
> >             \  +-------+ /     \
> >           A2 \ |       |/      |\/-----\ |
> >               \|  SG2  |---------| ASP2|
> >                | "STP" |       | \-----/ |
> >                |       |        - - - - -
> >                +-------+
> > 
> > The SP loses linkset A1.  Traffic is succesfully changed
> > over to linkset A2.  Linkset A1 restores.  SP peforms
> > changeback procedure per Q.704 6.2.1 (b) (i) (that is, on
> > a per-destination basis).  It sends a CBD for each SLS
> > which is being diverted from A2 back to A1 with a DPC of
> > the SPMC.
> > 
> > What is SG2 to do with the CBD?  If it responds with a CBA
> > there may be messages between SG2 and ASP1 or ASP2 which
> > have not yet arrived at the ASP and might be overtaken by
> > the diverted traffic.
> > 
> > The SG must have a message which it can send to the each
> > ASP which has the same effect as a changeback-declaration
> > which will be responded to by the ASP with a changeback-
> > acknowledgement so that mis-sequencing can be avoided
> > during changeback procedures per Q.704 6.2.1 (b)(i).
> > 
> > I can put together proposed text if anyone is interested.
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> 
> -- 
> Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                         ¦ Therefore  all  progress  depends on the ¦
>                         ¦ unreasonable man. -- George Bernard Shaw ¦
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 14 Mar 2002 03:22:23 -0600

Pierre,

Yes, a BEAT mechanism should work when SP is changing traffic
back from linkset A2 to A1.  So, in the example, linkset A1
has failed and recovered and SP sends CBD on linkset A2 to SG2
and SG2 sends BEAT (ordered in the necessary stream) to active
ASPs possibly with the CBC and some marker in the heartbeat
info.  When SG2 receives enough BEAT Acks from active ASPs, it
sends CBA with the necessary CBC back to the SP and the
changeback can complete correctly.

However, when the SPMC is restarting traffic on a recovered
association it is changing back that traffic, say, from SG2
to SG1.  There is no way for an ASP to ask an SG to send CBA
to SP on its behalf so that it can perform the coordinated
changeback.  Because the SPMC is viewed as a SEP in the SS7
network, it must send CBD when redirecting traffic flows to
the SS7 network or this "virtual" SPMC will fail SS7 (Q.782)
conformance.  BEAT/Ack will not do in this case, becase the
SG cannot know for which BEAT messages to send CBD and for
which to not send CBD (heartbeat info is opaque to the receiver
of the BEAT).

The ASP cannot just flip traffic flows back between SGs when
associations and RCs become active according to simple loadsharing
rules: it must ensure that the traffic flow is flushed with
a CBD before restoring traffic to a newly active or restored SG.

Now, you might think that an SG could just send CBDs on the
ASPs behalf when reactivating traffic; however, the CBA does
not have to take the same reverse path through the SS7 network
that the CBD took.   That is, a CBD launched by SG1 could be
acknowledged by the SP by sending a CBA via SG2.  In this case
SG1 would never see the reply.

Getting it working in both directions might require the
addition of a new message type to M3UA/SUA so that the
ASP can ask an SG to launch CBD and so that it can receive
the equivalent of CBA from any SG before restarting traffic
on a new or restored routing context and stream.

--brian

Garnero, Pierre wrote:                                   (Thu, 14 Mar 2002 09:36:38)
> Brian,
> 
> Yes, I think that this problem must be fixed and I suppose that if it
> is possible to use HEARTBEAT messages on a stream basis (and not only
> on stream 0), we could implement this mechanism with an already
> existing M3UA (ou SUA) message (on receipt of the HEARTBEAT_ACK, we
> could consider that the messages send (before the HEARTBEAT) on a
> particular stream have been "flushed" and then received by the ASP). 
>

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/