Subject: RE: [Sigtran] M3UA-12: Contents of Protocol Data

From: [email-masked]
Date: Mon, 11 Mar 2002 08:59:17 +0100

Hi Ken,

My preference would be for the first byte in the Protocol Data to contain
the least significant 4 bits of the CIC in its top 4 bits. The bottom 4 bits
would be reserved and must be ignored by the receiver, whether they are zero
or not. That is:

           +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
           |CIC ls | resvd |    CIC (ms)   |
           +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Regards,
Joyce

==================================================================
Joyce Archibald, TSD R&D     | Phone:    +44 (0) 131 3317521 
Agilent Technologies UK Ltd  | Telnet:   313 2521
South Queensferry,           | Mailstop: SQFRD3A
EH30 9TG, Scotland.          | E-mail: [email-masked]
==================================================================

> -----Original Message-----
> From: Ken Morneault [mailto:[email-masked]]
> Sent: 08 March 2002 21:26
> To: [email-masked]; [email-masked]
> Subject: Re: [Sigtran] M3UA-12: Contents of Protocol Data
> 
> 
> 
> 
> Joyce,
> 
> The implementation guide will need to contain a note about
> handling TUP.  Do you prefer that the CIC be placed into
> a field or that that byte that is shared by CIC/OPC be the
> first byte in the Protocol Data (the OPC bits should/must
> be zeroed)?  Or, do you have another alternative?
> 
> Regards,
> 
> Ken
> 
> At 12:49 PM 3/5/2002 +0100, [email-masked] wrote:
> >Hi,
> >
> >Section 3.3.1 defines Protocol Data as follows:
> >
> >"The Protocol Data fiels contains a byte string of MTP-User 
> information from
> >the original SS7 message starting with the first byte of the 
> original SS7
> >message following the Routing Label."
> >
> >However TUP uses a 40-byte Routing label containing DPC, OPC 
> and CIC. Where
> >the least significant 4 bits of the CIC are in the same 
> octet as the most
> >significant 4 bits of the OPC.
> >           +-+-+-+-+-+-+-+-+
> >           |CIC ls | OPC ms|
> >           +-+-+-+-+-+-+-+-+
> >
> >How will this be formatted when TUP is carried by M3UA?
> >
> >Regards,
> >Joyce
> >
> >==================================================================
> >Joyce Archibald, TSD R&D     | Phone:    +44 (0) 131 3317521 
> >Agilent Technologies UK Ltd  | Telnet:   313 2521
> >South Queensferry,           | Mailstop: SQFRD3A
> >EH30 9TG, Scotland.          | E-mail: [email-masked]
> >==================================================================
> >
> >_______________________________________________
> >Sigtran mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/sigtran 
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 11 Mar 2002 02:25:07 -0600

Joyce,

Another (this time MTP-user-specific) protocol-specific protocol
data payload?

Please leave the SLS bits in the SLS field and only place the
8 CIC bits that do not overlap with SLS, in the payload.  The
M3UA to MTP-User interface for TUP can place them back together
for the TUP user if required.

Thanks.

--brian

[email-masked] wrote:     (Mon, 11 Mar 2002 08:59:17)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/