Subject: Re: [Sigtran] ASP states

From: "Subhodeep Sarkar" <[email-masked]>
Date: Thu, 21 Mar 2002 08:59:48 +0530

Sachin,

The problem is there only when you are going to have loadsharing i.e. more than one ASP is required to mark the AS active. Any way, IUA user will not be able to sent traffic unless the interfaces are up - and in your scenario the DL-ESTABLISH request will be rejected at the SG and so potentially no payload (i.e. DL-DATA/DL-UDATA) will be lost.

Siddhartha,

Why will SGP queue up the message when AS is in AS-INACTIVE state assuming only one ASP is in ASP ACTIVE state and the other one is in ASP-UP/DOWN state ? The SG/SGP will only queue up the message when AS is in AS-PENDING state and ASP is going through state transition.

Cheers,

Subhodeep

"Siddhartha Prasad" wrote:

Sachin

As per the drafts of sigtran UAL (user adaptation layers) , AS is an
logical entity &amp; may have n number (max 16) of ASP`s associated with it,
note that one ASP can be associated with more than one AS also.
SG does send Ack for ASP up message though it may be the first ASP. Incase
of some failure or transition (no ASP is active), SGP will buffer the
message destined for this AS for a time t( ) or until an ASP becomes
available. When no ASP becomes available before expiry of t( ), the SGP
will flush the buffered messages and initiate the appropriate return or
refusal procedures.

Would appreciate comments on this.

Siddhartha

----- Original Message -----
From: "Sachin Sharma" 
To: 
Cc: 
Sent: Wednesday, March 20, 2002 3:48 PM
Subject: [Sigtran] ASP states

&gt; Consider this scenario:
&gt; Suppose we need two ASPs to handle traffic for a particular AS.Now one of
&gt; the ASPs becomes active and sends ASP Active.The SG responds with ASP
Active
&gt; Ack for that.Now logically that ASP can send data to that SG.But as we
&gt; require two ASPs to handle traffic,the SG won't handle traffic from that
&gt; ASP.
&gt; Now SG knows it can send data to that ASP but it won't send it.But the ASP
&gt; doesn't know if to send data to the SG/not.
&gt; Don't we risk losing data in this case?
&gt; Or the SG won't send the ASP Active ACK even for the first ASP?
&gt;
&gt; Sachin
&gt;
&gt;
&gt; _______________________________________________
&gt; Sigtran mailing list
&gt; [email-masked]
&gt; https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in

---

From: "Siddhartha Prasad" <[email-masked]>
Date: Thu, 21 Mar 2002 10:48:33 +0530

Subhodeep,

 If an AS is in INACTIVE state all ASP`s associated with it would be in INACTIVE state. So there is no point SG queues up messages here.. it goes for queuing up for a period of T(r) only in pending state.

Siddh
  ----- Original Message ----- 
  From: Subhodeep Sarkar 
  To: Siddhartha Prasad ; Sachin Sharma ; [email-masked] 
  Cc: [email-masked] 
  Sent: Thursday, March 21, 2002 8:59 AM
  Subject: Re: [Sigtran] ASP states

  Sachin,

  Siddhartha,

  Cheers,

  Subhodeep

    Sachin

    logical entity & may have n number (max 16) of ASP`s associated with it,

    Siddhartha

    ----- Original Message -----
    From: "Sachin Sharma" 
    To: 
    Cc: 
    Sent: Wednesday, March 20, 2002 3:48 PM
    Subject: [Sigt! ra! n] ASP states

    > Consider this scenario:
    > Suppose we need two ASPs to handle traffic for a particular AS.Now one of
    > the ASPs becomes active and sends ASP Active.The SG responds with ASP
    Active
    > Ack for that.Now logically that ASP can send data to that SG.But as we
    > require two ASPs to handle traffic,the SG won't handle traffic from that
    > ASP.
    > Now SG knows it can send data to that ASP but it won't send it.But the ASP
    > doesn't know if to send data to the SG/not.
    > Don't we risk losing data in this case?
    > Or the SG won't send the ASP Active ACK even for the first ASP?
    >
    > Sachin
    >
    >

    _______________________________________________
    Sigtran mailing list
    [email-masked]
    https://www1.ietf.org/mailm! an! /listinfo/sigtran

------------------------------------------------------------------------------
  Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com
  Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in