Subject: [Sigtran] Q.931 and Backhaul

From: "Panagiotis Galiotos" <[email-masked]>
Date: Wed, 6 Mar 2002 08:42:40 +0200

Ken,

    thanks for the answer. But I do not think I am confusing anything. NOTIFY is an MGCP command that will be send from the Media Gateway to the Media Gateway Controller when there is a Q.931 Setup message detected (with the E.164 address of the callee number). So what I am asking is that if the Q.931 Setup message goes (as backhaul defines) to the MGC, then who is going to send to the MGC the NOTIFY command???
Please give any ideas on these topic or even correct me if I am wrong?

Thank you,
Panagiotis Galiotos

---

From: "Subhodeep Sarkar" <[email-masked]>
Date: Wed, 06 Mar 2002 12:41:28 +0530

Hi,

In Q.931, the D-channel (signalling link) will be terminated to signalling gateway (SG) which coexits with MG and the signals will be backhauled to the MGC by the SG. So, when the SETUP message is received by the SG, it will be backhauled and the SETUP message will have the digits in Called Party IE. So you don't require any MGCP messages(NOTIFY) to be exchanged between MG and MGC when a SETUP message arrives at the MG. 

An example message flow at the originator is as follows :

[PBX] === Q.931====[SG/MG] ========= IP ======== {MGC]

--------- SETUP ----------&gt;              ------ SETUP (backhaul) ------&gt;

&lt;------- CALL PROC ----              &lt;----- CALL PROC (backhaul) ---

                                                &lt;----- CRCX (MGCP) ---------------

                                                 ------ 200 OK (MGCP) ------------&gt;

Hope this helps.

Cheers,

Subhodeep

Subhodeep Sarkar 
Wipro Technologies 
Voice Over IP Solutions 
Ph : +91-(0)80-8411990 x 1251 

"Panagiotis Galiotos" wrote: 

Ken,

Thank you,
Panagiotis Galiotos
Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in