Subject: [Sigtran] M3UA: SG and notify messages

From: "Zannin, Francois" <[email-masked]>
Date: Mon, 25 Mar 2002 18:06:47 +0100

Hi all,

I have a query about the behavior of the SGP regarding 
notify messages sent to the Asp.

It is said that notify are sent to the Asp when the AS 
state change. When an ASP is dynamically registered to 
the SG, what must the SG do about this notify, do it 
send it after the registration request/ack to inform 
the ASP of the change of state of the ASP (from ASP-DOWN 
to ASP-INACTIVE).

Now, in a static configuration, if we have two ASP that 
serve an AS, when the first ASP send the "ASP UP" to the 
SG, the SG answer with an "ASP UP ack" message and then 
send the notify ASP inactive because the AS change from 
DOWN to INACTIVE. Then the ACTIVE/ACK messages are exchanged 
and notify "ASP active" is sent by the SG to the ASP.

Then, when the second ASP sends the "ASP UP" message, the 
SG reply with an "ASP UP ack".
Event if the AS don't change of state (still the active) 
do the SG send a NOTIFY "ASP active" to the "new" ASP to 
inform it of the current state of the AS, state known by 
the SG but unknown by the "new" ASP.
When we said that a notify is sent when an AS change of 
state, does it mean change of state also in an ASP point 
of view?

Francois Zannin.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 25 Mar 2002 11:50:42 -0600

Zannin,,

Zannin, Francois wrote:                                   (Mon, 25 Mar 2002 18:06:47)
> the ASP of the change of state of the ASP (from ASP-DOWN 

Notifies are sent for AS state changes, not ASP state changes
(except failure).

> the SG but unknown by the "new" ASP.

It is not required, but I do: NTFY messages are advisory
and it certainly makes sense to notify a newly registering
ASP of the state of the AS.

> state, does it mean change of state also in an ASP point 

No, that's not what M3UA says: it only requires NTFY for
AS state changes from the SG viewpoint.  However, it also
does not preclude NTFY from being sent at any time.  I prefer
the approach where newly joining ASPs are given the current
state of the AS regardless of whether an AS state change
occurs.  M3UA permits this but does not require it.

I think that any ASP designed to rely on these notifications
after joining, would prefer to require the SG to give such
notifications in the case of dynamic regsitration.  Perhaps
we should capture this in the kmplementor's guide.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/