Subject: RE: [Sigtran] ASP Identifier

From: "Goel, Soni" <[email-masked]>
Date: Tue, 5 Mar 2002 13:17:04 -0800

Is it to all the ASPs associated with the SGP, or all the ASPs in the
configured AS ?

- Soni
-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, March 05, 2002 1:05 PM
To: Goel, Soni
Cc: 'Tolga Asveren'; Sigtran (E-mail)
Subject: Re: [Sigtran] ASP Identifier

Soni,

Goel, Soni wrote:                                           (Tue, 05 Mar
2002 12:25:03)
> Hi,
> 
> Following are my comments -
> 1) Notify for AS State Change - Following statement in section 4.3.4.5
> should be corrected -
> "A Notify message reflecting a change in the AS state MUST be sent to 
> all ASPs in the AS, except those in the ASP-DOWN state, with
> appropriate Status Information and any ASP Identifier of the failed 
> ASP."
> 
> This should be changed to -
> "A Notify message reflecting a change in the AS state MUST be sent to 
> all ASPs in the AS, except those in the ASP-DOWN state, with
> appropriate Status Information."
> 
> 2) The following question remains unanswered -
> > The Draft states following for "ASP Failure" -
> > "For the ASP Failure case, the SGP is indicating to ASP(s)
> > in the AS that one of the ASPs has transitioned to ASP-DOWN.  The ASP
> > Identifier (if available) of the failed ASP MUST be placed in the
> > message."
> >
> > Does it mean that if an ASP goes down and it was configured for AS1,
then
> > the "ASP Failure" message will be sent to only the ASPs which are
> > active/inactive in AS1 ?
> >
> Yes or No ? If not, then to which ASPs ?

I send it to all ASPs not in the ASP-DOWN state.

> 
> If an ASP is part of multiple RCs, and the answer to above question is
YES,
> this means that ASP Failure will be sent separately for each AS the ASP is
> part of. In this case the corresponding RC can be filled in Notify.
> 
> 3) The draft doesn't contain a open declaration that RC is required in
case
> of AS State changes + Insufficient ASP Resources Active in AS + Alternate
> ASP Active, it is implied. It just states it is an optional parameter and
> the following statement in 4.3.4.5 supports this -
> "In the case where a Notify message does not contain a Routing Context
> parameter, the receiver must know, via configuration data, of which
> Application Servers the ASP is a member and take the appropriate 
> action in each AS."
> 
> But as per the discussions in this thread this implication doesn't seem to
> be true for ASP Failure. Therefore, the need of RC in Notify should also
be
> explicitly stated.

It's fairly clear from Section 3.8.2 that RC is only required (where not
implied) for AS state changes.  There is no statement requiring RC in
messages not related to an AS state change (ASP Failure).

--brian

> 
> - Soni 
> 
> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 11:20 AM
> To: Goel, Soni; Sigtran (E-mail)
> Subject: RE: [Sigtran] ASP Identifier
> 
> 
> Soni,
> 
> Please see comments below.
> 
>   Tolga
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > Goel, Soni
> > Sent: Tuesday, March 05, 2002 1:46 PM
> > To: Sigtran (E-mail)
> > Subject: RE: [Sigtran] ASP Identifier
> >
> >
> > Hi,
> >
> > I have following queries -
> >
> > Does it mean that ASP Id is not required in following cases -
> >
> > 1) Notify with AS State Change - Yes or No
> [TOLGA] ASP Id is not required.
> > 2) Notify with Alternate ASP Active - Yes or No
> [TOLGA] If available, ASP Id of the alternate ASP is required
> >
> > The Draft states following for "ASP Failure" -
> > "For the ASP Failure case, the SGP is indicating to ASP(s)
> > in the AS that one of the ASPs has transitioned to ASP-DOWN.  The ASP
> > Identifier (if available) of the failed ASP MUST be placed in the
> > message."
> >
> > Does it mean that if an ASP goes down and it was configured for AS1,
then
> > the "ASP Failure" message will be sent to only the ASPs which are
> > active/inactive in AS1 ?
> >
> > Does the M3UA Draft state that "Routing Context is not present in the
ASP
> > Failure notification
> > message" ? Can you please give me the section number ?
> [TOLGA] If the ASP, which went down was active for multiple ASs, then how
> are you planning to fill RC field? It is not openly stated in the draft
but
> RC is not to be filled for ASP Failure case. Well, indirectly it is still
> indicated in the draft:
> 1- RC is optional, which means there are cases, where it is not filled.
> 2- For AS State changes + Insufficient ASP Resources Active in AS +
> Alternate ASP Active, RC is needed
> 3- So, only ASP Failure case is left, if it needed RC, then RC wouldn't be
> optional but mandatory.
> >
> > - Soni
> >

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 5 Mar 2002 15:30:09 -0600

Soni,

I send it to all ASPs that are ASP-UP within the scope of the ASP Id.
I do not support ASP Id scopes of less than an SGP (because ASP Id
is scoped on a per-SGP basis for its use in dynamic port assignment).
ASPs in the ASP-UP state which have not yet registered for any AS
also need to receive this notification, so I send it to all ASPs
associated with the SGP not in the ASP-DOWN state.  This does not
conflict with the statements in the draft, because I consider ASPs
that have not yet registered for an AS as being "in" the AS even
though they are not in the ASP-INACTIVE or ASP-ACTIVE state with
respect to that AS.

--brian

Goel, Soni wrote:                                           (Tue, 05 Mar 2002 13:17:04)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/