Subject: [Sigtran] tlv

From: "Nahar,virendra" <[email-masked]>
Date: Sat, 02 Mar 2002 14:39:26 +0530

Hi Brian/All
Pls. clarify
OPC List:

   The Originating Point Code List parameter contains one or more SS7
   OPC entries, and its format is the same as the Destination Point
   Code parameter.  The absence of the OPC List parameter in the
   Routing Key indicates the use of any OPC value,

Sidebottom et al                                             [Page 48]

Internet Draft       SS7 MTP3-User Adaptation Layer         Feb 2002

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |         Tag = 0x020e          |             Length            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |    Mask = 0   |          Origination Point Code #1            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |    Mask = 0   |          Origination Point Code #2            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   /                              ...                              /
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |    Mask = 0   |          Origination Point Code #n            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
The above digram signifies the OPC in the OPC list is not in TLV form.
Is my assumption correct ??

Thanks
Nahar
--
Virendra Nahar
HCL-Technologies Ltd
Networking Systems Lab
51, Jawaharlal Nehru Road
Guindy Industrial Estate,
Ekkatuthangal,
Chennai - 600 097.
Phone Off : +91 44 233 4174 or +91 44 233 4181(extn:261,218)
mailto:[email-masked]
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Sun, 03 Mar 2002 06:59:48 -0500

Nahar,

Yes, the OPC in OPC list is not in TLV format.  Please
follow the format provided.

Ken

At 02:39 PM 3/2/2002 +0530, Nahar,virendra wrote:

>Errors-To: [email-masked]
>X-Mailman-Version: 1.0
>Precedence: bulk
>List-Id: Signaling Transport <sigtran.ietf.org>
>X-BeenThere: [email-masked]
>
>
>Hi Brian/All
>Pls. clarify
>OPC List:

---

From: "Nahar,virendra" <[email-masked]>
Date: Sun, 03 Mar 2002 17:39:47 +0530

Hi Ken
Does the same applies to CIC RANGE TLV also as text on page 49 in
description of
CIC RANGE  is pretty confusing
page 49 m3ua12.txt in heading CIC RANGE
  The Origination Point Code is encoded the same as the
   Destination Point Code parameter, while the CIC values are 16-bit
   integers.

Pls clarify

Thanks in Advance
Nahar

---

From: Ken Morneault <[email-masked]>
Date: Mon, 04 Mar 2002 08:19:29 -0500

Nahar,

What, in particular, do you find confusing about the CIC range TLV.
Again, you should follow the format provided.

Regards,

Ken

At 05:39 PM 3/3/2002 +0530, Nahar,virendra wrote:
>Hi Ken 
>Does the same applies to CIC RANGE TLV also as text on page 49 in description of 
>><https://www1.ietf.org/mailman/listinfo/sigtran>https://www1.ietf.org/mailman/listinfo/sigtran
>
>-- 
>Virendra Nahar 
>HCL-Technologies Ltd 
>Networking Systems Lab 
><mailto:[email-masked]>mailto:[email-masked]

---

From: "Nahar,virendra" <[email-masked]>
Date: Mon, 04 Mar 2002 19:32:09 +0530

Hi Ken: the text in the draft is confusing
>   Destination Point Code parameter, while the CIC values are 16-bit
     but DPC is encoded as TLV so that the confusion between text & figure

thanks
Nahar

---

From: Ken Morneault <[email-masked]>
Date: Mon, 04 Mar 2002 10:01:54 -0500

Nahar,

By encoding, it is referring to the bit representation of
the point code (ANSI vs. ITU, see Section 3.4.1).  

Would you find it less confusing if the text were
changed to:

"The Origination Point Code is encoded the same
as the Destination Point Code, while the ...."

Ken

At 07:32 PM 3/4/2002 +0530, Nahar,virendra wrote:
>>>><<https://www1.ietf.org/mailman/listinfo/sigtran>https://www1.ietf.org/mailman/listinfo/sigtran>https://www1.ietf.org/mailman/listinfo/sigtran 
>>> 
>>>-- 
>>>Virendra Nahar 
>>>HCL-Technologies Ltd 
>>>Networking Systems Lab 
>>><<mailto:[email-masked]>mailto:[email-masked]>mailto:[email-masked]