Subject: [Sigtran] SUA Routing key ...

From: Steve Clark <[email-masked]>
Date: Fri, 22 Mar 2002 21:40:32 -0800 (PST)

Hello ,
         I want to know that in the Routing key
registration, the parameters for the routing key have
source address and destination address. In M3UA the
Routing key have OPC and DPC as parameters which have
a given format (14 bit and 24-bit (ANSI)), so the
operator can configure the values for routing key
according to the PC , but as in SCCP the Source and
destination address can have so many different formats
(i mean GT+ SSN or GT+DPC+SSN etc ), which come from
the upper layers . So, how can we give the source
address in the registration request or at
configuration time, because what address to put at
ourself is quite a big problem (as it have no
predifend fixe type only combinations of diffrent type
is possible), what is the techinque   or what method
is used for the Source and destination address and
what we have in Range paramter of Routing key ,  the
Range type in M3UA have values (1-500) for the given
point code value (for e.g 35 to 36,37 etc....). But,
how is range put in SUA as it is given that it should
be pairs of source addresses or destination addresses.
Can anypne explain me what is this and how it is
done..

regards
steve

__________________________________________________
Do You Yahoo!?
Yahoo! Movies - coverage of the 74th Academy Awards®
http://movies.yahoo.com/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 23 Mar 2002 00:15:40 -0600

Steve,

Well, for example, if a Source address range is start:
PC(1-1-1)SSN(5) end: PC(1-1-1)SSN(7) that would mean SSN
5-7 on PC(1-1-1).  Now some combinations do not
necessarily make much sense (such as PC(1-1-1)SSN(5) to
PC(1-1-10)SSN(7)) but it is up to the SG to either
interpret and accept the RK or to reject it with a REG RSP
indicating failure to register.

Another example might be: PC(1-1-1)GT(9722000000) to
PC(1-1-1)GT(9729999999).  PC(1-1-1)GT(9722000000) to
PC(1-1-10)GT(9729999999) might make sense to an SG or it
might not.

Again, just as in M3UA, it is up to the SG to determine
whether a RK overlaps or not and whether it can interpret
or support a specific routing key.  Whether an SG supports
a specific RK depends upon the SG implementation of the
AMF.

At a minimum I would expect an SG to support SSN and
possibly SSN ranges if it supports the optional
registration procedure at all.  Anything less than support
of SSN would make the SG incapable of registering normal
SCCP-Users which would rather defeat the purpose of SUA.

--brian

Steve Clark wrote:             (Fri, 22 Mar 2002 21:40:32)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/