Subject: [Sigtran] Re: M3UA: Changeback Issue

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 13 Mar 2002 14:17:59 -0600

Sigtraners,

We never corrected this problem with M3UA/SUA.  M3UA
cannot support interworking with the SS7 network for
multiple SGs and will fail Q.782 conformance tests
pertaining to changeback.

Should this be corrected in the implementors guide?

--brian

On Wed, 11 Jul 2001, Brian F. G. Bidulock wrote:

> All,
> 
> M3UA does not provide support for the SS7 MTP changeback
> procedure where multiple SG are involved.
> 
> Here is the scenario:
> 
> 
>                +-------+        - - - - - 
>                |       |       | /-----\ |
>                |  SG1  |---------| ASP1|
>               /| "STP" |\      |/\-----/ |
>           A1 / |       | \     /
>             /  +-------+  \   /|   AS    |
>     /----\ /       |       \ /
>     | SP |/        |        X  |  SPMC   |
>     |    |\        |       / \
>     \----/ \       |      /   \|         |
>             \  +-------+ /     \
>           A2 \ |       |/      |\/-----\ |
>               \|  SG2  |---------| ASP2|
>                | "STP" |       | \-----/ |
>                |       |        - - - - -
>                +-------+
> 
> The SP loses linkset A1.  Traffic is succesfully changed
> over to linkset A2.  Linkset A1 restores.  SP peforms
> changeback procedure per Q.704 6.2.1 (b) (i) (that is, on
> a per-destination basis).  It sends a CBD for each SLS
> which is being diverted from A2 back to A1 with a DPC of
> the SPMC.
> 
> What is SG2 to do with the CBD?  If it responds with a CBA
> there may be messages between SG2 and ASP1 or ASP2 which
> have not yet arrived at the ASP and might be overtaken by
> the diverted traffic.
> 
> The SG must have a message which it can send to the each
> ASP which has the same effect as a changeback-declaration
> which will be responded to by the ASP with a changeback-
> acknowledgement so that mis-sequencing can be avoided
> during changeback procedures per Q.704 6.2.1 (b)(i).
> 
> I can put together proposed text if anyone is interested.
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Thu, 14 Mar 2002 10:23:07 -0500

Brian,

Which Q.782 conformance tests are you worried about
for the scenario you drew? 

Regards,

Ken

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 14 Mar 2002 13:30:34 -0600

Ken,

Test cases 4.1 through 4.12, well... all the
test cases in clause 4.  Both verification
and interworking tests.

--brian

Ken Morneault wrote:                                          (Thu, 14 Mar 2002 10:23:07)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/