Subject: Re: [Sigtran] Re: Mismatch in configuration in IUA (Ken Morneault)

From: [email-masked]
Date: Tue, 19 Mar 2002 08:20:44 +0200

Hi Subhodeep,

I've been following you discussion, and not completely agree with your last
comment.

The AS is not a something configured (by management system) in SG but a
dynamically allocated entity.

When you add a new IID in SG (it really to be configured) you can't know
two things:
1. Which AS the interface will belong too
2. Does AS already configured with the same IID.

Same from opposite side.
When you add a new IID in MGC you can't know whether SG is already
configured with the same IID.

In my opinion only sending of ASP ACTIVE message and positive acknowledge
can bring new interface to the life.
Moreover, the preferable implementation that SG does not allow to establish
the data link with peer ISDN entity till this SG receives ASP ACTIVE from
MGC.

So ASP ACTIVE is desirable to ensure synchronization of data in SG and MGC.

Regards,
Lev.

                    "Subhodeep                                                                
                    Sarkar"                 To:     <[email-masked]>,             
                    <subhodeep@india        <[email-masked]>                                
                    times.com>              cc:                                               
                    Sent by:                Subject:     Re: [Sigtran] Re: Mismatch in        
                    sigtran-admin@ie        configuration in IUA (Ken Morneault)              
                    tf.org                                                                    

                    18/03/02 15:47                                                            
                    Please respond                                                            
                    to "Subhodeep                                                             
                    Sarkar"                                                                   

Hi,

If the IID is configured in one of the already configured AS, then you
don't need to send any ACTIVE message from MGC to SG. However, if the IID
is configured for an AS which not already handling traffic, you need to
send an ASP ACTIVE message for the activation of the same.

Cheers,

Subhodeep

Subhodeep Sarkar
Wipro Technologies
Voice Over IP Solutions
Ph : +91-(0)80-8411990 x 1251

[email-masked] wrote:

 Ken ,

 I want to understand whether the ACTIVE message from MGC to SG and
 the response ACK from SG to MGC a one-time cycle or repeated.
 If at any time in future, a new IID has to be configured , is it
 required by the MGC to resend the ACTIVE message to the SG with all the
 IIDs currently supported plus
 the new IID ?

 Thanks,
 Murthy

 -----------------------------------------------------------------------------------

 Date: Mon, 11 Mar 2002 11:12:15 -0500
 To: "Subhodeep Sarkar",
 From: Ken Morneault
 Subject: Re:[Sigtran] Mismatch in configuration in IUA

 Subhodeep,

 Ok, I will add to the IUA issues list (note: plan to rename this
 draft to implementors guide) with a description of changes to
 ERR message and a sample message flow for the this scenari! o.!

 Regards,

 Ken

 At 06:05 PM 3/11/2002 +0530, Subhodeep Sarkar wrote:

 >Ken,
 >
 >I also do prefer the Option 1 . We have to be very clear in the
 description of the ASPTM procedures i.e the SG SHOULD
 respond with an ACTIVE ACK for the IIDs for which it's configured and
 ERR message reporting the unsupported IIDs.And also
 the ASP on reception of the ERR message MAY act accordingly like
 generation of alarm which can be implementation
 dependent.
 >Cheers,
 >Subhodeep

 _______________________________________________
 Sigtran mailing list
 [email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

Get Your Private, Free E-mail from Indiatimes at
http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from
http://www.planetm.co.in

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Tue, 19 Mar 2002 10:20:55 -0500

Pls see comments below.

Ken

>2. Does AS already configured with the same IID.

When the new IID is added to the SG, it would be best to assign
it to an AS.  Otherwise, I think your implementation may be open
to problems, such as receipt of an ASP Active with no IIDs (meaning
go Active for all IIDS configured in this AS).

I agree that when the IID is configured o the SG, the SG has 
no knowledge of whether or not the IID is configured on the
AS.  However, the system operator will know. Further, the IID
is not usable until the AS takes action so this misconfiguation
issue would not be difficult to identify then resolve.

>configured with the same IID.

Yes, this misconfiguration can be a bit trickier to identify unless
the MGC side implementation generates an alarm for this condition.
  
When the MGC sends an ASP Active(IID) or Est Req(IID), the SG
will respond with Error(Invalid Interface ID ..note:  it is a good idea
for SG to make use of Diag info so that invalid IID is passed back
to MGC).  The MGC IUA implementation would receive this error 
and would indicate a mis-configuration to the Layer Mgmt.

>can bring new interface to the life.

I don't think it is necessary.  At a minimum, an Est Req is necessary
to bring this interface "to life".

>the data link with peer ISDN entity till this SG receives ASP ACTIVE from

It is up to SG implementation.  A SG that supports "modify" to an 
Active AS could potentially support dynamic addition of an IID.  If
MGC had sent an empty ASP Active (go Active for all configured
IIDs), it is reasonable for this SG to consider the new IID to be
Active.