Subject: Re: [Sigtran] RE: Dynamic Registration not supported - Day 3 summary

From: Andrew Booth <[email-masked]>
Date: Mon, 04 Mar 2002 10:05:33 -0500

Hi Brian,

If the diagnostic info is to be used to correlate the Error message with the
offending message, should diagnostic info be mandatory rather than optional?
Should there be more stringent requirements on the data contained in the
diagnostic info?

Thanks,
Andrew

"Brian F. G. Bidulock" wrote:

> Barry,
>
> The issue that came out of Madrid was correlation of error messages, not
> overloading the error code.  This issue was resolved by adding the offending
> message into the Diagnostic in the Error message so that the receiver of
> the Error could use it to correlate the Error response with the sent message.
> Correlation is necessary to cancel any timers or pending actions in the
> implemenation that would otherwise continue to wait for a response.  For
> management purposes the generic error code and the entire offending message
> are quite suitable for diagnostics, paritcularly in this case.
>
> In Madrid it was not possible to correlate ERR with any message sent and if
> multiple ASPAC Requests were being performed, for example, an ERR could not
> be correlated to the ASPAC requests (an imp could not tell which ASPAC request
> failed).  Adding the message to the Diagnostic solved this.
>
> The general feeling on the list and the concensus that was reached when
> Ken redid the error handling was that a proliferation of error codes should
> be avoided.  There is no reason to change that stance now.  This situation
> with REG REQ is just the failure of the imp receiving the error to use the
> information that it has at its disposal in the Diagnostic portion of the
> message.  There is no defense against lazy implementation.
>
> --brian
>
> [email-masked] wrote:                (Thu, 28 Feb 2002 15:54:21)
> > Thanks Jacques, for your excellent points. I and several others have been
> > requesting, in vain, the addition of more robust and descriptive error
> > messaging ever since the first M3UA bakeoff at Madrid in May 2001.
> >
> > Barry Nagelberg
> > Software Engineer
> > RadiSys, Corp.
> > Signaling Products Design Center
> > [email-masked]
> > +1-856-642-9229 x237
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 4 Mar 2002 17:10:39 -0600

Andrew,

The offending message is not optional in the Diagnostic.  The text
says that the diagnostic SHOULD contains the offending message.
The only reason I can see not to say "MUST" is that there might be
some circumstances where the error is not associated with a message.

The RFC2026 meaning of "SHOULD" is far from the definition of "OPTIONAL".

--brian

Andrew Booth wrote:                                        (Mon, 04 Mar 2002 10:05:33)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Andrew Booth <[email-masked]>
Date: Tue, 05 Mar 2002 09:35:46 -0500

Hi Brian,

I understand and agree with your interpretation, but I think the text is ambiguous for
the following reasons:
1) the Diagnostic Information parm is optional in the error message.
2) the paragraph which mentions that the Diagnostic Information SHOULD contain the
offending message is prefaced by "When included, the optional Diagnostic information can
be any information germane to the error condition [snip ]".

These phrases could be interpreted to mean that the Diagnostic Information is optional,
and only when included should it contain the offending message.  Also, is it the intent
that the diagnostic information contain exactly the offending message?  Or may it contain
other information as well?  If so in what order?

If the diagnostic information is the means of correlating errors with messages, perhaps
this wording should be stronger/more precise.

What do you think?
Andrew

---

From: Ken Morneault <[email-masked]>
Date: Tue, 05 Mar 2002 19:58:38 -0500

I would agree that the text needs to be stronger.  Otherwise, an
implementation cannot count on matching the Error to
a message because the sender may not send Diag (even
though it says "SHOULD").

Ken