Subject: Re: RE: [Sigtran] m3ua-mib-04 AS/SG concept

From: "Srivats P." <[email-masked]>
Date: Thu, 26 Sep 2002 11:8:40 +0500

Antonio, Tolga, Brian,

How about the following additional tables for ASP -

Dest Table
----------
  NA (Index)
  DPC (Index)
  SG Id (Index)
  State

RC Table
--------
  SG Id (Index)
  RK Id (Index) -- same as m3uaRkId of m3uaRouting
  RC

SGP Table
---------
  SG Id (Index)
  RC (Index)
  m3uaSpEpId (Index) -- i.e. the SGP
  State

Based on the above let's see the ASP message transfer procedure -

The ASP looks into the existing m3uaRoutingTable to reverse-match
the message against the RK parameters and retrieves the corresponding
RK Id. It then looks into the Dest Table and matches the NA and DPC
to retrieve an SG Id whose state is "accessible" i.e the NA+DPC is
accessible via the SG. Using this SG Id and the RK Id retreived
earlier it looks into the RC Table to retreive RC and finally
using SG Id and RC it selects a SGP (m3uaSpEpId) whose state is
"active" i.e. the RC is "active" wrt the SGP

Srivats

At 9/25/02 4:58:00 PM, you wrote:
>Brian,
>
>> > >
>> > > RC has no significance unless the SG is included.  RC assignments
>> > > are local to an SG.
>> > [TOLGA] Yes, you are right, I oversaw this So, maybe replacing
>> m3uaLocalRC
>> > with m3uaAsId might be better. This will enable to have the key as
>> > NA+DPC+AsId.
>>
>> What's an AsId ?
>[TOLGA] A value, internally unique on ASP for AS/RK -unlike RC-. Call it
>AsId, or RkId or whatever you like. If m3uaRouting table on ASP side will be
>similar to what it currently stands in MIB document, I think it will be
>called m3uaRKId.
>
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 08:32:12 -0400

Srivats,

> -----Original Message-----
> From: Srivats P. [mailto:[email-masked]]
> Sent: Thursday, September 26, 2002 2:01 AM
> To: Tolga Asveren
> Cc: sigtran
> Subject: Re: RE: [Sigtran] m3ua-mib-04 AS/SG concept
>
>
> Antonio, Tolga, Brian,
>
[TOLGA] Because SSNM contains RC inside, personally I would prefer m3uaRkId
as an index field in this table.
> accessible via the SG. Using this SG Id and the RK Id retreived
[TOLGA] Again like my comment before, I would think, looking to NA+DPC+RKID
would be more suitable.

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 08:41:43 -0400

Srivats,

Please see a further comment below.

  Tolga

> How about the following additional tables for ASP -
[TOLGA] Although I also believe that to have different RC values for the
same AS among SGPs belonging to the same SG does not sound very realistic, I
also think MIB document should reflect, what it stands in RFC+IG. From a
pure protocol point of view, one can have different RC values for SGPs of a
SG. So, I would think
a) either to add a sentence to IG saying that RC is unique in SG
b) or to keep RC per SGP in MIB