Subject: [Sigtran] semi-optional parameters

From: "Poetzl, Joachim" <[email-masked]>
Date: Tue, 24 Sep 2002 15:08:27 +0200

Hi,

by reading RFC3332 in conjunction with draft-ietf-sigtran-m3ua-implementors-guide-01.txt
I got puzzled by the term semi-optional parameter.

Can someone explain to me what a semi-optional paramter is?

> Best Regards
> Joachim Pötzl
Deutsche Telekom AG
T-Com Zentrale
T38-13; Signalling, Gateways and Switching Systems
64307 DARMSTADT, GERMANY 
Phone:  +49 6151 83-2134
Fax:      +49 6151 83-4577
> mailto:[email-masked]
> 
> 
> 
> 
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 24 Sep 2002 09:32:58 -0400

Joachim,

Semi-optional means, sometimes mandatory, sometimes optional. For example RC
is mandatory for DATA, when DATA belonging to multiple RKs is transferred
via a single association, but when traffic of a single RK is carried over
the association, RC is optional, because in such a case you know that all
traffic you receive from this association belongs to this specific RK.

    Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Poetzl, Joachim
> Sent: Tuesday, September 24, 2002 9:08 AM
> To: [email-masked]
> Subject: [Sigtran] semi-optional parameters
>
>
> Hi,
>
> by reading RFC3332 in conjunction with
> draft-ietf-sigtran-m3ua-implementors-guide-01.txt

---

From: "Sundaresan M G" <[email-masked]>
Date: Tue, 24 Sep 2002 19:19:59 +0530

Hi,

Semi-optional means that the particular parameter is mandatory only under
certain conditions.

In M3UA, Routing Context is Semi-optional. That is under situations were
Routing Keys are not co-ordinated between ASP and SGPs, then RC is not
required or in other words it need not be sent. But in case multiple RK
values are used across a same association, RC becomes mandatory.

This is my understanding.

Best Regards,
Sundar.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Poetzl, Joachim
Sent: Tuesday, 24 September 2002 6:38 PM
To: [email-masked]
Subject: [Sigtran] semi-optional parameters

Hi,

Deutsche Telekom AG
T-Com Zentrale

***************************************************************************
This message is proprietary to Future Software Limited (FSL) 
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information 
and should not be circulated or used for any purpose other than for 
what it is intended. 

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. 
FSL accepts no responsibility for loss or damage arising from 
the use of the information transmitted by this email including
damage from virus.
***************************************************************************
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran