Subject: RE: [Sigtran] M3UA IG-01 : SCON in response to DAUD

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 13 Sep 2002 15:42:44 +0200

Tolga, 

SS7 destinations does not mean SS7 local PC, but SS7 remote PCs.

Cheers // Javier. 

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, September 13, 2002 3:46 PM
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA IG-01 : SCON in response to DAUD
> 
> 
> Javier,
> 
> Why does "Where the SGP maintains the congestion status of the SS7
> destinations..." should mean where the SGP maintains the 
> congestion status
> of the remote SS7 point codes? We also need to take care of local link
> congestion. In my opinion local link congestion won't 
> propogate to the peer
> SCTP, and even if it were still this would be a very odd solution.
> 
>     Tolga
> 
> > -----Original Message-----
> > From: Javier Pastor-Balbas (ECE)
> > [mailto:[email-masked]]
> > Sent: Friday, September 13, 2002 9:26 AM
> > To: 'Tolga Asveren'; [email-masked]
> > Subject: RE: [Sigtran] M3UA IG-01 : SCON in response to DAUD
> >
> >
> > Hi Tolga,
> >
> > The sentence: "Where the SGP maintains the congestion status of
> > the SS7 destinations,..." means where the SGP maintains the
> > congestion status of the remote SS7 point codes.
> >
> > I think we agreed that congestion information for remote nodes is
> > not maintained in the ITU-International flavour according to Q.704.
> >
> > In addition, the "MUST" reference you use in your response to
> > Brian's bullet 1, refers to whenever the SGP maintains the remote
> > PC congestion status. Therefore there are cases (apart from
> > security reasons) where the SCON is not sent.
> >
> > Cheers // Javier.
> >
> > > -----Original Message-----
> > > From: Tolga Asveren [mailto:[email-masked]]
> > > Sent: Friday, September 13, 2002 3:18 PM
> > > To: [email-masked]
> > > Subject: RE: [Sigtran] M3UA IG-01 : SCON in response to DAUD
> > >
> > >
> > > Brian,
> > >
> > > If it were open to interpretation, I wouldn't have a 
> problem. But for
> > > anybody familiar with first order logic it is clear that:
> > >
> > > (1) Congestion Status Kept ===> SCON is sent as reply to DAUD
> > > (from M3UA)
> > > (2) Congestion Status Kept (from MTP3)
> > >
> > > Modus Ponens (1) + (2)   SCON is sent as reply to DAUD
> > >
> > > There is nothing open to interpretation.
> > >
> > >    Tolga
> > >
> > >
> > > > -----Original Message-----
> > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > Sent: Thursday, September 12, 2002 8:26 PM
> > > > To: Tolga Asveren
> > > > Cc: [email-masked]
> > > > Subject: Re: [Sigtran] M3UA IG-01 : SCON in response to DAUD
> > > >
> > > >
> > > > Tolga,
> > > >
> > > > That doesn't appear to be anyone else's reading of the 
> text.  Quite
> > > > the reverse...
> > > >
> > > > --brian
> > > >
> > > > Tolga Asveren wrote:
> > > >                    (Thu, 12 Sep 2002 18:01:52)
> > > > > Brian,
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > > Sent: Thursday, September 12, 2002 5:40 PM
> > > > > > To: Tolga Asveren
> > > > > > Cc: [email-masked]
> > > > > > Subject: Re: [Sigtran] M3UA IG-01 : SCON in response to DAUD
> > > > > >
> > > > > >
> > > > > > Tolga,
> > > > > >
> > > > > > That is not correct:  two passages from 4.5.3:
> > > > > >
> > > > > > 1:
> > > > > >
> > > > > > "The SGP SHOULD respond to a DAUD messages with the
> > > MTP3 availability/
> > > > > > congested status of the routeset associated with each
> > > > Destination Point
> > > > > > Code(s) in the DAUD message."
> > > > > >
> > > > > > Meaning that the SGP MAY refuse to respond at all (e.g.
> > > for security
> > > > > > purposes: the ASP is not authorized to audit the 
> requested DPC).
> > > > > [TOLGA] Bu then what about the sentence "Where the SGP
> > > maintains the
> > > > > congestion status of the SS7 destinations, the SGP MUST
> > > > additionally respond
> > > > > with an SCON message before the DAVA or DRST message." This
> > > > sentence uses a
> > > > > "MUST".
> > > > > >
> > > > > > and
> > > > > >
> > > > > > 2:
> > > > > >
> > > > > > "Where the SGP maintains the congestion status of the
> > > SS7 destination,
> > > > > > and the SS7 destination is congsted, the SGP MUST
> > > adiitionally respond
> > > > > > with an SCON message before the DAVA or DRST message."
> > > > > >
> > > > > > Which clearly indicates that where the SGP *does not*
> > > maintain the
> > > > > > congestion status, it is not obliged to respond with SCON.
> > > > > [TOLGA]The sentence "Where the SGP maintains the congestion
> > > > status of the
> > > > > SS7 destinations,..." does not have any meaning in my opinion.
> > > > Because, SGP
> > > > > *always* keeps congestion status of SS7 destinations,
> > > based on MTP3
> > > > > standards, and there is nothing we can do about this 
> in SIGTRAN
> > > > WG. So, if
> > > > > SGP keeps congestion status always, it also *MUST* 
> reply always
> > > > with SCON to
> > > > > DAUD, accordin to current M3UA text.
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > >
> > > > --
> > > > Brian F. G. Bidulock
> > > > [email-masked]
> > > > http://www.openss7.org/
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 13 Sep 2002 09:58:34 -0400

Javier,

I am not speaking of SS7 local PC, I am speaking of congestion of route set,
because of congestion of local links.

    Tolga

> Sent: Friday, September 13, 2002 9:43 AM