Subject: RE: [Sigtran] m3ua-mib-04 AS/SG concept

From: "Antonio Roque-Alvarez (ECE)" <[email-masked]>
Date: Tue, 24 Sep 2002 15:45:43 +0200

Hi Tolga,

I apologize for the so very late response.

So, if I understand you well, you mean that an SG is not a Logical Entity and that it does not represent a traffic range.

If we look at the definition of Signalling Gateway in the brand new RFC (page 5) we can read: "Where an SG contains more than one SGP, the SG is a logical entity and the...".

Besides, IMHO, an SG represents a traffic range since the moment that a set of traffic that want to reach some destinations in the SS7 network will be routed to a specific SG.

My modeling view here is that what a Signalling Process sees (as remote elements) is set of "Logical Entities" where to route/send traffic to. In the ASP case the "logical entities" are SGs and in the SGP/IPSP case they are ASs.

Basically the "logical entity" is the result of an operation in the routing table.

Thanks and regards,
Antonio

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Thursday, September 05, 2002 8:27 PM
> To: [email-masked]
> Subject: [Sigtran] m3ua-mib-04 AS/SG concept
> 
> 
> Hi Antonio,
> 
> 
> IMO, thinking a "Logical Application" as either AS or SG is 
> not the most
> correct way of modelling. SG does not represent a traffic 
> range but AS does.
> So, I think it is better to think "Logical Application Table" 
> as the entity
> corresponding to AS at both ASP nodes and SGP nodes (of course IPSP as
> well).
> 
>        Tolga
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 24 Sep 2002 10:29:45 -0400

Hi Antonio,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Antonio Roque-Alvarez (ECE)
> Sent: Tuesday, September 24, 2002 9:46 AM
> To: [email-masked]
> Subject: RE: [Sigtran] m3ua-mib-04 AS/SG concept
>
>
> Hi Tolga,
>
> So, if I understand you well, you mean that an SG is not a
> Logical Entity and that it does not represent a traffic range.
[TOLGA] My comment about SG not being a "Logical Entity" was in the context
of MIB document, i.e. that I didn't find it appropriate SG to be an element
of the "Logical Application Table".
>
> If we look at the definition of Signalling Gateway in the brand
> new RFC (page 5) we can read: "Where an SG contains more than one
> SGP, the SG is a logical entity and the...".
>
> Besides, IMHO, an SG represents a traffic range since the moment
> that a set of traffic that want to reach some destinations in the
> SS7 network will be routed to a specific SG.
>
> My modeling view here is that what a Signalling Process sees (as
> remote elements) is set of "Logical Entities" where to route/send
> traffic to. In the ASP case the "logical entities" are SGs and in
> the SGP/IPSP case they are ASs.
[TOLGA]But even if you take this view, there is no 1:1 realtionship between
traffic ranges and SG , whereas there is between AS and traffic ranges. For
example on ASP side, how will the m3uaRouting table look like if ASP is
connected to multiple SGs? Separete entries for each of them? Personally I
wouldn't prefer this approach.

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 24 Sep 2002 10:47:47 -0400

Hi Antonio,

I believe again related with this issue one comment/question about
Application-Endpoint Table:
(Assuming entries of m3uaAppTable are SGs on ASP side)
Application-Endpoint table entries will be SGPs on ASP side. There is
m3uaAppEpState field there ith possible values of active,inactive,down. Now,
because ASP can send traffic of multiple RKs to the same SG (no 1:1
relationship between SG and RK), how can we know states of SGPs per AS on
ASP side with such a datamodel?

    Tolga

> Tolga Asveren
> Sent: Tuesday, September 24, 2002 10:30 AM
> To: [email-masked]