Subject: RE: [Sigtran] SUA v14 doubt in SCON

From: [email-masked]
Date: Fri, 13 Sep 2002 14:33:17 +0530

Hi John and Tolga,

  I also agree with this ...
 But in SUA draft 14, SCON has  affected point code as a mandatory parameter and
RC as optional parameter.

 So what could be solution to this probelm ?
Can we have an invalid value for the affected point code which can be ignored at
the peer side ?
or some other solution ?

Comment on this.

Regards
Yogesh

[email-masked] on 09/13/2002 12:36:10 PM

To:   [email-masked], [email-masked]
cc:    (bcc: Yogesh Gahlaut/HSS)

Subject:  RE: [Sigtran] SUA v14 doubt in SCON

Hi Tolga,

> [TOLGA] I don't know, whether IPSP model of SUA will be similar to what we
> currently have in M3UA (based on M3UA-IG) or not. Assuming that it will be,
> AS will define the traffic at both ends in IPSP case. In such a case there
> won't be a need for AffectedPC in SCON for IPSP communication, RC will be
> enough.

Agreed.

John
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 13 Sep 2002 09:10:11 -0600

Yogesh,

SCON is used to indicate SS7 network congestion only.  It is not useful
in the IPSP case.  In the IPSP case, IETF mechanisms are more applicable:
such as ECN.

--brian

[email-masked] wrote:                                                     (Fri, 13 Sep 2002 14:33:17)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 13 Sep 2002 11:57:44 -0400

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, September 13, 2002 11:10 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [Sigtran] SUA v14 doubt in SCON
>
>
> Yogesh,
>
[TOLGA] For SUA-IPSP case, aren't we allowed to use SCON to inform the peer
about local subsystem congestion? Because there is no 1:1:1 relationship
between AS,SCTP associations and an IP address, I wouldn't think ECN or SCTP
congestion mechanisms can do, what SCON is intended to do.

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 13 Sep 2002 12:03:51 -0400

Oopps typo, correction below.

   Tolga
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Tolga Asveren
> Sent: Friday, September 13, 2002 11:58 AM
> To: [email-masked]
[TOLGA] congestion mechanisms can't do, what SCON is intended to do.
                              ^^^^^

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 13 Sep 2002 12:06:04 -0400

The typo was actually no typo, sorry for that, the original message is the
correct one.

  Tolga

> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, September 13, 2002 12:04 PM
> To: [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 13 Sep 2002 10:35:26 -0600

Tolga,

Q.714/2.8.4 "Routing failures due to Subsystem congestion are for further
study."

See also Q.714/5.2 (where the computation of congestion level is left for
further study and the action of the nodes is implementation dependent).

I don't see any need to echo this unspecified (or at least underspecified)
behavior into the IP network, do you?

--brian

Tolga Asveren wrote:                             (Fri, 13 Sep 2002 11:57:44)

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 13 Sep 2002 13:37:48 -0400

Brian,

> Sent: Friday, September 13, 2002 12:35 PM
> To: Tolga Asveren
> Cc: [email-masked]
[TOLGA] But using SCON for local congestion is similarly underspecified in
SUAv14 1.5.6 with a "MAY", so what is wrong if somebody wants to use SCON
for IPSP case? Still the action of nodes after receiving SCON is
implementation dependent, but personally I don't see something wrong by
notifying them about local subsystem congestion.