Subject: RE: [Sigtran] (M2PA) Receipt of User Data during AIP, PROVING sho uld cause transition to OOS

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Thu, 19 Sep 2002 09:06:32 +0200

Jeff,

your question is IMHO already answered in the MTP Level 2 spec.
Please have a look at ITU-T Recommendation Q.703 Figure 9/(sheet 5 of 6) or ANSI T1.111.3 Figure 9(sheet 3 of 3)
It shows the reaction upon reception of a correct SU during proving.
Reception during alignment is covered in Figure 9 sheet 2 (ITU-T) and sheet 1 (ANSI)

If the aim is to redo everthing linke in MTP2, I see no need for new handling of error causes.

greetings

HannsJuergen

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Wednesday, September 18, 2002 8:17 PM
>To: [email-masked]
>Subject: [Sigtran] (M2PA) Receipt of User Data during AIP, PROVING
>should cause transition to OOS
>
>
>Hello All,
>
>In my opinion, if M2PA receives User Data while in AIP or 
>PROVING states,
>it should
>generate LSO and transition to OOS state. Receiving User Data during
>alignment and
>proving indicates that the peer is erroneously in INS state. 
>It seems to me
>that M2PA
>should resynch as soon as this problem is detected, rather 
>than waiting for
>T3 timeout,
>or the peer's T7 timeout.
>
>Regards,
>
>Jeff
>
>
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran
>
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 19 Sep 2002 02:01:40 -0600

HanssJuergen,

Figure 9/Q.703 (sheet 5 of 6) and ANSI Figure9/T1.111.3 (sheet 3 of 3)
Correct SU indication from DAEDR is only used to trigger the start of a
new proving period when Further Proving is set.  It is really not
applicable to Jeff's question.

If you are interested in what Q.703 does when it receives an MSU in the
Proving state, consider that MSU/FISU Accepted is set to FALSE and look
at Figure 14/Q.703 (sheet 4 of 7, and 5 of 7).  The short of it is that
while proving, MSUs are discarded.  You will find the same thing in
ANSI Figure 14/T1.111.3 (Basic reception control).

Also, you will see this behavior tested in both Q.781 and GR-905-CORE.

But, I do agree with you on one point: M2PA should not try to reinvent
too much of MTP2.  Thus, M2PA should discard DATA while in Proving.

--brian

Schwarzbauer Hanns Juergen wrote:              (Thu, 19 Sep 2002 09:06:32)
> Please have a look at ITU-T Recommendation Q.703 Figure 9/(sheet 5 of
> 6) or ANSI T1.111.3 Figure 9(sheet 3 of 3) It shows the reaction upon
> reception of a correct SU during proving.  Reception during alignment
> is covered in Figure 9 sheet 2 (ITU-T) and sheet 1 (ANSI)
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/