Subject: RE: [Sigtran] M2PA V6: T7

From: "May, Howard" <[email-masked]>
Date: Thu, 26 Sep 2002 16:24:08 +0100

Hi Tolga,

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: 26 September 2002 15:32
> To: [email-masked]
> Subject: RE: [Sigtran] M2PA V6: T7
> 
> 
> Hi Jeff,
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Thursday, September 26, 2002 10:07 AM
> > To: Tolga Asveren
> > Cc: [email-masked]
> > Subject: RE: [Sigtran] M2PA V6: T7
> >
> >
> >
> > Hello Tolga,
> >
> > The goal of the T7 procedure is to distinguish a link 
> management failure
> > (delayed acks) from congestion (excessive load). SCTP/IP introduces
> > the possibility of dramatically varying latencies. The strict
> > interpretation
> > of the Q.703 T7 procedure does not handle this very well, as the
> > example scenario shows.
> [TOLGA] IMO, keeping propogation delay under certain limits 
> can be achieved
> better with SCTP. In such a case, T7 could be used as in 
> Q.703, i.e. as an
> indication of excessive delay of acknowledgement.

I think a real world system could operate with RTT of 100ms or less.  To allow changeover to occur in a timely manner it may be required to fail the M2PA link in a time of this order (0.5 seconds perhaps).  I believe this is below that which SCTP is specified to support. 

On this basis I believe it may be appropriate to use T7 to protect against excess PD.

> >
> > Regards,
> >
> > Jeff
> >
> >
> >
> >
> >
> >
> > "Tolga Asveren" <[email-masked]>@ietf.org on 
> 09/26/2002 08:58:51 AM
> >
> > Sent by:    [email-masked]
> >
> >
> > To:    <[email-masked]>
> > cc:
> > Subject:    RE: [Sigtran] M2PA V6: T7
> >
> >
> > Jeff,
> >
> > Just because of curiosity a question below (although it is 
> more related
> > with
> > implementation).
> >
> >   Tolga
> >
> > > -----Original Message-----
> > > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > > [email-masked]
> > > Sent: Thursday, September 26, 2002 8:19 AM
> > > To: May, Howard
> > > Cc: [email-masked]
> > > Subject: Re: [Sigtran] M2PA V6: T7
> > >
> > >
> > >
> > > Hello Howard,
> > >
> > > It may be helpful to view 'T7' as a collection of timers, one
> > > for each transmitted and unacknowledged MSU.
> > >
> > > One implementation would be to timestamp each User Data message
> > > when it is transmitted, and periodically check the oldest
> > (first) message
> > > in
> > > the retransmit queue (waiting-for-ack queue) for T7 timeout.
> > [TOLGA] What about such a scenario (T7 = 1s)
> > message1 is sent at t1
> > message2 is sent at t1+20 ms
> > message1 is acknowledged at t1+900ms
> > message2 is acknowledged at t1+1500ms
> > Based on the strategy you describe, I would assume this 
> will be seen as a
> > T7
> > expiry. But based on Q.703, I would think T7 should't 
> expire in such a
> > scenario.
> > >
> > > Regards,
> > >
> > > Jeff
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > > "May, Howard" <[email-masked]>@ietf.org on 
> 09/26/2002 07:24:59 AM
> > >
> > > Sent by:    [email-masked]
> > >
> > >
> > > To:    <[email-masked]>
> > > cc:
> > > Subject:    [Sigtran] M2PA V6: T7
> > >
> > >
> > > Hi,
> > >
> > > Please can you clarify my understanding of T7 by commenting on the
> > > following sequence of events as seen by one end of an M2PA link.
> > >
> > > Let us pretend T7 is configured with a value of second.
> > > ***********************
> > > The M2PA link comes into service.
> > > Data Message 1 is transmitted and T7 is started
> > > Data Message 2 is transmitted
> > > Data Message 3 is transmitted
> > > 900 ms passes
> > > Data Message 1 is acknowledged and T7 is restarted
> > > 900 ms passes
> > > Data Message 2 is acknowledged and T7 is restarted
> > > 900 ms passes
> > > Data Message 3 is acknowledged
> > > ************************
> > >
> > > Thank you
> > >
> > > Howard
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > >
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> >
> >
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 11:48:01 -0400

Hi Howard,

> From: May, Howard [mailto:[email-masked]]
> Sent: Thursday, September 26, 2002 11:24 AM
> To: Tolga Asveren; [email-masked]
> I think a real world system could operate with RTT of 100ms or
> less.  To allow changeover to occur in a timely manner it may be
> required to fail the M2PA link in a time of this order (0.5
> seconds perhaps).  I believe this is below that which SCTP is
> specified to support.
[TOLGA] If one uses values, which are recommended in SCTP RFC, that would be
right. But those values are based on (big I)Internet. One is free to use any
value for a private network.
> protect against excess PD.
[TOLGA] Even for MTP2, IMO T7 is not used to keep an eye on propogation
delay. I would consider propogation delay as a property of level1.