Subject: RE: RE: [Sigtran] m3ua-mib-04 AS/SG concept

From: "Antonio Roque-Alvarez (ECE)" <[email-masked]>
Date: Thu, 26 Sep 2002 15:51:35 +0200

Hi all,

Tolga:
- Yes it was a typo. A DPC state field has to be there.

- I agree with you: "Multiple SGs might be configured/used for the same
DPC/AS pair". That's why SG is needed to be declared as an index: That's an example:

NA	DPC	AS	SG 
--------------------
1	10	1	1
1	10	1	2

If only NA-DPC-AS have been declared as index, the entries above would not be allowed, because the table would not accept two entries with the same index (1-10-1).
When the management station wants to retreive all the SGs to be used to reach destination 1-10-1, only these three first keys will be provided in the SNMP request.

- Same applies to SGP table.

Tolga,Brian: In the SGP table: Altough they don't necessarily need to be equal, I would use the RC and the ASId with the same value. This would avoid having to declare a new table linking ASId's with RC's per SG.
Furthermore, I would use RC as the result of LOCAL routing table.

Srivats:
- Tolga is right, the RC may be included in the SSNM messages. Then, the availability of a destination depends on the RC. RC must remain in the destination table.
Besides, the result of LOCAL Routing can be the RC directly, so there is no need to use the RK Id.

Regards,
Antonio

> -----Original Message-----
> From: Srivats P. [mailto:[email-masked]]
> Sent: Wednesday, September 25, 2002 10:01 PM
> To: Tolga Asveren
> Cc: sigtran
> Subject: Re: RE: [Sigtran] m3ua-mib-04 AS/SG concept
> 
> 
> Antonio, Tolga, Brian,
> 
> How about the following additional tables for ASP -
> 
> Dest Table
> ----------
>   NA (Index)
>   DPC (Index)
>   SG Id (Index)
>   State
> 
> RC Table
> --------
>   SG Id (Index)
>   RK Id (Index) -- same as m3uaRkId of m3uaRouting
>   RC
> 
> SGP Table
> ---------
>   SG Id (Index)
>   RC (Index)
>   m3uaSpEpId (Index) -- i.e. the SGP
>   State
> 
> Based on the above let's see the ASP message transfer procedure -
> 
> The ASP looks into the existing m3uaRoutingTable to reverse-match
> the message against the RK parameters and retrieves the corresponding
> RK Id. It then looks into the Dest Table and matches the NA and DPC
> to retrieve an SG Id whose state is "accessible" i.e the NA+DPC is
> accessible via the SG. Using this SG Id and the RK Id retreived
> earlier it looks into the RC Table to retreive RC and finally
> using SG Id and RC it selects a SGP (m3uaSpEpId) whose state is
> "active" i.e. the RC is "active" wrt the SGP
> 
> Srivats
> 
> At 9/25/02 4:58:00 PM, you wrote:
> >Brian,
> >
> >> > >
> >> > > RC has no significance unless the SG is included.  RC 
> assignments
> >> > > are local to an SG.
> >> > [TOLGA] Yes, you are right, I oversaw this So, maybe replacing
> >> m3uaLocalRC
> >> > with m3uaAsId might be better. This will enable to have 
> the key as
> >> > NA+DPC+AsId.
> >>
> >> What's an AsId ?
> >[TOLGA] A value, internally unique on ASP for AS/RK -unlike 
> RC-. Call it
> >AsId, or RkId or whatever you like. If m3uaRouting table on 
> ASP side will be
> >similar to what it currently stands in MIB document, I think 
> it will be
> >called m3uaRKId.
> >
> >_______________________________________________
> >Sigtran mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/sigtran
> >
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 10:15:05 -0400

Hi Antonio,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Antonio Roque-Alvarez (ECE)
> Sent: Thursday, September 26, 2002 9:52 AM
> To: sigtran
> Subject: RE: RE: [Sigtran] m3ua-mib-04 AS/SG concept
>
>
> Hi all,
>
> Tolga:
> If only NA-DPC-AS have been declared as index, the entries above
> would not be allowed, because the table would not accept two
> entries with the same index (1-10-1).
> When the management station wants to retreive all the SGs to be
> used to reach destination 1-10-1, only these three first keys
> will be provided in the SNMP request.
>
[TOLGA] You are right, I noticed afterwards that my argument is in fact the
reason to include those in the index.
>
> Tolga,Brian: In the SGP table: Altough they don't necessarily
> need to be equal, I would use the RC and the ASId with the same
> value. This would avoid having to declare a new table linking
> ASId's with RC's per SG.
[TOLGA] On ASP side, I still would think, it might be better to stick, how
things are in RFC, i.e. to have RC per SGP/AS on ASP side. I know this might
need a new table but at least this would be inline with RFC.
>
> Srivats:
> - Tolga is right, the RC may be included in the SSNM messages.
> Then, the availability of a destination depends on the RC. RC
> must remain in the destination table.