Subject: RE: [Sigtran] M2PA V6: T7

From: "May, Howard" <[email-masked]>
Date: Thu, 26 Sep 2002 13:53:01 +0100

Excellent.  May I propose the following modification to the spec.

The per User Data message Timer T7 provides an indication of excessive delay of acknowledgement.  If the following conditions are true:
(a) A User Data message is not acknowledged within the span of T7.
(b) The remote M2PA is not in a Busy condition.

Howard

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: 26 September 2002 13:42
> To: May, Howard
> Cc: [email-masked]
> Subject: Re: [Sigtran] M2PA V6: T7
> 
> 
> Howard,
> 
> Well, no.  T7 in Q.703 is not intended to handle acknowledgement
> delays in the receiver.  The receiver is expected to acknowledge
> messages immediately upon receipt.  In Q.703 if messages 1, 2
> and 3 are sent in a group, they are expected to be acknowledged
> at the same rate at which they were emitted: i.e., no 900 ms
> delay between acknowledgements.  Also, in the Q.703 queueing model,
> one-way propagation delays are never greater than about 30ms for
> the basic method.  In this way, T7 is used as a guard timer.
> If RTT is variable and does not satisfy the relationship that
> PD << T7 then you will not get the results expected by the
> Q.703 model.
> 
> For M2PA it might be better, as Jeffrey puts, to view T7 as a
> per-message timer as the PD << T7 relationship cannot be
> guaranteed.
> 
> --brian
> 
> May, Howard wrote:                                 (Thu, 26 
> Sep 2002 13:25:27)
> > So in effect there is no bound on the length of time it may take to
> > acknowledge a message.  My previous example demonstrated 
> that it took 2.7
> > seconds to acknowledge Data message three even though T7 is 1s.
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: 26 September 2002 13:05
> > > To: May, Howard
> > > Cc: [email-masked]
> > > Subject: Re: [Sigtran] M2PA V6: T7
> > > 
> > > 
> > > Howard,
> > > 
> > > Close enough.
> > > 
> > > --brian
> > > 
> > > May, Howard wrote:                                     (Thu, 
> > > 26 Sep 2002 12:24:59)
> > > > Hi,
> > > > 
> > > > Please can you clarify my understanding of T7 by commenting 
> > > on the following
> > > > sequence of events as seen by one end of an M2PA link.
> > > > 
> > > > Let us pretend T7 is configured with a value of second.
> > > > ***********************
> > > > The M2PA link comes into service.
> > > > Data Message 1 is transmitted and T7 is started
> > > > Data Message 2 is transmitted
> > > > Data Message 3 is transmitted
> > > > 900 ms passes
> > > > Data Message 1 is acknowledged and T7 is restarted
> > > > 900 ms passes
> > > > Data Message 2 is acknowledged and T7 is restarted
> > > > 900 ms passes
> > > > Data Message 3 is acknowledged
> > > > ************************
> > > > 
> > > > Thank you
> > > > 
> > > > Howard
> > > > 
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > -- 
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 09:14:14 -0400

Howard,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> May, Howard
> Sent: Thursday, September 26, 2002 8:53 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sigtran] M2PA V6: T7
>
>
> The per User Data message Timer T7 provides an indication of
> excessive delay of acknowledgement.  If the following conditions are true:
[TOLGA] I don't think T7 is inteneded to be used as a timer for separate
message acknowledgements in Q.703. As Brian pointed out, in IP domain RTT
are variable but to deal with this is IMO SCTPs business.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 26 Sep 2002 07:30:49 -0600

Howard,

Sounds good to me.

--brian

May, Howard wrote:                                   (Thu, 26 Sep 2002 13:53:01)
> The per User Data message Timer T7 provides an indication of excessive delay
> of acknowledgement.  If the following conditions are true:

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 26 Sep 2002 07:31:40 -0600

Tolga,

SCTP fails at this.

--brian

Tolga Asveren wrote:                               (Thu, 26 Sep 2002 09:14:14)