Subject: Re: [Sigtran] M2PA V6: T7

From: [email-masked]
Date: Thu, 26 Sep 2002 08:18:48 -0400

Hello Howard,

It may be helpful to view 'T7' as a collection of timers, one
for each transmitted and unacknowledged MSU.

One implementation would be to timestamp each User Data message
when it is transmitted, and periodically check the oldest (first) message
in
the retransmit queue (waiting-for-ack queue) for T7 timeout.

Regards,

Jeff

"May, Howard" <[email-masked]>@ietf.org on 09/26/2002 07:24:59 AM

Sent by:    [email-masked]

To:    <[email-masked]>
cc:
Subject:    [Sigtran] M2PA V6: T7

Hi,

Please can you clarify my understanding of T7 by commenting on the
following sequence of events as seen by one end of an M2PA link.

Let us pretend T7 is configured with a value of second.
***********************
The M2PA link comes into service.
Data Message 1 is transmitted and T7 is started
Data Message 2 is transmitted
Data Message 3 is transmitted
900 ms passes
Data Message 1 is acknowledged and T7 is restarted
900 ms passes
Data Message 2 is acknowledged and T7 is restarted
900 ms passes
Data Message 3 is acknowledged
************************

Thank you

Howard

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 08:58:51 -0400

Jeff,

Just because of curiosity a question below (although it is more related with
implementation).

  Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Thursday, September 26, 2002 8:19 AM
> To: May, Howard
> Cc: [email-masked]
> Subject: Re: [Sigtran] M2PA V6: T7
>
>
>
> Hello Howard,
>
[TOLGA] What about such a scenario (T7 = 1s)
message1 is sent at t1
message2 is sent at t1+20 ms
message1 is acknowledged at t1+900ms
message2 is acknowledged at t1+1500ms
Based on the strategy you describe, I would assume this will be seen as a T7
expiry. But based on Q.703, I would think T7 should't expire in such a
scenario.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 26 Sep 2002 07:36:07 -0600

Tolga,

Tolga Asveren wrote:                                                                 (Thu, 26 Sep 2002 08:58:51)
> expiry. But based on Q.703, I would think T7 should't expire in such a

The above scenario does not occur in Q.703.  Message 2 must be acknowledged
at t1+920ms.  Receivers to no artificially delay acknowledgements and
propagation delays are fixed (quasi-variable but within tight bounds).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 10:02:58 -0400

Brian,

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, September 26, 2002 9:36 AM
> To: Tolga Asveren
> Cc: [email-masked]
> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
[TOLGA]I agree that acknowledgement and propogation delays are quasi
variable with tight bounds for MTP2. My example was just about T7 procedure
as described in Q.703, to show that it is not intended to be used as a per
message basis. Personally I still think, to guarantee that propogation delay
is within some bounds is SCTP business.