Subject: [Sigtran] M3UA: Clarification of Use of Stream "0"

From: [email-masked]
Date: Thu, 12 Sep 2002 14:49:52 -0400

The 3rd paragraph in M3UA Section 4.1.1 indicates "Data messages MUST be
sent on an SCTP stream other than stream "0."

Please clarify whether it is an M3UA requirement that Stream "0" only be
used for management messages? Also, can management messages be sent on
Streams other than Stream "0" ?

Thanks in advance.

Ray

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 12 Sep 2002 13:19:31 -0600

Ray,

Yes, and yes.

--brian

[email-masked] wrote:                                                         (Thu, 12 Sep 2002 14:49:52)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 12 Sep 2002 16:06:36 -0400

Brian,

According to M3UA-IGv01 3.13 ASPSM, MGMT, RKM should be sent on stream 0
(except BEAT/BEAT-ACK). So, based on that, aren't we restricted to use
Stream0 for management messages?

   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Thursday, September 12, 2002 3:20 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sigtran] M3UA: Clarification of Use of Stream "0"
>
>
> Ray,
>
> Yes, and yes.
>
> --brian
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 12 Sep 2002 14:08:54 -0600

Tolga,

ASPTM can (and should IMO) be sent on the data stream.  Are not ASPTM
"Management" messages?

--brian

Tolga Asveren wrote:                                                                 (Thu, 12 Sep 2002 16:06:36)

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 12 Sep 2002 16:31:15 -0400

Brian,

It also makes sense to me to use stream0 for ASPTM.

   Tolga

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, September 12, 2002 4:09 PM
> To: Tolga Asveren
> Cc: [email-masked]
> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > > Brian F. G. Bidulock

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 12 Sep 2002 14:39:54 -0600

Tolga,

I belive the RFC2b allows you send ASPTM on stream 0 as well.
The implication of send ASPIA/Ack on stream 0, however, is that
they will not be synchronized with the data stream and may beat
data messages in transit.  It is possible to use BEAT/BEAT Ack
as described in the corid draft to avoid that effect, however,
placing ASPIA/Ack on the data stream can also synchonize with data
and avoid ASPIA/Ack overtaking DATA.  There seems little point in
sending these messages "ordered" if they are not sent on the stream
to which they apply.

--brian

Tolga Asveren wrote:                                                                 (Thu, 12 Sep 2002 16:31:15)