Subject: RE: [Sigtran] M2PA V6: T7

From: "May, Howard" <[email-masked]>
Date: Thu, 26 Sep 2002 13:25:27 +0100

So in effect there is no bound on the length of time it may take to acknowledge a message.  My previous example demonstrated that it took 2.7 seconds to acknowledge Data message three even though T7 is 1s.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: 26 September 2002 13:05
> To: May, Howard
> Cc: [email-masked]
> Subject: Re: [Sigtran] M2PA V6: T7
> 
> 
> Howard,
> 
> Close enough.
> 
> --brian
> 
> May, Howard wrote:                                     (Thu, 
> 26 Sep 2002 12:24:59)
> > Hi,
> > 
> > Please can you clarify my understanding of T7 by commenting 
> on the following
> > sequence of events as seen by one end of an M2PA link.
> > 
> > Let us pretend T7 is configured with a value of second.
> > ***********************
> > The M2PA link comes into service.
> > Data Message 1 is transmitted and T7 is started
> > Data Message 2 is transmitted
> > Data Message 3 is transmitted
> > 900 ms passes
> > Data Message 1 is acknowledged and T7 is restarted
> > 900 ms passes
> > Data Message 2 is acknowledged and T7 is restarted
> > 900 ms passes
> > Data Message 3 is acknowledged
> > ************************
> > 
> > Thank you
> > 
> > Howard
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 26 Sep 2002 06:41:41 -0600

Howard,

Well, no.  T7 in Q.703 is not intended to handle acknowledgement
delays in the receiver.  The receiver is expected to acknowledge
messages immediately upon receipt.  In Q.703 if messages 1, 2
and 3 are sent in a group, they are expected to be acknowledged
at the same rate at which they were emitted: i.e., no 900 ms
delay between acknowledgements.  Also, in the Q.703 queueing model,
one-way propagation delays are never greater than about 30ms for
the basic method.  In this way, T7 is used as a guard timer.
If RTT is variable and does not satisfy the relationship that
PD << T7 then you will not get the results expected by the
Q.703 model.

For M2PA it might be better, as Jeffrey puts, to view T7 as a
per-message timer as the PD << T7 relationship cannot be
guaranteed.

--brian

May, Howard wrote:                                 (Thu, 26 Sep 2002 13:25:27)
> So in effect there is no bound on the length of time it may take to
> acknowledge a message.  My previous example demonstrated that it took 2.7
> seconds to acknowledge Data message three even though T7 is 1s.
>

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 09:09:07 -0400

Brian,

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Thursday, September 26, 2002 8:42 AM
> To: May, Howard
> Cc: [email-masked]
[TOLGA] Why? IMO, with proper SCTP parameter values, this can be guaranteed,
and if the requirement can't be met, SCTP association will be dropped.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 26 Sep 2002 07:33:34 -0600

Tolga,

Recommended SCTP values cannot meet the objective PD << T7 where
T7 is 1-2 seconds per Q.703.  In SCTP recommended RTOmin is 1 second.
Many retransmission attempts (5) can occur with 1 second doubling
each time before the association is dropped.  That would be
1+2+4+8+16 = 31 seconds.  Unacceptable.

--brian

Tolga Asveren wrote:                           (Thu, 26 Sep 2002 09:09:07)

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 26 Sep 2002 09:58:06 -0400

Brian,

> Sent: Thursday, September 26, 2002 9:34 AM
> To: Tolga Asveren
> Cc: [email-masked]
[TOLGA] I don't think anybody will deploy SCTP with those recommended
values, while using it for M2PA. Those values are like this, because they
are recommended for the (big I)Internet, and I don't think M2PA will run
over the (big I)Internet.