Subject: RE: [Sigtran] M3UA: Clarification of Use of Stream "0"

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 13 Sep 2002 07:16:24 +0200

Hi guys, 

Please take a look to the Implementor's Guide section 3.13 where the stream hanling is better explained.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, September 12, 2002 11:32 PM
> To: Schantz, John
> Cc: Tolga Asveren; [email-masked]
> Subject: Re: [Sigtran] M3UA: Clarification of Use of Stream "0"
> 
> 
> John,
> 
> I meant RFC-to-be.
> 
> --brian
> 
> Schantz, John wrote:                                          
>                   (Thu, 12 Sep 2002 15:49:39)
> > Did we go straight to RFC2b and skipped over first few RFCs?  ;^)
> > 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]] 
> > Sent: Thursday, September 12, 2002 3:40 PM
> > To: Tolga Asveren
> > Cc: [email-masked]
> > Subject: Re: [Sigtran] M3UA: Clarification of Use of Stream "0"
> > 
> > 
> > Tolga,
> > 
> > I belive the RFC2b allows you send ASPTM on stream 0 as well. The
> > implication of send ASPIA/Ack on stream 0, however, is that 
> they will
> > not be synchronized with the data stream and may beat data 
> messages in
> > transit.  It is possible to use BEAT/BEAT Ack as described 
> in the corid
> > draft to avoid that effect, however, placing ASPIA/Ack on the data
> > stream can also synchonize with data and avoid ASPIA/Ack overtaking
> > DATA.  There seems little point in sending these messages 
> "ordered" if
> > they are not sent on the stream to which they apply.
> > 
> > --brian
> > 
> > Tolga Asveren wrote:
> > (Thu, 12 Sep 2002 16:31:15)
> > > Brian,
> > > 
> > > It also makes sense to me to use stream0 for ASPTM.
> > > 
> > >    Tolga
> > > 
> > > > -----Original Message-----
> > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > Sent: Thursday, September 12, 2002 4:09 PM
> > > > To: Tolga Asveren
> > > > Cc: [email-masked]
> > > > Subject: Re: [Sigtran] M3UA: Clarification of Use of Stream "0"
> > > >
> > > >
> > > > Tolga,
> > > >
> > > > ASPTM can (and should IMO) be sent on the data stream.  Are not 
> > > > ASPTM "Management" messages?
> > > >
> > > > --brian
> > > >
> > > > Tolga Asveren wrote:
> > > >                    (Thu, 12 Sep 2002 16:06:36)
> > > > > Brian,
> > > > >
> > > > > According to M3UA-IGv01 3.13 ASPSM, MGMT, RKM should 
> be sent on 
> > > > > stream 0 (except BEAT/BEAT-ACK). So, based on that, aren't we 
> > > > > restricted to use Stream0 for management messages?
> > > > >
> > > > >    Tolga
> > > > >
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/ 
> _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Fri, 13 Sep 2002 16:11:07 -0400

Our implementation sends ASPTM messages on stream 1 to avoid messages being intermittently lost on up and down link
state transitions due to the fact that M3UA ASPTM messages are sent on a different stream than the data traffic.

"Tolga Asveren" <[email-masked]>@ietf.org on 09/12/2002 04:31:15 PM

Sent by:    [email-masked]

To:    <[email-masked]>
cc:
Subject:    RE: [Sigtran] M3UA: Clarification of Use of Stream "0"

Brian,

   Tolga

> ASPTM can (and should IMO) be sent on the data stream.  Are not ASPTM
> "Management" messages?
>
> --brian
>
> Tolga Asveren wrote:
> > According to M3UA-IGv01 3.13 ASPSM, MGMT, RKM should be sent on stream
0
> > (except BEAT/BEAT-ACK). So, based on that, aren't we restricted to use
> > Stream0 for management messages?
> >
> >    Tolga
> >
> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > > Brian F. G. Bidulock
> > > Sent: Thursday, September 12, 2002 3:20 PM
> > > To: [email-masked]
> > > Cc: [email-masked]
> > > Ray,
> > > Yes, and yes.
> > > [email-masked] wrote:
> > >                   (Thu, 12 Sep 2002 14:49:52)
> > > >  The 3rd paragraph in M3UA Section 4.1.1 indicates "Data
> > > messages MUST be
> > > > sent on an SCTP stream other than stream "0."
> > > >
> > > > Please clarify whether it is an M3UA requirement that
> Stream "0" only be
> > > > used for management messages? Also, can management messages
> be sent on
> > > > Streams other than Stream "0" ?
> > > >
> > > > Thanks in advance.
> > > >
> > > > Ray
> > > >